Jump to content

Search the Community

Showing results for tags 'server'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. rechigo

    Not finding TV show metadata

    Emby seems to be having trouble scanning the metadata for a series I have. My library type is set to Tv Shows and I have all metadata sources in use to try to search for the metadata. My series is "Star Wars the Clone Wars" and the episode names are in the format "Star Wars The Clone Wars 03X15 Overlords.mkv" Where "03X15" represents the season and episode, and "Overlords" is the episode name in this case. I am running server version 4.1.1.0 (latest) Any help would be appreciated as there is no way I am going to manually search for/enter the metadata for 6 seasons (over 150 episodes) worth of video.
  2. Hello, could somebody help me with this error in log file on Emby Server v4.1.1.0 (android tv box): 2019-05-26 22:37:03.585 Error ChannelManager: Error creating channel *** Error Report *** Version: 4.1.1.0 Command line: /data/app/com.emby.embyserver-1/base.apk Operating system: Unix 3.14.29.0 64-Bit OS: False 64-Bit Process: False User Interactive: False Runtime: file:///mscorlib.dll Processor count: 8 Program data path: /storage/emulated/0/Android/data/com.emby.embyserver/files Application directory: /data/user/0/com.emby.embyserver Mono: 5.14.0 (explicit/62031dcabf4) Android Version: 7.1.2-REL - SDK: 25 'NMr1' Patch Level: 20181014 (2018-10-14) Fingerprint: Xiaomi/sagit/sagit:7.1.1/NMF26X/V8.2.17.0.NCACNEC:user/release-keys Model: atvXperience_v2FF - atvXperience/atvXperience Hardware: atvX_S905X/atvX/amlogic/S905X SupportedAbis: armeabi-v7a, armeabi SQLitePCL.pretty.SQLiteException: Constraint: FOREIGN KEY constraint failed SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown. at SQLitePCL.pretty.SQLiteException.CheckOk (SQLitePCL.sqlite3 db, System.Int32 rc) [0x00017] in <a7b50c3af6fb4394800c2a95b825777a>:0 at SQLitePCL.pretty.SQLiteException.CheckOk (SQLitePCL.sqlite3_stmt stmt, System.Int32 rc) [0x00006] in <a7b50c3af6fb4394800c2a95b825777a>:0 at SQLitePCL.pretty.StatementImpl.MoveNext () [0x0004a] in <a7b50c3af6fb4394800c2a95b825777a>:0 at Emby.Server.Implementations.Data.SqliteItemRepository.UpdateAncestors (System.Int64 itemId, System.Collections.Generic.List`1[T] ancestorIds, SQLitePCL.pretty.IDatabaseConnection db, SQLitePCL.pretty.IStatement deleteAncestorsStatement) [0x000db] in <fde33dc083004d96a63cf2129ad12dfb>:0 at Emby.Server.Implementations.Data.SqliteItemRepository.SaveItemsInTranscation (SQLitePCL.pretty.IDatabaseConnection db, System.Collections.Generic.List`1[T] tuples) [0x000c9] in <fde33dc083004d96a63cf2129ad12dfb>:0 at Emby.Server.Implementations.Data.SqliteItemRepository+<>c__DisplayClass45_0.<SaveItems>b__0 (SQLitePCL.pretty.IDatabaseConnection db) [0x00000] in <fde33dc083004d96a63cf2129ad12dfb>:0 at SQLitePCL.pretty.DatabaseConnection+<>c__DisplayClass20_0.<RunInTransaction>b__0 (SQLitePCL.pretty.IDatabaseConnection db) [0x00000] in <a7b50c3af6fb4394800c2a95b825777a>:0 at SQLitePCL.pretty.DatabaseConnection.RunInTransaction[T] (SQLitePCL.pretty.IDatabaseConnection This, System.Func`2[T,TResult] f, SQLitePCL.pretty.TransactionMode mode) [0x00063] in <a7b50c3af6fb4394800c2a95b825777a>:0 at SQLitePCL.pretty.DatabaseConnection.RunInTransaction (SQLitePCL.pretty.IDatabaseConnection This, System.Action`1[T] action, SQLitePCL.pretty.TransactionMode mode) [0x0001b] in <a7b50c3af6fb4394800c2a95b825777a>:0 at Emby.Sqlite.ManagedConnection.RunInTransaction (System.Action`1[T] action, SQLitePCL.pretty.TransactionMode mode) [0x00000] in <918b38c4a304417e9492a8444a8b00f2>:0 at Emby.Server.Implementations.Data.SqliteItemRepository.SaveItems (System.Collections.Generic.List`1[T] items, System.Threading.CancellationToken cancellationToken) [0x000fb] in <fde33dc083004d96a63cf2129ad12dfb>:0 at Emby.Server.Implementations.Library.LibraryManager.CreateItems (System.Collections.Generic.List`1[T] items, MediaBrowser.Controller.Entities.BaseItem parent, System.Threading.CancellationToken cancellationToken) [0x00006] in <fde33dc083004d96a63cf2129ad12dfb>:0 at Emby.Server.Implementations.Library.LibraryManager.CreateItem (MediaBrowser.Controller.Entities.BaseItem item, MediaBrowser.Controller.Entities.BaseItem parent) [0x00013] in <fde33dc083004d96a63cf2129ad12dfb>:0 at Emby.Server.Implementations.Channels.ChannelManager+<GetChannel>d__41.MoveNext () [0x0010a] in <fde33dc083004d96a63cf2129ad12dfb>:0 --- End of stack trace from previous location where exception was thrown --- at Emby.Server.Implementations.Channels.ChannelManager+<GetChannelEntity>d__44.MoveNext () [0x000a6] in <fde33dc083004d96a63cf2129ad12dfb>:0 Source: mscorlib TargetSite: Void Throw() Thank you
  3. twistedvincent

    Images Disappearing Issue

    So, my folders image issues still remain. Same image repeated 4X which is really annoying, especially since I'm a bit OCD and little crap like that drives me nuts. Now, When I add new videos and edit the images they just disappear. I added the proper poster, backdrop, and banner, clicked save and thought that was it. Until I found a better backdrop image, went to change it, and discovered 2 out of the 3 images I added were gone. And after checking some other images discovered they were gone as well. So I re-added everything again went to double check and VOILA! Gone again. I have the new beta and was thinking of installing it but thought I'd better check for a solution here first.
  4. Hello. Currently what would be the cheapest hardware I can use to install emby server? The plan is just to connect emby with HDHomeRun and be able to watch live TV from outside home wifi. HDHomeRun doesn't support it natively, so it requires Plex or Emby. Plex requires PlexPass (paid) to broadcast live TV and emby does that for free via emby server. Any help is appreciated! Thank you.
  5. I renamed one of my libraries (from Animated - Movies to Movies - Animated), but it seems that it now cannot detect my collections. The collections are still showing in the user folder (C:\Users\User\AppData\Roaming\Emby-Server\data\collections) and if I look at any of the XML files they still show all the proper paths to the media. When viewing my library through the My Media section on the web app, if I go over the Collections tab there is nothing there. I'm on the latest version of the server (4.1.1.0)
  6. Ever since updating to version 4 (on 4.0.3.0 currently), I've been having some playback issues (freezing) on almost everything I play. This happens on two separate servers in two separate locations streaming to different types of devices. One server runs on Windows 7 and streams to a Roku+ streaming stick. The other runs on Windows 10 and streams to a Shield TV. Both servers have been experiencing the problem only since version 4 and have worked flawlessly for 2 years prior without a single freeze. I currently only have logs saved for one of the servers which I've uploaded below. In the first log while watching Jaws, there was one freeze which I was able to get past by simply pressing pause and then un-pause on the remote. In the second log while watching Slumdog Millionaire, it froze about 20-30 mins into the movie. I tried pause/un-pause again which resumed the movie. However, it froze again shortly after and would continue to do so until I just got frustrated and stopped watching the movie. In the third log while watching Skyfall, playback froze about 1 hour and 30 mins in. I was able to resolve by pausing/unpausing and it didn't freeze again. It's at the point now where I don't even want to watch something because I'm constantly thinking that it will freeze (which it does 80% of the time it seems) and it takes away from the enjoyment of watching. Hopefully there's something in the logs that can help get to the bottom of this. Thanks for any help! embyserver-jaws_freeze.txt embyserver-slumdog-freeze.txt embyserver-skyfall.txt
  7. I was running emby-server-deb_4.0.2.0_amd64.deb on Ubuntu 18.04.2. I noticed that the server was down. I discovered over 37,000 log files on my machine. All of the embyserver logs were zero bytes in length. There were thousands of "unhandled" log files all of the same length. The ones I checked all had the same info in them. I apt purged 4.0.2.0 and installed emby-server-deb_4.1.1.0_amd64.deb I discovered a "System.NullReferenceException:" that was occuring which I think is coming from Mono. Also, the embyserver log file are still zero bytes in length, but there are not 1000s of them being generated anymore. Here is a link to detailed information of my investigation. http://cdn.kolomona.com/emby/problem01 Any help to get myserver up and running would be greatly appreciated. Thanks
  8. Dizzy49

    Dell PowerEdge for Emby Server?

    So, I have a Norco case with a cheapy mobo and processor. I've got 16 drives in it, so I'm making good use of the 24 bays. I ran across a Dell PowerEdge R710 server with 2x Xeon 5660 CPUs and 64GB of Ram for a reasonable price. I don't even care about the 6x 2TB drives. My question is two fold. 1) Would the Dell PowerEdge be a good Emby server? 2) Is there a way to connect the drives in my Norco to the PowerEdge so the Norco is essentially just a big box of drives? I'd rather not connect via Ethernet as I believe it would lose a lot of efficiency trying to stream/re-encode from a network drive. Thanks! -Sean
  9. Doebert

    Emby shows unknown users

    All of a sudden I can no longer get into Emby?? When I start Emby in windows 10 it shows 2 unknown users. 1-computerguyiptv and 2-doom. I have no idea who they are? When I try to log in with my credentials it doesn't recognize my account. I first noticed a problem when I was trying to access it on Roku and it showed my server name with addition info after that "LIVETV VOD AND MORE". I have no idea where that came from either?? So........what should I do to resolve this without losing all my media? Thanks in advance.
  10. casperch

    configurazione server emby

    salve mi presento mi chiamo Casper sono entrato da poco nel mondo Emby ho fatto un test su un server locale più ho aggiunto nas Qnap di 4 Tb dove ho tutti i film ed e collegato in rete locale con il server. Emby e strutturato bene ora vorrei fare bkp e metterlo su un server dedicato e meglio fare server linux o windows ? io ho a disposizione un server dedicato online Bandwidth: Unltd @ 1Gbps IP: 1 HDD: 2x 2000GB HW RAID 1 RAM: 32GB CPU: Intel Xeon E3-1220 3.10Ghz + ILO e vorrei reinstallare tutto con il bkp e riconnettere con il mio server nas locale per i contenuti film ho visto che con tre user sul mio server locale test veniva consumato molta cpu a causa del trascoding e possibile disabilitarlo e come si fa? saluti casperch
  11. I have been an Emby user since MediaBrowser. I loved and still love how it works with Windows Media Center on Windows 7. My current media server is set up on Windows 7, and I use WMC on my main TV that's hooked to the sever, and a few other TVs in the house. I guess I'm just looking for some advise on what to do now that support for Windows 7 is ending. I'm just so used to the layout of Windows Media Center, and the flawless execution between it and my Windows 7 server set up, that I'm anxious about how to make sure things work for me once Windows 7 is no longer a good solution. Does anyone else on here still use 7 and WMC? Did you used to use it and have moved on to something new and you still like it? I love the LiveTV of WMC. I know Emby now has LiveTV options...but I think I need to buy a specific tuner for that? Is Windows 10 my only option with Theater? What about Linux server? So...yeah...bit of a ramble. I guess I'm just looking for any suggestions or advise for someone who has used a Windows 7 setup through Windows Media Center since original Mediabrowser. The future and change is scary...please hold my hand and help me through it!
  12. rene.teniere

    Budget Ryzen 5 Server Build

    Hi All, I am a recent convert from Plex, and am wanting to replace my current lackluster media server. Typically, I may have two Roku units running emby within the home network, and maybe one offsite tops. It is only on rare occasions that I would have two or more streams of 1080p max. I have on hand the following: ASRock B450M PRO4 AM4 AMD B450 SATA 6Gb/s USB 3.1 HDMI Micro ATX AMD Motherboard Team T-Force Vulcan 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3000 (PC4 24000) Hanmi Micronics, Caslon II Series Power Supply 500W I was studying your forum, and trying to find an AMD solution (locked-in to AMD). From what I have read, the AMD Ryzen 5 is an ok choice? My question is because of my relatively small budget, should I just go with the Ryzen 5 2400G, or the Ryzen 5 2600 + GPU, or even the Ryzen 7 1700 + GPU? Please let me know if anything above the Ryzen 5 2400G would be overkill in my application. If not, then would I go for the Ryzen 5 2600, or Ryzen 7 1700 (or any suggestions of any kind)? The problem for me would be the added cost of the GPU. How important is it in my application, and what can I get away with? I have read that the Gigabyte Geforce GTX 1050 Ti 4GB and the Gigabyte GeForce GT 1030 OC 2G are ok cards, or is that again overkill or not enough? I have time to wait until I buy (probably after Christmas) so hopefully something new will come out to drop the prices a bit? Not as much savings here in Canada as the US for the same product. My final question would be once I set up my recommended server, is there anything else I should know to properly setup / tweak both hardware and software? Thanks, René
  13. I migrated my server from synology to an intel nuc running ubuntu server 18.04 lts. I installed emby server 4.0.2.0. After I did all my libraries and the scan was completed, I restore a backup. The backup was created from beta server 4.1.0.15. Everthing seems to work like it should. However, at startup, I get a lot of "Error App: LoaderException". See attached logs. I just wondering why I get all those errors at startup and if there is something I can do to fix it? Thank you Logs.txt
  14. buddyweiser

    Raspberry Pi 3B+ as Server

    What I want: I am looking for a very small form factor solution to serve up media to 1 possibly 2 devices(direct stream, NOT transcode), and also act as a router. This will be for travel. I also want to keep cost down as much as possible (less than 100 is good, under 60 is better) Why these specifics: For vacation, most times the rental does not have wi-fi, and more often than not, only has a TV with a blu-ray player. I have a fire stick I bring for travel, and use my laptop to act as a temp-travel server(my home upload speed is terrible, and also I want a solution that does not require internet connection just in case there is no cell coverage or wi-fi). I also store my "travel media" on a 2 tb external hdd. I am looking for a solution with considerably smaller footprint, that I can plug in when we get here, and its ready whenever I want to use it. I thought of the raspberry pi because I have seen people building wi-fi routers with them. I thought, wouldn't it be great if I could build a small enclosure for a headless raspberry pi, make it a wifi router, and also have Emby Server run on it when it boots up? I could even have a small 3" lcd on the outside of the enclosure to display bits of information like connected devices, status of internet connection if any, and even status of Emby Server. But this entire idea would depend on how well emby server runs on Raspberry pi. Does anyone have any experience here? Any feedback would be welcome!
  15. When I try to Browse Library or Configure Emby I receive the above error message. I have delete the Emby Server App and re-installed without any success. I had to replace my BT Hub a few days ago. Any help would be greatly appreciated.
  16. I have been having problems for days on both my home and work computer. I can log in but then it asks me to pick a server. No matter which one I pick it says "We're unable to connect to the selected server right now. Please ensure it is running and try again." I thought I was doing something wrong and I have tried this a ton of times. One of my friends just went on his computer and logged in with my info and everything popped right up for him. He did not have to pick a server or snything. PLEASE HELP. This is SO frustrating. TIA
  17. Since joining Emby last December, I have spent a lot of time organizing my media libraries, including correcting any mis-'identify' linking, updating metadata, and even setting custom "sort as" information to organize my libraries. Then the previous media server updated versions came out, I installed the new server version, and to my dismay, all of that custom information and work was lost! as the server restarted and essentially ran what looked like a fresh scan and link process. So much work and time, gone in an instant. I suspect that there's a way for me to help ensure this doesn't happen again, before I install the latest update. I appreciate any guidance or tips to help ensure that I don't make this same mistake again. I did find the 'lock this metadata' near the bottom of the metadata screen for each individual piece of media - is that sufficient to select to preserve my inputs? Or is there more to be done. Thanks in advance!
  18. meatball

    Server Bitrate settings/question

    Hi I’ve recently migrated from plex and trying to get my arms wrapped around the server bitrate settings and was hoping for some guidance. If I go to expert-advanced and set the bitrate setting, this is the global setting applied per remote device- is this correct? Ultimately this is going to determine how much upload bandwidth you allocate per streaming device not on the LAN. HOwever I can augment this by going into the individual users settings on the server and increase/decrease their allowed bitrate/upload bandwidth which will override the global setting I mentioned previously. Am I in the ballpark or am I not understanding? Please feel free to correct me if I’m off base. Thanks for the help.
  19. Just updated to 4.0.2 on my Nvidia Shield box and now Live TV channels will not tune-in. The Shield just shows a spinning blue circle and if I try via a browser, I get the message 'No compatible streams are currently available' Tried removing and re-adding my HD Homerun, no change. All channels seems to be detected and are listed. Guide is populated. Anyone else experiencing this or any ideas please.
  20. Hello! I'm have been trying for the past few days, to set up Emby to be able to play an audio stream over ethernet. More specifically I would like to be able to play a broadcasted/multicasted audio stream from another machine on my LAN. I've tried using both the IPTV plugin and strm files. I've had no luck using the strm method as described on the wiki so I've given up on that for the time being. I've been able to play internet radio streams directly using the IPTV plugin, but this will not be possible where it will be used, due to data limitations on the internet connection. Sifting through the logs, I've noticed the same error in FFMPEG, "streams and format are both null." I've been able to play the stream on other applications, such as VLC, so I'm thinking this has to be somekind of a configuration issue in FFMPEG. Right now I'm using a free version of the Emby server on my PC and I've used the browser interface on the same computer and on my phone, as well as the Emby app on an LG TV. Where it will be used I'll have the Premium version if that makes any difference? I've been able to play both audio and video from directly linking to files on the server, as well as directly linking to internet radios using http. What I have not been able to do is to play from streams in house, no matter if it's video or audio, directly from a file or transcoded from an internet radio stream. So, is it possible to use Emby to handle in house streams, and if so, how on earth do you make it work? I would very much like to be able to use Emby for this, since it handles all my other media as well.
  21. Hello, I am having trouble connecting remotely to the Emby server on my computer, from my android phone (or any other device). I am able to connect when on my home network, but not off of it. I have gone through the steps in the Connectivity section, to no avail. I have opened port 8096 in Windows Firewall, as well as set up port forwarding for 8096 in my router (using router Asus RT-AC68U). When trying on canyouseeme.org, i get the error "i could not see your service on ... on port 8096". I have checked for other Firewall rules, and found none, and even tried temporarily disabling firewall, and it still won't connect. Also rebooted router and Emby server multiple times after changing settings. What am i doing wrong?
  22. The Plugin Catalog in the WMC app doesn't seem to properly download files from the server (Testing with EMC 3.0.315.0) . Basically I simply deleted one of my themes and tried to download it again and it basically hangs at installing the theme. This was brought to my attention by a user having issues installing the theme. I tried uploading a new version to the site and all seemed to process well but still it won't seem to download the file and basically just sticks a file with 0 bytes in the \programdata\plugin directory. This is not limited to my themes as I tried to install the backdrop screen saver and the cover screen saver and the same issues occured.
  23. I love the additional subfolders for Movie Extras (eg, Shorts, Scenes, Interviews, etc.)! I would like to propose an additional folder: "Easter Eggs". This would be intended for content that is usually hidden somehow within a DVD/Blu-ray menu (eg, Incredibles 2 Easter Egg List). What would be nifty about having a folder designated for this content is that then perhaps someday someone could write a plugin that would handle this content differently in how it is displayed in Emby apps, somewhat approximating the original experience of hunting for easter eggs in the DVD menu (eg, maybe a movie with easter eggs would display a special icon, and that would clue the user into needing to hunt for a link they could navigate to, but which was hidden somehow, in a similar fashion to how this sort of thing works in DVDs/Blu-rays). Now admittedly this is very much in the "nice, but not necessary" category. But it's a fun idea so I thought I'd put it out there for folks to possibly vote on if they're interested. Also, note that just as with the Galleries folder feature request, I would want this to also be available to TV shows, as noted elsewhere. PS - If this is something you might like to see implemented, be sure to "Like" this top/first post (as well as any subsequent posts in this thread that highlight particular aspects of what you are interested in) -- "Liking" the top/first post helps the Devs to know how much interest there is in a given Feature Request.
  24. Hi, I have a problem with the QNAP Arm64 version (aarch64), my NAS is a TS-328, Versión 3.6.0.84 beta. Using the same folder with an emby server windows 10 the metadata is correct, but in the nas server there is an artist called "Artistes Divers" which includes many albums that do not have that artist. The albums that are included are those that the artist of the album "Various Artists" actually has. It seems somewhat random. I have tried to reinstall emby from scratch and have also created the library several times. In reality the artist "Artistes Divers" only has one album and "Various Artists" has 337 albums. I have tried in Emby server windows 10, Plex and Mediamonkey, this is all correct.
  25. Kimballslice1890

    Convert Media Failed

    After updating to the latest emby server, I have an alert saying convert media failed. Here is the content of that error: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown. at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Sync.SyncRepository.GetJobs(SyncJobQuery query) at Emby.Server.Sync.SyncJobProcessor.EnsureSyncJobItems(String targetId, CancellationToken cancellationToken) at Emby.Server.Sync.SyncJobProcessor.Sync(IProgress`1 progress, CancellationToken cancellationToken) at Emby.Server.Sync.SyncConvertScheduledTask.Execute(CancellationToken cancellationToken, IProgress`1 progress) at Emby.Server.Implementations.ScheduledTasks.ScheduledTaskWorker.ExecuteInternal(TaskOptions options) is this an issue that will impact my experience or server?
×
×
  • Create New...