Jump to content

Search the Community

Showing results for tags 'windows'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. We have a couple of Samsung TVs in the house, which are not very "smart" out of the box. To solve that problem we have installed nVidia Shield devices for each of these TVs. This solved the problems with the built in functionality. Streaming apps are working perfectly now ... with the exception of Emby. The problem is that the Emby client for Android TV cannot manage a server that is in the Sleep State. I'm respectfully requesting for a feature that can manage the sleep/wake state of the Emby Server (in my case the host is Windows 10). This can be done by: - Sending a WOL magic packet to the server when a client requests a video to be streamed (and the server is in the sleep state). - Keeping the server awake during streaming. Really love the Emby server, as it provides many benefits over its competitors, like Plex, but the absence of this feature really limits its usability in the Android TV space.
  2. TKX57

    Audio Books not Joining

    I'm hoping you guys can shed some light on why some of my audio books are not combining. It seems to be pulling the metadata it just isn't joining them into one. It keeps separating them by disc. Here is an example, Both of these are by the same author and named in the exact same format.
  3. This guide will explain how to setup a Windows Server instance of Emby server with IIS as full transparent reverse proxy with SSL offload and auto-renewing certificates via Lets Encrypt. First, What is IIS? IIS or Internet Information Services is the web server service provided with Windows and Windows server installations. It is industry standard technology and is widely supported and regularly maintained by Microsoft. Second, What is a reverse proxy? A reverse proxy will take requests coming into your server (in this case HTTPS on port 443) and route them to a backend application (in this case Emby Server on port 8096 on the same box or another). Reverse proxies are very useful if you only have 1 public IP and multiple services you would like to run on a single port (443, for example is standard secure web traffic) or multiple servers that need to appear as one. Third, Why do I want a certificate for my site from Lets Encrypt? Well, most sites now days are secure (read they encrypt your traffic to prevent people from seeing your data), browsers these days flag sites that are not using properly signed certificate chains or run on insecure ports. If you use a self signed certificate in Emby, you may have difficulty getting things like the iOS app or Roku app to work properly outside your home. (Not sure about the rest of you, but Emby on the kid’s iPad is a life saver for long car rides). Let’s Encrypt provides free SSL certificates that are signed by certificate authorities that will be recognized on all devices and platforms. I will be using Windows Server 2019 with IIS 10 and AAR 3. All of this should work with Windows Server 2012R2 and Windows Server 2016 as well as Windows 10, however there may be some differences. You can use either stable or beta version of Emby Server, however in this guide we will use the stable version. At the time of writing, this guide will get you a full A+ rating from SSLlabs.com security test. (For comparison purposes, Facebook’s rating is a B.) In this guide we will: Install Emby Server Move Emby Server Installation to a non-user-locked location Setup a service user to run Emby Server as Configure Emby Server to run as a service Configure Windows Firewall Install IIS Install AAR Install IIS Rewrite module Configure AAR Configure IIS as a reverse proxy for Emby Configure SSL cypher suites for the server Install the Certify the Web client. Configure Certify the Web for auto-renewing SSL certificate for your domain Note: To be externally accessible, you will need to configure your route/modem to port forward 80 and 443 to your server. Pre-reqs/Assumptions: A physical server or VM running Windows Server An Internet Connection A DynDNS/No-IP URL (or similar routable dns name pointed at your router’s public IP) You have port forwarded ports 80 and 443 through your router to the machine you will use as a reverse proxy (in this guide we will use the same box for the reverse proxy and Emby server, but these can be run on different hosts). You have installed Notepad++ on the machine you will be setting up. Install Emby Server Download Emby Server Run the Installer Click Run when prompted If prompted by smart screen, click run anyway If prompted to install Visual C++ runtime, click install It will install to default location of %APPDATA%\Emby-Server. Move Emby Server to Non-User Locked Location Ensure that Emby Server is not running (right click icon in system tray if present and click Exit) Navigate to default location of %APPDATA% (%userprofille%\appdata\roaming) Right click the folder and click "cut" Navigate to C:\ (or root of the drive you wish to have Emby run from) Right click in the whitespace and paste. (if prompted to provide administrator permission, approve) Create a Service Account to run Emby as Note: Instructions show how to do this using local users and computers, you can also do this with Active Directory Users and Computers if your server is running that role. Right click on the start button (Windows flag) on the left side of the task bar Click Computer Management Expand Local Users and Groups on the left side Click Users Right click the whitespace and click new user Complete the new user dialog as shown (make sure you save whatever password you use as you will need it later, ProTip: don't re-use passwords) Click create Click close Close the computer management window Setup NSSM NSSM (Non-Sucking Service Manager) is needed to run Emby Server as a service as Emby Server does not include the nessicary components to run as a Windows service by default. Download here: https://nssm.cc/download Double click downloaded zip to open it in windows explorer Navigate to /win64 folder inside zip Copy/extract 64 bit version of the file to C:\Emby-Server Setup Folder Permissions Navigate to C:\ Right click the Emby-Server folder Click Properties Click Security tab Click Advanced Click Disable Inheritance Click Convert to Explicit Select CREATOR OWNER Click Remove Select Users (special) Click Remove Click Add Enter SvcEmby in the dialog Click OK Click Full Control Click OK Click Change next to owner at the top of the box Type SvcEmby in the dialog Click OK Check the Replace owner check box Check the Replace permissions checkbox Verify the dialog window looks similar to this (computer name will be different) Click OK When prompted if you want to replace permissions click Yes Verify security tab looks like this Click OK Setup Emby as a Service using NSSM Right click the start button on the left side of the task bar Click Windows Powershell (Admin) Type: "cd C:\Emby-Server" and press enter Type ".\nssm.exe install Emby" and press enter The install service dialog will launch, fill out as follows: Application Tab Details Tab Logon Tab (note, if you are using active directory it should be: YOURDOMAIN\SvcEmby) Exit Actions Tab Click Install Service Click OK Config ure Windows Firewall Click Start Click Control Panel Click Windows Defender Firewall Click Advanced Settings on the left hand side Click Inbound Rules Click New Rule on the right hand side Click Port Click Next Type 80, 443 in the ports box Click Next Click Next Click Next Name it Web Server Ports Click Finish Install IIS (Internet Information Services) Click Start Click Server Manager Click Add Roles and Features Click next on the Before you Begin page Click Role Based install Click Next Verify you are installing on your local server Click Next Check the box for "Web Server (IIS)" When prompted to install management tools Click Add Features Click Next Under Features, click Next Click Next again to get to role services Check the boxes for all of the following role services Make sure you check the box for web sockets under Application Development, this is needed for various features of Emby to work right. Click Next Click Install Once installation completes, click close Install Web Platform Installer add-on Download from: https://www.microsoft.com/web/downloads/platform.aspx Run the Web Platform Installer add-on installer Click Install Click Finish Install AAR (Advanced Application Routing) Download from: https://www.microsoft.com/en-us/download/details.aspx?id=47333 Run the Request Router installer Click Install Install IIS Re-Write Module Click Start Click Administrative Tools Open Internet Information Services (IIS) Manager Click the name of your server on the left Double Click on the Web Platform Installer In the search box type "url rewrite" Click Add Click Install Click I Agree Click Finish Configure AAR Click Start Click Administrative Tools Open Internet Information Services (IIS) Manager Click the name of your server on the left Right Click Server Farms Click Create Server Farm Name your Server Farm Click Next Enter the IP address of the server or "localhost" Click Add Click Finish Click No in the dialog that pops up Expand your newly created Server Farm Click Proxy Configure settings as shown Click Apply Click your Server Click Application Request Routing Click Server Proxy Settings Configure settings as shown Click Apply Click Your Server Configure IIS Server Variables Click Url Re-Write Click View Server Variables Click Add Type "HTTP_ACCEPT_ENCODING" Click OK Click Add Type "HTTP_X_ORIGINAL_ACCEPT_ENCODING" Click OK Click Add Type "HTTP_X_FORWARDED_FOR" Click OK Click Add Type "HTTP_X_REAL_IP" Click OK Click Your Server Create Emby Site Expand Sites on the left hand side Right Click "Default Web Site" Highlight "Manage Website" Click Stop Right Click the white space in the Sites list Click Add Website Click the "..." button to the right of Physical Path Browse to C:\inetpub\wwwroot Click it Click Make New Folder Call it Emby Click OK Under Binding Fill in with your public host name (see dynamic dns mentioned in pre-reqs) Click OK Configure Logging Click your server Click Logging Click Select Fields Click Add Field Configure as shown Click OK Click OK Click Apply Install and Configure Certify The Web client Download From: https://certifytheweb.com Run the Certify the Web installer Click Next Click Next Click Next Click Install Click Finish Click New Certificate Click on on Contact Prompt Fill in your contact email Click Register Contact Click New Certificate again Select Emby from the sites list Name and domain will populate automatically. Click Deployment Configure as shown Complete certificate verification process Click your site in IIS manager Click Bindings Verify there is an HTTPS binding and that it looks similar to this (with your domain information) Edit Web.Config for Emby Site Click HTTP Response Headers Click Add Configure as show (we are just creating a header to get the web.config to exist, we will paste in a premed one below, so these values dont really matter) Click OK Open an Explorer window and Browse to C:\inetpub\wwwroot\Emby Right click web.config and Edit with Notepad++ Replace existing content with web.config below <?xml version="1.0" encoding="UTF-8"?> <configuration> <system.webServer> <rewrite> <rules> <clear></clear> <rule name="Redirect to https" enabled="true" patternSyntax="Wildcard" stopProcessing="true"> <match url="*" negate="false" /> <conditions logicalGrouping="MatchAny"> <add input="{HTTPS}" pattern="off" /> </conditions> <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Found" /> </rule> <rule name="Proxy to Emby" stopProcessing="false"> <match url="(.*)" /> <serverVariables> <set name="HTTP_X_ORIGINAL_ACCEPT_ENCODING" value="{HTTP_ACCEPT_ENCODING}" /> <set name="HTTP_ACCEPT_ENCODING" value="" /> <set name="HTTP_X_REAL_IP" value="{REMOTE_ADDR}" /> </serverVariables> <action type="Rewrite" url="http://localhost:8096/{R:1}" logRewrittenUrl="true" /> <conditions> <add input="/{R:1}" pattern=".well-known" negate="true" /> </conditions> </rule> </rules> <outboundRules> <rule name="Add Strict-Transport-Security when HTTPS" enabled="true"> <match serverVariable="RESPONSE_Strict_Transport_Security" pattern=".*" /> <conditions> <add input="{HTTPS}" pattern="on" /> </conditions> <action type="Rewrite" value="max-age=31536000; includeSubDomains; preload" /> </rule> <rule name="Proxy to Emby" preCondition="ResponseIsHtml1" enabled="true"> <match filterByTags="A, Area, Base, Form, Frame, Head, IFrame, Img, Input, Link, Script" pattern="^http(s)?://http://localhost:8096/(.*)" /> <action type="Rewrite" value="http{R:1}://media.example.com/{R:2}" /> </rule> <rule name="Restore-AcceptEncoding" preCondition="NeedsRestoringAcceptEncoding"> <match serverVariable="HTTP_ACCEPT_ENCODING" pattern="^(.*)" /> <action type="Rewrite" value="{HTTP_X_ORIGINAL_ACCEPT_ENCODING}" /> </rule> <preConditions> <preCondition name="ResponseIsHtml1"> <add input="{RESPONSE_CONTENT_TYPE}" pattern="^text/(.+)" /> </preCondition> <preCondition name="NeedsRestoringAcceptEncoding"> <add input="{HTTP_X_ORIGINAL_ACCEPT_ENCODING}" pattern=".+" /> </preCondition> </preConditions> </outboundRules> </rewrite> <caching enabled="false" enableKernelCache="false" /> <httpProtocol> <customHeaders> <add name="X-Frame-Options" value="SAMEORIGIN" /> <add name="X-Xss-Protection" value="1; mode=block" /> <add name="X-Content-Type-Options" value="nosniff" /> <add name="Referrer-Policy" value="same-origin" /> <add name="Feature-Policy" value="sync-xhr 'self'" /> <add name="Cache-Control" value="no-cache" /> </customHeaders> </httpProtocol> </system.webServer> </configuration> Save changes (if prompted to restart Notepad++ in admin mode allow it and then try saving again) IIS will now be properly configured as a reverse proxy for Emby. Under IIS Manager > Rewrite you should now see the following rules: Configure Server Cyphers Download here: https://www.nartac.com/Products/IISCrypto/Download (GUI version) Run the IISCrypto too Click Templates In the template drop down box, select PCI 3.2 This will disable IIS from being able to serve via SSL 2.0, 3.0; TLS 1.0 and TLS 1.1. This will leave just the industry standard TLS 1.2. Click Apply Click OK. Reboot your server. Emby Internal Settings Navigate to your server via the localhost:8096 address Click the gear in the top right corner Click Network from the list of tabs on the right Configure as shown (use your hostname in the external domain box) Conclusion Upon rebooting your computer will start IIS services and Emby server as a service. Traffic coming in on port 80 (if someone just types your url without HTTPS in their browser's address bar) will be automatically redirected to port 443 and the HTTPS:// version of your host name. Your certificate will auto-renew every so often and re-bind to the site in IIS without any interaction on your part. This allows for a server that you can for the most part setup, and forget about and just manage your Emby installation via its web ui. There are a lot of ways to set up Emby server depending on your environment and other factors. For my environment this made the most sense and since large portions of this took quite a bit of digging and research to get working just right, I figured Id make someone else's life a little easier if they were trying to do something similar. These instructions can be adapted for Windows Server 2012 R2, Windows Server 2016, Windows 8 and Windows 10. In the end browsing to your domain should look like this in the browser Additional Information for Updating When Updating your Emby installation. Simply stop the service for Emby, install like you normally would, then just cut the system folder inside the %appdata%\emby-server folder and paste it into the C:\Emby-Server folder. When prompted replace all files, then start the service again once the copy completes. Additional Information about Connecting with Emby Apps When connecting to your Emby installation remotely with Emby apps remember to prefix your domain name with https:// and use 443 for the port number. <Edit> Additional Information about changing Emby Server Title: For those users who wish to change their page title in browser (as discussed here), here is additional Web.Config information that will let you do just that! Using IIS Re-Write rules to change the page title means, you don't have to edit files to reset it every time you upgrade your Emby Server! Add these 3 rules at the bottom of the rules list, replace whole <preConditions> block too.: NOTE: Make sure you replace ALL 4 instances of NAME_OF_YOUR_SERVER with what you want your server to display in the tab bar. <rule name="RewriteTitle" preCondition="ResponseIsHtml1" enabled="true"> <match filterByTags="None" pattern="&lt;title>(.*)&lt;/title>" /> <action type="Rewrite" value="&lt;title>NAME_OF_YOUR_SERVER&lt;/title>" /> </rule> <rule name="RewriteAppHeaderJs" preCondition="ResponseIsJS" enabled="true"> <match filterByTags="None" pattern="document.title=&quot;Emby&quot;" /> <action type="Rewrite" value="document.title=&quot;NAME_OF_YOUR_SERVER&quot;" /> </rule> <rule name="RewriteAppHeaderJs2" preCondition="ResponseIsJS" enabled="true"> <match filterByTags="None" pattern="title.Name||&quot;Emby&quot;:&quot;Emby&quot;" /> <action type="Rewrite" value="title.Name||&quot;NAME_OF_YOUR_SERVER&quot;:&quot;NAME_OF_YOUR_SERVER&quot;" /> </rule> <preConditions> <preCondition name="ResponseIsHtml1"> <add input="{RESPONSE_CONTENT_TYPE}" pattern="^text/(.+)" /> </preCondition> <preCondition name="ResponseIsJS"> <add input="{RESPONSE_CONTENT_TYPE}" pattern="application/javascript|text/javascript" /> </preCondition> <preCondition name="NeedsRestoringAcceptEncoding"> <add input="{HTTP_X_ORIGINAL_ACCEPT_ENCODING}" pattern=".+" /> </preCondition> </preConditions> </Edit>
  4. Hi all, I came across a strange situation in which i request help. I have running a dedicated W10 Emby server for quite some years now. Version 4.6.4 already. When i first started the server i had a smartphone with Android One running and i was not able to login through remote access. Tried everything even with the help from you guys and eventually we concluded the isp must have something blocked on their end. When it was time to buy a new phone, i bought an android phone again but not from the Android One program. To my happiness i tried to use emby remotely and it worked! Unfortunately i dropped my phone and it broke this week so i bought a new one which is part of the Android One program again and i just found out i am again unable to login remotely. I have not changed any settings from my router, pc and also we now know the isp is also not the problem. I hope someone can shed a light to help me solve this. Thanks in advance everybody.
  5. artatgray

    Collections have disappeared!

    Ever since the latest updates my Collections have disappeared from My Media. How do I restore them, if possible? Thanks in advance, Bill
  6. Py7h0n

    Extremely Slow

    Hi all, I've been chasing a huge slowdown in Emby recently and I am stuck - Not normally one to ask for help! Browsing media takes 10-15 seconds to load images. Clicking play can take the same. It used to be instant! I was running the latest production version when I ran into the problem but then decided to build a new Windows server and try the Beta build to try get around the problem. It has however not helped. Emby is running on a Windows 10 VM Xeon D-1521 - 4 cores presented 8GB ram SSD OS - Tested at ~200-500MB/s Storage is running on Freenas and is fast. Tests from the Windows VM run at ~1000MB/s anytime. Emby accesses the storage over standard SMB File shares EmbyServer has no tasks running, one "Admin" user logged on and is constantly using 15-35% CPU. Nothing in the logs I can see? I have also tried to store metadata with the media to try and speed things up but it has not helped. I do have a lot of data it is looking at - Around 27Tb but this has never been an issue before? This is my last attempt to find a solution before I wipe my installation again and try to piece it together manually vs using my backup to see if that helps. Emby is one of 4 VMs on the same SSD / Hardware. Nothing else is running slow. Any suggestions or things to look at? Thanks!
  7. Emby Server: Windows 10 Version 4.0.2.0 HDHomeRun Connect Firmware 20180817 Emby Clients: LG webOS, Roku, iOS, Android, Windows Chrome Please advise how to manage uncontrolled growth of transcoding-temp file, which apparently will grow until entire disk is consumed.
  8. This is quite an unusual request, I'm asking for a way to name 1 file containing 2 episodes that are not adjacent to eachother For example: S1E01-06 will be episodes 1 THROUGH 6 S1E01+06 will be episodes 1 AND 6 Is that possible?
  9. Good morning, Emby Server has been updated automatically and now the images contained in the monitored folders are no longer visible regardless of the type of library chosen (personal photos and videos - mixed content, etc.). I have already tried to shut down the server and delete the contents of the programdata\cache folder. Do you have solutions?
  10. quisiera saber que características debe tener mi HTPC para tener la mejor transcodificacion en peliculas Full HD cual seria el mejor procesador AMD o INTEL la tarjeta de video tiene algo que ver? tengo una galeria de mas 500 peliculas y tarjetas sintonizadoras de television satelital ... pero tengo problemas con algunas peliculas se escuchan con muy bajo volumen y la imagen y el audio no sincronizan creo que esto se debe a una mala transcodificacion.....!!!
  11. I have quite a lot of shows that have ASS Subtitles in them. But the problem is that when I enable them my server immediately jumps to transcoding. Which sacrifice quite a lot of video quality. I have noticed that It does not do that in the mobile version.
  12. For anyone like me who started off creating their library of media and and deciding at a later date that maybe they want to move the those movies into their own folders, but don't want to manually create thousands of folders, and then manually move the files, you can automate that process with PowerShell (on WIndows). Open up a PowerShell prompt and navigate to the directory with your movies being stored, in my case on a network share. cd \\unraid\media\movies Make sure this command will create a folder for every file in the directory you just navigated to. WARNING, I was lazy when I made this. This will technically create a folder for any object in the folder that has a period in the name. So, if for whatever reason, you already have folders with a period in the name, it will try to create a folder for it as well. If you already have a folder structure with periods, either don't use this or revise the command. Get-ChildItem | Where-Object {$_.Name -Like "*.*"} | Select BaseName | ForEach-Object {New-Item -Name $_.BaseName -ItemType "Directory"} This next command will actually move every item with a period in the name, into a folder of the same name, minus the file extension. So, if you have multiple copies of a movie, with multiple resolutions, or if you keep your metadata in NFO files, ALL of those files will be moved into the same folder. Get-ChildItem | Where-Object {$_.Name -Like "*.*"} | ForEach-Object {Move-Item $_.Name $_.BaseName}
  13. I just bought a new hard drive because my old one was full, I am now in the process of transferring my libraries to the new hard drive. I was wondering if once everything is transferred if there was a easy way to change the Emby servers media library location, without losing all of the data and having to refresh everything and start over like it's brand new. Thanks, Nick
  14. Hi I just installed Emby (4.5.4.0) and can't get the identify function to work. It returns a blank page without results. My folder Structure is D:\Emby\Anime (Movies)\Evangelion 3.0 You Can (Not) Redo (2012)\Evangelion 3.0 You Can (Not) Redo (2012).mkv Automatic identification seems to work. Also, CanYouSeeMe.org doesn't detect my port yet wich is quite strange since I never had any Issues with Plex. embyserver.txt
  15. After installing emby, my emby client app would not connect to the server and after poking around I noticed that several emby entries in the "allowed apps" of the Windows firewall were duplicated. After removing the duplicated entries my client app was able to connect to the server. Today after rebooting my home server, again my emby client app could not connect to the emby server. And again there were duplicates emby entries in the firewall. I removed them and the client app could then connect. As a test, I went to the taskbar tray and close the emby server and manually restarted it: duplicate entries in the firewall were found and the client could not connect to the server. There seems to be a bug with the emby server adding entires to the Windows firewall each time it is restarted.
  16. As the title suggests, I'm having a problem with double versions of the same episodes (not movies but "TV series"). I say "TV Show" because they are "+18 H." (screenshots will be censored for security). The question is simple: In theory they are renamed right. My rule follows this pattern: Show Name - SxxEyy - Release Group Name 1 [TV] + Release Group Name 2 [BD] - OEyyy - Episode Title - Extra Info from original release Ex: [1080p] Where is it: TV if subtitles are present are based on the TV version of the video. OE = Original Episode For example, an OVA that would be episode 25 of a series on TheTVDB is perhaps considered s00e13. By doing so I know that s00e13 is actually ep 25 of the absolute numbering. Wrapped OE is the absolute number of that episode, EX: "One Piece - s21e59 - OPF HD - OE950 - .mp4". Now, that episode of the group "HF", is seen as ep 1 but separate from episode 1 of [80vogliadihentai]: So if I select them and group them (which should merge them into a single entry) I should solve the problem, right? This happens instead: The episode of the group "HF" disappears and if I open the only episode 1 available, it is as before (as a single episode, no choice). Also, I can't even tell him to delete the group because it just isn't created (apparently). Maybe I'm noob I and something wrong? The result I thought I was getting is like for movies (where this problem doesn't arise). I want to clarify one thing, this problem has been present for like 3 4 months, emby updates itself ... So I don't think it's a specific version bug. Thanks in advance
  17. Hello,yesterday I setup emby but on port 80 since my router cant port forward 8096 beause of a security thing everything was working and I added the m3u so some movies appeard on my ip:80 but when I went to the live tv I saw it needed subscription,I bought it. I enterm 3u and when I go on my ip : 80 I see no channels and not any movies anymore how can I fix that? I tried a file/m3u link neither did work Also I tried the iptv plugin but its not stable and also I can only add channels one by one
  18. I have all my photos from my dSLR visible on my Emby install and it appears that something is creating PNG files that are the same size as the source content. The issue here is that the source files are typically 5472 x 3648 (Landscape) or 3648 x 5472 (Portrait). Is there a specific reason why it's creating these files for my images? There's absolutely no better to creating in JPG format -- they're already compressed as JPG. I'd expect to see it generate downsized versions at lower resolutions, not convert 1:1 to PNG and waste disk space. Here's some output from windirstat on my Emby server. The PNG images are eating up a solid 1/3 of my disk space right now. It's completely wasteful and the images end up taking a lot longer to transfer and decode on any end clients. You can see in the second image that they're all named "folder.png" or "landscape.png". Server info: - Windows Server 2012 R2 - Emby 3.2.13.0 - Plugins: Auto Box Sets, Channel Downloader, CovertArt, Email Notifications, Genre Cleaner, IPTV, Revision3, Roku Thumbnails, Rotten Tomatoes Reviews, Server Configuration Backup, Server Restart, Trailers
  19. I recently set up Emby on my PC running Linux so that my mom could easily watch stuff on her Chromecast, and it worked great. I use both Windows and Linux (specifically Pop Os) and today I booted up Windows and configured Emby there too. Everything seemed to be working fine until my mom told me she was unable to get Emby working on her Chromecast (stuck on "Ready to Cast"), which seemed weird because I tried it on mine and worked perfectly. After trying several times, restarting, opening ports, etc., I just decided to try booting the server on Linux, and her Chromecast works now! The only problem is that mine doesn't anymore, so it seems like once a Chromecast connects to an Emby server, if you switch to a different OS and run another server it will refuse to play files. Hope I can get this fixed because it'd be very frustrating if I have to switch to a different OS every time someone wants to use the server.
  20. Quick question that might have a quick response. After setting up a new server, I noticed that whenever I run the "download subtitles" task it always takes over 2 hours. I thought it was normal at first since it was starting from scratch. But it's been a month and it's still taking just as long. When I opened up the log, I did notice a few errors, but I'm completely unfamiliar with it, so I do need some help deciphering it please. I believe the log includes the two times I ran it today. I'm pretty sure this question will come up, but I did sign into my Open Subtitles account (Free account, not VIP) on the dashboard. Here is a link to my log: https://filebin.net/fxsw3xneaqthg1wj/embyserver.txt?t=zt4ilqlz Definitely let me know if I can clarify anything! Thank you as always!
  21. EVDEADSHOT

    Subtitles out of sync

    Hi guys, Loving the work you’ve done. Is there any update on the discussion around the subtitle delay setting? My subs are fine, they play correctly in VLC locally. But when I cast to my tv, all subs play ahead of audio by 4 or 5 seconds. If anyone has any input that’d be appreciated too. But yeah keen to hear what’s happening with the prospect of subtitle delay settings. Thanks.
  22. Hi, A few weeks ago, I renamed all my content according to the convention. I also renamed my moves with the right version (4k/hdr/1080p/x265) at the end. Here's an example: /Movies/Fury (2014)/Fury (2014) - 4K x265 HDR.mkv I've also setup to automatically make a low quality x264 copy for devices that doesn't support hevc or for LTE streaming. I used the "Mobile" Profile at 4Mbps Since then, the conversion took the file but added " -mobile" at the end of it instead of removing whatever is after the Hyphen. Ex: /Movies/Fury (2014)/Fury (2014) - 4K x265 HDR - mobile.mkv instead of: /Movies/Fury (2014)/Fury (2014) - mobile.mkv Then, it proceeded to also make a copy and transcode the new file. Now my directory looks like this: /Movies/Fury (2014)/Fury (2014) - 4K x265 HDR.mkv /Movies/Fury (2014)/Fury (2014) - 4K x265 HDR - mobile.mkv /Movies/Fury (2014)/Fury (2014) - 4K x265 HDR - mobile - mobile.mkv /Movies/Fury (2014)/Fury (2014) - 4K x265 HDR - mobile - mobile - mobile.mkv etc. I'm not sure what I did wrong or what logs you need, let me know and I'll edit this post.
  23. I have been running Emby Server 4.3 using a HP computer running Windows for several months. I plan on using the NVidia Shield as a server and migrating the libraries/ collections/ favourites/ users data etc across. I still would like to keep the library content itself on the HP computer and have NVidia Shield libraries point to the HP machine. I was able to successfully install the server on the NVidia Shield and copy my library. 1. I have an issue with setting up the new folder paths I have tried to follow the "Optional Network Path" guide on your site but still can't get the server to find the folders. My content is stored locally on the HP computer. Existing Setup: Machine Name: HP Drive Name: DRIVE1 (Located On F:) Library Structured As follows: DRIVE1\MOVIES\... DRIVE1\TV\... Existing Movies Library: F:\DRIVE1\MOVIES Existing TV Library: F:\DRIVE1\TV New Setup: I created a shared folder for MOVIES to test. \\HP\DRIVE1\MOVIES (Network path) Emby Library Settings: I tried several things including the following: Folder: Network (Optional) Shared network folder: \\HP\DRIVE1\MOVIES I also tried: Folder: F:\DRIVE1 (Optional) Shared network folder: \\HP\DRIVE1\MOVIES Each time I get the error cannot find path. Can you please advise the correct paths I need to setup. Thanks 2. Is there a way I can permanently disable automatic scans of library. Ideally set into manual scans only. Until I can successfully redirect the existing library paths. As they are cause my existing data to be cleared. 3. At the moment the I have only been able to migrate to the Shields Internal storage which is very limited in size. I have attached an usb stick. And tried to redirect cache, metadata and transcode paths to locations on the stick. A) Do these locations have to located in the auto created folder "NVIDIA_SHIELD". As android is very restrictive as to what folders can be written to. For Example NVIDIA_SHIELD\EMBY\cache NVIDIA_SHIELD\EMBY\metadata NVIDIA_SHIELD\EMBY\transcode b: I was able to copy the folders and adjust the paths inside Emby in order to point to the usb folders. In order to complete the process do I simply just delete the folders from internal storage? I assume Emby doesn't have a library migration functionality like Plex? C) Log files location can't be set so do these automatically delete after a set time or do I need to do this manually. Thanks for your assistance
  24. johnsonb

    Emby under Windows

    Hello. Thanks everyone, very much for your ideas to take Linux Emby and try it out under Windows. I did not have much luck and I think I'll I'll stick with running it under Mint. Bj
  25. hecdanf

    google drive sync

    I have a student account in google drive practically unlimited, I can use that shared drive for emby sync or I necessarily need to use the common drive that only has 15 gb? @@cayars
×
×
  • Create New...