Jump to content

Search the Community

Showing results for tags 'android'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hi, The music sync performance never has been the best of the world, but it wasn't bad. It's sadly to say that since the last version the performance is horrible. Sorry devs, but I had to say it. I love Emby, but the main reasons to migrate my Plex Server was the music sync. I have to clarify that Plex Server is a fucking nightmare with offline music and Emby is the better option to do this actually. So, I have a list with the main problems with offline music: Not real sync. When Android App die and start again, songs download several times and is necessary to use third party software to clean duplicate files to save storage. When you try to sync playlist or collection with so many songs (500 or more is enough to start the party xD), server and client (android app) goes crazy/slow. Many times, sync process is blocked by a single song. My workaround is edit sync object, delete the blocked song and wait server refresh that song again to include in sync object. After this, sync process start again in some moment, not immediately. I have to clarify that my devices (server and phone) are very powerful: Phone: OnePlus6 (8GB RAM, 8 cores, 128GB internal storage) Server:Dedicated server (bare-metal) in professional hosting. Debian 9 Intel® Xeon® CPU W3520 @ 2.67GHz 16GB RAM Emby is running using Docker (18.06.1~ce~3-0~debian) Attaching my personal sync objects. As always, thank for your support.
  2. Hi, I am developing an android app using Xamarin in visual studio. I am re-using code from my c# windows application that I know is working, but in android I am getting a null object exception that I am not able to trace. Anyone more than me that is using xamarin and android? The code is simple: // Developers are encouraged to create their own ILogger implementation var logger = new NullLogger(); // This describes the device capabilities var capabilities = new ClientCapabilities(); // If using the portable class library you'll need to supply your own IDevice implementation. var device = new Device { DeviceName = "MyDeviceName", DeviceId = "11" }; // If using the portable class library you'll need to supply your own ICryptographyProvider implementation. var cryptoProvider = new CryptographyProvider(); var client = new ApiClient(logger, "http://192.168.0.100:8096", "My client name", device, "11", cryptoProvider); try { var authResult = new MediaBrowser.Model.Users.AuthenticationResult(); authResult = await ApiClientHandler.GetApiClient().AuthenticateUserAsync("usernamexxx", "passxxx"); // Report capabilities after authentication await ApiClientHandler.GetApiClient().ReportCapabilities(capabilities); } catch(Exception e) { string x = e.ToString(); } Singleton to get the api client: (Embyclient derives from api client with a couple of extra methods... public static EmbyClient GetApiClient() { if (_apiClient == null) { var device = new Device { DeviceName = "asdf", DeviceId = "My Device Id" }; var logger = new NullLogger(); // If using the portable class library you'll need to supply your own ICryptographyProvider implementation. var cryptoProvider = new CryptographyProvider(); _apiClient = new EmbyClient(logger, "http://192.168.0.100:8096", "asdf", device, "asdf", cryptoProvider); } return _apiClient; } exception is thrown on this row: authResult = await ApiClientHandler.GetApiClient().AuthenticateUserAsync("usernamexxx", "passxxx"); And is working perfectly in my windows app. {System.NullReferenceException: Object reference not set to an instance of an object. at Emby.ApiClient.Net.HttpWebRequestFactory.Create (Emby.ApiClient.Net.HttpRequest options) [0x00070] in <adca890d653b4bfd8613ba04b19aa10a>:0 at Emby.ApiClient.Net.HttpWebRequestClient+<GetResponse>d__10.MoveNext () [0x0003b] in <adca890d653b4bfd8613ba04b19aa10a>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in <43dbbdc147f2482093d8409abb04c233>:0 at Emby.ApiClient.Net.HttpWebRequestClient+<SendAsync>d__13.MoveNext () [0x00073] in <adca890d653b4bfd8613ba04b19aa10a>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in <43dbbdc147f2482093d8409abb04c233>:0 at Emby.ApiClient.ApiClient+<SendAsync>d__30.MoveNext () [0x0009d] in <adca890d653b4bfd8613ba04b19aa10a>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in <43dbbdc147f2482093d8409abb04c233>:0 at Emby.ApiClient.ApiClient+<PostAsync>d__94`1[T].MoveNext () [0x0010f] in <adca890d653b4bfd8613ba04b19aa10a>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter`1[TResult].GetResult () [0x00000] in <43dbbdc147f2482093d8409abb04c233>:0 at Emby.ApiClient.ApiClient+<AuthenticateUserAsync>d__89.MoveNext () [0x0012a] in <adca890d653b4bfd8613ba04b19aa10a>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <43dbbdc147f2482093d8409abb04c233>:0 at System.Runtime.CompilerServices.TaskAwaiter`1[TResult].GetResult () [0x00000] in <43dbbdc147f2482093d8409abb04c233>:0 at EmbyManager.Fragments.FragmentSeenShows+<NewMethod>d__7.MoveNext () [0x000b9] in C:\Users\jorge\source\repos\EmbyManager\EmbyManager\Fragments\FragmentSeenShows.cs:145 }
  3. Hey Guys, Its been about 3 or 4 months since I enquired about Android TV Source, and it's disappeared again? Please advise.
  4. I didn't see this reported anywhere, so here it goes: When I click on an album, and then on the (big) play button/triangle, only the first song plays. To play the whole album, I have to play the first song instead. Seems kinda backwards to me.
  5. tinskip

    OSS Contributions

    Hi. I'm a Plex refugee who is looking to contribute to an OSS media server platform so that instead of waiting for features I feel are important, I can be a bit more proactive. Is Emby Open Source? I see there is a GitHub repository (https://github.com/MediaBrowser/Emby) with GPL licensing. It doesn't seem to have recent contributions, however. I'd be interested in contributing to the Server, and the Android mobile and TV apps. Thanks!
  6. Hey everyone, first post here, hoping to get some help with this issue. Getting ready to pull the trigger on Emby Premier as I have been way happier with it over Plex aside from a single issue I have ran across (below). So currently for whatever reason my audio is consistently always out of sync with my video on my Emby for Android app. Although when playing back the same files on a PC through the web client it's perfectly in sync. The audio happens just before the video on the Android apps though, it's consistent, doesn't change when paused/unpaused or anything like that, it's almost exactly the same amount of out of sync. I've been browsing this topic for about 3 days now trying to find a solution and can't figure it out. Below is a list of stuff I have tried so far. Also keep in mind I haven't tried any other apps yet (don't easily have the ability too) such as Roku and the like so maybe it's an app thing and not just Android only. -Restart server (both Emby server, and the physical server) -Restart phones -Try other phones -Try local network and 4G LTE -Tried direct playback rather than transcoding Other Details: -Files are all .mp4 -Server is Windows 10 -PC Playback (which works fine) is Windows 10 -Android version is Oreo -Phones are BlackBerry Key2, and Samsung Galaxy S8+ -Files are perfectly in sync when played on the server directly (via VLC) -System specs (that matter) of the server are AMD Threadripper 1950X 16 Cores, 64GB of RAM, and SLI GTX 1080tis, so I don't think lack of power could possible be the issue -LAN is all through Google Wifi, doubt this would matter as one PC plays back through wifi fine so it's not like a wifi issue -Footage is in varying resolutions from 1080p to 4K all with the same issue If anyone here has any other ideas that would be great.
  7. When listening to music while also having Google Maps speak turn-by-turn directions the music is played over the directions. Instead Emby should duck the audio so that I can clearly hear the GPS.
  8. When playing music, the app shows a notification (presumably because the app is using a ForegroundService). The only way to stop the Service is to click the notification (or nav back to the app manually), then click the play list button, then click stop. It would be much easier if there was a stop button right in the notification.
  9. On a fresh install of Emby Server 3.5.2.0 on Windows 10 I'm unable to access my test media library via DLNA. WIth an iPhone (iOS 11.4.1) none of the apps I've tried that claim to support DLNA detect an Emby DLNA stream (Glider, Nplayer, 8player). Invoking refresh a billion times on the apps hasn't helped. Likewise on an Android tablet running BubbleUpnP. These apps/devices do see and access files on another DLNA server on the network. In Emby Server I have checked "Enable Dlna server" and "Blast alive messages," and I've tried knocking the Alive message interval way down to make sure blasting happens during my refresh attempts. I've restarted the server. Port 1900 is open. Emby otherwise works (I think). I can access the test library from the iPhone via Chrome at the server URL* The Emby app looks ok but I'd like the flexibility to use alternative apps via DLNA and I hope to use a receiver I have that has decent DLNA support as well. I can't find any basic guide to using DLNA with Emby--has anyone written one? The wiki shows "coming soon" in the DLNA section, but is there a 1-2-3 somewhere else that I'm missing? Log file attached. -Steve *Off topic, but just in case there's a quick fix: AAC files won't play via iPhone browsers (Chrome or Safari). I get a "Playback Error -- No compatible streams..." message on the phone. The Emby iPhone app seems to play the AAC streams but I haven't paid for it yet. Vorbis and mp3 files do play. Any suggestions for browser playback of AAC? Emby server log sc 2018-08-11.txt
  10. MayorRAZZ

    Unnecessary Transcoding H.264>H.264

    Server knows that the device is eligible for direct play according to the logs but only gives transcode options anyway. server: custom build x86 hardware ubuntu 18.04 emby 3.4.1.0 athlon 5350 emby runs from behind a nginx proxy (if deemed necessary will post configurations) client: sony xperia z3 android 6.0.1 snapdragon 801 (hevc supported) same result for my samsung my s7 edge, transcode options are set to default. logs included but cut first post here thank you in advance Log server cut.txt log transcode cut.txt
  11. Hey all. I'm having a problem with syncing to an android tablet. First, its actually a fire tablet that I've sideloaded the emby app onto. Second, and the biggest problem, is that the server doesn't appear to do any conversion, even though in the interface I choose the 4mbps option. The original file is always copied. I've attached what I think is the relevant portion of the log file. It doesn't seem that anyone else appears to be having this problem, so I wonder if I'm just doing something wrong. Thanks. EmbyLog.txt
  12. Hi all, I've been using emby for a while now and one of my use cases was transferring music onto my phone. Since upgrading to 3.4.1.0 some of the files no longer transfer. They just remain "Transferring" in the Sync view and show up in the sync notification on Android in a loop. It's always the same files (some 20 out of 3000) as if the server couldn't read them. The only error I could find: 2018-07-05 09:01:34.049 Error App: Error sending web socket message SyncJobs *** Error Report *** Version: 3.4.1.0 Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb Operating system: Unix 3.14.1.64 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 24 Program data path: /var/lib/emby Application directory: /opt/emby-server/system System.FormatException: Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx). at System.Guid.GuidResult.SetFailure(ParseFailureKind failure, String failureMessageID, Object failureMessageFormatArgument, String failureArgumentName, Exception innerException) at System.Guid.TryParseGuidWithNoStyle(String guidString, GuidResult& result) at System.Guid.TryParseGuid(String g, GuidStyles flags, GuidResult& result) at System.Guid..ctor(String g) at Emby.Server.Implementations.Library.UserManager.GetUserById(String id) at Emby.Server.Sync.SyncRepository.GetJobs(SyncJobQuery query) at Emby.Server.Sync.SyncManager.GetJobs(SyncJobQuery query) at Emby.Server.Sync.Api.SyncJobsWebSocketListener.GetDataToSend(WebSocketListenerState state, CancellationToken cancellationToken) at MediaBrowser.Controller.Net.BasePeriodicWebSocketListener`2.<SendData>d__18.MoveNext() System.FormatException at System.Guid.GuidResult.SetFailure(ParseFailureKind failure, String failureMessageID, Object failureMessageFormatArgument, String failureArgumentName, Exception innerException) at System.Guid.TryParseGuidWithNoStyle(String guidString, GuidResult& result) at System.Guid.TryParseGuid(String g, GuidStyles flags, GuidResult& result) at System.Guid..ctor(String g) at Emby.Server.Implementations.Library.UserManager.GetUserById(String id) at Emby.Server.Sync.SyncRepository.GetJobs(SyncJobQuery query) at Emby.Server.Sync.SyncManager.GetJobs(SyncJobQuery query) at Emby.Server.Sync.Api.SyncJobsWebSocketListener.GetDataToSend(WebSocketListenerState state, CancellationToken cancellationToken) at MediaBrowser.Controller.Net.BasePeriodicWebSocketListener`2.<SendData>d__18.MoveNext() Any idea what could be happening? The files do have the "+" character in their name, some also have quotes, but other files like that sync fine. Where do I look for clues? Thanks!
  13. I have install emby for mobile version 2.9.92 When i play any video ,movie all play in like paint or poster mode color not clear all faded check my attached images. I also try in other phones after install emby videos play normally. Last thing in chrome web mode in my phone videos play normally
  14. Hi, I would like the Latest TV logic to be improved to only show tv series which are continuing, not ended. To vote for this, please like this post.
  15. hi ok i am looking for some info what are the best Android TV boxs ? that work well i know about the nvidia Shield but it is too pricey i have tried lots of boxs and most work well but they all have the same problem in that the TV guide is not displayed properly and it does not look like it will be fixed anytime soon. i am looking for tv boxs that the TV guide is displayed properly thank you Emby is the best
  16. Hi, With the progression of Emby I am surprised there is still no function to set a TV series as currently being watched/followed. This is a much needed function. This would also tie in with the watched function, so only unwatched items from series currently being watched would appear in Next Up. To vote for this feature, please like/upvote this post.
  17. First let me start off by saying the new theme music integration for the Android TV app is amazing... Thanks for this, it works flawless! I was holding off on doing theme music until this happened. So, started applying themes today and testing on different devices.... IOS, Android Phone, PC, Android TV. And I noticed a few things. 1. On IOS, Android and the Web interface, once you go into a TV series and the music starts playing it will not stop if you go back out. So if I hit the back button at the top to go back to my series list its still playing, unless I hit the home button, go into another series or start a video. Granted, I can always hit the pause button at the bottom to stop it if I need to, but I feel like going out of the series should stop it like it does on the other devices. 2. It works perfect on the android TV app and Emby theater. Is the way it works on IOS, Android, and the web interface expected for now? Thanks,
  18. I just bought an emby lifetime subscription today and I can't get any of the android apps to work. I can log in fine to Web Gui, Emby Theater, Kodi work (although EmbyCon is extremely slow and part of the reason I want to use the apps). I bought this subscription mostly to use the apps so I'm currently feeling like I wasted money. I can log into each of the apps (Fire TV and Android Phone). I have used my reverse proxy using apache, direct https and direct http ports and I can sign in using all of them but when I try to select something to play it just sits there. Although sometimes it seems I can get a SSL Handshake Error and other times it seems like it's not even recognized. Any ideas on what could be wrong? I have attached a couple server log.
  19. Good afternoon! Yesterday I tried to setup my very first media server, with Emby! I think i have setup everything right now but unfortunately the quality on my android mobile phone and tablet aren't good. I have set this on auto. Can somebody help me with this? Some info about the movie file: Container: mkv Bitrate: 2,7 Mbps Video codec H264 High Video bitrate: 2,7 Mbps Audio codec: AAC HE-AAC Audio bitrate: 320 Kbps Audio channels: 6 Audio Sample ratte: 48000 Hz This is the Emby streaming video quality: This is the local quality: I just checked my internet speed, this is: 36 ping 180 Mbps downloading 18 Mbps uploading Does anybody know how i can fix this? log 06-05.txt Log Planet earth.txt
  20. My chromecast does appear, however when I select it, the emby interface just spins for a bit (the multicolored spinning circles), and the device seems to respond, but then fails. I've been using it for about a year now without issues but it failed over the weekend. I used it on Saturday (March 10th) without any issues and it wouldn't work at all on Monday evening until now. My chromecast is not what I would consider a typical chromecast device. It's a Vizio M50 smartTV, which actually has a chromecast built into it (ie not a dongle that just plugs into it). I have tried from the chrome browser on my MacBook Pro (web interface), an Android tablet (admittedly running an older version of android), an iPhone 6s and an iPhone 5s, all of which are using the newest released version of the app of their respective systems (Android and iOS). They all do the exact same thing. If the TV is powered off, starting chromecast will trigger the TV to power on (which is as it should, and is really nice), and normally it would then show an information screen that corresponds to what I'm looking at in the app, however the TV just shows a black screen. After about a minute the spinning circles stop on emby and the TV goes to the google wallpapers (a default when you don't give it anything to cast). I have power cycled the TV (completely unplugged it from power), the computer that emby server is running on (windows 10; full system reboot), the router (also full power removal), and all of the devices I've tried. Other than that, emby does seem to be functioning, meaning that it will play in the browser or app on all of the devices listed, it just won't cast it. I think I'm in the correct place as it doesn't seem to be tied to any one device or app. I do not believe I changed any settings between Saturday and Monday in emby or on any of my devices. My log files are attached, in which I replicated the issue at least twice. I did enable Debug Logging before I tried it the second time. I think this is the correct location of the forum as it doesn't seem to be related to playback or the apps, just to the chromecast functionality itself. Feel free to move it or ask me to post if it's not
  21. So for a while now I just thought maybe the file format or transcodeing of the video was not able to be played back on some of my devices. Playback of any content using the android emby app on my galaxy S8 or S8+ doesn't play. I get the "No compatible streams are currently available. Please try again later or contact your system administrator for details." I have tested Samsung tablets, Galaxy S7, Note 5, and other android. They all are able to play back the same media. So could this be a phone compatibility issue? Maybe the 18.5 by 9 aspect ratio has something to do with it. I am not to sure. App version is 2.9.92 and the server is 3.3.1.0.
  22. Hi all, i have 4 android devices that worked fine with android I think half a year ago. Now I have the problem that only one device is still working correctly. On all other devices the screen of the conected TV changes to black after showing the background picture of the movie instead of playing it. I allready tried to connect via http instead of https with no better result. I think it cannot be a conection problem, since all devices are in the same network and and it works since the stream starts. The working device is HTC One Max with android 5.0.2 Not working devices are: - Samsung Tab SM-P600 with android 5.1.1 - HTC U11plus with android 8.0.0 - a no name tablet which I cannot find at the moment ... ^^ Attached you will find the normal logfiles. Last try was from the not working U11plus. If you need logfiles in debug mode please ask. Best regards laotze Server.txt fmpeg-remux.txt
  23. When I go to play an album on my phone, it gets pretty jittering since it's streaming it, without much of a buffer. It also doesn't buffer/sync ahead, so this makes it very internet-sensitive. I would really love it, if that when I play an album it syncs the whole album, or whole "scope" of what I told it to play. Syncs it to the phone. This way as my internet fluctuates, it buffers a-head. If there is some way we can set (on the client/phone) how far a-head it syncs based on Wifi/Cellular I think that would be rad too. Say X number of songs if you're on Cellular, Y if you're on wifi (with the option for unlimited for either). As for other forms of multimedia, this may be helpful, but I'm not 100% sure how that would translate to video content... Thoughts?
  24. EveraldoCunha2018

    Chromecast on Android 4.2

    i'm having a problem with the last version of emby app from android 4.2.2, i have a 2 gen chromecast and he don't appear on the device list...is a tablet SMT110, but on chrome browser, both desktop and android, my chromecast appear. sorry for my english, i'm brazilian.
  25. Hi Since a while the sync progress of my music library is stuck (at around 60%). Every scheduled sync I can see the notifications for the missing files, but they won't download. Here's a part of the log which shows a NullPointerException for one of the files. In the music folder there are currently 32 "Various_Artists (some number)" folders. Wed Jan 03 17:23:42 GMT+01:00 2018 Saving media to Emby_Home/Music/Various_Artists/Sucker_Punch__Original_Motion_Picture_Soundtrack/Disc_1_-_1_-_Sweet_Dreams__Are_Made_of_This_.flac Wed Jan 03 17:23:42 GMT+01:00 2018 Save file directory: /Emby_Home/Music/Various_Artists/Sucker_Punch__Original_Motion_Picture_Soundtrack Wed Jan 03 17:23:42 GMT+01:00 2018 Save file name: Disc_1_-_1_-_Sweet_Dreams__Are_Made_of_This_.flac Wed Jan 03 17:23:42 GMT+01:00 2018 Save file mimeType: audio/flac Wed Jan 03 17:23:42 GMT+01:00 2018 ensureDirectory treeUri: content://com.android.externalstorage.documents/tree/primary%3AEmbySync Wed Jan 03 17:23:42 GMT+01:00 2018 ensureDirectory: /Emby_Home Wed Jan 03 17:23:42 GMT+01:00 2018 ensureDirectory new treeUri: content://com.android.externalstorage.documents/tree/primary%3AEmbySync/document/primary%3AEmbySync%2FEmby_Home Wed Jan 03 17:23:42 GMT+01:00 2018 ensureDirectory: /Emby_Home/Music Wed Jan 03 17:23:43 GMT+01:00 2018 ensureDirectory new treeUri: content://com.android.externalstorage.documents/tree/primary%3AEmbySync/document/primary%3AEmbySync%2FEmby_Home%2FMusic Wed Jan 03 17:23:43 GMT+01:00 2018 ensureDirectory: /Emby_Home/Music/Various_Artists Wed Jan 03 17:23:44 GMT+01:00 2018 ensureDirectory createDocument tree:content://com.android.externalstorage.documents/tree/primary%3AEmbySync/document/primary%3AEmbySync%2FEmby_Home%2FMusic name:Various_Artists Wed Jan 03 17:23:44 GMT+01:00 2018 Error sending request java.lang.NullPointerException com.mb.android.sync.data.AndroidFileRepository.ensureDirectory(AndroidFileRepository.java:238) com.mb.android.sync.data.AndroidFileRepository.saveFile(AndroidFileRepository.java:148) com.mb.android.sync.data.LocalAssetManager.saveMedia(LocalAssetManager.java:77) com.mb.android.sync.server.mediasync.MediaSync$3.onResponse(MediaSync.java:259) com.mb.android.sync.server.mediasync.MediaSync$3.onResponse(MediaSync.java:245) com.mb.android.apiinteraction.RequestHelper.getResponseStreamInternal(RequestHelper.java:139) com.mb.android.apiinteraction.RequestHelper$2.run(RequestHelper.java:61) java.lang.Thread.run(Thread.java:764) Wed Jan 03 17:23:44 GMT+01:00 2018 Error downloading item java.lang.NullPointerException com.mb.android.sync.data.AndroidFileRepository.ensureDirectory(AndroidFileRepository.java:238) com.mb.android.sync.data.AndroidFileRepository.saveFile(AndroidFileRepository.java:148) com.mb.android.sync.data.LocalAssetManager.saveMedia(LocalAssetManager.java:77) com.mb.android.sync.server.mediasync.MediaSync$3.onResponse(MediaSync.java:259) com.mb.android.sync.server.mediasync.MediaSync$3.onResponse(MediaSync.java:245) com.mb.android.apiinteraction.RequestHelper.getResponseStreamInternal(RequestHelper.java:139) com.mb.android.apiinteraction.RequestHelper$2.run(RequestHelper.java:61) java.lang.Thread.run(Thread.java:764) I've tried to create another file with the name stated in the log and I've copied the file from the share to the same location with TotalCommander, both were successfulll. My phone currently is on Android 8.0 but the issue was already there earlier. The corresponding server log doesn't seem suspicious: 2018-01-03 17:23:27.845 Info HttpServer: HTTP Response 200 to 192.168.2.217. Time: 1ms. http://192.168.2.11:80/mediabrowser/users/58cb54c946614d26a0ba47130662c54a?format=json 2018-01-03 17:23:27.883 Info HttpServer: HTTP POST http://192.168.2.11:80/emby/Sync/Data?format=json. UserAgent: Dalvik/2.1.0 (Linux; U; Android 8.0.0; ONEPLUS A3003 Build/OPR6.170623.013) 2018-01-03 17:23:27.946 Info HttpServer: HTTP Response 200 to 192.168.2.217. Time: 62ms. http://192.168.2.11:80/emby/Sync/Data?format=json 2018-01-03 17:23:27.952 Info HttpServer: HTTP GET http://192.168.2.11:80/emby/Sync/Items/Ready?TargetId=6482367051939149&format=json. UserAgent: Dalvik/2.1.0 (Linux; U; Android 8.0.0; ONEPLUS A3003 Build/OPR6.170623.013) 2018-01-03 17:23:28.555 Info HttpServer: HTTP Response 200 to 192.168.2.217. Time: 602ms. http://192.168.2.11:80/emby/Sync/Items/Ready?TargetId=6482367051939149&format=json 2018-01-03 17:23:28.683 Info HttpServer: HTTP GET http://192.168.2.11:80/emby/Sync/JobItems/9bd0374494024d8d8b2d1d26300e4f66/File. UserAgent: Dalvik/2.1.0 (Linux; U; Android 8.0.0; ONEPLUS A3003 Build/OPR6.170623.013) 2018-01-03 17:23:28.862 Info HttpResultFactory: Transmit file \\synologymedien.home\musik\Musik\Various Artists\Sucker Punch - Original Motion Picture Soundtrack\Disc 1 - 1 - Sweet Dreams (Are Made of This).flac 2018-01-03 17:23:30.266 Info HttpServer: HTTP GET http://192.168.2.11:80/emby/Users/58cb54c946614d26a0ba47130662c54a/Views. UserAgent: Mozilla/5.0 (Linux; Android 8.0.0; ONEPLUS A3003 Build/OPR6.170623.013; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/63.0.3239.111 Mobile Safari/537.36 All affected files seem to have Various Artists as album artist. The app (verson 2.9.76) and the server (version 3.2.60.0) are on the current stable release, but the issue was already present in earlier versions. Do you have an idea how to fix this? Thanks a lot 2fc2084b-2b32-4c2e-a6d4-e7905418cdc1.log server-63650534400.txt
×
×
  • Create New...