Jump to content

Search the Community

Showing results for tags 'Metadata'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hi, I have 2 tv-shows in my library that somehow doesn't get metadata downloaded. If I go into Metadata Editor (both for the show, season and episode) I can see that Emby has the right ID for the show on thetvdb.com and IMDB, which both has at least some text descriping the specific episode. But the text doesn't get downloaded into Emby. The shows are named like "show name S01E01 episode name", but I have tried without episode name which didn't make any difference. The episodes are located in a folder named "Season 1" which in turn are located in a folder named "show name". I have tried to look at the log files, but as I don't know what to look for it is not easy. Does anyone has any idea on how I can fix this issue?
  2. quackpipe

    Common Sense Media ratings

    You have critic ratings and tomato meter, it would be be nice to see a Common Sense Media age rating. Or an option to turn it on or a plugin to enable it. Thanks!
  3. I am wondering what is the use of this people slot for each artists, as why would one add a composer or writer directly under an artist's metadata but not within the song's one. Also, I tried to add a person by typing his name but the dialog just closes after I push the Enter button, and nothing shows up under people. Any help is appreciated, thanks!
  4. the-dumb1

    Bulk Meta Data Editor

    I mentioned it in another thread, but thought I'd put it here since this looks like a new section--just for posterity. Would like to have a bulk meta data editor function. For example, if I have 750 videos whose producing studio is the same, I want to select those videos and apply the name of the studio to those videos. Similarly, if there is a custom tag I want to apply to a subset of those movies, I want to be able to select them in bulk and apply the tag to those videos (instead of selecting them one by one).
  5. Greetings, I've updated the embedded images for an audiobook album with Picard, but I can't seem to get emby to see the change. In Picard, you can see I've updated the embedded image for the whole album in the bottom right corner: Yet in emby, it still shows the old embedded image: There are no images like `cover.jpg` or anything like that in the album folder. I'm only sourcing from the embedded images for the album. I only have external image fetchers enabled for artists: On songs, I only have the image extractor enabled: Here are some of the things I've tried: I tried refreshing Metadata with replace images checked on: the entire audiobook library, the album, every individual file within the album I tried removing the album and readding it I tried deleting my entire audiobook library, then readding it. Because I've tried deleting and readding it, I'm assuming some sort of cached image keeps getting reused. Is there some way to prevent that? Or to clear out that cached image? I tried `Vacuum the database on the next Emby Server startup`, but that didn't seem to help at all. Any help would be appreciated. I've been pulling my hair on this one for a couple hours now... embyserver.txt
  6. I am really struggling and need some help. I am trying to set up a large collection of fitness videos in Emby (and Jellyfin and Plex for that matter) and struggling badly. Tvdb does not support fitness videos. Luckily moviedb does, one must enter each workout as a "movie" and tag it is a "video." This works, it downloads a nice poster, but it also pulls down the long file name (e.g. A Little Obsessed - Day 5 Legs) - see Figure 1. Because the rules at moviedb are that each "movie" must contain the series name first, and the workout name second, titles are very long, and they get cut off- so each video is labelled "the same" (see FIgure 2). On the other hand, if I embed the shortened title (eg. Day 5 Legs) in the metadata of the .mp4 and then in Emby select "prefer local metadata" and NO fetchers/agents, I get what I want - nice readable titles - except I don't get the nice poster (only a random segment of the video as a still). Or I can start with that, but as soon as I choose "identify" (or match in Plex) it pulls down the poster and the long title - for the ones that I do that for (see Figure 3). How can I fix this? I have too many videos to update the record for each video in Emby- I am looking for a solution that will work across the board (in part because I am experimenting in Windows but my final server will be on my Nvidia shield- once my disk drive/files/etc are all set up properly). Please help! Suggestions welcome! At one point I tried altering the title with .nfo files, but then it didn't stick- the system used the .nfo file to identify the video, and then pulled down the full poster and long title, and overwrote the .nfo file! (Arrghghg).
  7. If I add new movies to Emby the movie metadata isn't downloaded directly. If I manually Identify the movie only some metadate (like Images and Title) are fetched. Other metadata (like Plot and Actors) are not downloaded. I only use TMDB as metadata provider. For example I tried the movie Independence Day (1996). The complete metadata of this movie is available on TMDB, but it's not downloaded completely:e I also appended the Logs ("CompleteLog.txt") and already identified a relevant section ("RelevantLogSection.txt"). Emby reports an Error in TheMovieDB that states: I already restarted my NAS (Synology DS 220+), restarted Emby (Version 4.7.4.0), tried different movies and used the Refresh Meta button. In Addition the metadata fetching was possible until yesterday. RelevantLogSection.txt CompleteLog.txt
  8. Hi - I'm experiencing an unusual problem associated with reading Metadata updates. I'm running Emby Server with a PPTP/VPN server and NGINX reverse proxy server. In general Emby works as expected (remote connections to the server and streaming are all possible) but for some reason, when connected to the VPN Metadata updates (and I think EPG updates) cannot be read. I've tested this and the problem is repeatable. When the server is connected to the internet via the VPN connection Metadata updates and searches cannot be read, when connected to the local ISP internet provision then Metadata updates can be read. I've attached the error log which may give some indication as to the source of the problem. I'm confident it isn't a Firewall problem and I've checked routing for both Ports 8096 and 8920. I'm fairly confident the problem is something to do with the interaction between the NGINX server and the VPN connection. I'd welcome any suggestions from folk as to how I might fix this problem . Thank you. embyserver(3).txt
  9. Hi, so i reorganized my YT Backup/downloaded library to include more metadata. I am basically using <Videotitle> - <Uploaddate> - <YTVideoid>. but instead of registering for example 2022-05-14 as full date it detects it as from the year 20220514. Any idea how to fix it or define certain positions in the file name as year / month / day bc when you count the letters from the back of the file name the yt id is 11 characters on every video then space - space and then the date Regards :)
  10. mengoshmink

    Synology + Docker + Emby + Metadata

    Hi guys, for reasons not worth explaining here I am currently without my dedicated server hardware. So I decided to install Docker to my Synology NAS and install the Emby image. My reasons for using the Docker Emby image and not the native Synology Emby app are various. DSM 6.2.4-25556 Update 2 Docker 20.10.3-0554 Emby latest (4.7.0.9) When I entered my premier key I got an error. After a bit of digging I found that if I turned off my Synology firewall then the key worked fine. Not ideal but to turn off the firewall for a few seconds while my premier key is validated and verified is not a deal breaker. What I found next is that when scanning my video library it doesn't download any metadata unless the firewall is off. I've tried a few different firewall rules but to no avail. Does anyone here have any ideas or the answer? Many thanks in advance! Container Log emby-1.html Container Settings emby.json embyserver.txt
  11. I am changing my home Emby server from an Ubuntu based .deb package installation to a Docker setup. I did not realise that you could keep all the metadata, images and subtitles in each Movie or TV Show folder. Is it possible to wave a magic wand and copy all the current metadata, images and subtitles (gathered over the years!) to each of the Movie or TV Show folders when I install Emby using Docker? I guess this is Docker independant and it would be best to do this operation before the change to Docker? /var/lib/emby/metadata/ --> /srv/storage/Emby/Movies/Movie Name (YEAR)/Movie Name (YEAR).nfo etc I await your magic wand. Paully
  12. Skyobliwind

    Pictures from Fanart just grey

    Starting a few days ago all pictures from fanart ar just shown in grey. Updating the FreeNas plugin to the newest available version didn't change anything. It happened from one day to the other without changes on the system. Did fanart make changes on their api side or something? Other sources work fine. Problem seems to only occur with different series. No problem with films. (See attached Screenshot).
  13. I've got some shows with sentence-long file names which are picked up in the web interface but with no metadata and without the ability to play them back on clients (tested on Android and TV version). I've enabled LongPathEnabled in the registry, which leads me to believe that there might have something to do with Emby. Is this something that can perhaps be fixed on your side?
  14. Emby Server on Windows 10 (v 4.6.7.0) After adding Moon Knight (https://thetvdb.com/series/moon-knight) the first episode is available with the title in Emby as "TBA". No matter how many times I try and refresh all metadata on the episode, series or whole TV show it remains at "TBA". TVDB is the first metadata provider for the TV Shows library and it has the correct name for the episode. The filename even has the name of the episode in it. The metadata is NOT locked (first thing I checked). I had this before with Book of Boba Fett and had to edit the metadata manually but thought it was an isolated case. The server log only shows ffprobe.exe refreshing the episode thumbnail and coverart doing it's thing (CoverArt: image enhance of Moon Knight took 0.016 seconds.) I even deleted the metadata nfo file and refreshed the episode, and it recreate the file with TBA in the details: <?xml version="1.0" encoding="utf-8" standalone="yes"?> <episodedetails> <plot><![CDATA[Steven Grant learns that he may be a superhero, but may also share a body with a ruthless mercenary.]]></plot> <outline /> <lockdata>false</lockdata> <dateadded>2022-03-31 00:22:13</dateadded> <title>TBA</title> I've run out of troubleshooting ideas now!
  15. Hello everyone, I'm having an issue with metadate images for actors, I have tried refreshing all metadata, searching for missing data and manually replacing the images but nothing seems to stick. Can anyone give any advice? I've added an image from the android app as reference but this also appears like this when using localhost Many thanks! EDIT: so manually refreshing metadata for each actor and ticking replace existing images works but is there a better way to do this? Refreshing all metadata from the emby server menu doesn't seem to clear it up?
  16. pettergulbra

    Metadata, wrong language..

    Hi I try to get my metadata to be in Norwegian, nothing I do change this. I have tried Norwegian, Norwegian Bokmål and Nynorsk. Stil does not change. Is there something I don't do right? Petter
  17. Hello I do have problem with reduplicating labels (names) on some albums, genres and song and with randomly generated albums/artists in music library. It started with Amy Winehouse +- half year ago, after some updates (4.7.0.28) issue spread on AC/DC, Limp Bizkit and few more, both for flac and mp3. My tags are fine, I tried to scan library and refresh metadata with no luck. I did create new library but It seems that old library share same metadata with new one, I assume I would have to delete old library first but in that case I will lost all "favourite" labels. If I switch to "Album Artist" tab artists will not be splitted but album will keep duplicated name. What am I doing wrong? Is there any solution? Thank you
  18. Hi. I've set up a Raspberry Pi 4 with an external 4TB HDD. It's running Raspberry OS Lite (Debian GNU/Linux 11, bullseye), with installed Docker and Emby server in it - it's all working well for direct streaming to my LG C1. About SUBTITLES - I always do this manually - find them and put them in the same folder where the movie file is. About IMAGES and other info - I don't have any images, covers, etc. I only have movie+subtitle files, nothing else. All the extra data which Emby creates automatically when creating a library (nfo metadata files, covers, actor images, etc.) I'd like to have it in separate folder of my choice. I "played" a little when creating a test library. But I cannot seem to find the solution. 1) NFO files: When creating a library, if I enable "metadata savers", it saves the NFO's in same folder that the media is located. When leaving the "metadata savers" disabled, I have no idea where it stores the NFO's files. 2) IMAGES: When creating a library, if I enable "save artwork into media folders", it save the images in same folder that the media is located. When leaving the "save artwork into media folders" disabled, I have no idea where it stores the image files. I'd like to have my files that I manually downloaded (media+subtitles) intact, AS IS, without any extra info in the same folder - all the NFOs, covers, etc. in one folder (to rule them all ). Inside that "one" folder I don't mind having subfolders My media structure is simple like this: MOVIES: \movies\air_america_1990\avatar_2009.mkv \movies\air_america_1990\avatar_2009.srt \movies\atlantis_the_lost_continent_1961\atlantis_the_lost_continent_1961.mkv \movies\atlantis_the_lost_continent_1961\atlantis_the_lost_continent_1961.srt \movies\the_kings_man_2021\the_kings_man_2021.mp4 \movies\the_kings_man_2021\the_kings_man_2021.srt \movies\mortdecai_2015\mortdecai_2015.mkv \movies\mortdecai_2015\mortdecai_2015.srt \movies\elysium_2013\elysium_2013.mkv \movies\elysium_2013\elysium_2013.srt SERIES: \series\loki_2021\loki_s01e01_glorious_purpose.mp4 \series\loki_2021\loki_s01e01_glorious_purpose.srt \series\loki_2021\loki_s01e02_the_variant.mp4 \series\loki_2021\loki_s01e02_the_variant.srt \series\loki_2021\loki_s01e03_lamentis.mp4 \series\loki_2021\loki_s01e03_lamentis.srt ... etc ... \series\the_it_crowd\the_it_crowd_s01e01.mkv \series\the_it_crowd\the_it_crowd_s01e01.srt \series\the_it_crowd\the_it_crowd_s01e02.mkv \series\the_it_crowd\the_it_crowd_s01e02.srt \series\the_it_crowd\the_it_crowd_s02e01.mkv \series\the_it_crowd\the_it_crowd_s02e01.srt \series\the_it_crowd\the_it_crowd_s02e02.mkv \series\the_it_crowd\the_it_crowd_s02e02.srt \series\the_it_crowd\the_it_crowd_s03e01.mkv \series\the_it_crowd\the_it_crowd_s03e01.srt \series\the_it_crowd\the_it_crowd_s04e01.mkv \series\the_it_crowd\the_it_crowd_s04e01.srt ... etc ... Any help appreciated
  19. my setting: series - 3dots menu - "Edit Metadata" - "Display order" : "Aired" When S00E03 has earlier "Release date" in metadata than S00E02, How they are displayed is: S00E01 S00E02 S00E03 S05E01 ~ S05E12 (Unfortunately, the order of episode numbers and aired dates provided by tvdb does not match. Not natural.) The 3 special episodes have same "Special Episode Info" in their metadata setting which is "Airs during season" : 5, "Airs before episode": 1 When I manually changed "Episode number" in metadata of S00E02 from 2 to 4, it displayed: S00E01 S00E03 S00E02 S05E01 ~ S05E12 So, it seems to follow the episode number instead of the release date it was supposed to follow. (There is no "Aired date" in metadata, I assumed "Release date" is the "Aired date") In my opinion, for sure it is most natural to follow the order of the episode numbers If it is the same season. Specials will also follow the episode number in their special library. But, how about making sure that special episodes follow the aired date order only when they appear in other seasons?
  20. Hello, Recently, I've been trying to script some bulk editing of the NFO file in my Emby Library. This was mostly just a fun project for myself to learn more with Python. Currently my biggest issue I'm running into is trying to update the video NFO file to use a new Poster. Whenever I edit the NFO file lines: <art> <poster>/config/metadata/library/37/3776ebd48296df86690cc5c678d8814e/poster.jpg</poster> </art> to something like: <art> <poster>/config/my_posters/MoviePoster.jpg</poster> </art> Then try to update the Metadata for the video in Emby, Emby will overwrite the poster data back to the original value. A couple notes on how I've set up my system. Ubuntu 20.04 LTS with Emby installed inside of a Docker Container. The media is stored a ZFS file set up across 3 mechanical hard drives and mapped to Emby via docker The Emby program and config files are on the SSD and mapped to Emby via docker My goal was to have the NFO and Posters on the SSD while the media files could live on the much larger drives. Currently, the NFO files live in the media folders (which means they are on the mechanical hard drives). I'm okay with keeping the NFO files on the mechanical drives. I was hoping to keep the loading times down on the thumbnails, but it's possible that the NFO file has to be accessed before loading the thumbnails so I might be shooting myself in the foot. Also, I am aware that it's probably overkill keeping the thumbnails on the SSD, but I really prefer my system to be as snappy as possible. (I have thousands of videos in certain directories, so any optimizations can make a difference). My main questions are: Is there a way to update the poster via the NFO? Or am I doing something incorrectly. Do you think NFO files on the mechanical disks would bottleneck the posters enough to the point where keeping the posters on the mechanical disks wouldn't matter? Thanks for any help you can provide, and sorry if I posted this in the wrong subforum
  21. Hello Is there a way that emby don't show voice actors or that emby don't catch and load this data? I always delete them manually from the metadata, but as soon as I change something or add a new season to a series and emby has to recognize it again, all information are downloaded again. For live action movies this might be okay but for anime it really bothers me. If anything I want to have the fictional carakter like you find it at anisearch. show in picture next However, such a thing is not built into Emby. Therefore I would like that for defined libraries this information is not loaded from the voice actors.
  22. I am having an issue with album titles not updating in Emby when the ALBUM tag changes. File rescan and a normal library scan have not solved this issue. Specific example, Lady Gaga "The Fame" existed in my library for some time was recently renamed/retagged to "The Fame (HDtracks)". This new album title is not showing up in Emby, even after multiple general library scans and a forced metadata refresh on the artist page. I have NOT tried a metadata refresh on the entire library as this would take days with a 15TB library. A library rescan is usually enough to update track artists or titles, but unfortunately does not update the album title. The only way Emby has updated the album title is when I completely remove the album from my library, rescan library files, add the album back, and then rescan once again. Please let me know what additional info I can provide to help troubleshoot.
  23. thegrunge

    Reorder metadata sources

    @LukeBonjour, de mon coté j'essaie de faire reconnaitre des contes a emby, peut importe la facon que je nomme les fichiers que ce soit le titre original ou bien la traduction en anglais ou francais. Emby ne veux pas les reconnaitres. j'ai installer tout les pluggins indiqué, mais ca ne fonctionne pas plus. J'ai donc seulement garder themoviedb car les scan sont plus rapide et il y a moins d'erreurs d'association. Les titres de contes originaux sont en allemand. J'ai aussi une question a part de ce sujet. Pourquoi chaque fois que je retire un fichier d'un dossier, emby le place comme si je venais de l'ajouter. Pourtant la date de l'ajout du fichier dans le dossier ne change pas. C'est que j'ai un logiciel qui crée automatiquement des dossiers pour chaque film et ce n'est pas nécessaire. Je fais une comparaison avec plex car, avec lui ca ne fait pas ca tout comme il trouve les contes mentionner plus haut sans problèmes. Merci! Hello, for my part I try to recognize emby tales, no matter how I name the files whether it is the original title or the translation in English or French. Emby don't want to recognize them. I installed all the pluggins indicated, but it doesn't work anymore. So I only keep themoviedb because the scans are faster and there is less association error. The original story titles are in German. I also have a question aside from this topic. Why every time I remove a file from a folder, emby places it as if I had just added it. However, the date of adding the file to the folder does not change. It's that I have software that automatically creates folders for each movie and that isn't necessary. I make a comparison with plex because, with him it does not do that just as he finds the tales mentioned above without problems. Thank you!
  24. I tired to word it as best as I could for the title, but what I mean is pretty simple. Currently when you have the same movie or media in multiple format/resolutions such as 1080p, 4K, or SD, as far as I know, you have to go into the actual files and rearrange them into there own folder and rename them for the Emby Server to link them together, otherwise your going to have to duplicates when viewing them in the Media Gallery. And as someone who likes to have both 4K and 1080p versions for most of my media, it can be pretty time consuming to look through all the files rearranging them and renaming them. Not to mention frustrating as there is no UI or clean way of identifying them without having to read long file names and looking through the same looking files/folders. Made even harder when its a large collection and more than half are in multiple formats, so its a lot to comb through searching and rearranging/renaming. It is what I have currently been doing, but I haven't even gotten through half of it as of now. So I got to thinking of a way and I figured, why not have the server link them up within the info or metadata that it saves. It doesn't have to change the file name or relocate the files, just have a note that these are the same movie/media and they should be link together within the data that it creates and saves for the media. And create a simple and easy UI within the client that would cut the time and complexity of doing this task by a lot. Now it would be as easy as selecting the duplicates with clear artwork and identifiers and "merging" them! Without the hassle of going into the files and renaming or rearranging them. I have created images and mock ups to better illustrate what I mean with the image attached below and with a description below You see the duplicates that the Emby Server has {Image 1} because the media files, besides being the same media, are in different files due to differences in format or resolution and are treated as different movies/media. To fix this, you click into one of the duplicated media and select the extended options (the 3 dots) that would have a new option titled something like "Link", "Join", or "Merge" {Image 2} that once clicked this would open an overlay displaying your collection of movies {Image 3} from which you select the duplicate(s) with the easy titles and artwork to tell them apart. Then just confirm that these are the items you want to merge. You are then presented with the artwork and file name or path about the selected items that you would like to join, and how you would like to label the different versions/resolutions/file types {Image 4} The server wouldn't have to ask to identify them or change any info on them as they are duplicates and are already the same. Once Confirmed the server adds a "note" or saves it in the information or metadata that these two files are the same and now shows them as one with the option to select the version with the imputed label selected by the user as it currently does {Image 5} I know you guys work hard and don't know if/how hard this would be to implement, as I don't code. But I truly believe this feature would be a time saver and one that I would highly appreciate if it could be added into a future update. Thanks in Advance and for all the hard work you guys do!
  25. DSM 7, x64 Emby 4.6.7.0 No matter what setting configuration, artist metadata from a newly created music library will never be downloaded at all despite any type of scan EXCEPT a personal, individual, one-by-one refresh. Steps to reproduce: Enable appropriate settings when creating the library (see pics). Library finishes import and no artist metadata is saved like it should be. Manually trigger a scan, meta refresh, literally try any scan possible for the library. Still, no artist metadata is saved like it should be again. Music library settings upon creation: Things tried: Checking/unchecking NFO settings (Both after the library was already created, AND after deleting the library and starting from scratch with the settings checked). Changing music folder structure to "other or unstructured" (After deleting the library and starting from scratch with the setting). The only way I am able to get an artist's meta to download is by manually going to their specific page and performing a metadata refresh on just them. Still, this method does not work if the two "NFO" options are unchecked. It doesn't make any sense. Why are all of the SAME options perfectly functional for video libraries but just flat out don't work for music libraries for years? How? Furthermore, half of the settings literally do absolutely nothing at all. This includes: Metadata readers/savers - Unlike a movies or tv library that populates nfo files next to the content on the HDD, the settings for a music library seemingly do nothing. Save artwork into media folders - Nope, just flat out doesn't work / has been broken for at least 2 years. Every time I bring it up it's somehow twisted around that I am misunderstanding the feature and it's working as intended. Again, works just great for both my movies and tv libraries. Does nothing at all for the music library. Can provide video evidence of everything if necessary, a remote session, just about anything to get this solved. No logs or anything of the sort should be necessary. I can easily install a brand new, fresh Emby server, add a music library and watch the same results happen every time
×
×
  • Create New...