Jump to content

Search the Community

Showing results for tags 'vpn'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 21 results

  1. xiiMaGzx

    VPN

    Ok so my problem is my server uses usenet and I need/want to use a vpn so that makes me use a vpn on my emby server due to them being on the same pc. Now when using a vpn (nord) I cant connect directly to my server and remotely on my devices. Any thing i can do?
  2. Hi guys. I am looking for a vpn for kodi that is absolutely free and works very well with kodi. Can you guys recommend any?
  3. Hello I got emby premier and current on all its software The emby app in my iphone was running fine getting into the server via vpn until an upgrade sometime last year leaving me with a vague "unable to connect" message The phone's web browser still works getting into the emby server via vpn using its local ip over http I'm guessing it's a timeout value somewhere, but don't see any settings to find or change them, so gave up, until someone from emby answered my apple store feedback, suggesting I post here.
  4. Hi, I've been having a issue with Emby lately, It's working perfectly through OpenVPN, but not on IPsec. With IPsec I can connect to Emby through the browser (Chrome and Firefox), but the Android app doesn't connect at all, after opening the app It stays on the loading screen for a while and shows the screen to select servers, Also shows Failed Connection. With OpenVPN, Emby loads on both browser and App correctly. This isn't a configuration issue with IPsec, since I'm routing everything to my gateway (0.0.0.0/0), Emby even loads normally with the browser. Is there anywhere I can get the logs to known why It isn't connecting? Thanks.
  5. kpkimmel1983

    ExpressVPN and server

    Hello I use ExpressVPN because for some reason comcast blocks me from watching IPTV. I'm not even sure how to configure this for outside access. I have my vpn setup at the router because if i do it just on that computer it gets blocked. Anyone use this vpn and get this working? Thanks. PS I don't think WOW blocks anything so i might try them out after i get this working.
  6. The PC that I have set up an Emby server on uses Mullvad VPN often, but not always. My goal is to be able to watch the server's media files through other devices, no matter if the VPN is active or inactive. When the VPN is active, the connection fails. When the VPN is inactive, the connection succeeds. Mullvad allows port fowarding, and I've read a few guides on that, as well as the Connectivity Wiki for Emby but am still having trouble, either because I don't quite understand how it works or because the guides weren't specific enough for my issue. So far, I have only tried to connect through a Fire Stick and it works only when the VPN is inactive. If the VPN is on, entering either the LAN and WAN address still gives a connection error. Emby Connect has connected my user account to the server, but the server still does not show on the app after entering the pin. I appreciate any suggestions that you can give.
  7. I've seen some helpful posts regarding this by some advanced users, notably @@skidmarks and @@Tur0k but I'm having no luck. Anyone else successfully doing this with PIA? My setup is: * Emby server 4.2.0.40 on MacOS 10.12.6 Sierra and also running PIA 1.1.1 * Internet is cable to an ISP-supplied modem, WAN port to Asus RT-AC68U, ethernet to the Emby server. * Emby server has a manually-assigned IP via the Asus GUI to its MAC address. * Emby remote port is 8096 via http When my server is not connected to the PIA VPN, I can scan the server's public-facing IP (from another computer) for open ports and I see 8096 is indeed open. When I connect the server to the VPN and scan the server's new public-facing IP, 8096 isn't open. These are the things I've tried and have all failed: 1. Forward 8096 to the server's local IP address via the Asus GUI. 2. Enable port-forwarding in the PIA VPN client; change the Emby server remote http port to the port the VPN is forwarding (this is a read-only assigned port in PIA); forward the new port to the server's local IP address via the Asus GUI. Scanning the new public-facing IP shows the new port (and 8096) is not open. 3. Same as #2 but leave the Emby remote port as the default 8096. 4. In the Asus GUI additionally specify the destination local port as 8096. 5. All of the above with different PIA VPN locations among the ones that support port-forwarding. 6. All of the above with MacOS firewall disabled. Thanks!
  8. So after the recent privacy controversy with Plex I've started looking elsewhere for media servers with remote access. It seems Emby is a decent alternative however I'm having issues using it with a VPN. I've had these issues with Plex so I'll explain further. The problem Plex had with the VPN is that it had the wrong IP address for me (it was displaying the VPN IP, as it should do) and because of that, when I was attempting to connect remotely via the VPN IP it could not find the Plex server. The way to get around this was to set up a static port with my VPN provider, which they did, then enter this port into the "Manually specify public port" setting on Plex. After this, the server was remotely accessible, as the VPN provider would listen for incoming connections on the specified port, forward it to my server and all was good. I'm not having any success running this with Emby. I can see that there are settings where I can manually set the public and local ports to access the server (it is listing my VPN IP rather than my real IP, just as Plex did) but I may not be entering my static VPN IP in the right box? I've tried remote access without the VPN running and it worked (though I did have to set up port forwarding in my router). I've tried entering my static VPN IP in the "Public HTTP port number" box in Advanced Settings but this hasn't worked. To be clear, as I seem to be different to most others, I am looking to run Emby behind the VPN and not bypass it. Can anybody assist? There must be some way to do this as it works fine with Plex.
  9. Pseudomax

    Selective VPN for Emby

    Hi I have an HTPC that drives all the media in my home. It is connected to a QNAP NAS where the media is stored. I try to run most apps behind a VPN for a variety of reasons, but that then causes some problems with streaming for example BBC iPlayer (which does not work if it detects a VPN is switched on). I have added a second NIC as I thought I might be able to bind the traffic of one app to one and another to the other and then select the IP of the NIC I want to protect via an OpenVPN client on the router. However, having asked the question on AskUbuntu I did not receive any suitable answer, and therefore I am wondering if there is a way that I can do this within Emby itself? Suggestions welcome ...
  10. robrhedrick

    Sync 2 emby servers across VPN

    We are moving soon and will have gigabit internet. I have an emby server and so does my buddy. We have a vpn connection between our houses so our connections appear "local". I'd like to find a way to sync or media libraries so we can be "fail-overs" for each other to our friends and family. I know there isn't an official supported method to do this, but I wanted to ask the minds in this forum for suggestions. We both run emby server on Ubuntu server 18.04 with similar storage capacities.
  11. Hi, I run a synology NAS (DS1817+) with an external VPN Network connection set on the unit and local IP which to date of update has worked flawlessly. Nice update otherwise, thank you .NET core update using less CPU time now. Until upgrade to the recent synology build the local network which uses 10.0.0.0 ect and still does connected to the Emby server on the NAS and used this range of IP. After upgrade with the VPN on the Emby server picks up the VPN IP which is wrong and fails to connect. Manual entry of the correct IP in the emby app for the server does not work. The only solution in my ignorance is to turn off the VPN connection and then emby will connect from the shield TV I will add that the issue does not occur when using a mobile app or Mac or PC which strangely defaults to the VPN ip and this issue therefore only occurs when using the Nividea Shield TV, it seems the emby app is now looking at the VPN as default rather than the local IP range set on the network and NAS. No other related apps have this issue. It also when the VPN is enabled allows Emby conection as explained and shown in the images via the local Lan using the VPN IP as the server and guess it makes sense other than the shield TV does not now like the setup and refuses connection. Ideas suggestion and help please as I am now lost and prefer to use the external VPN for other NAS applications if possible but retain use of the shield TV, is this a bug with the shield TV app? Many thanks.
  12. Hi, I've been trying to get Mullvad working with Emby but so far no luck. I have a port forwarded through Mullvad (eg 12345), which I have checked is definitely open when connected to the VPN. So in Emby settings I have changed the public port to "12345". Also Emby doesn't seem to automatically pick up the new VPN IP address, so in the 'External Domain' setting I have put the new IP. So far this hasn't worked for remote access (in home streaming works fine). Is there anything else I need to change? I've also tried forwarding the VPN port on my router but still nothing. Thanks
  13. grizzlybear1024

    Emby w/mullvad doesn't work

    I opened a port on mullvad, ran an iPerf server on said port, and the port was reachable. I closed the iPerf server, opened Emby with the public http set on said port, and Emby doesn't want to work. I've tried setting the External Domain to the IP mullvad was using. I've tried restarting. Ive looked at all the other servers running and none of them use the port opened for mullvad. Mullvad is a vpn, by the way
  14. milkjunkie90

    Do I need a VPN

    Hi I have a collection of movies on my hard drive and i am running the Emby add on inside Kodi on my Windows PC to catalog and stream them to my other devices throughout the house. I am not using any internet streaming services like IPTV or anything like that. I am just wondering if i need to be running a VPN or not. I have a Private internet Access subscription but I don't have it running 24/7. Should I have?
  15. h1smajesty

    Issues connecting

    Hello, I set up my emby server recently and immediately ran into the "We're unable to connect to the selected server right now" error message. I googled around, made sure my firewall had these ports open. The real problem was what I feared most: my university has all of the incoming ports closed. I can stream between devices on the same network, but can't stream between different networks (e.g. Uni wifi and Uni LAN). They don't allow port forwarding im pretty sure, but what I am really confused about is that it worked when I tried connecting my server/pc to the internet through NordVPN. That was a few days ago, and I have since been unable to reconnect, but I am pretty sure the connection was from Lan to wifi, so cross-network streaming. Why did it work? Weren't the ports still closed within the university network even with the VPN? Did I hallucinate streaming those 3 episodes of 30 rock? If the VPN did allow to bypass my university restriction somehow, do I have to manually check all their servers to find the right one now (they dont support port forwarding I think)? Very new to servers and port forwarding in general, maybe I missed something. Thanks in advance!!
  16. mataus

    Advanced Tomato router

    Hi all, I have a router running latest Advanced tomato firmware and PIA VPN running on it. I would like to run a script to enable Port Forwarding to the Port PIA provides me so I can access the Emby server remotely. However after searching the internet I am still no clearer on how to achieve this. Any help would be very much appreciated. Thanks
  17. Looking at getting a VPN, so wondered which one people use/prefer. I've been looking at IPVANISH and PRIVATE INTERNET ACCESS (PIA). I'm in the UK, so perhaps UK based VPNs are better? Also, I use DDNS (configured on my router) to access my home services, so are VPNs and DDNS compatible ?? All comments are appreciated. Thanks.
  18. I have couple of users who are outside my network but still can access my server via vpn. I set a bitrate in the playback settings of 1mbit. "An optional per-stream bitrate limit for all out of network devices. This is useful to prevent devices from requesting a higher bitrate than your internet connection can handle. This may result in increased CPU load on your server in order to transcode videos on the fly to a lower bitrate." But it doesn't look like it's working. I want to limit anything outside of my network to 1mbit and force transcoding. Here is my setup: There is NO access from WAN. Server side: 192.168.1.0/24 <-- SITE TO SITE VPN --> 192.168.10.0/24 Remote site It seems when the users access server from 192.168.10.0/24 emby just direct plays content there is no limit. the files that are being played are huge (1080p/ 4k etc... ) so that saturates my upstream immediately. Plex solves this by a setting that you can set "Networks that belong to local net" and anything that's outside that range is considered remote and limits are enforced. Is there a way to implement this?
  19. i have my vpn running through the router on DD-WRT,im not real good with this stuff and wondered if somebody could help me configure open vpn with this router. this is what i am using, Firmware: DD-WRT v3.0-r31884 (07/17/17) thanks for any help provided
  20. otabob

    two locations and a vpn

    I have an idea that if Emby can stream media to my device over the internet (with proper dynamicdns and isp provided speed connection) then could Emby stream media through a vpn connection? Let me explain a little. I have a vpn connection between my shop and my home. The computer in the shop is already backing up to a server in my home. So, if the shop burns down (or some weather disaster) I have data backed up to my home server. So, if I am already streaming 'that data', could Emby server (setup in the shop) stream data to my Emby client in my home? Seems to me that this should work? Any thoughts?
  21. Windows 7 Pro Server Version 3.0.5597.1 Router D-Link dir-655 VPN->PrivateInternetAccess VPN is running on same machine as EmbyServer. I ensure that EmbyServer is started after any VPN start/re-starts. ************************ QUESTION: Is it necessary to prioritize startups like this? ********************************** Below is a screenshot of Advanced settings: Below is a screenshot of my VPN settings: The URL I use to connect to EmbyServer is my ISP_provided_IP:8096. The IP is static. Remote access (from laptop) works fine with VPN off. I am ABLE to connect to EmbyServer with the ISP_provided_IP:8096 from the server machine. I am UNABLE to connect to EmbyServer with the ISP_provided_IP:8096 from a client machine (laptop). I saw a direction in the forum to "...go to dashboard -> advanced -> hosting and override your external address". I assumed this meant to enter my ISP_provided_IP in the "dashboard -> advanced -> hosting -> External WAN Address:".. Still no joy. There was another direction on the forum to "...manually edit the common config file and put in the machine name/ip address for the server." I poked around around looking for a "common config file" to no avail. What tag would I edit if I found it? After hours of trying different settings (e.g., port mapping on/off) and searching this forum and the web for a solution, I have become very frustrated and need your help. Thanks Here is my server log: server-63566876397.txt Thanks
×
×
  • Create New...