Jump to content

Search the Community

Showing results for tags 'transcoding'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. RobertDi

    J4105-ITX GPU Transcoding

    Hallo liebes Forum, Ich habe Emby-Server auf dem ASRock J4105-ITX laufen, nativ unter Debian Buster. (Integrated Intel® UHD Graphics 600) Umstieg von der Docker Variante um die GraKa das Transkoding durchführen zu lassen. Leider musste ich feststellen das mit aktivem Hardwaretranskoding nahezu kein Film mehr im Browser darstellbar ist. Alles viel zu langsam und nur Aussetzer. Folgende Ansätze brachten leider keinen Erfolg: #1 RAM der GraKa auf 512 MB hoch # 2 Intel non-free Treiber Hat jemand noch eine Idee oder ist die interne GraKa einfach zu schlecht? Mittels Software Transkoding funktioniert die Wiedergabe, allerdings mit entsprechender CPU Last. Spezifikationen Board: https://www.asrock.com/mb/Intel/J4105-ITX/#Specification Gruß Robert
  2. berndbausch

    Switch off transcoding?

    Bear with me, I am a total newbie as far as Emby is concerned. I installed Emby on an Odroid C+, which I normally use as a general backup/DNS/DHCP server in my home network. The goal is a library of home videos to which the family has access at all times. First, I have to say that it blows me away that it just works out of the box. But I would like to not transcode videos So far I have done tests with an MP4 file I created with ffmpeg without any options: ffmpeg -i myvideo.avi myvideo.mp4. I viewed the file from a Firefox browser, on a Windows 10 PC and on an Android phone. I expected no transcoding, but I see ffmpeg using up 75% of the CPU. An MTS file (footage directly from the camera) causes a similar load. I have not been able to try my old DV avi files yet. So my initial tests show that it works, but I wonder: Is it possible to configure Emby not to transcode at all? Is it possible to configure an external viewer such as VLC? [EDIT: Yes it looks like it can be done depending on the viewing app, but I have not found if and how it's possible with the default browser app] In other words, is it possible to move the decoding load to the client side?
  3. Migrated my server to an old optiplex with an i5 4590 that has an HD 4600 with quicksync. If I throw in a Radeon RX 560 2GB, can I leverage the hardware acceleration from both the Intel iGPU and the Radeon GPU? or is it one or the other?
  4. lesensei

    Unable to stream some movies

    Hello, I've been happily using Emby (with Premiere) on a XPenology NAS for a few years now, and recently seem to have hit a bug. When I try to play some movies of my collection, I hit the "Aucun flux compatible n'est actuellement disponible." (please pardon my french setup, this would be "No available stream" or something like that in english). I looked at the attached logs, tried to launch the "actual command" and sure enough, got the same error before ffmpeg quits: Stream specifier ':3' in filtergraph description [0:3]scale@f1=width=720:height=-2:force_original_aspect_ratio=decrease[f1_out0];[0:0][f1_out0]overlay@f2=x=(W-w)/2:y=(H-h):repeatlast=0[f2_out0] matches no streams. Just in case, here's the output of ffprobe on the file: ffprobe version 4.3.0-emby_2020_02_24-20200406T210855UTC Copyright (c) 2007-2019 the FFmpeg developers and softworkz for Emby LLC built with gcc 7.3.0 (GCC) Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/volume1/video/redactedfilename.m4v': Metadata: major_brand : mp42 minor_version : 512 compatible_brands: isomiso2avc1mp41 creation_time : 2017-10-22T20:12:17.000000Z encoder : HandBrake 1.0.7 2017040900 Duration: 02:05:05.32, start: 0.000000, bitrate: 1089 kb/s Stream #0:0(und): Video: h264 (Main) (avc1 / 0x31637661), yuv420p(tv, smpte170m/bt470bg/bt709), 720x426 [SAR 64:45 DAR 512:213], 756 kb/s, Level 31, 25 fps, 25 tbr, 90k tbn, 180k tbc (default) Metadata: creation_time : 2017-10-22T20:12:17.000000Z handler_name : VideoHandler Stream #0:1(fra): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 160 kb/s (default) Metadata: creation_time : 2017-10-22T20:12:17.000000Z handler_name : Stereo Stream #0:2(eng): Audio: aac (LC) (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 160 kb/s Metadata: creation_time : 2017-10-22T20:12:17.000000Z handler_name : Stereo Stream #0:3(fra): Subtitle: dvd_subtitle (mp4s / 0x7334706D), 720x576, 1 kb/s (default) Metadata: creation_time : 2017-10-22T20:12:17.000000Z handler_name : SubtitleHandler Stream #0:4(eng): Subtitle: dvd_subtitle (mp4s / 0x7334706D), 720x576, 2 kb/s Metadata: creation_time : 2017-10-22T20:12:17.000000Z handler_name : SubtitleHandler Stream #0:5(eng): Data: bin_data (text / 0x74786574) Metadata: creation_time : 2017-10-22T20:12:17.000000Z handler_name : SubtitleHandler Unsupported codec with id 100359 for input stream 5 Any idea what I can do to make this work again (I'm pretty sure it has worked in the past) ? Thanks for your help. ffmpeg-transcode-8b813c11-e81a-4a0b-876d-a6cf032d5a2f_1.txt
  5. dredrizzah

    Xbox 360 DLNA Profile

    Hello, i was wondering if there's a way to play media to a Xbox 360 that is not a AVI file? I'm aware that the Xbox 360 can play MP4 files, however the MP4 can not be a multi-channel file. In order for the Xbox to play the MP4 it has to have two channel audio. I'm trying to get Emby to, transcode the files to either a wma file, a multi-channel avi file or to a two channel mp4. So hopefully with all the great minds in this forum someone can help me with this???\ Thanks!!!!
  6. sharrisct25@hotmail.com

    Need Transcoding help

    So I have recently added a HDhomerun EXTEND to my Emby system. The goal is to allow people to watch a few local stations in Emby that we do not get on other steaming services. All of my TVs are Roku clients of different types. Some hardwired some Wifi. I use my Android client on my phone on occasion also. I have 2 HDhomerun EXTEND units connected and my goal is to be able to support 4 users watching / recording at the same time without any major load on my Emby server. The Server is virtualized running as a Windows 10 system in VMware 6.5. It has 4 cores and 10GB or RAM. All the storage is local SSD on a RAID 5 array. The server is Emby Premier version 4.4.2.0 and the Roku clients are using Emby beta. Historically software transcoding has been fine for the movies and other videos I have in my library but with TV I knew the use would spike and more transcoding maybe needed. This lead me to buy the HDhomerun Extend versions due to their capability to decode. Once setup I had a few issues with specific channels that I have learned are down to reception thanks to posts and help in other Emby forums. Then I was still seeing ffmpeg activity going on, sometimes as a directstream where the audio was being converted, others full transcoding. With more help from the Forum I purchased and installed a NVIDIA GTX 1030 card to do hardware decoding. The problem is I am still seeing ffmpeg activity for the Roku clients. I now DO NOT see it for the Android but definitely for the Roku clients. Can somebody help me sort what is going on here? Shouldn't the decoding all be happening in hardware now between the HDhomerun EXTEND and the NVIDIA card? I see that the Processing Plan in the ffmpeg log still says False for all CanDoInHardware lines does that mean the card is not working correctly? I have attached logs for more details. hardware_detection-63724218955.txt ffmpeg-directstream-0194bed2-a9ad-4aac-b654-03b1a909ac4e_1.txt embyserver.txt
  7. Hi @@ebr, Android TV stats show that this movie is transcoding due to "Video Bitrate Exceeds Limit" Audio was expected to transcode due to playback through TV/headphones Playback rate set at Auto in ATV app Home Network Quality set to 4k - 120Mbps User Transcoding: Audio and Video Allowed Ethernet connection An ffmpg "Transcoding" log was produced which suggests Video encoding happened when it shouldn't have as the shield is capable of Direct Playback of this video - as proven when Video Trancoding is turned OFF As a test, I set Video transcoding = Not allowed and ATV Playback rate to 100Mbps This time, an ffmpg "Remux" log was produced - for the Audio i presume. Playback still worked fine but ATV Stats still show "Video Bitrate Exceeds Limit" Not sure why - Bug? Attached: 2*Server logs, 2*ffmpg logs, MediaInfo, image of ATV stats for the test playback embyserver-Original Playback.txt ffmpeg-transcode-Original playback.txt embyserver-Test Playback.txt ffmpeg-remux-Test palyback.txt
  8. docoon

    rookie guidance

    Hello, guys my knwlodge with plex and emby is very basic, so treat me as a child by now... I've started a private server to me and brother (who is in the other side of the country), I thought of that because I have some drivers with 187 TB of movies/series/docs ... (some of the TB are games .. so) But... since I started my plex server using a virtual mounted driver, I notice that my brother eats my cpu to watch it, that's because of the transcoder, I know I could disable it, but that would have problems with some codecs and some subtitles... as far as I understood. So my question is simple, is there a way to set my plex//emby ->> (i'm going to migrate to emby, that's why i'm searching here) to let the user (my brother) consume his own cpu/gpu to transcode the movie he wants? Or it has to be the server the only thing that can transcode... Excuse my ignorance, i'm new at this. If there's a way, point me the direction @@cayars
  9. Hello, currently when Emby is playing media there are lots of transcoding options, for example for video files - 1080p, 720p etc., including a special option called 'Auto'. To my understanding if Emby decides that you have a fast enough connection it will switch to a 'Auto - Direct' mode and it will stream the movie as is, without transcoding. However, there is no 'Direct' standalone option present. Why is this feature needed: Sometimes the 'Auto' option decides that the connection speed is not fast enough so it switches to a transcoding method (usually 720p 1Mbps for me). This is problematic, as not only the movie quality becomes terrible to watch, but induces stress to the server, which becomes too great once more than 2-3 users are watching simultaneously - resulting in a buffering movie even at a low quality. Currently to get around the problem with low quality stream I have to go to settings and manually change the transcoding to the same resolution and bitrate that I know the movie is originally (or greater). This is unnecessary and could be avoided by providing a separate 'Direct' streaming option.
  10. iv been using emby for a while now and i have found that using any file that has a Codec of H264 makes emby stutter like a mad man. i have tested this with a lot of file and it happens like clock work. i start the video and the system starts to trans-code, i look at the dashboard and see that the buffer is like 2 mins ahead of playback as it should be. but when i play it, it just stops and plays stops and plays over and over. not sure if its a software bug but i have looked at all other areas that could cause this to happen (I.E my internet speed, cpu usage, RAM usage, client internet speeds) and it all comes back to just this one Codec. Not sure what to do other then i replace all files that are H264 as that seems to fix the problem. Also it does not matter what Bitrate i set it too it still does it no mater what the setting is set to.
  11. My Samsung TV does not support DTS so I use the audio only transcoding feature of Emby. It would be great to set higher bitrates for Audio transcoding or if possible to send a DD+ stream instead. Many thianks.
  12. Pseudomax

    Question about my bandwidth

    Hi I have used Emby for a while and I have never managed to set my server up to work properly for transcoding. I had always assumed that I just had inferior hardware, but I recently updated my HTPC to a fairly reasonable machine (AMD Ryzen 5 3400G Processor with Radeon RX Vega 11 Graphics & 16GB DDR4 RAM 500GB SSD) but I still have the problem. I therefore have now a dedicated router for a Wireguard VPN with a stable 10MB/s connection when roaming, but I still get some movies that buffer incessantly (once every 2min for 30sec). I have: Emby Server 4.4.1.0 Hardware Acceleration is enabled Transcoding thread count: 3 H.264 encoding preset: Auto H.264 encoding CRF: 23 Internet streaming bitrate limit (Mbps): 6MB/s Is there anything I am missing? Thanks
  13. jaspils

    Will adding a GPU benefit me?

    Currently running Emby on a virtual machine (ESXi) with the following specs: 8 CPUs from the 2 Xeon E5520 @ 2.27GHz in the host 8GB of RAM a 40GB disk on SSD for the OS and app Media content through a SMB-share (over Gbit network, mostly 100MB/s+ read/write speeds) Debian Buster Emby Premiere subscription Most content gets streamed fine. However, when something needs to be transcoded, it gets tricky. Especially high-quality stuff like 4K is simply not possible to watch through Emby. Also, subtitle burn-in hardly ever works. So my question would be: - Will adding a GPU benefit my setup, and what kind? I would probably add the GPU to the virtual machine through DirectPath I/O PCI passthrough. Of course adding a RTX Titan would probably improve it, but I just want something cheap. I was looking at used GPU's like the GTX950 of GTX960, mainly because they don't draw too much power from my server and would only cost me like €60. So does anyone know wheter this could help me, or perhaps suggest an alternative? Thanks! @ @@arrbee99 @@cayars
  14. Familia Chapin

    Transcoding due to max bitrate

    First, I love what you all are doing with this software. It is amazing. Since the latest update, i noticed when my external Emby users watch videos, I am getting a lot of transcoding due to max bitrate. I don't think this is correct because for the same device, it might do it one time and then for the same video, it will direct play. They are all either SD videos (TV shows) or movies off Yify which have always played flawless on the different devices. I am only experiencing this since the update. Are there any particular logs I should give you guys to help? I really appreciate all that you do!!
  15. Hallo Zusammen, ich will mal versuchen, das Problem auf die bloßen Fakten zu reduzieren: Auf einem externen Server laufen ein PMS und Emby, Emby erst seit heute, ich kenne mich damit also noch nicht wirklich aus und bitte entsprechend um Nachsicht :smile. Clients für den Test sind eine Shield und ein Web-Browser. Der Content ist so, dass ihn die Shield und der Browser über den PMS als Direct Stream wiedergeben können, das sieht dann in etwa so aus: Das gleiche File an gleicher Stelle mit Emby wiedergegeben sieht dann so aus: Ich habe sowohl im Browser als auf dem Shield-Client die gefundenen Einstellungen so angepasst, dass alle Werte, die sich auf Bandbreite beziehen auf dem Maximalwert anstatt auf Auto stehen, mehr habe ich aber erst mal nicht ifnden können, gerade die Setings auf der Shield wirken eher spartanisch. Hat jemand einen Tipp für mich, wo man hier ansetzen kann?
  16. RDSII64

    New guy with questions

    My budget emby server consists of: dual E5-2680 xeons 128 gigs of 1600 ECC ram 8 gig RX580 HP EX950 NVME (boot drive) Rosewill 4u server chassis Storage currently is one 12TB 7200 RPM drive (with room for 7 More) My media collection predates high definition so its a mixture of all common resolutions (DVD, 720p and 1080p) I don't have any plans for 4k outside the home. (1) Does hardware transcoding happen on the GPU or the CPU? (2) If I have a choice, which is better? (3) What is software transcoding? (4) If I have a choice, which is better software or hardware? (5) Is a second SSD for caching a good idea? Thanks in advance The new guy
  17. Hey guys @@softworkz, Currently I am having issues playing media on devices which need transcoding to play the file. E.g my Oneplus 5T phone manages to direct play x265 encoded files and Emby works like a charm for that device. However when I try to watch on a notebook or PC which needs to transcode the x265 into x264 the video never starts or just stops after a few seconds. I restarted the emby server and the whole windows server multiple times but that does not solve the problem. I attached the server logs for you. embyserver.txt ffmpeg-transcode-ee2800e7-7a19-4344-b5ba-a7306af79f88_1.txt
  18. abufaisal

    [4.3.1.0] Transcoding Advanced empty!

    Hello, I have server with gpu rtx 2070 super. already install drive and add to emby docker. my issue in dashboard of emby can't see any options on Transcoding enable hardware acceleration.
  19. Skyobliwind

    Tips for Codecs and Fileformats

    Hi, after some testing on different devices and with different media I noticed that almost all files transcode which reduces quality and sometimes makes playback shutter. My main Playback devices are Firefox on Windows, The Emby app for Tizen(Samsung) and the Android app. My Films and Series are all in mkv container. Most are DVD Rips in Mpeg2 Codec, some are Bluray Rips in Mpeg4 codec and I think also a few in HEVC. Even Musicvideos in H.264 seem to transcode. All transcode to H.264(AVC) if played from Firefox on Windows, Firefox on Android and emby app on Android. So is H.264(AVC) the codec to go for? It makes no difference if I disable or enable subtitles. Is there any guide or something which are the preferrable formats/codecs for which Playback device? (Video and Audio) (The goal obviously is to get as many files to directplay as possible (sorted from important to less important 1.quality, 2.speed, 3.storagespace) In the future there may be other devices like fire-TV stick, IOS Devices, maybe Xbox or Emby Theater added. At the moment there Are mostly DVD Rips and FHD Bluray Rips, but I'd also like to add 4k Bluray Rips in the future (i alread read this makes some trouble in other topics). @ @@maegibbons @@arrbee99 @@JaScoMa @@pir8radio @@AdrianW
  20. I am looking for opinion and /or facts to help me understand more about the quality of my video. Say i have 4 videos - same title - different transcoding or format as follows 1. 4K Movie at 8bits and 12.9 Mb/s bit rate (NVENC) 2. 4K Movie at 8bits and 4.5 Mb/s (NVENC) 3. 4K Movie at 10bits and 60.0 Mb/s (i suppose this one should be the best quality) 4. 4K Movie at 10bits and 4.5 Mbs I have a 4K/HDR Quantum Dot LED Tv... What is the real perceivable difference in these files. Can/Should we be able to see a difference with 10bit HDR vs 8 bit and does the bit rate make a significant difference in the quality. Do i lose effective resolution by compressing way down? I realize disk space is cheap but it seems that even my Shield Pro which is SUPPOSED to be able to stream multiple 4K streams will struggle with the higher bit rate stuff and im just not so sure the difference in quality is worth 50GB files (even though i have 20TB) Im an older guy (who also happens to be color blind) so my vision isnt great but im not lost in the fact that others watch my content and i want everyone to get good quality. thanks in advance.
  21. I have another wish. Get better audio quality for audio tracks by using . They're already good but in terms of quality not the best out there. Would it be possible to utilize fdk-aac for the transcoder? Or even better, qaac.
  22. ertagon2

    Transcoding Thread Limiter

    It doesn't seem to be working vert well, when transcoding is not running the CPU stays at 3% usage.
  23. feerlessleadr

    Transcoding Green Screen

    Hi All - similar to another post that I made a few weeks ago, I recently re-installed Windows 10 on my server running Emby. Prior to the re-install, transcoding worked on my server with Windows 10 (same version, just did a clean install) without problems with harware acceleration enabled. I just noticed that whenever I try to transcode anything after the re-install, I just get a green screen with sound. I used the backup addon to restore all of my settings, etc. after the re-install. I did a google search and I made sure that I installed the latest intel graphics driver from the intel website. I'm running a 4th gen Haswell Intel Core i7 4770. Just to be sure, I re-downloaded the latest x64 drivers, installed them and rebooted, but am still getting the green screen. See attached for my logs. Thanks embyserver.txt ffmpeg-transcode-56fea1c5-824c-44d2-af42-3aeac6398299_1.txt
  24. Hello, I am absolutely new to any mediaserver. I used Kodi only from a HDD on my Nvidia Shield. I have a QNAP now, installed and configured Emby now and I have two questions/problems. 1: is it possible to get all metadata (which worked with downloading for most files) BUT show the actual filename and not the metadata name while still having pictures, info and actor info and so forth? this was possible in kodi but i couldnt figure out how to do it with emby 2: i tried to stream to my android phone using the official android emby app. all worked well, the direct stream with no transcoding works. then i tried to use a smaller resolution, which forced my qnap to transcode. everything works fine, on my external ssd i see that the transcoding cache files are created, the lower resolution showed on the phone, everything great. BUT when i ended watching the movie and closed the emby app on my phone, the server still proceeded transcoding the file. even after shutting down the emby server in qnap i see the process still in the services. when i started the emby server again and tried to transcode another movie to my phone, i saw a second instance of the transcoding on the qnap server and i saw cache files for both movies being created. is there a possibility to quit a transcode? it seems kind of silly to keep transcoding the movie even if i dont want to watch it after all. this way i cant just scroll through a movie on the go and decide i dont want to watch it. because after 2 or 3 transcodes my qnap will be at 100% cpu usage since i dont yet have emby pass for hw transcode. i would appreciate some advice
  25. Hi, I would like to direct play a movie to my Chromecast Ultra but i can't.... I can't understand why because here https://github.com/MediaBrowser/Wiki/wiki/Chromecast, it says that MKV is supported by Chromecast, but when I try to play it it says "The media is compatible with the device regarding resolution and media type (H.264, AC3, etc.), but is in an incompatible file container (.mkv, .avi, .wmv, etc.). The video will be re-packaged on the fly before streaming it to the device."... Do you know why ? log.txt embyserver.txt
×
×
  • Create New...