Jump to content

Search the Community

Showing results for tags 'video'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. In the Android app on my tablet (Google Pixel C with Android 8.1.0), if I set the Play On to the instance of Emby on my Roku stick, and then select a video to play on it, a transport control bar appears at the bottom of the tablet screen. However, it is displayed underneath Android's own navigation bar therefore cannot be accessed. Trying to touch one of the transport controls or the playlist icon, results in the Android navigation button being selected instead. A lot of apps cause the Android navigation bar to slide out of the way when the app is in fullscreen and allow it to be brought back with a swipe. See attached screenshot. Server: 4.6.4.0 Emby Android app: 3.2.05
  2. Bottles51

    auto stretch 4:3 video

    Can we get a setting to auto stretch 4:3 video ether on the app or the server itself. I know we have a setting to do it, but It gets tiresome to have to stretch the video each time you play something.
  3. Before I start, I'll explain what I mean by "without giving any reason why" usually when it starts to transcode, it would give a reason why like this (check the blue circling) Note:- I've forcefully made this video to transcode in the above picture by reducing the bitrate so that is not a bug but in this case, it doesn't this could be a bug so I'm just reporting that Now, I have no clue as to why this video transcodes while other videos with the same format doesn't. It's definitely not the subtitles or the audio because I've reencoded the video to HEVC and the audio and subtitle plays directly. Here's the logs ffmpeg-transcode-f5e334ff-98b7-4cd7-85d5-aeab259c3705_1.txt Here's the media info mediainfo.txt And here's the sample video Flowers of Evil - S01E01 - Flowers of Evil 1 of 13 (1)-001.mkv Ran with galaxy s10 on Emby android 3.1.94
  4. Hello - has anyone seen this issue and been able to resolve it? https://github.com/google/ExoPlayer/issues/8394 Basically - whenever I have a video which is exactly 800 pixels high and played in Emby it has a flickering line at the bottom. It looks as though it's some sort of issue between Sony's Android TV implementation or hardware and Exoplayer. There is some detail in the link around the cause being "sharing" the player activity within a webview rather than creating a new player activity withing the webview. Is there anything that can be done to resolve this strange issue?
  5. It's really great the way the theme audio continues when navigating through info on a movie or series and fades when leaving. It would be great if the audio of video backdrops faded out also when leaving.
  6. Hi! I'm requesting the feature to be able to use the video timeline in the player for the Emby app on Samsung SmartTV, we are not able to to forward or backward a video so can you put the feature on? I know there is a new version of Emby for Samsung SmartTV (Ver. 1.0.84) since 3 days but the feature is not in. Thanks! Greetings, Brandon
  7. Hi, Can anybody recommend a simple to use, but free to use video splitter? All I want to do is cut out adverts from a couple of videos I've downloaded. Thanks Pete
  8. Hi, Ho do I organise video with different languages? DO i rip the DVD first in english and then a second time in italian? What folder strucutre do use? media-> movies-> my_movie->mymovie-IT.mkv mymovie-EN.mkv I don't seem to be able to find the naming structure on the wiki or searching "language" in the forums. And what about a series of 26 DVD, each an episode of a cartoon my kids follow? Episode 1 - mymovie.mkv Episode 2 - mymovie.mkv Episode 3 - mymovie.mkv etc? For now I have added all 26 episodes in a collection "mymovie" but I noticed that Emby has recognised that "The Smurfs" and the "The Smurfs 2" belong both to a single collection that Emby created itself. Thanks for you help in advance.
  9. Hello, I have lots of home videos that are recorded in portrait mode but emby's player only launches in landscape mode thus I"m not being able to see the videos in "full screen". I know I can use an external player but that wouldn't let me have played status and resume support. Any reason why the player is forced to landscape? Thanks
  10. Server: Arch Linux Emby server 4.4.0.40 Client: Sony KD-55AG9 Android TV 9 Yesterday I played this movie (see spoiler) in a Sony KD-55AG9: This smart TV supports H.265 video codec natively (see specifications: https://www.sony.co.uk/electronics/support/televisions-projectors-oled-tvs-android-/kd-55ag9/specifications). Why Emby transcode it?
  11. So, I see all of these Plex pre-roll videos that people are making. I'm old and nostalgic, so I thought that I would jump on the bandwagon and make a VHS-ish preroll to use with my Cinema mode. Of course, I had to also show my support for Emby. Anyhoo, here's what I slapped together using GIMP and KDEnlive. https://www.dropbox.com/s/jgugx5ucmxd6cqz/test1.mp4?dl=0
  12. I'm just trying to figure out if I have something set incorrectly or is Emby really has different playback screens for TV shows vs movies. When you get to a TV show episode playback screen, it shows the audio and video details and then has a drop down list of the available subtitles. When you get to a movie playback screen, the same information is not shown. The movie does have the details embedded. Using Tiny Media Manager, I get this information: So, I'm wondering what I need to do or change with my Emby settings to get the movie playback screen to show the same information as the TV episodes. Just as an FYI, I have also added an external subtitle file (.srt) file for this movie. So I would hope that some kind of subtitle information would be shown. Any help would be appreciated. I am still setting items up and have only done about 15% of our movies. I want to make sure that I copy everything the way Emby likes it.
  13. Hi, it would be very nice if you could change 1-2 things 1. when a video is playing and OSD is shown pressing the Back-Button should make the OSD disappear but actually the whole video stops playing and I fall back to the menu screen. same behavior as netflix, amazon prime video or maxdome would very nice ;-) This should not be a big thing I think. 2. actually it's not possible to access the progress bar of a movie with a normal remote. it's only possible to click on the progress bar and jump to a special timestamp of the movie if you have a "magic remote" with some kind of mouse integrated. It would be very nice to get the possibillity to access the progress bar by pressing the up-button once the osd is visible and then jump within the movie by pressing left or right buttons on the remote (maybe in 5 or 10 min steps) because again... same behavior as netflix, amazon prime video or maxdome would very nice ;-) thanx and keep on doing your great work! :-)
  14. Hello all. There was recently a new version of Emby which seems to have changed how videos, specifically TV show episodes are tracked and displayed. I used to just get the season for latest video, if I put more than one episode in the folder. Now it shows the season, and each episode, and sometimes the series as a separate item in the folder. I want it to go back to just the season or the episode. What changed? What setting do I need to adjust, Thank you.
  15. edencorbin

    thumbnails for my home videos

    I have a library of home videos (450GB) mostly mov and mp4. Emby is working fantastic for streaming these, however I'd like to learn how to generate thumbnails, ideally any suggestions on a program/automated way to do this. I don't care what image they use (could be first frame / middle / etc), I would just like the helpful image reference for all my videos and choosing which to watch. Also, my server is Ubuntu Budgie, and in the OS I can see thumbnails just fine on all the videos. Thanks for any suggestions. Really liking Emby!
  16. As suggested by @ebr I have split my original request to allow better monitoring of interest and progress. The original request is here https://emby.media/c...brary-overhaul/ If you are interested please like the post. I have noted that when I open a video from my picture folder, Emby doesn’t "understand" that it is part of the photo album and open it as a single file in the video player instead of the slide show. I think this should be seamlessly integrated into the Photo slide show. I don't know if it a bug or if it should be considered as a new feature.
  17. icedragonslair

    Audio Placement Mask Issues

    I am wondering if this will have any issues the audio in a theater surround system using kodi v18? It seems to be a little heavy on the audio on the right side or is it just me. These are the comparison of the two files (original vs converted) MediInfo entries, should I be concerned? ​​​​​​​ Full audio reports from mediainfo here: my newly converted hevc source: I am not sure if this is the correct place to post this, please feel free to move if needed. Thanks again for all, Ice
  18. Hello All, Im a bit new at this I just installed emby server on my Mac computer and just started with adding a couple of files to test it on my computer, S8 phone and Smart TV. However I am able to play all videos on both my mac and android phone but when I try on my Smart TV some wont play and I get error HTTP Status code returned by the server was 500 Im not sure why they wont play as they are mp4 videos, Im attaching the log file I got see if you guys could help me with it. Thanks in advance. error log Smart TV.txt
  19. I just bought an emby lifetime subscription today and I can't get any of the android apps to work. I can log in fine to Web Gui, Emby Theater, Kodi work (although EmbyCon is extremely slow and part of the reason I want to use the apps). I bought this subscription mostly to use the apps so I'm currently feeling like I wasted money. I can log into each of the apps (Fire TV and Android Phone). I have used my reverse proxy using apache, direct https and direct http ports and I can sign in using all of them but when I try to select something to play it just sits there. Although sometimes it seems I can get a SSL Handshake Error and other times it seems like it's not even recognized. Any ideas on what could be wrong? I have attached a couple server log.
  20. When I press on a video, it shows an information screen with media info, a thumbnail, and play/download/delete buttons. Is there a way to skip or bypass this screen and just play the video by pressing on it?
  21. Hi, Where can I see the audio and video formats not yet supported by Emby Server? I have in the collections several formats and some are not reproduced. Thank you
  22. Why: mediacowboy needed something to help find videos that wouldn't play directly on the Roku, but ended up required transcoding to do so. Notes: This only detects at present very basic reasons a file might fail. Container not mkv, mp4, mov, m4v, m3u8, ts Video Codec not H.264 Audio Codec not AC3 or Stero AAC Requirements: AutoIt FFMpeg Instructions: Install AutoIt and set it to execute scripts when double clicked. Create a folder somewhere...lets call it "Roku Detect uncompliant Videos" just to be unimaginative. Now inside "Roku Detect Uncompliant Videos" create a sub folder called "Bin". Now extract the contents of FFMpeg's "Bin" folder into your new "Bin" sub folder. Now going back into "Roku Detect Uncompliant Videos" folder Right Click on it's background and select "New\AutoIt v3 Script" from the context menu, and Rename it "Roku Detect Uncompliant Videos.au3" Now Right Click "Roku Detect Uncompliant Videos.au3" & select "Edit Script" from the context menu. Now paste the following code into: #Include <Array.au3> #Include <File.au3> #Include <String.au3> Dim $aKnown[7] = [6 , '.mkv' , '.mp4' , '.mov' , '.m4v' , '.m3u8' , '.ts'] Dim $aUnknown[1] = [0] Dim $sErrorLog ; Select Video Folder While 1 $sFolder = FileSelectFolder( 'Select Video Folder.' , '' , 6 ) If @Error = 1 AND $sFolder = '' Then MsgBox( 4096 , 'Exit:' , 'Ending Application' ) Exit ElseIf $sFolder = '' Then MsgBox( 4096 , 'Error:' , 'Unable To Open Folder.' ) ElseIf NOT FileExists ( $sFolder ) Then MsgBox( 4096 , 'Error:' , 'Invalid Folder.' ) Else If StringRight( $sFolder , 1 ) <> '\' Then $sFolder &= '\' $aAllFiles = _FileListToArrayRec( $sFolder , '*.*|*.bif;*.db;*.jpg;*.nfo;*.png;*.tbn;*.xml;*.srt;*.sub;*.ssa;*.mp3' , 1 , 1 , 0 , 2 ) If NOT IsArray( $aAllFiles ) Then MsgBox( 4096 , 'Error:' , 'No Videos Found.' ) Else _ArraySort( $aAllFiles , 0 , 1 ) ExitLoop EndIf EndIf WEnd For $ii = 1 To $aAllFiles[0] _Macros( $aAllFiles[$ii] ) $iFind1 = _ArraySearch( $aKnown , $sFileExt , 1 ) If @Error Then $sErrorLog &= 'Unknown File Type:' & @CRLF & $aAllFiles[$ii] & @CRLF & @CRLF $iFind2 = _ArraySearch( $aUnknown , $sFileExt , 1 ) If @Error Then _ArrayAdd( $aUnknown , $sFileExt ) $aUnknown[0] += 1 EndIf Else ; Build Array of Streams $sRandomString = _RandomString() RunWait( @ComSpec & ' /c ffprobe -show_streams "' & $aAllFiles[$ii] & '">"' & @TempDir & '\' & $sRandomString & '.txt"' , @ScriptDir & '\BIN\' , @SW_HIDE ) $aAllStreams = _StringBetween( FileRead( @TempDir & '\' & $sRandomString & '.txt' ) , '[STREAM]' , '[/STREAM]' ) FileDelete( @TempDir & '\' & $sRandomString & '.txt' ) ; Find Video Streams $aFindVideoStreams = _ArrayFindAll( $aAllStreams , 'codec_type=video' , 0 , 0 , 0 , 1 ) If $aFindVideoStreams <> -1 Then ; Process Video Streams For $aa = 0 To UBound( $aFindVideoStreams ) - 1 $sSVideoCodec = _RegExString( $aAllStreams[$aFindVideoStreams[$aa]] , '(?s)(?i)(?:.+?codec_name=(\S+))?' ) If $sSVideoCodec <> 'h264' And $sSVideoCodec <> 'mpeg4' Then $sErrorLog &= 'Unsupported Video Codec: (' & $sSVideoCodec & ')' & @CRLF & $aAllFiles[$ii] & @CRLF & @CRLF ContinueLoop 2 EndIf Next Else $sErrorLog &= 'Missing Video Stream:' & @CRLF & $aAllFiles[$ii] & @CRLF & @CRLF ContinueLoop EndIf ; Find Audio Streams $aFindAudioStreams = _ArrayFindAll( $aAllStreams , 'codec_type=audio' , 0 , 0 , 0 , 1 ) If $aFindAudioStreams <> -1 Then ; Process Audio Streams For $aa = 0 To UBound( $aFindAudioStreams ) - 1 $sSAudioCodec = _RegExString( $aAllStreams[$aFindAudioStreams[$aa]] , '(?s)(?i)(?:.+?codec_name=(\S+))?' ) $iSAudioChannels = _RegExString( $aAllStreams[$aFindAudioStreams[$aa]] , '(?s)(?i)(?:.+?channels=(\S+))?' ) If $sSAudioCodec <> 'AAC' And $sSAudioCodec <> 'AC3' Then $sErrorLog &= 'Unsupported Audio Codec: (' & $sSAudioCodec & ')' & @CRLF & $aAllFiles[$ii] & @CRLF & @CRLF ContinueLoop 2 EndIf If $sSAudioCodec = 'AAC' And $iSAudioChannels > 2 Then $sErrorLog &= 'To Many Audio Channels: (' & $iSAudioChannels & ')' & @CRLF & $aAllFiles[$ii] & @CRLF & @CRLF ContinueLoop 2 EndIf Next Else $sErrorLog &= 'Missing Audio Stream:' & @CRLF & $aAllFiles[$ii] & @CRLF & @CRLF ContinueLoop EndIf EndIf Next ; Create Error Log If StringLen( $sErrorLog ) > 1 Then If NOT FileExists( @ScriptDir & '\Error Logs\' ) Then DirCreate( @ScriptDir & '\Error Logs\' ) $sErrorLogFile = @ScriptDir & '\Error Logs\[' & @YEAR & '-' & @MON & '-' & @MDAY & '] ' & @HOUR & '-' & @MIN & '-' & @SEC & '.txt' FileWrite( $sErrorLogFile , $sErrorLog ) ShellExecute( $sErrorLogFile ) EndIf ; Create Unknown File Extensions Text If $aUnknown[0] > 0 Then $sUknownExtensions = @ScriptDir & '\UnKnown.txt' If FileExists( $sUknownExtensions ) Then Dim $aPriorUnknown _FileReadToArray( $sUknownExtensions , $aPriorUnknown ) For $ii = 1 To $aPriorUnknown[0] $iFind2 = _ArraySearch( $aUnknown , $aPriorUnknown[$ii] , 1 ) If @Error Then _ArrayAdd( $aUnknown , $aPriorUnknown[$ii] ) $aUnknown[0] += 1 EndIf Next FileDelete( $sUknownExtensions ) EndIf _FileWriteFromArray( $sUknownExtensions , $aUnknown , 1 ) ShellExecute( $sUknownExtensions ) EndIf MsgBox( 0 , 'Finished' , 'Batch Operation Complete' ) Func _Macros( $sFile ) Global $sFileDir = StringLeft ( $sFile , StringInStr( $sFile , '\' , 0 , -1 ) ) Global $sFileExt = StringTrimLeft ( $sFile , StringInStr( $sFile , '.' , 0 , -1 ) - 1 ) Global $sFileName = StringTrimLeft ( $sFile , StringInStr( $sFile , '\' , 0 , -1 ) ) Global $sShortName = StringLeft ( $sFileName , StringInStr( $sFileName , '.' , 0 , -1 ) - 1 ) Global $sParent = StringLeft ( $sFileDir , StringInStr( $sFileDir , '\' , 0 , -2 ) ) Global $sFolderName = StringTrimRight( StringTrimLeft( $sFileDir , StringInStr( $sFileDir , '\' , 0 , -2 ) ) , 1 ) EndFunc Func _RandomString() $sString = '' Dim $aSpace[3] For $i = 1 To 15 $aSpace[0] = Chr( Random( 65 , 90 , 1 )) ; A-Z $aSpace[1] = Chr( Random( 97 , 122 , 1 )) ; a-z $aSpace[2] = Chr( Random( 48 , 57 , 1 )) ; 0-9 $sString &= $aSpace[Random( 0 , 2 , 1 )] Next Return $sString EndFunc Func _RegExString( $sString , $sRegEx ) Local $sValue = _ArrayToString( StringRegExp( $sString , $sRegEx , 1 )) If StringIsFloat( $sValue ) = 1 OR StringIsInt( $sValue ) = 1 Then Return Number( $sValue ) Else If $sValue = 'N/A' OR $sValue = 'N' OR $sValue = 'A' Then Return '' Else Return $sValue EndIf EndIf EndFunc Now save the script & execute it by double clicking it and then select the folder holding your videos that you wish to process. Now go do something else, this will take a while...maybe a great while depending on the number of videos you have. The script will notify you when it's done...and if you're curious as to if it's still running there should be a icon in your system tray that looks like a blue "A". Past that you can start your Task Manager and you should more than likely see FFMpeg running in the background. Result: This should possibly produce one or more text files. The primary one will be what is produced in the "Error Logs" folder, this will list what files failed and why...but keep in mind these only list the first reason why it failed, not all possible reasons it may have failed. A number of these may not even be video files at all...but a format that should have been excluded from the search. Which brings me to the next file "UnKnown.txt" this file will be updated with one instance per unknown file extension, possibly every time you run the script and it finds something new. Now ideally I have all or at least most common non video extensions excluded from the search...this is everything on the right side of the pipe "|" symbol on line 21 at present. You may wish to add new extensions to be excluded from future searches...thus speeding the script along...but please consider sharing your additional excludes here in this thread, to help others out as well. What Next: You may wish to use one of my app's, called VideoGain (free) to process the failed video files. It's main purpose is to batch adjust audio volume, so that all the videos have more or less the same gain...so you don't have to monkey around with your volume all the time. Originally it only processed folders full of videos...not individual, but since I was already making some corrections to it already...I set it up to do single files as well. Here is where we get hackish. Download VideoGain & extract it somewhere...ideally in a folder called VideoGain so it's easier to find later on. Now Start it by double clicking on it's exe...then close the app...it will now have produced a new INI file...and we are going to edit it's contents with whatever your favorite text editor happens to be (Notepad, Notepad++, UltraEdit,..). In the VideoGain.ini all the way at the bottom...you should see an entry called "[Folders]". Now below that we'll be adding entries of our own...basically copy and paste from your Error Logs...into this file...but before each path put "Folder_#=" replacing the # with a number value...please keep each value different, and each entry on a new line. I'll likely write a simple script to help in this matter tomorrow. Anyways once all the edits are made...save the file, and restart VideoGain. You should now see all the files you want to process listed on the "Folders" tab. Now check "Direct Replace" and uncheck "Recurse Folders" (not needed). Now click on the "Settings" tab. If you had any videos that failed because they were not H264 then set the Encoder to "Conditional" which basically means if VideoGain doesn't detect the video stream to be H264..to then encode..but only then. Make further adjustments as you like to the H264 settings and Video settings. Now if you had Audio errors, you have a few picks...you can go with AAC or AC3...encoders...with the covet that AAC is limited to stereo. Right now if you select AC3...all videos will have the audio track re-encoded, bar non...I don't have an early out for that right now as I just added AC3 support...however if you select AAC and a number of your tracks are already AAC...and those tracks are Stereo...then you can select "ReplayGain (Tags)" this will do a non damaging adjustment to the AAC tracks...however all non AAC tracks will be encoded to AAC. Select "Stereo DownMix" if you plan to use AAC. All resulting files will ether be Mp4 or Mkv depending on what you selected for a container, from the drop down at the bottom of the application. Press "Start" and away you go. I would personally suggest doing at little processing as you need to. Each time something gets encoded...it gets more damaged.
  23. With the recent Emby Theater update, my video does not start in full screen. I think it has something to do with multiple monitors, because it will go to full screen if I move it to the other monitor. However, both monitors are at the same resolution, 1920x1080. After I move it to the monitor that fixes it, I can move it back to the proper monitor and it stays full screen.
  24. Blue Kachina

    Camera Upload - Video Files?

    Hey all; Does anyone know if it's possible to enable the upload of video files from the camera upload feature? Mine seems to be grabbing images, and I'm amazed at how fast it's working, but video files get left behind.
  25. SmokenOaken

    Google Cardboard

    I've been using google cardboard a lot as of late to watch my media via my Note 4 in Virtual Reality 3d. There are some decent apps for this, but none so far from what I can see with the ability to stream media to my phone. My favorite app the 3d application so far is Full Dive. Has there been any thought to build native support in to the Android Media Browser app to view streaming media browser content and 3D movies to a smart device in a sort of Virtual Cinema view. I think this would be a great addition to this already amazing product.
×
×
  • Create New...