Jump to content

Search the Community

Showing results for tags 'library'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hi, so what I'm suggesting isn't just the whole WebUI page refreshing when any changes is detected, I'm leaning more toward the Plex approach. Meaning, when scanning your library folders (per show/movie/etc.) you'll get the percentage indicator or a spinning icon signaling that the server is in the middle of the process. The lack of indicators when making changes is resulting in an unawareness of if the action you just performed is in effect or has completed. It's a small but appreciated quality of life addition.
  2. 怎么修改媒体库默认顺序? How to modify the default order of the media library? 当我设置新用户的时候,媒体库顺序是我想要的顺序呢? When I set up a new user, the order of the media library is what I want? 是添加CSS还是修改配置文件? Should I add CSS or modify the configuration file? 图片1是目前默认的媒体库顺序,对于我来说不是很满意,图片2为我手动修改的媒体库顺序。 Picture 1 is the current default order of the media library, which is not very satisfactory to me. Picture 2 is the order of the media library that I manually modified.
  3. After upgrading to Emby Server 4.6.4.0 my music library no longer displays graphics. Every MP3 song of every album in my collection contains an embedded album image. Each folder includes a folder.jpg. I also did a new library scan after the upgrade. So I don't know why the views are all blank now. - How can I fix this or is this a problem of the Emby server release?
  4. Queria saber como posso usar um servidor local como pasta / caminho de acesso aos meus arquivos de vídeo para da biblioteca, tentei localizar com uma opção de rede pórem ele não encontrado, e como sugerido tentei colocar o endereço, mas também não consegui localiar. Eu criei esse servidor no meu aparelho android atraves do app termux e utilizei o rclone para compartilhar as minhas pastas no google drive, como não possuo e não pretendo fazer root, não consigo montar o drive na minha pasta raiz, mas consigo compartilhar em uma rede ftp / sftp / http / webdav / dlna local. a ideia seria, acessar esse rede agrupada para criar uma biblioteca no emby, eu até conseguiri montar no app kodi, mas queria poder fazer o mesmo no emby, abaixo segue um exemplo/uma das minhas tentativas de criar uma biblioteca, no caso eu utilizei um servidor http, com endereço http: // localhost: 8080 /.
  5. artatgray

    Collections have disappeared!

    Ever since the latest updates my Collections have disappeared from My Media. How do I restore them, if possible? Thanks in advance, Bill
  6. acnp77

    Default Library Images

    I made some default library images for those who like a clean, simple interface. The idea is to put the content in first place. Just in case anyone wants to use them. I used the green from the default Emby theme, the icons are from the google material icon set, style set to rounded, to match the recent Emby style. (Although I do not like that everything needs to be round nowadays). Images are 16:9 / 1920x1080px png-files. Movies: TV: Music: Home Videos: Playlists: All.zip
  7. Hi guys, I created those simple library icons for myself but decided to share - maybe someone will find them useful. Every icon is a PNG file in 1280x720 px. Download link: https://drive.google.com/drive/folders/15SGUccIljBZEysLj-cuMzpJ3I3QOVbIB?usp=sharing
  8. Hi, Yesterday Emby started acting very strange. It does not update the library after I manually select "Scan Library Files." Also, it is behaving very strange re: one of my TV series, The Streets of San Francisco. The file structure for that TV series is shown below. When I click on the three dot menu for the folder, as you can see below, there is no option to identify the content. And, when I click on the folder, I see the following: Any idea as to what is going on? I've attached my server log, in case that is helpful. Thanks, I appreciate the help. Bruce embyserver.txt
  9. Hi, I use one single source containing both Music and Videos files, organized by Music Styles and then Artists. I configured two libraries : One for music, the other for the videos. I want to browse by Folders, as my hard disk is well organized. If I ask Emby to scan one of them, it scans them both at once. After the scan, I can only see content in the Music library and nothing in the Videos library. I already tried with two different sources, one for music and one for videos, and it works, but I need Emby to scan one single source and produce two different libraries with different media. I also tried using a Mixed Content Source, but no result at all. Is it a bug in Emby ? How can I view videos in the same source ? Thanks,
  10. Hello, running Emby 4.5.4 on a QNAP NAS (installed the QPKG). I do have a large collection of photos. They are organized as follows: photos - album-1 |_photo-files.jpg - album-2 |_subfolder-1 | |_photo-files.jpg |_subfolder-2 |_photo-files.jpg For one folder, the thumbnail generation is way of . e.g. 15000ms vs 50ms in other folders Here is a log snippet of the "bad ones" after enabling debug logging - there are a lot of those entries. 2021-01-20 12:23:28.818 Debug ImageProcessor: Image encoding to /share/CE_CACHEDEV1_DATA/.qpkg/EmbyServer/programdata/cache/images/resized-images/e/e6ca8522-d110-e989-efd3-c056bc02c700.webp took 15305ms for /share/Multimedia/Bilder/0001 - Kita Elia/Fotos/20190417_083426.jpg 2021-01-20 12:23:28.823 Info Server: http/1.1 Response 200 to 192.168.20.38. Time: 15311ms. http://192.168.20.201:8096/emby/Items/1901/Images/Primary?maxHeight=402&maxWidth=536&tag=99aecaefa4ef3ca0641c3fcc51d802dc&quality=90 2021-01-20 12:23:28.838 Info Server: http/1.1 GET http://192.168.20.201:8096/emby/Shows/NextUp?Limit=24&Fields=PrimaryImageAspectRatio,SeriesInfo,DateCreated,BasicSyncInfo,CanDelete&UserId=3a9f52e6bee44f3d9a64905a3747f7b3&ImageTypeLimit=1&EnableImageTypes=Primary,Backdrop,Banner,Thumb&EnableTotalRecordCount=false&X-Emby-Client=Emby Web&X-Emby-Device-Name=Firefox&X-Emby-Device-Id=9338ec6d-560f-4712-9779-72decc4795fc&X-Emby-Client-Version=4.5.4.0. UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:84.0) Gecko/20100101 Firefox/84.0 2021-01-20 12:23:28.915 Debug ImageProcessor: Image encoding to /share/CE_CACHEDEV1_DATA/.qpkg/EmbyServer/programdata/cache/images/resized-images/5/51418746-845f-7c34-663c-e1199d08cf41.webp took 7734ms for /share/Multimedia/Bilder/0001 - Kita Elia/Fotos/20190515_105751.jpg 2021-01-20 12:23:28.916 Info Server: http/1.1 Response 200 to 192.168.20.38. Time: 13974ms. http://192.168.20.201:8096/emby/Items/1332/Images/Primary?maxHeight=402&maxWidth=536&tag=005f85d5e1c3948a54e5d8c73b94fae4&quality=90 2021-01-20 12:23:28.917 Info Server: http/1.1 GET http://192.168.20.201:8096/emby/Users/3a9f52e6bee44f3d9a64905a3747f7b3/Items/Latest?Limit=16&Fields=PrimaryImageAspectRatio,BasicSyncInfo,ProductionYear,Status,EndDate,CanDelete&ImageTypeLimit=1&EnableImageTypes=Primary,Backdrop,Thumb&ParentId=d28622d6e0964adea39c5655ae42ebf0&X-Emby-Client=Emby Web&X-Emby-Device-Name=Firefox&X-Emby-Device-Id=9338ec6d-560f-4712-9779-72decc4795fc&X-Emby-Client-Version=4.5.4.0. UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:84.0) Gecko/20100101 Firefox/84.0 2021-01-20 12:23:28.918 Info Server: http/1.1 GET http://192.168.20.201:8096/emby/Users/3a9f52e6bee44f3d9a64905a3747f7b3/Items/Latest?Limit=16&Fields=PrimaryImageAspectRatio,BasicSyncInfo,ProductionYear,Status,EndDate,CanDelete&ImageTypeLimit=1&EnableImageTypes=Primary,Backdrop,Thumb&ParentId=edae26323168f18aa689be99f2f84e42&X-Emby-Client=Emby Web&X-Emby-Device-Name=Firefox&X-Emby-Device-Id=9338ec6d-560f-4712-9779-72decc4795fc&X-Emby-Client-Version=4.5.4.0. UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:84.0) Gecko/20100101 Firefox/84.0 The difference is that the photos in this folder are created by mobile phones out of my reach (daycare teachers). I deleted and readded the library and no change. ALSO I noticed that the thumbs are recreated on other devices. I scrolled through the folder and thumbs are shown on my MacBook/PC then I moved to a FireTV and the thumbs had to be created again (took a looooong time to see one). In comparison to other folders, which go fast, this is weird. I now moved the cache path from standard to an external one to have faster and better access. Any idea how can help debugging this further? Weirdly I used Jellyfin shortly prior to moving to Emby (dont want to open "wounds" here) and Jellyfin even cannot create thumbs of the images in this folder. With both solutions I can watch them though. But in Emby the server gets busy creating thumbs and the experience degradates while watching this album/folder. I searched the forum and didnt find a solution. Any help - for debugging or fixing it?
  11. Hello, i just started with Emby Server and added new Music Library with hundreds of songs. They are id tagged with track name, artist, album and genre. When library scan finish, genre and album section in library is empty. Is because genre are not standard like "POP" but personalized "POP1"? But the same happened to "album". Please help Thanks
  12. Hello, I already have a Movies library for 1080p content however, I would like to add another Movies library for UHD (4K) content. Currently, if I create another Movies library with the title, UHD Movies, each UHD movie that also has an identically titled counterpart in the original Movies library for 1080p content shares the same play status progress and subsequently, 2 thumbnail images are displayed on the homescreen under the Continue Watching heading. One which is linked to the 1080p movie, and another for the UHD movie. Is there any way to disassociate the movie libraries by creating a library content type for us called 4K Movies or UHD Movies that will contain it's own unique play state information? Or, allow us to name our own content type to create the split which we will also then select it's parent content type from the existing list. Many thanks
  13. Below are several system configuration outputs. Files are accessible using file manager. EMBY Library Access pi@raspberrypi:~ $ ls -l /media/pi total 12 drwxr-xr-x 2 pi pi 8192 Dec 31 1969 'AL USB' drwxrwxr-x 1 emby emby 4096 Sep 26 09:49 embydisk pi@raspberrypi:~ $ sudo lsblk -o UUID,NAME,FSTYPE,SIZE,MOUNTPOINT,LABEL,MODEL UUID NAME FSTYPE SIZE MOUNTPOINT LABEL MODEL sda 57.7G USB_D EC68CD1868CCE306 └─sda1 ntfs 57.7G /media/pi/ EmbyDisk sdb 14.5G 8280-12EE └─sdb1 vfat 14.5G /media/pi/ AL USB mmcblk0 59.5G 6284-658D ├─mmcblk0p1 │ vfat 256M /boot boot 3a324232-335f-4617-84c3-d4889840dc93 └─mmcblk0p2 ext4 59.2G / rootfs pi:x:1000:1000:,,,:/home/pi:/bin/bash /etc/fstab /dev/sda1 /media/pi/embydisk ntfs-3g rwx,uid=emby,gid=emby,dmask=0002,fmask=0003 0 0 Thanks for any help.
  14. Hi all Half a year ago, I moved my emby instance from my NAS to a seperate machine (Win10) to get better performance. However, as I'm using emby as a DVR and my library got quite ... ähm ... "comprehensive" by now, I also upgraded my NAS and seperated media server and data storage. I'm using SMP paths in my libraries to add the shared folders to emby (location = \\SERVER\FOLDER1). I had a power outage today and (re-)noticed an odd behaviour of emby: as my media server is a lot faster in booting up as my NAS, accessing the library failed when emby service started. As a result, some of my libraries where just gone from the admin interface and in the remaining ones, nearly all the entries were missing. Restoring my nightly backup did fail as well (I experienced the already known bug with multiple entries after restore) ending up with me deleting all libraries and setting them up again. Yes, one could think that the settings were damaged by the shutdown, but I already experienced the same behaviour when I shut down the NAS and media server in parallel a few month ago. Did you experience something similar in the past? If so, it seems that emby doesn't destinguish between "non accessible" and "non existent" when accessing libraries. It might then be a good idea to catch that error and allow some access retries or even "halt" / "pause" a library that can't be accessed instead of just deleting the entries or even the whole library. If not, it might just be my setup and I would appreciate any tips on how to change it to avoid a repetition of that... Cheers!
  15. Hello, i have this music collection where the folder structure is the that. artist - artist name and box set name - disk name - flac file the problem is te album name or flac file dont appears on library. same budy can tell me why?
  16. Hi I just added my library from downloaded youtube channels to emby, but it tries to add every video to a season and is really buggy. pic 1 I tried the library type mixed, home videos and pictures and musicvideo. This happens only with 7 channels the others are how it should be pic 2. I have one folder called Youtube and for every channel a subfolder. I havent added anything to the videonames like S01E02 or sth How can i turn off season sorting for the whole library Thx
  17. Hi I have one library for my downloaded youtube videos with several folders (for every youtube channel one) Because they are youtube videos there is no metadata from moviedb or other and one frame is taken as prev. Very warped with the default view. Because of that i went to setting and choose the view "thumb" image 1 But this is not used for the subfolders for each channel and i dont want to go through 100ths of folders and set it in every folder manually. Can i set this as default for the whole library. The second thing is do i need to click sth that the prev images are rendert? because some of the videos do have prevs but others not and it isnt rendering at the moment. Thanks
  18. I am in a process of moving my libraries from NAS to Mac mini. I have about 25 libraries and it is a pain in the *** to update the location of each library. Can you please add a simple way to bulk edit libraries to update locations?
  19. Emby is far better, in every way, than Plex. An improvement would be a drop down option from the Menu bar to Scan the Library (videos added to my source folder for the library don't automatically appear in Emby, so I have to scan to load them).
  20. I’d like to be able to set a library to filter its contents, rather than including everything in a folder. in particular I’d like to be able to filter by language, so I can have one library that contains only TV shows with English audio, and another that has only shows with Russian audio, and I can have both pointed at the same folder (containing some English, some Russian, and some dual audio). In another topic Luke confirmed that filters for language will be in the next release, but as far as I know there’s no way to permanently set a filter for library contents. Searching with filters is ok when I’m looking for something, but way too cumbersome for my wife and kids. A solution that lets them just open the Russian library (without keeping duplicates of all my dual-audio content) would be really cool. Thanks!
  21. Good night, my Emby Server stopped adding new movies and series to the library, even running manual manually it won't. Please help me. thank yo
  22. Hello I manage to add a public, so not password protected share of a samba server as a library folder, which seems to work just fine. \\servers-hostname-or-address\sharename It took me a while to figure out that I really have to use windows style network share annotation BTW, despite anything here is Unix-ish, including the docker host and the Emby docker image.. so smb:// is simply not understood... Perhaps It would be great the documentation mentioned that somehow. If told where I'd not hesitate to contribute that tiny little However, I'd like my Emby Server to store metadata as NFO, and thumbnails along with my media files. So that obviously requires write access. For obvious reasons I'd not like to share my media file directories writeable without any password protection at all. So how would I enter the URL with username and password? Or does Emby even offer a better way to identify itself to a windows like samba server? I don't have any active directory or anything. It is really the dumbest and least advanced version of a samba config I could manage to get a modern samba version to agree on running with. TIA for any hints. Casaper PS: Currently I have that working but quirky and not ideally as SMB-Shares mounted natively to the docker host system and then linked to emby server with additional volumes.
  23. Why It's troublesome to manage bottom up permissions (User -> Access -> Folder) and personally I think that a top down (User <- Access <- Folder) approach would be better (or both). I understand that changing access permission structure might be troublesome (or not desired by everyone) so I'd like to suggest something else instead Feature I think it would be a good idea to have a setting in the "Libraries" that allows you to make a folder hidden by default. That way when you add a new user you don't have to worry to much about them having access to all the folders and it improves user management. It's a good solution for servers that have a lot of users to manage. This isn't a must have but more of "Quality of life" feature. How These changes would have to be implemented: 1. Add the setting to the Libraries under "Advanced options" -> "Library Settings" 2. Disable "Enable access to all libraries" setting in the user access settings if any of the libraries (for that user) are hidden, and enable all but the hidden library. OR alternatively... disable "Enable access to all libraries" (so that the list of libraries shows up) for all users if any folders are hidden, then the hidden folder should not be enabled on the access list.
  24. Neil Newbie

    Music libraries are merged

    Newbie here, just transitioning from Plex. Forgive me if this has previously been discussed, I have searched the forum but I haven't found anything. I have multiple music folders, Albums, Singles, Live Concert etc. I've created them all as separate libraries. But under the 'Artist' or 'Album Artist' tabs they all get merged together. How can I ungroup these, making the separate libraries?
  25. Hi, i have a pc with win 10 and emby 4.4.3 running on it. There are 5 HDDs (V:/ - Z:/) and each of them contains a "movie" directory and a "tv-shows" directory. All directorys are read to the library exept one, it's W:/Movies. W:/Tv-Shows is read without problems. I've tried to read a single Movie from W:/Movies (All movies are listet in the dropdown menu when i add this directory) without success. I've detached and reattched W:/Movies several times. I've uninstalled and reinstalled emby server from my pc without success. What's the problem here and how can it be solved? @cayars
×
×
  • Create New...