Jump to content

Search the Community

Showing results for tags 'kodi'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hallo liebe Gemeinde, Problem1: Ich brauche eure HILFE , es geht darum ich habe zwei Systeme wo Kodi 17.4 darauf läuft, einmal einen Fire tv2 und einen Fire tv stick und einen emby server auf dem RaspberryPi 3 . Ich habe das Problem das jedes mal wenn ich einen Film schaue und den zum Beispiel nach 30 min Stoppe wird er mir bei Kodi sowie auf dem emby Server als gesehen angezeigt und kann ihn nicht an der gestopten stelle weiter fortführen. Problem2: Wenn ich über meinen Computer schauen möchte dann kann ich die Filme anwählen aber er spielt sie nicht ab ffmpeg ist installiert . Desweitern meckert auch der Apple TV und gibt eine Fehler warnung heraus. Liegt das an dem RaspberryPi3 das er die mkv dateien nicht transcodieren kann oder ist er zu schwach auf der Brust ? ffmpeg-transcode-60cc35fa-ab79-43ea-97a1-ebbafc208778.txt
  2. Hi guys, I have Emby (V 3.0.5972.0) as the librarian/server for a huge Movie and TV library and watch the shows via Kodi. Problem is, regularly when I start Kodi, it will lose the link to Emby (a orange message appears in the middle of the screen) and I have to re-scan the WHOLE library to be able to watch anything, and have the watched state change. If that was just the problem, it would be OK, just annoying, however, most times when it tries the re-scan it will stop and say an Error Log has been created. 1) Where is the Error Log saved ? 2) How to I get to the error log on an Asustor ? 3) How do I read it ? or copy the error log to my PC so I can read it ? Thanks. (PS Using Kodi with Emby is a real nightmare !!)
  3. nerachnaku

    Path Substitution Issues

    Howdy, I have been having issues with my setup after switch to streaming to Kodi using direct paths and path substitution on the server side. I have found a work around and am posting here in case someone else was having this issue. Issue: When setting path substitution for folders movies are handled differently than TV shows. EX: For movies the trailing \ is required to resolve a path properly (\\EXAMPLE\Movies\ will resolve correctly but \\EXAMPLE\Movies won't as it merges the file name and the folder name together). TV shows on the other hand behave differently and require the opposite when setting the Path Substitution per folder (\\EXAMPLE\TVShows will resolve correctly but \\EXAMPLE\TVShows\ will not as the Kodi plugin resolves it as SMB:\\EXAMPLE\TVShowsSMB:\\(TVSHOWNAME)). It seems that the movie handler won't add the trailing \ when resolving a network path and the TV handler interprets a trailing \ as SMB:\\ Work around: When setting the path substitution on the server be sure to include a trailing \ (\\EXAMPLE\Movies\) for Movies and when setting the path substitution for TV folders omit the trailing \ (\\EXAMPLE\TVShows) If anyone has any questions please reply and I will try to clear up anything I can.
  4. Hi there, I have an Emby Server that is capable of transcoding. When transcoding and watching the transcoded stream in a browser everything is perfectly fine. However I have a RPi3 with Kodi, that is connected via Wifi and one that is connected over the Internet. Both play videos, that are not transcoded perfectly fine. For some videos however, I need transcoding and these videos keep on stuttering. I tried to enable the Kodi cache in the advancedsettings.xml, cause it seems like a caching problem for me. Caching works fine for videos that are not transcoded. The cache is filled up to the desired value. When I start a transcoded video the cache is not filled and the videos stutters every now and then because the Wifi speed sometimes drops under the bitrate value (but is a lot over that in average). Is this a known behaviour? Might be connected to the fact that transcoding produces lots of small .ts-files. I couldn't find anything in the search. Are there workarounds so the transcoded files are cached as well and can be watched smoothly over Wifi? Thanks for your help!
  5. edd--

    kodi addon not updating / syncing

    Hi, since a few week I noticed my library is not syncing anymore: when new movies or episodes get added I have to perform a manual refresh to get the changes pushed through. I tried reinstalling after doing a library purge (erasing all emby addon settings) and also tried on a completely differnt system. Kodi is OSMC (latest build) Any help is appreciated !
  6. thejacer87

    SMB instead of HTTP

    so here's my setup: Media Server: shitty computer that runs sonarr, transmission etc. and the HDDs storing all the media are here. SMB server is here! My Main computer: running the emby server Rpi3 with Kodi: uses the emby for kodi add-on. obviously connects to the emby server at 192.168.1.X (emby server IP). No playback issues. But if i try to use smb. it tells me it can't connect to smb://192.168.1.X/path_to_file. Well that's obvious, my main computer doesn't have an SMB server. so in the network settings i add for the ip 192.168.1.Y (media server ip) and the network creds. but when i go to play a video, i get the same error saying "can't connect to smb://192.168.1.X/path_to_file". So i guess my question is: What is the correct way to smb to a different server than the emby server? Or, is that even possible? thanks
  7. Hi, I've found a bug in the network credentials add wizard. If the username contains a \ because its authenticating against a domain. It doesn't work, I believe it's doing something with the \ I tried, good number of times reentering it. Reopened Kodi, still no luck. I fixed it but going in to the file manager. Adding a new Source, then when it asked for my SMB credentials I said to remember these credentials for this path. Used my domain\user and then I was able to use Kodi. I hope this can be fixed as I took a while for me to think of another way for Kodi to remember my credentials. Jonny Using Kodi 17.2 I would upload logs but using an Android TV box(Nvidea Shield), so not so easy to grab the logs off it. I'm guessing its converting the character to something else
  8. mrbrahman

    Folder view for "Unset (mixed content)"

    I'm trying to setup Emby plugin for Kodi to view my home videos, and setup the folder in the library as "Unset (mixed content)". While the Emby UI (on the browser) shows the folders nicely, I'm not able to see the folders in Kodi (using Emby plugin). The Kodi plugin shows all the videos flattened out under the top folder. I used the instructions in kodi wiki to setup the Emby plugin, and use the default skin (Estuary for Kodi 17.3) Any pointers on how to view all the sub-folders in Kodi? Thank you!
  9. Syztemlord

    Add from shared server?

    Hi guys, A friend has shared his server with me and I'd like to link this content to my server so I don't have to keep switching between the 2. I'd ideally like to link his content so I can view it in EMBY-Kodi alongside my local content. Is this possible?
  10. Hi, Before I was using Emby, when I'd use Kore to control Kodi, if something was playing, the Kore app on my android device would show the backdrop, poster etc within the App. Now after setting up Emby and using it within Kodi, the Kore Remote no longer shows the poster or the backdrop within the App. The cast pictures and preview image are also no longer showing in Kore. Within the folders for each TV Show/Movie on the media server I can see the folder.jpg and the backdrop.jpg and they display fine within the web access to Emby and within Kodi. My guess is that Emby is storing these media within it's own database and while these images are available via the addon in Kodi, it's not the case for the Kore app. Anyone else seen a similar thing or have any ideas what to do? I'm reluctant to change the settings in Emby to store the media within the TV folder because that will change the modify dates on the folders and ruin the order within Kodi (sorted by date modified), but if that's what I have to do, that's what I have to do. Attached are some screenshots, 2 from a computer I've not installed the Emby Addon in Kodi (Kodi1 & Kodi2) and the other (the main mediapc) has the Emby Addon installed (Emby1 & Emby2). Any idea on what I should do to resolve this? Thanks.
  11. Hi, As @@Luke asked for logs here - I'm making this thread in Synology section since I'm using server on DS916+ I have a problem with external ass subs. Tried few clients (server restart before, tested in that order - might be useful info while reading logs), and that's what I've got: Windows: Emby Theater: ASS ok, Direct Playing Chrome - ASS ok, Direct Streaming, F11 fullscreen OK Raspberry: Emby for Kodi- ASS shows, but no formating/color Kodi directly from NAS share - ASS OK - just to check, that Pi/Kodi itself can handle it Android: App: Not playing movie at all - movie not starting, som other plays ok, and once after trying others tested file started but only with English subs, and after closing it - again not starting ... Chrome: ASS OK, Direct Streaming, Fullscreen OK VLC directly from NAS share without Emby - ASS OK Ipad App - transcoding 3.2 Mbps, no subs, even embedded English are not working Chrome - Direct Streaming, ASS works, but not on fullscreen (I know, that subs in browser is some kind of hack - Luke explained me already in different thread) Safari - same as Chrome Ipad VLC directly from NAS - Video plays, I see english subs, but external ass are not available (no on list) All tests made on same video file, transcoding in server set to not using VA API - only software. Bellow I attach logs from this debug session. If this will help, I can send link to tested video/subs (it's less than 300mb) ffmpeg-remux-2b9e70bb-7c04-4f5d-8fad-b45472958b51.txt ffmpeg-remux-20af0644-03d6-47aa-9c37-51620505dd21.txt ffmpeg-remux-923d313f-12c8-4b5e-821d-633a37c9e8e1.txt ffmpeg-remux-abc20902-069f-400a-a4d9-00a13c17bd83.txt ffmpeg-remux-abf09d87-c4b6-4b74-b04f-b2c0674e7d8a.txt ffmpeg-transcode-7ed88e21-482c-4990-b358-669f78c3df2e.txt ffmpeg-transcode-1223dba0-0ba2-4da7-a12c-afa53a1a40cf.txt ffmpeg-transcode-bcb65f5a-7982-414a-8685-07aa9ef18ee7.txt server-63635074186.txt server-63635117859.txt
  12. Hi, I'm having some issues attempting to use an external player (in this case VLC) with the Emby for Kodi add-on. If I use the "Add On" playback mode (which I prefer), the external player will not open and Kodi defaults back to the default videoplayer. It will only work if I use the "Native (Direct Paths)" playback mode in the Emby add-on settings (or if I navigate directly to the video using the Kodi file manager). Seems like a path issue of some sort, but it seems others have had success with external players without any special path gymnastics, so not sure what is causing this issue. Please note, I am using smb to access in Kodi (path subsitution is set up on the Emby server). Using latest (stable) version of add on. Kodi version is 17.3, running this on a Windows 10 system. Copy of playercorefactory.xml is attached (but it is very plain vanilla). So what am I missing?! playercorefactory.xml
  13. lacattano

    problems with repository not showing up

    hey, I'm new to kodi (version 17 btw if that matters) but I've managed to set up a few add ons but there is one I just can't get to work. I've added a new source, I can confirm I've done this correctly as I did it wrong initially haha, now the repository shows when i click in the name of the file source. My next step is to go to add ons, then Install from repository but the repository doesn't show there? I' tried uninstalling the other repositories but that hasn't helped. If anyone can helo point out where i went wrong that would be great
  14. awakening

    Favorites kodi and synology

    Hi. I installed the Emby server to my synology 1010 server. Via the Emby dashboard i added favorite movies. Somehow the Emby favorites folder on Kodi remains empty. When Emby was running from my PC before, the favorites would be accessible from within Kodi. Now the Emby favorites folder remains empty. Any suggestions perhaps?
  15. Guardian Hope

    Arctic Zephyr: From Ashes

    Arctic Zephyr: From Ashes http://imgur.com/a/bNlCO The beloved theme which has had an 80 page run with Kodi Isengard (v15) returns in Kodi Jarvis (v16) as Arctic Zephyr: From Ashes. As @@im85288 and @@badaas move on to Eunique (which so happens to use From Ashes' Audio Suite so check it out!) long term support custodianship of what I personally like to believe is one of the best themes currently out for Kodi has fallen to me. Although updates won't be as frequent as they once were, the point of From Ashes is to ensure that it continues to work in Jarvis and beyond. Released Christmas Eve, Arctic Zephyr: From Ashes features all the enhancements made to the Kodi experience by its predecessor while introducing new enhancements such as the Arctic Zephyr: From Ashes Audio Suite to ensure that you have an engaging multimedia entertainment experience. Current Version: 3.4.70 (December 13, 2016) / 4.9.92-alpha9 (January 08, 2017) Official Sites Official Site: https://northebridge.com/systems/oss/kodi/fromashes (IN DEVELOPMENT) Kodi Forums: http://forum.kodi.tv/editpost.php?pid=2227162 Emby Forums: http://emby.media/community/index.php?/topic/29180-arctic-zephyr-from-ashes/ Lifecycle Policy To help ensure and maintain the Arctic Zephyr: From Ashes experience, NortheBridge has imposed a lifecycle policy. Each major release of Arctic Zephyr: From Ashes undergoes several phases during the active life of the Kodi addon: Preview Availability (PA), General Availability (GA), Long Term Support (LTS), and End of Life (EoL). The lifecycle policy for Arctic Zephyr: From Ashes is available at https://northebridge.com/systems/oss/kodi/fromashes/lifecycle as well as displayed below: Arctic Zephyr: Exploded - Kodi 15 Isengard - Initial Release: April 2015 - Status: End of Life (November 2015) Arctic Zephyr: From Ashes - Kodi 16 Jarvis - Initital Release: December 2015 - Status: LAST CALL UPDATE (November 2016) Arctic Zephyr: From Ashes (Danvers) - Kodi 17 Krypton - Initial Release: August 2016 - Status: Preview Availability (August 2016) Arctic Zephyr: For Another Age - TBD/Future Successor Requirements (Kodi 17 Krypton) Kodi Krypton (v17) NortheBridge by Design® Repository or the Emby Beta Repository Optional Suggested Addons (Kodi 17 Krypton) Get Emby Server (All Platforms) Install the Emby Server Addon for Kodi Kodi 16 (Jarvis) Arctic Zephyr: From Ashes support for Kodi Jarvis (Kodi 16) is coming to an end and is now in "End of Life" Status. As of November 2, 2016, it is no longer supported and will not receive future updates. However, we understand that not all devices are Kodi Krypton ready yet. The installation is a little different on Jarvis than it is on Krypton. Rather than installing from a Repo, you'll need to download the zip file from the "How to Get It (Release Channels)" section below and you'll need: Emby Beta Repository Script.Duration which is also available in the Emby Beta Repository Description Conceived in April 2015 as "Arctic Zephyr: Exploded," by @@im85288 and @@badaas before later being curated and published by NortheBridge as "Arctic Zephyr: From Ashes," authored by @Guardian Hope - From Ashes is the second generation and successor of the "Arctic Zephyr: Exploded" skin for Kodi and introduced support for Kodi Jarvis while retaining its predecessor's capabilities and design. Now that the From Ashes Project is moving into its second year, the third generation of the skin - "Arctic Zephyr: From Ashes Danvers" is now co-authored by @Guardian Hope and minus0 and introduces new features and design aesthetics for a modern skin intended for Kodi Krypton. It continues to be published by NortheBridge and is based on the original Arctic Zephyr created by Jurialmonkey although many have posed the notion that Arctic Zephyr: From Ashes is in its own right, a skin by itself due to how far it has diverged from the original. History This From Ashes project has existed on the Emby forums since 2015 and was brought to the Kodi forums with the release of the "Arctic Zephyr: From Ashes Audio Suite," into the official Kodi Repo the latter available for use with any skin or skin modification provided the appropriate credits are given. Officially, the "Arctic Zephyr: From Ashes Audio Suite" is used in Arctic Zephyr: From Ashes and Eunique but will work with any skin. Arctic Zephyr: From Ashes supports everything its predecessor did except it has moved well beyond in both design and scope. The idea is to stay true to AZ:E (http://forum.kodi.tv/showthread.php?tid=223715 / http://emby.media/community/index.php?/topic/19594-arctic-zephyr-exploded/page-1) while advancing forward with a theme favored by a lot among the Emby community. How to Get It (Release Channels) Arctic Zephyr: From Ashes can be obtained from a variety of official sources. Please, only download Arctic Zephyr: From Ashes from the sources outlined below to ensure you have the authentic skin: Enterprise CDN (https://embycdn.northebridge.com - DV/OV SSL Secured): NortheBridge by Design Repo (Kodi 17 Krypton): https://embycdn.northebridge.com/NatalieDormer/repository.northebridge.by.design.kodi-2.0.00.zip Dormer (Kodi 16 Jarvis): https://embycdn.northebridge.com/AZFA/dormer/3.4.70/skin.arctic.zephyr.fromashes-3.4.70.zip Danvers (Kodi 17 Krypton): https://embycdn.northebridge.com/AZFA/danvers/4.9.90/skin.arctic.zephyr.fromashes.danvers-4.9.92-beta9.zip Emby Beta Repository for Kodi: http://www.mb3admin.com/downloads/addons/xbmb3c/kodi-beta-repo/repository.beta.emby.kodi-1.0.5.zip GitHub (FOR ADVANCED USERS): https://github.com/NortheBridge/skin.arctic.zephyr.fromashes/ GitHub also contains the source code for "Arctic Zephyr: From Ashes." Installing For Kodi Krypton (v17) or later - Enable "Addons from Third-Party Sources" and Install the NortheBridge by Design Repository. Once installed, simply browse to "Install from Repository," Select "NortheBridge by Design," Select "Arctic Zephyr: From Ashes Danvers," and Select "Install." It may take two minutes to install depending on the specifications of your hardware and internet connection. Kodi will ask you to switch to "Arctic Zephyr: From Ashes Danvers" when it's ready. For Kodi Jarvis (v16) - Install the Dormer Zip File (AZ:FA 3.2.40) or you may get it from the Emby Beta Repository by installing the Emby Beta Repository and then browsing to "Install from Repository," Select "Emby Beta Repository," Select "Arctic Zephyr: From Ashes," and Select "Install." It may take two minutes to install depending on the specifications of your hardware and internet connection. Kodi will ask you to switch to "Arctic Zephyr: From Ashes" when it's ready. Install from GitHub Source (for advanced users) - Simply download from GitHub and rename the folder inside the zip to either "skin.arctic.zephyr.fromashes" for Kodi 16 Jarvis (Dormer - 3.2.40) or "skin.arctic.zephyr.fromashes.danvers for Kodi 17 Krypton (Danvers - 5.x). You may apply this same method to install a development branch which is usually signified by its version number suffixed with "-dev" such as "5.0.00-dev." Please note that using a development branch is intended for advanced users who know how to install the released version as development branches share the same version number as their released counterparts. Pre-Release Software Notice (Krypton - "Danvers Preview") ARCTIC ZEPHYR: FROM ASHES (DANVERS PREVIEW) IS EARLY STAGE PRE-RELEASE SOFTWARE MADE AVAILABLE TO THE COMMUNITY FOR TESTING. ALTHOUGH IT IS LIKELY MOST, IF NOT ALL, FEATURES OF ARCTIC ZEPHYR: FROM ASHES WORK ON KODI 17 KRYPTON, IT IS POSSIBLE THAT CERTAIN FUNCTIONALITY MAY BE LIMITED OR MAY NOT WORK AT ALL. YOUR USE OF PRE-RELEASE SOFTWARE IS DONE SO AT YOUR OWN RISK. Known Issues As with any software, Arctic Zephyr: From Ashes is not immune to glitches, bugs, and other limitations which may crop up from time to time. Some issues have been inherited from Arctic Zephyr: Exploded while others have been introduced through the ongoing development of Arctic Zephyr: From Ashes. The following is a list of all known validated issues: To be UpdatedThe Best Audio Experience To get the best experience, Arctic Zephyr: From Ashes will try to change Kodi's default Confluence sounds over to the From Ashes Audio Suite. If it doesn't do that, simply go to "Look and Feel," click "GUI Sounds," and enable the Audio Suite by clicking on it and selecting "Use." It's compatible with any theme working for Jarvis or later and integrated with Eunique as well (another great theme I strongly recommend you check out!). Special Thanks I would like to give a special thanks to @@im85288 especially for helping (and continuing to help me) ease into the Kodi theme development process. I'd like to also thank @@im85288 and @@badaas for making such a great theme! This theme is the reason I stuck with Kodi after Windows Media Center was removed from Windows 10 Pro. I also believe a special thanks to @@marcelveldt is in order who was the one that created the skin helper which this and virtually every other theme here relies upon. Continued Development As I had mentioned earlier, development will continue on Arctic Zephyr: From Ashes although the pace may be quite slow at times. One of the best ways I have found to speed up seeing things that you want to see is that if you know how to develop Kodi addons and themes, simply hop on over to GitHub and contribute. It is a community theme now after all and a contributors page will be in the next release! http://imgur.com/a/0aw3A
  16. I have been trying to get Emby to run on an android device running Kodi. Every time I have installed it, I get an error within a minute of Kodi loading. The error ends up saying "ImportError: cannot import name SNIMissingWarning". For the setup: Server: I have Emby server running on a windows 10 machine and it works fine except that I can not get the settings right to load when I boot. I have the 'Run server on startup' set under settings of the dashboard. Client1: On my laptop, I can go to "http://app.emby.media/dashboardgeneral.html"under chrome and everything works fine. Client2: Android device (cheap box to run Kodi; originally set up with all the programs to run a lot of stuff from tv.addons; still trying to get all this removed) running Android 5.1.1 API level 22; Kodi 16.1. For Emby, I have tried both repositories at 'http://kodi.emby.media/'. In going through the forum, I did find a similar problem from a windows box having the SNIMissingWarning posted by user kro on 24 February 2016 - 04:47 AM. AngelBlue05 seemed to find a solution but I could not figure it out from the forum posts. It seemed as if by changing this setting fixed it: In the add-on settings > Emby > HTTPS, do you have verify host ssl enabled? I do not see an HTTPS setting under Emby's settings on my version. Under settings, I have "General, Sync options, Video Playback, Extras and Advanced". I do not see anything about HTTPS under any unless they show up by changing something from the default. I have tried both connect methods of Manual and Emby Connect. I have also turned off Enable fast startup(I don't remember installing a plugin for this). When either I boot Kodi or try to start Emby, I get an error on the screen saying "Emby error: Check the log for more information". I have gone through the log and found that the problem is that the emby cannot find a version of urllib3 that contains SNIMissingWarning. Here is an excerpt from kodi.log(https://paste.ubuntu.com/24398876/) 01:40:42 T:18446744072342938800 DEBUG: -->Python Interpreter Initialized<-- 01:40:42 T:18446744072342938800 DEBUG: CPythonInvoker(26, /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.openweathermap.maps/default.py): the source file to load is "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.openweathermap.maps/default.py" 01:40:42 T:18446744072342938800 DEBUG: CPythonInvoker(26, /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.openweathermap.maps/default.py): setting the Python path to /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.openweathermap.maps:/data/data/org.xbmc.kodi/cache/apk/assets/addons/script.module.pil/lib:/:/data/app/org.xbmc.kodi-1/base.apk/assets/python2.6/lib/python26.zip:/data/app/org.xbmc.kodi-1/base.apk/assets/python2.6/lib/python2.6:/data/app/org.xbmc.kodi-1/base.apk/assets/python2.6/lib/python2.6/plat-linux3:/data/app/org.xbmc.kodi-1/base.apk/assets/python2.6/lib/python2.6/lib-tk:/data/app/org.xbmc.kodi-1/base.apk/assets/python2.6/lib/python2.6/lib-old:/data/app/org.xbmc.kodi-1/base.apk/assets/python2.6/lib/python2.6/lib-dynload 01:40:42 T:18446744072342938800 DEBUG: CPythonInvoker(26, /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.openweathermap.maps/default.py): entering source directory /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.openweathermap.maps 01:40:42 T:18446744072342938800 DEBUG: CPythonInvoker(26, /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/script.openweathermap.maps/default.py): instantiating addon using automatically obtained id of "script.openweathermap.maps" dependent on version 2.20.0 of the xbmc.python api 01:40:42 T:18446744072326974200 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<-- - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS! Error Type: <type 'exceptions.ImportError'> Error Contents: cannot import name SNIMissingWarning Traceback (most recent call last): File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/service.py", line 22, in <module> from service_entry import Service File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/service_entry.py", line 14, in <module> import userclient File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/userclient.py", line 12, in <module> import artwork File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/artwork.py", line 17, in <module> from database import DatabaseConn File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/database.py", line 15, in <module> from views import Playlist, VideoNodes File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/views.py", line 15, in <module> import read_embyserver as embyserver File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/read_embyserver.py", line 12, in <module> import downloadutils File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/downloadutils.py", line 12, in <module> import connect.connectionmanager as connectionmanager File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/connect/connectionmanager.py", line 18, in <module> from requests.packages.urllib3.exceptions import InsecureRequestWarning, InsecurePlatformWarning, SNIMissingWarning ImportError: cannot import name SNIMissingWarning -->End of Python script error report<-- 01:40:42 T:18446744072283713896 DEBUG: ------ Window Init (DialogKaiToast.xml) ------ 01:40:42 T:18446744072283713896 DEBUG: Window DialogKaiToast.xml was already loaded 01:40:42 T:18446744072283713896 DEBUG: Alloc resources: 0.00ms 01:40:42 T:18446744072328978960 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<-- - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS! Error Type: <type 'exceptions.ImportError'> Error Contents: cannot import name SNIMissingWarning Traceback (most recent call last): File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/default.py", line 22, in <module> import entrypoint File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/entrypoint.py", line 19, in <module> import artwork File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/artwork.py", line 17, in <module> from database import DatabaseConn File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/database.py", line 15, in <module> from views import Playlist, VideoNodes File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/views.py", line 15, in <module> import read_embyserver as embyserver File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/read_embyserver.py", line 12, in <module> import downloadutils File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/downloadutils.py", line 12, in <module> import connect.connectionmanager as connectionmanager File "/storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/addons/plugin.video.emby/resources/lib/connect/connectionmanager.py", line 18, in <module> from requests.packages.urllib3.exceptions import InsecureRequestWarning, InsecurePlatformWarning, SNIMissingWarning ImportError: cannot import name SNIMissingWarning -->End of Python script error report<-- I know that there are still some unregistered apps which I have been working to remove, but this problem started before I removed anything. I have been banging my head on the wall as to what might be the problem. I can not see a way to add the urllib3 into the python path. I hope I just have some setting wrong here. Thanks for any assistance.
  17. Jaha

    My rating sync

    Hello! I want my ratings in Kodi to be stored in Emby Server and in nfo-file. Is there any script to use? For example to export/import my rating from Kodi. Example using nfo tag: <tag>My rating: 5</tag> From Kodi 17.1
  18. Hi Guys. I'm fairly new to this community, hell this is my first post ;-) Im not as tech savvy as the next guy, however I get by. I have installed and been using Serviio as my server to stream all my media to my Minux Neo U1. Dont get me wrong, it works flawlessly. I love how you have total control over disabling all those useless folders, genres and all that crap. I like my folder view to be simple. I have three folders, Movies Anime Tv I can access the folders that I share as I see them on my computer. No added category's or any of that. I disabled transcoding as the minux is capable of playing anything I throw at it. I've been hearing alot about Emby and I researched abit about it, and I must say its absolutely gorgeous. So I installed it onto my windows machine, and installed the add-on via kodi. I wasnt fond of all the different folders everywhere, too many to mention. Im hoping I can change that and only display the root folders and the content within them. Anything I play through Serviio, no hang, no freezing, no buffering, plays flawless. I cant even get anything to play with Emby. It doesnt just hang or freeze, my whole box freezes. Mind you, I had both Serviio and Emby running at the same time on my Windows PC. I was hoping someone could point me in the right direction, as I'm sure if I played around with the category's displayed and fixed the issue with playback I would switch to Emby in a heartbeat. I dont know why everyone is buzzing about it? Is it just me? :'(
  19. spider85

    Strange kodi/emby smb bug?

    Hi all, Yesterday i installed emby server and configed it as i wanted, after that i connected my android Shield (SPMC) with the emby server, after some tweaks i had no problems playing all of the content thru the native mode. Today i tried to connect a second kodi machine (intel Nuc + Libreelec 8.01) to the server, made the same settings and tried to sync, then a strange problem appeard. the message was Kodi cant locate file smb://SERVER/SERIES/MOVIESsmb://MOVIENAME.mkv The normal path would be: smb://SERVER/SERIES/MOVIES/MOVIENAME.mkv So for some strange reason there is a "smb://" in the middle of the file name, the shield doest have this problem, so it looks like there is a bug or something in libreelec / emby for kodi ? or iam i missing something? In the Log files i cant find anything thats giving me a hint or something The problem only exists with movies, series (same settings other path) work directly Hope somebody can shine a light. Kind Regards
  20. EVERY time I startup KODI and try to play a movie, it tells me that one or more of the items failed to play, see log. I dont know what I am looking at in the log. I always have to go to my computer, and manually restart the server. There are even times that I have to complete shutdown the server and restart it. Sunday it happened twice, and I never even closed KODI. I just had it in idle for about an hour. I have attached both logs from that day. Thank you for you help. Log 19MAR171624.txt Log 19MAR172014.txt
  21. I'm using the Titan skin and when I go into Settings -> Skin Settings -> General Skin Settings -> Use Custom Image instead of Kodi Logo it then dumps me out to search for the file. It pops up what looks like a Network Share (see attached pic) for Emby and then under that is Public Testing and Dependencies. I assumed it would let me go out and search for the file but I can't get out of this tree. Ideas? (My goal is to upload a blank transparent image and remove the Kodi logo). Thanks
  22. Hi, I'm having a little trouble here. I've been making great strides getting Kodi set up on my shield with the Emby Add-on. It's working great for my administrator account. Once it was set up, I wanted to now go in and change the Username associated with it. I go into the add-on setting and and click "Change Emby Connect User". The login prompt pops up, I type in the credentials and it says "Welcome Username". All working great there. However, nothing changes. The current user still has access to the same Libraries. If I quit and go back in it then says "Welcome Administrator" again. If I change a user do I then need to go in and do a full refresh? I didn't want to spend the time doing this if it's not related. Thanks
  23. Brucegood

    Kodi for fire Sick

    Help please cant not get kodinolimits videoplug wizard to load keeps giving error .
  24. Hi all :-) I'm a new user, trying to setup my Emby + Kodi environment. I've issues in library setup, during the "path substitution" phase, now integrated with library folders. The issue is that Emby "shared network folder" field seems to accept only UNC paths (\\server\share...), so any linux client tries to access the share via Samba instead of using NFS. My NAS exports shares both via SMB and NFS, but since I'm using some RaspberryPi as Kodi front-ends (OSMC distribution), I want to avoid using Samba, since it has an overhead on CPU. The only way I've find to end the library setup is by using UNC paths, but of course all clients try to access the share via Samba. Example, from kodi log: I've already tried to search for a solution on wiki and forum, but I've seen only threads (eg. https://emby.media/community/index.php?/forum/116-linux/)without solutions to get NFS works with Emby. It seems that it was supported without problem in the previous "path substitution" way: https://emby.media/community/index.php?/topic/24109-no-playback-with-beta-add-on/?p=235928 Is there any solution or workaround (even by edit manually some config file...) to pass to clients an NFS path instead of UNC, with the new library setup procedure? Thank you in advance. Bye, Edoardo
  25. webnar

    TVShows season-01 numbering invalid

    Hi maybe someone know how to solve this issue. But since a update end last year i got some strange issues with the numbering of the season-01 of all TVShows. Season 1 always has the number of the total seasons there are. See the attached screenshots. I already reinstalled everything many times now. But iam not the only one who has the issue i know 2 more users with exactly the same issue.
×
×
  • Create New...