Jump to content

Search the Community

Showing results for tags 'subtitle'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 102 results

  1. ntfox

    New Plugin - Subscene subtitle

    Hi, I created the subtitle plugin for Subscene. Please install and let me know if there is a problem Source Code: https://github.com/nRafinia/Emby.Subtitle.Subscene Binary: https://github.com/nRafinia/Emby.Subtitle.Subscene/releases Version 2.0.0 is released, Add subtitle search capability for TV series Version 1.2.3 is released, More efficient search output
  2. I have been trying to figure out how to configure my Emby server/clients to do things the way I want them to. One thing I haven't been able to figure out is how to get Anime subtitles to play properly on all my devices. When I occasionally use Chrome or the Android client, which play my subtitles just fine, graphically and positioned on the screen appropriately. However my main method of playback is on my Roku TVs. Roku TVs by default appear to extract subtitles from my video files and display them using closed captioning. This is a much less visually appealing way of providing subtitles. It is especially problematic when the show I'm watching positions subtitles next to Japanese characters, which is totally lost when converting to Closed Captioning. I would like to find a best solution which allows me to have the visuals I am looking for. Right now, the only way I can find to make that happen is to begin playing a video, and then forcing playback correction twice (after using the beta, the text there says the 1st time forces remuxing and then the 2nd time forces transcoding, which at least explains why I have to do it twice) but that is not really an option I want to live with long term if I can avoid it. Ideally, there would be a way to allow the Roku client to support these subtitles (SSA in the show I tested as I am writing this, but other types as well) and display them graphically like VLC or Chrome or Android player or basically most other players out there. If this is not possible due to technical limitations, then I would rather have my videos transcoded than have to watch them with solid black closed caption boxes that are placed rigidly on the bottom of the screen. In this case, ideally I would be able to set only my Anime library to force transcoding, but not force my movies or US TV Shows. An alternate option would be to have it controlled by user, and I could create a 2nd ID for myself to watch Anime if I had to. Complicating my situation is the fact that sometimes when I select the episode I want to watch, I am presented with a pair of dropdown boxes to see what language the audio is and what subtitles are selected, while other times those boxes are not visible. I think it has something to do with selecting the video from the suggestions vs. from the Next Up section vs. selecting the title from Latest Anime and choosing the episode I want. When the dropdowns are not visible, the subtitles as captions will usually show up, but after selecting force playback correction twice, the subtitles have been turned off as transcoding is started. At this point, turning on the subtitles forces me to choose the correction option multiple additional times, each time possibly having to turn subtitles back on. Usually, once I get it to transcode with subtitles once it will continue to work with only two times selecting the correction option, and I can watch additional episodes in the same season for that viewing session with minimal additional issues. Honestly, I'm hoping that one of the devs or more knowledgeable users will point out some setting I haven't seen or some tweak in the server files that will allow me to do what I'm looking to do, or even link me to a thread where this has already been discussed and fixed which I wasn't able to find myself. Right now, I'm stuck forcing playback correction twice every 20 minutes of watching, and it is a real pain. Please let me know what I can do to assist with troubleshooting this issue if I can be of assistance. Thanks!
  3. n00b42

    Library Filter By Language

    I would suggest to add the possibility to filter the library by languages, i.e. - Allow to filter for the audio and/or subtitle language. Regards Max ( Request taken from a former github issue: https://github.com/MediaBrowser/Emby/issues/1782#event-982356301 )
  4. Marci32

    Subtitles can not be turned off

    Hi guys, I can't turn off subtitles in the Emby App. It says "No subtitles" in the settings and I can select "Off" in the Subtitles while playing a movie but subtitles will not disappear. I tried to reinstall the app (1.09), didn't help. If I stream the same movie from the Web App to the same TV, then I can turn off subtitles in the TV settings (maybe I could say WebOS based settings) but I would like to use the app on the TV only. Do you have any idea? Thanks, Marci
  5. Hello, I'm on Debian 9.8 on server side, running the latest beta, but this issue is there since I upgraded to Emby 4.0. (was working fine with Emby 3.5.2/3.5.3). Tried with: - emby-server-deb_4.0.0.2_amd64.deb - emby-server-deb_4.0.1.0_amd64.deb - emby-server-deb_4.0.2.0_amd64.deb - emby-server-deb_4.1.0.10_amd64.deb - emby-server-deb_4.1.0.12_amd64.deb When playing MKV files with ASS Subtitles, tested on Firefox and Chrome (HTML5 playback), subtitles are not showing. I checked server logs, and found that ASS track is encoded/demuxed via ffmpeg: ./embyserver.txt:1029:2019-03-11 13:22:56.065 Info SubtitleEncoder: ProcessRun 'ffmpeg-subtitle_extract' Execute: /opt/emby-server/bin/ffmpeg -i file:"/srv/media/Series/Sword.Art.Online/S03/SAO.S03E21.VOSTFR.1080p.WEBRiP.x264.mkv" -map 0:2 -an -vn -c:s copy "/var/lib/emby-server/cache/subtitles/b/b3fd429fcf754f26313b86b441d5104e_636877678715979463_2_0_0_False.ass" ./embyserver.txt:1079:2019-03-11 13:23:17.462 Info SubtitleEncoder: ffmpeg subtitle extraction completed for file:"/srv/media/Series/Sword.Art.Online/S03/SAO.S03E21.VOSTFR.1080p.WEBRiP.x264.mkv" to /var/lib/emby-server/cache/subtitles/b/b3fd429fcf754f26313b86b441d5104e_636877678715979463_2_0_0_False.ass So it seems that's why subtitles are not available, but when the process is finished, Subtitle doesn't show up, I need to disable and enable them back again (and seek back to the beginning of the file). With big movies, we have to wait many minutes for the ASS to be "available". Also when streaming (from Android app) to my Chromecast (tested with Chromecast v1, v2 and Ultra), thoses ASS subtitle are not available at the begining and then, they show up, but accelerated, and are kind of out of sync with audio/video. We must stop, disconnect and restart the stream to have them properly displayed. Sometimes they don't show up at all. Let me know how I can help to debug those ASS playback issue.
  6. I'm ready to wipe this program and re-install, but really don't want to set everything up again. A month ago the only issues I had with this program were TV show episodes not going to the next one at random intervals. This problem has been systematically getting worse.and started with movies. Until Thursday or Friday, it wasn't affecting TV shows at all. Movies started pausing or skipping if the embedded subtitles were used. Often they would finally work with repeated tries. Now, unless subtitles are off or srt files are used, movies won't play. In general, I don't mind srt subtitles but they do not line up with the movie timing. Like I said, this was going on with movies but you could finish a movie and go to a TV show and the TV show would play fine. Now nothing plays right. I don't know if the Emby program settings are screwed up (a big possibility) or if part of the program has become corrupted. This is happening across several user profiles and is happening with both the LG TV and if trying to play directly in the web interface. Issues apply to DVD and Bluray. I would say 4k, but I don't know if those issues are 4k issues or these issues. But starting and stopping, especially with subtitles was first noticed on 4k movies. Oh, have seen the error "Playback Error: No compatible streams are currently available. Please try again later or contact your system administrator for details." a couple of times tonight. As soon as I "try again" the file plays. Any help whatsoever is greatly appreciated. embyserver.txt ffmpeg-transcode-6b942f4c-719a-4889-b071-cab3dd2f31da_1.txt ffmpeg-transcode-07467def-4b2e-4f35-8183-1b03a6a928a5_1.txt ffmpeg-transcode-b237b0f5-cd3e-426a-9a8b-25bb6b9a6c2b_1.txt
  7. GoofyCDN

    ANSWERED Subtitle Location not changing

    I have set up my Emby server a while ago, but haven't really used it much. I have been running Plex for years, but am experimenting with switching to Emby. There are a number of things I like about each. With all that said I have one issue that i can't seem to get to work properly. I have a number of movies and shows that are missing subtitles. I like the fact with Emby I can go and to each individually if needed and click download to search OpenSubtitles. I have done this but every time I do the subtitles go into the metadata location at /var/lib/emby. I have the box checked to save subtitles in the media folder. Shouldn't that save the location to the same location as the media folder? Steps taken so far Removed all SRT files from /var/lib/emby/metadata/library.... Checked the library for the "save subtitles to media location" restarted server Ran library scan Refresh metadata - replace all metadata I have even deleted the library and added it back. I did name the new library the same as the old library. Any help would be appreciated Thanks
  8. Juubeii

    Subtitles folder

    Hi, I switched from Plex to Emby recently and I have one issue. With Plex I was using Subzero and Bazarr for getting my subtitles and both were downloading them in a folder named 'subtitles' in the same location of my video files. And Plex detected them but Emby doesn't. Anyone knows if emby has an option for that? I really dont want my subtitles file in the same folder than my video file and neither in my server's metadata folder. Thank you.
  9. hello everyone can somebody guide me how to add a custom font to make my emby use it for subtitles, I already have the font file and it's works like a charm in another media player but I really liked empy and I don't want to use any other platform. best regards
  10. hopykito

    Black screen on specific files

    Hi Guys ! TV : LG Smart TV (OLED55B8PLA) - Software : 05.10.50 Emby Server version: 4.4.0.40 Operating system: Unix 4.4.59.0 I have some strange crash when i play specific files only in my LG TV This files is : Anime with subtitle VOSTFR Stream is ok with Android phone and with computer But why i have only the problem with LG (i think the problem is subtitle) In my tv LG i have this scenario : Start 2s show and black screen and start again and black screen ... i have this message error (in french) : "Aucun flux compatible n'est actuellement disponible." Logs and video here : https://wetransfer.com/downloads/cd90dc46bd9b8e3e08af05f464c0ae5620200421091512/54fe3b Thanks guys ! ffmpeg-directstream-bd744a78-5645-4dd5-9bf6-cc9e3dbf38b5_1.txt ffmpeg-transcode-25f31677-e3af-4f3a-be52-5f7df0101cb0_1.txt ffmpeg-transcode-d7a10017-03f7-48d9-9909-3eb2cc9ef16a_1.txt
  11. MrSmile

    Persian Subtitle font problem

    Hi thanks for your nice apps. android app have problem with Persian subtitle. this font is bad and some alphabets doesn't show correctly (like what you see in the attached photo) we have bad font in the web and TV too. but they can show all alphabets Please change this fonts, I suggest to use "B Koodak" font for Persian subtitles as default. it's most popular font for subtitles in the Persian.
  12. ayoubmst7

    Change Subtitle Font

    hi, I Start using for while now and the subtitle font looks terrible on android mobile. a lot of letter don't shows up, if somebody knows how to change the subtitle. please let me know how. Ps: I am using emby on windows, and the problem i have with Arabic Subtitle Best Regards
  13. Whatever I do, I can't watch films with subtitles. Subtitles never appear.
  14. Dumb question: If the option to only get exact subtitles is enabled - how is the match for 'exact' done? I'm assuming by filename and/or hash with a stock install (so only OpenSub plugin is enabled)? Asking because I was looking at some subs that had downloaded during my test the past 5 days. I had some files that were Filebot renamed that had some subs downloaded. It made me wonder when I saw them "How did they get downloaded if exact match was chosen"? Filebot saves the original filename in xattr - but I'm not sure if Emby reads that? It is entirely possible that while playing with settings, there was a period where I had changed the setting (I did go through all of the settings to get an idea of where everything was - but I don't *think* I changed it during the time period the subs were downloaded - but who knows, it's possible). Anyway - it made me wonder how matches were done and whether renaming files in an Emby-based system is a good practice (as opposed to leaving them as originally named.
  15. I would love the ability to increase the size of subtitles on the different platforms, specially android, chrome and roku... One additional thing that would be great would be the ability to change font color, outline, drop shadow, font background... Thank you
  16. DancingMan

    default to external subtitle

    Is it possible to set my external subtitles to be the default? I see that I can set subtitles to always be on, and I can set a particular language as the default. Most of my mp4 movies have graphic subtitles in them (dvdsub), and for lots of them I also have external subtitle files (srt, sub). If I have an internal english subtitle and an external english subtitle file, it seems like Emby uses the internal as the default (the attachment is from the bottom of Emby's WebUI for one of my movies). Is there any way to set a system wide default to say "if there are external & internal subtitles for the default language, use the external subtitle"?
  17. Phuein

    Tiny Subtitles With MKV

    Hey, Thanks for your guys hard work. Emby is always a pleasure to use. I've noticed that when playing files with embedded subs, like the MKV format, the default size is tiny. Unreadable basically. When I extract the subs into an .srt file ( ffmpeg -i "%~1" "%~n1.eng.srt" ) it works fine, loading the subs as expected. Any chance Emby could work with this better automatically? Thanks
  18. I have one library of movies and it works OK except some of the movies have subtitles that does not belong to them. Automatic subtitle is enabled for English language. It downloads the subtitles but for some movies the subtitle that shows on screen is not for this movie. Opensubtitle plugin is installed and in the settings I have entered my username and password for opensubtitle. (I even checked again and I can login to opensubtitles.org with my ID and password). What could be the cause of this subtitle mismatch? PS: I have checked and unchecked "Require Hash Match" but the end result is the same. I appreciate any help in troubleshooting this.
  19. Good afternoon, I need some help. Syncing a movie or episode to Google Drive no longer has the subtitle option available. Thanks in advance
  20. DancingMan

    subtitle problems

    I recently added a few TV shows on my emby server and I'm having an issue with the subtitles. The files have English subtitles, but they are mislabeled inside the mp4 files. If I look at the files using ffprobe, the subtitle and audio streams show "und" next to them (my other files show "eng" for the audio & subtitle streams). Emby seems to go on the assumption that the "und" audio streams are English, and uses them automatically. For the subtitles though, since emby does not see English subtitle streams, it follows through with the server's subtitle settings and tries to download subtitles from online. I have two questions: 1) is there a way to set emby to assume "und" language subtitle streams are English just like it does with "und" audio streams? 2) how can I set those subtitle streams in the mp4 files to have the correct label of "eng"? Thanks
  21. I am on latest beta of Emby Android TV app running on Google certified Android 8.0 TV. I have connected my TV to Sony HT-RT3 soundbar (via HDMI ARC) that supports only AC3 and EAC3 (no DTS). So if I play a video with DTS audio, Emby app transcodes audio alone and use the same video stream. All good and fine. But of late I am starting to notice an issue. Consider the following the scenarios. 4K HDR Video Dolby Digital+ 5.1 Audio SRT subtitle Result = Direct Playback 4K HDR Video Dolby Digital+ 5.1 Audio PGSSUB subtitle Result = Direct Playback 4K HDR Video DTS 5.1 Audio SRT subtitle Result = Direct video + Transcoded audio But if 4K HDR Video DTS 5.1 Audio PGSSUB subtitle Result = Transcoded video + Transcoded audio Is this the expected behaviour? I am not sure why PGSSUB needs to be burned (resulting in video transcoding) if audio is an unsupported format. I mean the app displays PGSSUB just fine if the audio is supported. So what difference does it make to subtitle whether the audio format is supported or not?
  22. Vikh0

    smartv lg subtitle problem

    Hello good night friends of the forum, I am here because I am a new user of emby and I have a problem, before I used plex, but when I tried to watch subtitled movies, with the server mounted on my personal use pc, I transcoded and gave me buffering, for this motive stop using plex and try emby, and I liked it, much just that now I have a problem, which is that when I watch the movies I put the option to show subtitles and they do not appear or leave when they want, in the middle of the movie or at In the end, I have a powerful PC, for this type of work, and 100 mb of connection, mkv format and in 1080p quality use w10 pro, updated, I hope you can help me, try to play the same movies on my pc and if it shows subtitles and I have a smartv Lg Webos 43lj5500
  23. Gulan

    Subtitle settings

    Hi, I use my video files(mkv) with srt subtitles. For a while it seemed so that you only had one size for the subtitle and the black background for subtitles were not removable. With the new version (1.0.19) under settings there came a "subtitle appearance" setting where you could set the font size, color and drop shadow. Oddly enough this does not seem to work with any of my MKV with srt subtitles. The subtitle stays with black background and one font size and white letters. Am I missing something? If you include something like drop shadow, i would expect also that the black background would dissappear because otherwise this would be a useless setting. But maybe it doesn't work with external srt subs? Thanks in advance for any advise. WEB OS (5.10.20)
  24. I'm just trying to figure out if I have something set incorrectly or is Emby really has different playback screens for TV shows vs movies. When you get to a TV show episode playback screen, it shows the audio and video details and then has a drop down list of the available subtitles. When you get to a movie playback screen, the same information is not shown. The movie does have the details embedded. Using Tiny Media Manager, I get this information: So, I'm wondering what I need to do or change with my Emby settings to get the movie playback screen to show the same information as the TV episodes. Just as an FYI, I have also added an external subtitle file (.srt) file for this movie. So I would hope that some kind of subtitle information would be shown. Any help would be appreciated. I am still setting items up and have only done about 15% of our movies. I want to make sure that I copy everything the way Emby likes it.
  25. Hi .. empy web using Google Chrome: the ASS subtitle style works on both but .. I have installed the same font that used at the subtitle on Win 10 and macOS. Chrome macOS shows the fonts correctly Chrome Win10 shows different font Please see the attached screenshots for both. ----- emby Version 4.0.2.0 Lunix Ubuntu server 16.04.5 Google Chrome Version 73.0.3683.103 (Official Build) (64-bit) - Windows 10 64bit Google Chrome Version 73.0.3683.103 (Official Build) (64-bit) - macOS 10.14.4 logs files are attached Thanks log_mac.zip log_win.zip
×
×
  • Create New...