Jump to content

Search the Community

Showing results for tags 'Library'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. ltworf13

    Duplicate Libraries show up

    Hi Folks. I'm new to Emby and I was impatient when I was adding my folders. It wasn't doing the sync fast enough so I removed the folder and re-added it. Now some of my folders are duplicated. How do I resolve please and thank you in advance
  2. rwyarbrough

    My Library Setup

    I'm rather proud of my Library. Lots of work has gone into it. Couldn't resist sharing. Maybe others can share their Library setups for us to get ideas to make our libraries better. The "WIP" libraries are those I'm still working on getting them sorted, cleaned up, and accurate. Once the content is accurate and complete, I move it to the "non-WIP" library. Each have their own directories to keep things clean. One of these days there will be less in the Work In Progress libraries than there are in the finished ones. I love the audio book support and the way I can listen to my OTR library. My only negative about Emby is the lack of book reading support. Wish there was a way to tie it into Calibre and vice versa. Thanks for a great product.
  3. riothamus

    How often are .nfo files created?

    How often does Emby write data to .nfo files? More specifically, after a file is uploaded, provided that it is a valid TV episode or Movie file, when does an .nfo metadata file for the item get created? Nevermind, I found that my nfs share mounted read-only, so the data is not getting saved. The server is trying to create the .nfo file at scan time, but can't save it. Please disregard.
  4. cmart2112

    Add Directory To Library From Afar

    Hello! I manage a linux media server for my sister. She lives in a remote location and only has broadband internet. I built a linux server with emby on it with the intention of giving her an external USB drive from time to time with new content. I can only access this machine via SSH, but within the local network, Emby is working like a champ. My question is, how can I add the external USB to the Emby library via ssh? I tried to symlink the content into the existing library directory, but it doesn't appear to be working. The local hard drive is about 1TB and already full of content and the external hard drive is about 5 TB. I have it mounted in the same root directory as the current content. Any tips would be great! Thanks!
  5. When in "Detail view" of an item in a Emby library (like Movies), is it already technically possible for the Emby devs (@@Luke & @ebr), to incorporate swipe actions, to go to next or previous Movie in that library ? Would be awesome if mobile Emby users could browse their Movies in a Emby library just by swiping left or right AND still stay in detail view ! Example of swiping content with Infuse 5.x on iOS: https://streamable.com/5zv2i
  6. Hi, I am a complete noob! Recently switched from Windows to Linux. I'm having trouble setting up my library with the files from NTFS drives created using windows. Can anyone tell me how to add files from other drives to my emby library? I'm using deepin x64bit (debian 9 based).
  7. cochize1

    Library posters

    Let’s assume I have a movie library called BOX OFFICE. Every week I add some new interesting content and I want my users to know that right away. The best way show that is to ‘update” the library poster with new contents’ posters (4 new posters with the water-like reflections in random order for every new library created). My server is running on Synology NAS so I can access my files with WinSCP. In /var/packages/EmbyServer/target/var/root/default I have access to all generated poster.png files (4 posters from library). By copying these files I COULD change the library posters BUT for newly created libraries (I put 4 new movies in that library showing posters for new content) it takes AGES to generate the poster.png file for newly created library. I have tried: refreshing the library restarting the server restarting and clearing my cache from the computer I access the server How long does it take for that file to repopulate on the server and show in WinSCP?
  8. Pretty sure there’s no place to do this...I want to change the number of columns displayed on web app, Apple TV and Roku. It displays 6 columns of thumbnails but I’m getting old and my eyes are getting old so i want to change to 5 columns, this increasing the thumbnail size. One of the few things I like about Plex these days is that I can make such an adjustment with a slider that increases/decreases number of thumbs. Maybe put it on the wishlist?
  9. Hi All, What does the following indicate? 2019-08-15 17:29:22.135 Error App: Error resolving path \\dondersteendc\Media_DSdcTiered\TV Series\TV Series - Ended\Avatar The Last Airbender\Season 02 *** Error Report *** Version: 4.2.1.0 Command line: C:\Shares\Emby190814\system\EmbyServer.dll -service Operating system: Microsoft Windows NT 6.2.9200.0 64-Bit OS: True 64-Bit Process: True User Interactive: True Runtime: file:///C:/Shares/Emby190814/system/System.Private.CoreLib.dll Processor count: 8 Program data path: C:\Shares\Emby190814\programdata Application directory: C:\Shares\Emby190814\system System.IO.IOException: System.IO.IOException: An unexpected network error occurred : '\\dondersteendc\Media_DSdcTiered\TV Series\TV Series - Ended\Avatar The Last Airbender\Season 02' at System.IO.Enumeration.FileSystemEnumerator`1.GetData() at System.IO.Enumeration.FileSystemEnumerator`1.FindNextEntry() at System.IO.Enumeration.FileSystemEnumerator`1.MoveNext() at System.Linq.Enumerable.SelectEnumerableIterator`2.ToArray() at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source) at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path) at MediaBrowser.Controller.IO.FileData.GetFilteredFileSystemEntries(IDirectoryService directoryService, String path, IFileSystem fileSystem, IServerApplicationHost appHost, ILogger logger, ItemResolveArgs args, Int32 flattenFolderDepth, Boolean resolveShortcuts) at Emby.Server.Implementations.Library.LibraryManager.ResolvePath(FileSystemMetadata fileInfo, IDirectoryService directoryService, IItemResolver[] resolvers, Folder parent, LibraryOptions libraryOptions) at Emby.Server.Implementations.Library.LibraryManager.ResolveFileList(List`1 fileList, IDirectoryService directoryService, Folder parent, IItemResolver[] resolvers, LibraryOptions libraryOptions) Source: System.IO.FileSystem TargetSite: Boolean GetData() I’m working on a VM with Emby and I'm currently in the testing phase. Most of it working well except that Emby seems to get stuck scanning a certain directory. As far as I can understand it must be folder permission related. Running the latest version What do you think? More info on request and thank for any help or suggestions, Peran embyserver.txt
  10. Guest

    Custom library images

    I've created some images to customize your libraries in an "Emby style", I've just combined the Emby logo with the default library image. It's not an amazing job but I like it, it gives your server more Emby flavour I think .
  11. The current libraries view in the server settings display large icons with the library names. This is useful when there are a few libraries. However, when there are more than 20 libraries, scrolling and finding the right libraries becomes cumbersome. Can you please add a more compact view. A division of libraries would be even better. For example Personal, Kids, Other section with libraries in them. Edit: I am referring to Admin - Manage Server - Library
  12. Hello, I have noticed that I am missing a movie in my library. I can see the film in Metadata Editor and if I go into folder view I can find it's folder and the movie in it. However If I am in the library view the movie is missing. Any Ideas?
  13. BP_Tec

    Network Path Problems

    Hi all, So I'm having problems setting up my library on only one of my drives. I know this is probably a permissions issue, but I just cant figure out what the problem is. These are my media locations, the first two work fine, but the USER_DATA drive does not, and i get the error. All locations are accessible from my Linux machine. /home/alex/Videos /mnt/BACKUP_DRIVE/media /mnt/USER_DATA/media1 /home/user/Videos drwxr-xr-x 6 alex alex 4096 Jun 22 15:43 Videos /mnt/BACKUP_DRIVE/media drwxr-xr-x 2 root root 4096 Jun 23 12:23 media /mnt/USER_DATA/media1 drwxr-xr-x 2 root root 4096 Jun 23 12:23 media1 If i change the owner and group on media1 to alex, i still get the same issue chown alex:alex media1 drwxr-xr-x 2 alex alex 4096 Jun 23 12:23 media1 If I change it to emby:emby still exactly the same error. I also restated the emby service after each attempt. So any help at all in understanding what is happening here would be awesome. Kind regards
  14. I renamed one of my libraries (from Animated - Movies to Movies - Animated), but it seems that it now cannot detect my collections. The collections are still showing in the user folder (C:\Users\User\AppData\Roaming\Emby-Server\data\collections) and if I look at any of the XML files they still show all the proper paths to the media. When viewing my library through the My Media section on the web app, if I go over the Collections tab there is nothing there. I'm on the latest version of the server (4.1.1.0)
  15. If I load a library as content type "TV-Shows" I get the following picture. The naming convention for TV-Shows is explicated here. https://github.com/MediaBrowser/Wiki/wiki/TV%20naming But how it's possible to name the TV-Shows so that emby knows on which station the programm was broadcasted? On the menu point Networks it should than be possible to see the stations. https://github.com/MediaBrowser/Wiki/wiki/TV%20naming
  16. Kimballslice1890

    Scan Media Library Hanging

    Not sure if it was a result of server release 4.1.1.0 or TVDB release 1.07 but my library scans have been hanging at 92.3% going on at least 6 hours now and the server has slow responses while this is happening. My emby server hung up 2 days ago and I had to do a full restart of the VM, not sure if it was because of the library scan or not. There are no issues with the storage locations in which my media is hosted. I searched the forums and didn't see anyone else reporting such issue.
  17. twistedvincent

    Library Cover Images All The Same

    I've been (unsuccessfully) trying to get my library set up properly and there's been a seemingly random issue I have that, being new I have no idea how to solve. One of the four libraries in my media has an issue with it's cover image, basically it's the same cover repeated 4 times while the other libraries have 4 different images. I've tried deleting/reinstalling, refreshing metadata, different metadata settings etc., but it really is a random thing. I restarted the server once and the problem was solved but when I decided to split my movie library into 2 parts, 4K and HD, I can't seem to fix the issue no matter what I try. Just so you know my metadata settings are exactly the same for both of my movie libraries I don't have a big fancy setup, just 4 sections of media which I've been working with for about 48 hours mostly by trial and error. Compared to Plex there's a LOT to learn here and I I have to say I'm pretty intimidated right about now. I hope somebody can help.
  18. Hello, I’ve searched the Emby forums and have found very similar postings but without the clear answer I am searching for. My TV library stores each episode into a separate season sub-folder. So my library folder structure is similar to what is shown below. The parent series folder (Star Trek) has no actual episode files directly in it. Instead, the season sub-folders (Season 1) contains the individual episodes. When Emby goes to work on scanning the library: nfo files (i.e. tvshow.nfo) and image files are populated within the season sub-folders (Season 1). There are no nfo or image files in the parent series folder (Star Trek). As a result, Emby does not display the series folder art work for the series (Star Trek). ☹ As an experiment and to prove my theory: I manually copied a single episode from one of the season folders into the parent series folder and rescanned. Bingo, I got folder art work. So either I’m missing an important setting/configuration or Emby doesn’t support folder artwork for series and season sub-folders. I’m hoping someone can point out the missing configuration or tell me “No, your out of luck” so that I can stop spinning my wheels. TV Library ....Star Trek The Next Generation .......Season 1 .......Season 2 ......etc.. ....Star Trek .......Season 1 .......Season 2 ......etc.. As Always Thank you in advance, Julie
  19. FurlerFan

    Library Thinks Folder Is A Single Video

    I installed Emby 4.0.2 yesterday (3/14/2019 -- happy pi day!). After building my library, I found that some folders (with lots of sub-folders) are being represented as video files rather than folders. As you can see in the images, the Sci-Fi folder (see the contents in the second image) appears to be just another video file. As you can see, that's not the case. How do I get Emby to recognize it (as well as the Animated, Mystery -- with dozens of complete sets of tv shows -- and and Music -- which contains musical movies and TV shows not music files) as folders rather than video files? If I click on any of those in the library, I get the same view as if I were clicking on a video file, but there's nothing to play. Please advise. Thanks!
  20. schmitty

    Local and cloud libraries

    Hello, I would like some clarification please. I currently have three tv and two movie libraries setup. I have a local and cloud library for tv and movies, and I set up a third tv library which merges the local and cloud tv libraries, which I only access at the moment for testing. The idea was to, while I am in the process of moving media across to the cloud have one library which merges the two together... for some reason though, it doesn't seem to work that way. It is showing duplicate series... one from local and one from cloud, instead of merging the two.
  21. Hi, I was wondering if I can change or customize the data fields whiche are shown in the library. This is probably a more general question, but I couldnt find any hint which draws me into one direction. Using a browser to browse through the library I click on Music -> Album and I get an overview of albums. It also shows below each album picture the TITLE of the album and the ARTIST. Lets say I would like to change this to TITLE and GENRE (for whatever reason). Or swap TITLE - ARTIST to ARTIST-TITLE. Is this possible? And how can I do this? Thx Tob
  22. The image previews in library News feed are distorted. Instead in the continue watching section, the pictures have the right format. How is it possible to show the previews in the right format?
  23. Blackie

    FreeNAS - Emby Library Access Jail

    Very much a NOOB. I am trying out Emby and Plex on a FreeNAS setup. I used the new Emby plugin (thank you!) Everything runs except: With Emby I can only put SMB shares for Windows into the Library: \\FREENAS\FN-Media\Movies Yet with Plex I can put the jail folders into its libraries: \\FreeNAS\jails\plex\Movies I understand this is not correct and I should be putting the Emby jail folders into its libraries. \\FREENAS\FN-Media\Movies \\192.168.1.219\jails\emby_1\Movies Also tried using // vice \ since I am on windows. When I try this I get: "There was an error adding the media path. Please ensure path is valid and Emby Server Process has access to that location" The jail folders are owned by user root, group wheel. I have made a user emby and assigned it to the group wheel. This user has the same ID as the user emby inside the jail (983). Can't find the solution to this in any post I have seen.
  24. Hello, I want to migrate my local windows emby server into a docker image. I know, that I can use the backup/import plugin, but my library has about 2000 entries and many of them are manual, manual pictures, manual names etc. Is there a way to migrate the whole database and everything to my new server and change the library path to the new linux path without rescanning/manually editing all my files?
  25. gerry.emm

    Library problems

    Hi everyone, I've been using EMBY since it was called MB Server...I switched over from Plex MANY moons ago. Over time, it seems my library has become corrupt. Where it's become apparent is in my TV shows. I stream EMBY to my Roku over my home network. The EMBY channel on my Roku is displaying double episode titles for SOME of my TV shows, not all. Only one of the two icons for an episode will actually play the episode. The "ghost" icon tries to load the episode, gets to about one third, then stops and there is no playback. I was thinking I might fix the problem by deleting the library for my TV shows and re-creating it, but I get the same result. Somewhere, EMBY must keep a backup of the library if it just brings back the exact same duplicated episode titles right? So, outside of un-installing EMBY and starting fresh, is there a way to have EMBY re-scrape a library fresh, and properly? Also, I have upgraded my Roku 3 to a Roku Ultra, even though my TV is not 4K. as It is downwards compatible, plus I got it for a song. (And I'll be ready when I DO get a 4K TV...) Only now, some of my videos refuse to stream. I found out by trying the Roku BETA channel (looks GREAT btw) that the videos that refuse to stream are 1080p but HEVC (rather than h.264 I believe it is). The point is, they used to play just fine on my Roku 3. I have gone over the Roku settings with a fine-tooth comb and cannot find any setting that could affect the playback of those files. Does anyone have any words of wisdom on fixing that problem also? Thanks in advance to anyone that can shed some light on either of those problems for this old guy with the tired eyes!!! Gerry
×
×
  • Create New...