Jump to content

Search the Community

Showing results for tags 'mount'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 9 results

  1. I have hosted my emby server on a vps and using rclone mount as my library . I am currently renaming and sorting all my content . Just had this very simple question I currently have 2 choices Either i can scrap all metadata directly in my google drive using tiny media manager or other tools and don't let emby fetch any metadata. So each TV show & Movie will have its own nfo , posters and everything in its respective drive folder itself . In short emby would read metadata individually for each folder The other option is i can not scrap any metadata externally . Just rename them properly following emby naming convention using any tool and while adding that library , let emby fetch all the metadata for it ( which i beleive it stores locally in /var/lib/emby/metadata ) So my main question is which option do you recommend me ? What would give better performance and quicker loading of metadata ? ( Locally or mounted drive ) On another note - Assuming i have metadata in my source itself , is there any option to ignore the metadata in source library - google drive ie the ones within individual movies and tv shows folder and force use the emby metadata fetched by emby itself ?
  2. xsteacy

    Windows sofware raid on linux

    Hi, I need emby to access a Windows formatted raid in linux. I mounted the raid with the ldmtool but I cannot access the files with emby. I gave emby access to the drive with chown but with no luck. I saw lots of posts in Google and here about that but for normal drive... I use Elementary OS 5.1(bases on Ubuntu 18.04) Thank you for any help, all is welcome.
  3. DutchEllie

    ANSWERED Path could not be found

    Hi all, I just installed emby server on my linux vps. I want to have my emby libraries on a different server however, specifically a onedrive server. Don't worry, I have that all sorted out, using rclone and a cache. It works like a charm. However, the folder currently is in the root directory, under the name of /onedrive owned by a user and group called qbtuser (from qbittorrent) so it can write nicely to it. Now I need to assign the emby libraries to somewhere like /onedrive/movies and /onedrive/series. However when I try to add a library in emby server and specify the folder, /onedrive is not found. /onedrive is owned by user and group qbtuser, and the directories and files inside are given the permissions of 775. The folder /onedrive itself also has permissions 775. Now, not only does that mean that everyone should be able to read and see what is in every folder, but the first problem arose when the root user tried to read from the /onedrive folder, and they are not allowed to.. Now also emby is not allowed to read or anything. There is a group qbtuser as mentioned before and I have added emby to that, and even rebooted the server, but it still does not work. I am out of ideas. Anyone else got any ideas?
  4. Hello, I'm sorry, but I could not figure where to report bugs/issues with the docker: emby/embyserver image? So, I'm posting it here the bug is with the emby/embyserver:4.0.1.0 I've created a CentOS VM using VirtualBox. after that, I've followed the docker installation guide mentioned on docker.com then added my shared folders from [host] to [guest] with the read/write permissions of course. the problem is that the docker emby image, crashes and exit, if the '/config' location was pointed to a shared-folder from the [host]. even if it has the correct permissions! and here is some information: [host] Distro that is running VirtualBox: [deadsoul@workstation ~]$ cat /etc/redhat-release Mageia release 6 (Official) for x86_64 [deadsoul@workstation ~]$ uname -a Linux workstation.hom 4.14.89-server-1.mga6 #1 SMP Mon Dec 17 15:00:02 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux [deadsoul@workstation ~]$ cat /proc/version Linux version 4.14.89-server-1.mga6 (iurt@scwx861.mageia.org) (gcc version 5.5.0 (Mageia 5.5.0-1.mga6)) #1 SMP Mon Dec 17 15:00:02 UTC 2018 [deadsoul@workstation ~]$ cat /etc/mageia-release Mageia release 6 (Official) for x86_64 [deadsoul@workstation ~]$ [host] VirtualBox info: [deadsoul@workstation ~]$ VBoxHeadless --version Oracle VM VirtualBox Headless Interface 5.2.22 (C) 2008-2018 Oracle Corporation All rights reserved. 5.2.22r126257 [deadsoul@workstation ~]$ /sbin/modinfo vboxnetadp filename: /lib/modules/4.14.89-server-1.mga6/dkms-binary/3rdparty/vbox/vboxnetadp.ko.xz version: 5.2.22 r126257 ((0xA2CDe001U)) license: GPL description: Oracle VM VirtualBox Network Adapter Driver author: Oracle Corporation srcversion: 29B5552C5D92B8323EE00BD depends: vboxdrv name: vboxnetadp vermagic: 4.14.89-server-1.mga6 SMP mod_unload [deadsoul@workstation ~]$ /sbin/modinfo vboxnetflt filename: /lib/modules/4.14.89-server-1.mga6/dkms-binary/3rdparty/vbox/vboxnetflt.ko.xz version: 5.2.22 r126257 ((0xA2CDe001U)) license: GPL description: Oracle VM VirtualBox Network Filter Driver author: Oracle Corporation srcversion: 59BC88F16B267340502BA6B depends: vboxdrv name: vboxnetflt vermagic: 4.14.89-server-1.mga6 SMP mod_unload [deadsoul@workstation ~]$ /sbin/modinfo vboxdrv filename: /lib/modules/4.14.89-server-1.mga6/dkms-binary/3rdparty/vbox/vboxdrv.ko.xz version: 5.2.22 r126257 (0x00290001) license: GPL description: Oracle VM VirtualBox Support Driver author: Oracle Corporation srcversion: D24FE4B53DF0D2A2995E45D depends: name: vboxdrv vermagic: 4.14.89-server-1.mga6 SMP mod_unload parm: force_async_tsc:force the asynchronous TSC mode (int) [deadsoul@workstation ~]$ [guest] Distro that is running docker info: [root@wsvmdockertest CentOS]# cat /etc/redhat-release CentOS Linux release 7.6.1810 (Core) [root@wsvmdockertest CentOS]# uname -a Linux wsvmdockertest.hom 3.10.0-957.1.3.el7.x86_64 #1 SMP Thu Nov 29 14:49:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux [root@wsvmdockertest CentOS]# cat /proc/version Linux version 3.10.0-957.1.3.el7.x86_64 (mockbuild@kbuilder.bsys.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-36) (GCC) ) #1 SMP Thu Nov 29 14:49:43 UTC 2018 [root@wsvmdockertest CentOS]# [guest] VirtualBox guest additions info: [root@wsvmdockertest CentOS]# modinfo vboxguest filename: /lib/modules/3.10.0-957.1.3.el7.x86_64/misc/vboxguest.ko version: 5.2.14 r123301 license: GPL description: Oracle VM VirtualBox Guest Additions for Linux Module author: Oracle Corporation retpoline: Y rhelversion: 7.6 srcversion: 87A2347C02617B1A8239C8B alias: pci:v000080EEd0000CAFEsv00000000sd00000000bc*sc*i* depends: vermagic: 3.10.0-957.1.3.el7.x86_64 SMP mod_unload modversions [root@wsvmdockertest CentOS]# modinfo vboxsf filename: /lib/modules/3.10.0-957.1.3.el7.x86_64/misc/vboxsf.ko version: 5.2.14 r123301 alias: fs-vboxsf license: GPL author: Oracle Corporation description: Oracle VM VirtualBox VFS Module for Host File System Access retpoline: Y rhelversion: 7.6 srcversion: E55F865E93C04E4FFB34C09 depends: vboxguest vermagic: 3.10.0-957.1.3.el7.x86_64 SMP mod_unload modversions parm: follow_symlinks:Let host resolve symlinks rather than showing them (int) [root@wsvmdockertest CentOS]# [guest] Docker info: [root@wsvmdockertest CentOS]# docker --version Docker version 18.09.1, build 4c52b90 [root@wsvmdockertest CentOS]# docker info Containers: 1 Running: 0 Paused: 0 Stopped: 1 Images: 3 Server Version: 18.09.1 Storage Driver: overlay2 Backing Filesystem: xfs Supports d_type: true Native Overlay Diff: true Logging Driver: json-file Cgroup Driver: cgroupfs Plugins: Volume: local Network: bridge host macvlan null overlay Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog Swarm: inactive Runtimes: runc Default Runtime: runc Init Binary: docker-init containerd version: 9754871865f7fe2f4e74d43e2fc7ccd237edcbce runc version: 96ec2177ae841256168fcf76954f7177af9446eb init version: fec3683 Security Options: seccomp Profile: default Kernel Version: 3.10.0-957.1.3.el7.x86_64 Operating System: CentOS Linux 7 (Core) OSType: linux Architecture: x86_64 CPUs: 16 Total Memory: 7.636GiB Name: wsvmdockertest.hom ID: 4YXA:ZX3N:ACS2:CEEV:S2B6:5PCS:FRMW:H4ES:QYAQ:AXDK:MPT2:5FN7 Docker Root Dir: /var/lib/docker Debug Mode (client): false Debug Mode (server): false Registry: https://index.docker.io/v1/ Labels: Experimental: false Insecure Registries: 127.0.0.0/8 Live Restore Enabled: false Product License: Community Engine [root@wsvmdockertest CentOS]# docker version Client: Version: 18.09.1 API version: 1.39 Go version: go1.10.6 Git commit: 4c52b90 Built: Wed Jan 9 19:35:01 2019 OS/Arch: linux/amd64 Experimental: false Server: Docker Engine - Community Engine: Version: 18.09.1 API version: 1.39 (minimum version 1.12) Go version: go1.10.6 Git commit: 4c52b90 Built: Wed Jan 9 19:06:30 2019 OS/Arch: linux/amd64 Experimental: false [root@wsvmdockertest CentOS]# [guest] Shared folder info: [root@wsvmdockertest CentOS]# mount | grep /dockers Dockers on /dockers type vboxsf (rw,nodev,relatime) [root@wsvmdockertest CentOS]# grep Dockers /etc/fstab Dockers /dockers vboxsf uid=1000,gid=1000,rw 0 0 [root@wsvmdockertest CentOS]# ls -lahn /dockers/emby/config-v4/ total 0 drwxr-xr-x. 1 1000 1000 132 Jan 27 04:39 . drwxr-xr-x. 1 1000 1000 96 Jan 27 04:22 .. drwxr-xr-x. 1 1000 1000 272 Jan 25 13:58 cache drwxr-xr-x. 1 1000 1000 116 Jan 25 01:45 config drwxr-xr-x. 1 1000 1000 708 Jan 25 09:23 data drwxr-xr-x. 1 1000 1000 448 Jan 25 01:41 localization drwxr-xr-x. 1 1000 1000 2.0K Jan 27 04:33 logs drwxr-xr-x. 1 1000 1000 50 Jan 25 09:24 metadata drwxr-xr-x. 1 1000 1000 186 Jan 25 01:45 plugins drwxr-xr-x. 1 1000 1000 14 Jan 25 01:41 root drwxr-xr-x. 1 1000 1000 0 Jan 25 01:46 transcoding-temp [root@wsvmdockertest CentOS]# id 1000 uid=1000(deadsoul) gid=1000(deadsoul) groups=1000(deadsoul),991(vboxsf) [root@wsvmdockertest CentOS]# find /dockers/emby/config-v4/ -uid 1000 -a -gid 1000 | wc -l 63908 [root@wsvmdockertest CentOS]# find /dockers/emby/config-v4/ | wc -l 63908 [root@wsvmdockertest CentOS]# find /dockers/emby/config-v4/ -not -uid 1000 -o -not -gid 1000 | wc -l 0 [guest] Docker run command: docker pull emby/embyserver:4.0.1.0 docker run -d \ --network physical_nw \ --ip 192.168.1.114 \ --hostname "emby-v4.hom" \ --mac-address "00:11:22:33:01:14" \ --volume /dockers/emby/config-v4:/config \ --volume /mnt/Media:/mnt/Media \ --volume /dockers/emby/backup-v4:/mnt/Backups \ --publish 8096:8096 \ --publish 8920:8920 \ --env UID=1000 \ --env GID=1000 \ --env GIDLIST=100,39 \ --restart unless-stopped \ --name emby-v4 \ -it emby/embyserver:4.0.1.0 sh [guest] Docker run logs: [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] done. [services.d] starting services [services.d] done. / # Info Main: Application path: /system/EmbyServer.dll Info Main: Emby Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3 Operating system: Unix 3.10.0.957 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 16 Program data path: /config Application directory: /system Info App: Application version: 4.0.1.0 Info App: Loading assemblies Info App: File /config/plugins/AudioDb.dll has version 1.0.4.0 Info App: File /system/plugins/AudioDb.dll has version 1.0.4.0 Info App: File /config/plugins/Emby.Server.CinemaMode.dll has version 1.0.10.0 Info App: File /system/plugins/Emby.Server.CinemaMode.dll has version 1.0.10.0 Info App: File /config/plugins/Fanart.dll has version 1.0.2.0 Info App: File /system/plugins/Fanart.dll has version 1.0.2.0 Info App: File /config/plugins/MovieDb.dll has version 1.0.6.0 Info App: File /system/plugins/MovieDb.dll has version 1.0.6.0 Info App: File /config/plugins/MusicBrainz.dll has version 1.0.1.0 Info App: File /system/plugins/MusicBrainz.dll has version 1.0.1.0 Info App: File /config/plugins/NfoMetadata.dll has version 1.0.10.0 Info App: File /system/plugins/NfoMetadata.dll has version 1.0.10.0 Info App: File /config/plugins/OMDb.dll has version 1.0.3.0 Info App: File /system/plugins/OMDb.dll has version 1.0.3.0 Info App: File /config/plugins/OpenSubtitles.dll has version 1.0.11.0 Info App: File /system/plugins/OpenSubtitles.dll has version 1.0.11.0 Info App: File /config/plugins/StudioImages.dll has version 1.0.0.0 Info App: File /system/plugins/StudioImages.dll has version 1.0.0.0 Info App: File /config/plugins/Tvdb.dll has version 1.0.1.0 Info App: File /system/plugins/Tvdb.dll has version 1.0.1.0 Info App: Loading AudioDb, Version=1.0.4.0, Culture=neutral, PublicKeyToken=null from /config/plugins/AudioDb.dll Info App: Loading AutoBoxSets, Version=1.2.2.0, Culture=neutral, PublicKeyToken=null from /config/plugins/AutoBoxSets.dll Info App: Loading Emby.Server.CinemaMode, Version=1.0.10.0, Culture=neutral, PublicKeyToken=null from /config/plugins/Emby.Server.CinemaMode.dll Info App: Loading Fanart, Version=1.0.2.0, Culture=neutral, PublicKeyToken=null from /config/plugins/Fanart.dll Info App: Loading IMVDb, Version=1.0.5.0, Culture=neutral, PublicKeyToken=null from /config/plugins/IMVDb.dll Info App: Loading MBBackup, Version=1.3.4.0, Culture=neutral, PublicKeyToken=null from /config/plugins/MBBackup.dll Info App: Loading MovieDb, Version=1.0.6.0, Culture=neutral, PublicKeyToken=null from /config/plugins/MovieDb.dll Info App: Loading MusicBrainz, Version=1.0.1.0, Culture=neutral, PublicKeyToken=null from /config/plugins/MusicBrainz.dll Info App: Loading NfoMetadata, Version=1.0.10.0, Culture=neutral, PublicKeyToken=null from /config/plugins/NfoMetadata.dll Info App: Loading OMDb, Version=1.0.3.0, Culture=neutral, PublicKeyToken=null from /config/plugins/OMDb.dll Info App: Loading OpenSubtitles, Version=1.0.11.0, Culture=neutral, PublicKeyToken=null from /config/plugins/OpenSubtitles.dll Info App: Loading StudioImages, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null from /config/plugins/StudioImages.dll Info App: Loading Tvdb, Version=1.0.1.0, Culture=neutral, PublicKeyToken=null from /config/plugins/Tvdb.dll Info App: Loading MediaBrowser.Api, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.WebDashboard, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.Model, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.Common, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.Controller, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.Providers, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Photos, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Server.Implementations, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.LiveTV, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Server.MediaEncoding, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Dlna, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.LocalMetadata, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Notifications, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Codecs.Dxva, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Codecs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Server.Connect, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Server.Sync, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading EmbyServer, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info SqliteUserRepository: Sqlite version: 3.26.0 Info SqliteUserRepository: Sqlite compiler options: COMPILER=gcc-6.3.0,ENABLE_COLUMN_METADATA,ENABLE_DBSTAT_VTAB,ENABLE_FTS3_PARENTHESIS,ENABLE_FTS3_TOKENIZER,ENABLE_FTS4,ENABLE_FTS5,ENABLE_JSON1,ENABLE_PREUPDATE_HOOK,ENABLE_RTREE,ENABLE_SESSION,ENABLE_UNLOCK_NOTIFY,ENABLE_UPDATE_DELETE_LIMIT,LIKE_DOESNT_MATCH_BLOBS,MAX_SCHEMA_RETRY=25,MAX_VARIABLE_NUMBER=250000,OMIT_LOOKASIDE,SECURE_DELETE,THREADSAFE=1 Error Main: Error in appHost.Init *** Error Report *** Version: 4.0.1.0 Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3 Operating system: Unix 3.10.0.957 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 16 Program data path: /config Application directory: /system SQLitePCL.pretty.SQLiteException: IOError: disk I/O error SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown. at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) Source: SQLitePCL.pretty TargetSite: Void CheckOk(SQLitePCL.sqlite3, Int32) at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) Error Main: UnhandledException *** Error Report *** Version: 4.0.1.0 Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3 Operating system: Unix 3.10.0.957 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 16 Program data path: /config Application directory: /system SQLitePCL.pretty.SQLiteException: IOError: disk I/O error SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown. at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) at EmbyServer.Program.RunApplication(ServerApplicationPaths appPaths, ILogManager logManager, IEnvironmentInfo environmentInfo, StartupOptions options) at EmbyServer.Program.Main(String[] args) Source: SQLitePCL.pretty TargetSite: Void CheckOk(SQLitePCL.sqlite3, Int32) at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) at EmbyServer.Program.RunApplication(ServerApplicationPaths appPaths, ILogManager logManager, IEnvironmentInfo environmentInfo, StartupOptions options) at EmbyServer.Program.Main(String[] args) UnhandledException SQLitePCL.pretty.SQLiteException: IOError: disk I/O error SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown. at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) at EmbyServer.Program.RunApplication(ServerApplicationPaths appPaths, ILogManager logManager, IEnvironmentInfo environmentInfo, StartupOptions options) at EmbyServer.Program.Main(String[] args) Source: SQLitePCL.pretty TargetSite: Void CheckOk(SQLitePCL.sqlite3, Int32) at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) at EmbyServer.Program.RunApplication(ServerApplicationPaths appPaths, ILogManager logManager, IEnvironmentInfo environmentInfo, StartupOptions options) at EmbyServer.Program.Main(String[] args) [cont-finish.d] executing container finish scripts... [cont-finish.d] done. [s6-finish] syncing disks. [s6-finish] sending all processes the TERM signal. [s6-finish] sending all processes the KILL signal and exiting.
  5. I have Emby Server installed in a docker container on an Unraid server. I have Emby for WMC installed on a separate Windows 7 machine. I am using the Path Substitution feature of Emby Server. I have configured Virtual CloneDrive in the Emby for WMC Configurator tool. When attempting to play an ISO in Emby for WMC I receive an error message in a VCDMount widow outside Emby for WMC saying... "Can't mount " and then the path. The path displayed is the path on the server, not what has been configured in Path Substitution - which is why it fails to mount.
  6. Scenario: Using EMC (Media Browser Classic in WMC). Loading External Players. Issues: 1. When loading MPC-HC with MadVR from EMC it sometimes starts to play audio only but sometimes plays fine. I either need to right click a mouse (not very reasonable as this is supposed to be all controlled with a remote) to get the file to play or I need to try repeatedly by stopping the playback and starting over from one to three times to get video playback. 2. ISO mounting. I have the configurator set to load TMT5 set for playback for ISO only and I have Elaborate Bytes Virtual Clone Drive set as the ISO mounter in the ISO and Extender tab. I have Mikhano's ISO mounter for WMC also installed. The iso's are not mounting nor playing back, unless I mount them prior to loading EMC which is not good as EMC loads when WMC loads when I Select HTPC on my Harmony Remote. Any assistance would be appreciated.. My logs from yesterday and previously when this occurred will not open correctly and I get the following from ServiceStack: Response Status Error CodeOutOfMemoryExceptionMessageException of type 'System.OutOfMemoryException' was thrown.Stack Trace[GetLogFile: 1/4/2016 8:54:42 PM]: [REQUEST: {Name:server-63587389501.txt}] System.OutOfMemoryException: Exception of type 'System.OutOfMemoryException' was thrown. at System.Text.StringBuilder.ToString() at System.IO.StreamReader.<ReadToEndAsyncInternal>d__19.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task) at MediaBrowser.Server.Implementations.HttpServer.HttpResultFactory.<GetStaticResult>d__7.MoveNext() I will try to grab a log immediately next time this occurs but stopping to do something like that lowers WAF tremendously! Thanks.
  7. domenic

    problem after replacing external disk

    Hi I am running on debian testing 386 build. All fine but I had a disk issue in which I have copied the data to a new drive and mounted it to the same location. The only difference is I switched file systems from NTFS to XFS as this will perform better. The emby server no longer can access the data. In the web browser it displays the mount point but after I select it none of the data is shown. I have verified that the mediabrowser account can access the data by allowing account to logon and changing to the mount. I also have a different XFS file system mounted which is displayed in the browser and can be explored. any ideas? Domenic
  8. Hi again. I have many 3D Blu-Ray titles which I've ripped to my NAS as ISO files. I watch these 3D Movies using TMT5 and NVidia 3DTVPlay software and have been doing so for a while now. Alcohol 52% is the ISO mount software I use, and it works a treat. What I haven't been able to do so far is to work out how I set Media Browser to work with these ISO files so I don't have to load this manually (ie, the way I do now). Here is what I do to watch a Blu-Ray 3D ISO today: 1. Start Alcohol 52% and mount the ISO image 2. Start Total Media Theatre 5 and hit play I do these steps from the Windows desktop interface and would like Media Browser to handle this as it does with the other movies. I'm sure there is a simple answer out there, but I haven't found it yet. Any help would be greatly appreciated. Thanks Paul
  9. I asked the same question on the old forum. Unfortunately, it still needs an external program. It can be configured from MBC config.
×
×
  • Create New...