Jump to content

Search the Community

Showing results for tags 'embyserver'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 13 results

  1. Hi all, thank you for this great product! I wanted to share an annoying issue I run into on the Android TV version of the Emby app when using the live tv mini guide. I hope below describes the issue clearly and I am willing to help wherever I can! Server: Latest stable Linux server docker image on unraid. Emby server version is 4.4.3.0 using Live TV via HDHomeRun Prime (3 tuner) using Emby Guide Data Client: This issue happens in apps that have the mini guide such as Android TV in my case Nvidia shield pro 2020. *I can DM logs if needed but its very easy to repo and consistent. I believe I know the server logic that may need to changed to fix this issue. Repro steps: 1. Saturate the Tuners having (in my case 3 devices watching 3 different shows) 2. On any one of the devices open the mini guide while watching say channel 7 and switch to another channel say channel 9 that the other 2 devices are not watching. Results: The server will prevent the channel switching because its still tuned to channel 7 so there will be no open tuner. This shows and error and stops playback. Workaround: Close the current viewing session before choosing another one. For example instead of switching the channel via the mini guide, back out of live tv to the full guide to change channels and things will work. Potential Emby Server logic fix: When changing channel via the mini guide, check to see if anyone else is watching the pre channel change channel (7 from the example above) and if not close the session with the tuner and then open a new session as there should be a tuner available.
  2. Hi, my Emby server crashes from time to time and it often happens at startup or when the server is accessed by an Android/IOS app. On my Odroid XU4 I freshly installed the latest Armbian image (Armbian 20.02.7 Buster with Linux 4.14.180-odroidxu4 kernel) and then installed the latest Emby version 4.4.2.0 for armhf via armbian-config. I did a lot of research and did all the necessary steps to make sure it wouldn't crash. I disabled the realtime library scan and it still crashes randomly. I manually installed Samba server next to Emby-server. I made sure that Emby has the necessary read and write permissions. I have added the Emby-server user "emby" to "users" group and I have adjusted the rights of the media directories. The Emby-server plays movies as it should, but the problem with crashing still persists. I have attached log files and I will be grateful for any help to try fixing my Problem. Thank you! Edit: Now, logs are there. sorry logs.zip
  3. CopiousEnnui

    No compatible streams are currently available.

    I'm runnning EmbyServer on my Unraid server and it works great. However, after a certain amount of time, the when I go to play media on any device, I will get this message 'No compatible streams are currently available. Please try again later or contact your system administrator for details.' The server itself is still functional: I can still configure things, mess with settings etc. However, I can not play any media. The fix I've found for this right now, albeit a poor one, is to simply delete my library folders and then recreate them. After this, I can watch media again, but then the issue will occur again in a few days or so. This is really frustrating, especially since I have EmbyPremiere and I have to keep remapping my library just to watch media. Can anyone help me fix this issue permanently? Cheers.
  4. Hello, I'm sorry, but I could not figure where to report bugs/issues with the docker: emby/embyserver image? So, I'm posting it here the bug is with the emby/embyserver:4.0.1.0 I've created a CentOS VM using VirtualBox. after that, I've followed the docker installation guide mentioned on docker.com then added my shared folders from [host] to [guest] with the read/write permissions of course. the problem is that the docker emby image, crashes and exit, if the '/config' location was pointed to a shared-folder from the [host]. even if it has the correct permissions! and here is some information: [host] Distro that is running VirtualBox: [deadsoul@workstation ~]$ cat /etc/redhat-release Mageia release 6 (Official) for x86_64 [deadsoul@workstation ~]$ uname -a Linux workstation.hom 4.14.89-server-1.mga6 #1 SMP Mon Dec 17 15:00:02 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux [deadsoul@workstation ~]$ cat /proc/version Linux version 4.14.89-server-1.mga6 (iurt@scwx861.mageia.org) (gcc version 5.5.0 (Mageia 5.5.0-1.mga6)) #1 SMP Mon Dec 17 15:00:02 UTC 2018 [deadsoul@workstation ~]$ cat /etc/mageia-release Mageia release 6 (Official) for x86_64 [deadsoul@workstation ~]$ [host] VirtualBox info: [deadsoul@workstation ~]$ VBoxHeadless --version Oracle VM VirtualBox Headless Interface 5.2.22 (C) 2008-2018 Oracle Corporation All rights reserved. 5.2.22r126257 [deadsoul@workstation ~]$ /sbin/modinfo vboxnetadp filename: /lib/modules/4.14.89-server-1.mga6/dkms-binary/3rdparty/vbox/vboxnetadp.ko.xz version: 5.2.22 r126257 ((0xA2CDe001U)) license: GPL description: Oracle VM VirtualBox Network Adapter Driver author: Oracle Corporation srcversion: 29B5552C5D92B8323EE00BD depends: vboxdrv name: vboxnetadp vermagic: 4.14.89-server-1.mga6 SMP mod_unload [deadsoul@workstation ~]$ /sbin/modinfo vboxnetflt filename: /lib/modules/4.14.89-server-1.mga6/dkms-binary/3rdparty/vbox/vboxnetflt.ko.xz version: 5.2.22 r126257 ((0xA2CDe001U)) license: GPL description: Oracle VM VirtualBox Network Filter Driver author: Oracle Corporation srcversion: 59BC88F16B267340502BA6B depends: vboxdrv name: vboxnetflt vermagic: 4.14.89-server-1.mga6 SMP mod_unload [deadsoul@workstation ~]$ /sbin/modinfo vboxdrv filename: /lib/modules/4.14.89-server-1.mga6/dkms-binary/3rdparty/vbox/vboxdrv.ko.xz version: 5.2.22 r126257 (0x00290001) license: GPL description: Oracle VM VirtualBox Support Driver author: Oracle Corporation srcversion: D24FE4B53DF0D2A2995E45D depends: name: vboxdrv vermagic: 4.14.89-server-1.mga6 SMP mod_unload parm: force_async_tsc:force the asynchronous TSC mode (int) [deadsoul@workstation ~]$ [guest] Distro that is running docker info: [root@wsvmdockertest CentOS]# cat /etc/redhat-release CentOS Linux release 7.6.1810 (Core) [root@wsvmdockertest CentOS]# uname -a Linux wsvmdockertest.hom 3.10.0-957.1.3.el7.x86_64 #1 SMP Thu Nov 29 14:49:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux [root@wsvmdockertest CentOS]# cat /proc/version Linux version 3.10.0-957.1.3.el7.x86_64 (mockbuild@kbuilder.bsys.centos.org) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-36) (GCC) ) #1 SMP Thu Nov 29 14:49:43 UTC 2018 [root@wsvmdockertest CentOS]# [guest] VirtualBox guest additions info: [root@wsvmdockertest CentOS]# modinfo vboxguest filename: /lib/modules/3.10.0-957.1.3.el7.x86_64/misc/vboxguest.ko version: 5.2.14 r123301 license: GPL description: Oracle VM VirtualBox Guest Additions for Linux Module author: Oracle Corporation retpoline: Y rhelversion: 7.6 srcversion: 87A2347C02617B1A8239C8B alias: pci:v000080EEd0000CAFEsv00000000sd00000000bc*sc*i* depends: vermagic: 3.10.0-957.1.3.el7.x86_64 SMP mod_unload modversions [root@wsvmdockertest CentOS]# modinfo vboxsf filename: /lib/modules/3.10.0-957.1.3.el7.x86_64/misc/vboxsf.ko version: 5.2.14 r123301 alias: fs-vboxsf license: GPL author: Oracle Corporation description: Oracle VM VirtualBox VFS Module for Host File System Access retpoline: Y rhelversion: 7.6 srcversion: E55F865E93C04E4FFB34C09 depends: vboxguest vermagic: 3.10.0-957.1.3.el7.x86_64 SMP mod_unload modversions parm: follow_symlinks:Let host resolve symlinks rather than showing them (int) [root@wsvmdockertest CentOS]# [guest] Docker info: [root@wsvmdockertest CentOS]# docker --version Docker version 18.09.1, build 4c52b90 [root@wsvmdockertest CentOS]# docker info Containers: 1 Running: 0 Paused: 0 Stopped: 1 Images: 3 Server Version: 18.09.1 Storage Driver: overlay2 Backing Filesystem: xfs Supports d_type: true Native Overlay Diff: true Logging Driver: json-file Cgroup Driver: cgroupfs Plugins: Volume: local Network: bridge host macvlan null overlay Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog Swarm: inactive Runtimes: runc Default Runtime: runc Init Binary: docker-init containerd version: 9754871865f7fe2f4e74d43e2fc7ccd237edcbce runc version: 96ec2177ae841256168fcf76954f7177af9446eb init version: fec3683 Security Options: seccomp Profile: default Kernel Version: 3.10.0-957.1.3.el7.x86_64 Operating System: CentOS Linux 7 (Core) OSType: linux Architecture: x86_64 CPUs: 16 Total Memory: 7.636GiB Name: wsvmdockertest.hom ID: 4YXA:ZX3N:ACS2:CEEV:S2B6:5PCS:FRMW:H4ES:QYAQ:AXDK:MPT2:5FN7 Docker Root Dir: /var/lib/docker Debug Mode (client): false Debug Mode (server): false Registry: https://index.docker.io/v1/ Labels: Experimental: false Insecure Registries: 127.0.0.0/8 Live Restore Enabled: false Product License: Community Engine [root@wsvmdockertest CentOS]# docker version Client: Version: 18.09.1 API version: 1.39 Go version: go1.10.6 Git commit: 4c52b90 Built: Wed Jan 9 19:35:01 2019 OS/Arch: linux/amd64 Experimental: false Server: Docker Engine - Community Engine: Version: 18.09.1 API version: 1.39 (minimum version 1.12) Go version: go1.10.6 Git commit: 4c52b90 Built: Wed Jan 9 19:06:30 2019 OS/Arch: linux/amd64 Experimental: false [root@wsvmdockertest CentOS]# [guest] Shared folder info: [root@wsvmdockertest CentOS]# mount | grep /dockers Dockers on /dockers type vboxsf (rw,nodev,relatime) [root@wsvmdockertest CentOS]# grep Dockers /etc/fstab Dockers /dockers vboxsf uid=1000,gid=1000,rw 0 0 [root@wsvmdockertest CentOS]# ls -lahn /dockers/emby/config-v4/ total 0 drwxr-xr-x. 1 1000 1000 132 Jan 27 04:39 . drwxr-xr-x. 1 1000 1000 96 Jan 27 04:22 .. drwxr-xr-x. 1 1000 1000 272 Jan 25 13:58 cache drwxr-xr-x. 1 1000 1000 116 Jan 25 01:45 config drwxr-xr-x. 1 1000 1000 708 Jan 25 09:23 data drwxr-xr-x. 1 1000 1000 448 Jan 25 01:41 localization drwxr-xr-x. 1 1000 1000 2.0K Jan 27 04:33 logs drwxr-xr-x. 1 1000 1000 50 Jan 25 09:24 metadata drwxr-xr-x. 1 1000 1000 186 Jan 25 01:45 plugins drwxr-xr-x. 1 1000 1000 14 Jan 25 01:41 root drwxr-xr-x. 1 1000 1000 0 Jan 25 01:46 transcoding-temp [root@wsvmdockertest CentOS]# id 1000 uid=1000(deadsoul) gid=1000(deadsoul) groups=1000(deadsoul),991(vboxsf) [root@wsvmdockertest CentOS]# find /dockers/emby/config-v4/ -uid 1000 -a -gid 1000 | wc -l 63908 [root@wsvmdockertest CentOS]# find /dockers/emby/config-v4/ | wc -l 63908 [root@wsvmdockertest CentOS]# find /dockers/emby/config-v4/ -not -uid 1000 -o -not -gid 1000 | wc -l 0 [guest] Docker run command: docker pull emby/embyserver:4.0.1.0 docker run -d \ --network physical_nw \ --ip 192.168.1.114 \ --hostname "emby-v4.hom" \ --mac-address "00:11:22:33:01:14" \ --volume /dockers/emby/config-v4:/config \ --volume /mnt/Media:/mnt/Media \ --volume /dockers/emby/backup-v4:/mnt/Backups \ --publish 8096:8096 \ --publish 8920:8920 \ --env UID=1000 \ --env GID=1000 \ --env GIDLIST=100,39 \ --restart unless-stopped \ --name emby-v4 \ -it emby/embyserver:4.0.1.0 sh [guest] Docker run logs: [s6-init] making user provided files available at /var/run/s6/etc...exited 0. [s6-init] ensuring user provided files have correct perms...exited 0. [fix-attrs.d] applying ownership & permissions fixes... [fix-attrs.d] done. [cont-init.d] executing container initialization scripts... [cont-init.d] done. [services.d] starting services [services.d] done. / # Info Main: Application path: /system/EmbyServer.dll Info Main: Emby Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3 Operating system: Unix 3.10.0.957 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 16 Program data path: /config Application directory: /system Info App: Application version: 4.0.1.0 Info App: Loading assemblies Info App: File /config/plugins/AudioDb.dll has version 1.0.4.0 Info App: File /system/plugins/AudioDb.dll has version 1.0.4.0 Info App: File /config/plugins/Emby.Server.CinemaMode.dll has version 1.0.10.0 Info App: File /system/plugins/Emby.Server.CinemaMode.dll has version 1.0.10.0 Info App: File /config/plugins/Fanart.dll has version 1.0.2.0 Info App: File /system/plugins/Fanart.dll has version 1.0.2.0 Info App: File /config/plugins/MovieDb.dll has version 1.0.6.0 Info App: File /system/plugins/MovieDb.dll has version 1.0.6.0 Info App: File /config/plugins/MusicBrainz.dll has version 1.0.1.0 Info App: File /system/plugins/MusicBrainz.dll has version 1.0.1.0 Info App: File /config/plugins/NfoMetadata.dll has version 1.0.10.0 Info App: File /system/plugins/NfoMetadata.dll has version 1.0.10.0 Info App: File /config/plugins/OMDb.dll has version 1.0.3.0 Info App: File /system/plugins/OMDb.dll has version 1.0.3.0 Info App: File /config/plugins/OpenSubtitles.dll has version 1.0.11.0 Info App: File /system/plugins/OpenSubtitles.dll has version 1.0.11.0 Info App: File /config/plugins/StudioImages.dll has version 1.0.0.0 Info App: File /system/plugins/StudioImages.dll has version 1.0.0.0 Info App: File /config/plugins/Tvdb.dll has version 1.0.1.0 Info App: File /system/plugins/Tvdb.dll has version 1.0.1.0 Info App: Loading AudioDb, Version=1.0.4.0, Culture=neutral, PublicKeyToken=null from /config/plugins/AudioDb.dll Info App: Loading AutoBoxSets, Version=1.2.2.0, Culture=neutral, PublicKeyToken=null from /config/plugins/AutoBoxSets.dll Info App: Loading Emby.Server.CinemaMode, Version=1.0.10.0, Culture=neutral, PublicKeyToken=null from /config/plugins/Emby.Server.CinemaMode.dll Info App: Loading Fanart, Version=1.0.2.0, Culture=neutral, PublicKeyToken=null from /config/plugins/Fanart.dll Info App: Loading IMVDb, Version=1.0.5.0, Culture=neutral, PublicKeyToken=null from /config/plugins/IMVDb.dll Info App: Loading MBBackup, Version=1.3.4.0, Culture=neutral, PublicKeyToken=null from /config/plugins/MBBackup.dll Info App: Loading MovieDb, Version=1.0.6.0, Culture=neutral, PublicKeyToken=null from /config/plugins/MovieDb.dll Info App: Loading MusicBrainz, Version=1.0.1.0, Culture=neutral, PublicKeyToken=null from /config/plugins/MusicBrainz.dll Info App: Loading NfoMetadata, Version=1.0.10.0, Culture=neutral, PublicKeyToken=null from /config/plugins/NfoMetadata.dll Info App: Loading OMDb, Version=1.0.3.0, Culture=neutral, PublicKeyToken=null from /config/plugins/OMDb.dll Info App: Loading OpenSubtitles, Version=1.0.11.0, Culture=neutral, PublicKeyToken=null from /config/plugins/OpenSubtitles.dll Info App: Loading StudioImages, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null from /config/plugins/StudioImages.dll Info App: Loading Tvdb, Version=1.0.1.0, Culture=neutral, PublicKeyToken=null from /config/plugins/Tvdb.dll Info App: Loading MediaBrowser.Api, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.WebDashboard, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.Model, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.Common, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.Controller, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.Providers, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Photos, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Server.Implementations, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.LiveTV, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Server.MediaEncoding, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Dlna, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading MediaBrowser.LocalMetadata, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Notifications, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Codecs.Dxva, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Codecs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Server.Connect, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading Emby.Server.Sync, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info App: Loading EmbyServer, Version=4.0.1.0, Culture=neutral, PublicKeyToken=null Info SqliteUserRepository: Sqlite version: 3.26.0 Info SqliteUserRepository: Sqlite compiler options: COMPILER=gcc-6.3.0,ENABLE_COLUMN_METADATA,ENABLE_DBSTAT_VTAB,ENABLE_FTS3_PARENTHESIS,ENABLE_FTS3_TOKENIZER,ENABLE_FTS4,ENABLE_FTS5,ENABLE_JSON1,ENABLE_PREUPDATE_HOOK,ENABLE_RTREE,ENABLE_SESSION,ENABLE_UNLOCK_NOTIFY,ENABLE_UPDATE_DELETE_LIMIT,LIKE_DOESNT_MATCH_BLOBS,MAX_SCHEMA_RETRY=25,MAX_VARIABLE_NUMBER=250000,OMIT_LOOKASIDE,SECURE_DELETE,THREADSAFE=1 Error Main: Error in appHost.Init *** Error Report *** Version: 4.0.1.0 Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3 Operating system: Unix 3.10.0.957 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 16 Program data path: /config Application directory: /system SQLitePCL.pretty.SQLiteException: IOError: disk I/O error SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown. at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) Source: SQLitePCL.pretty TargetSite: Void CheckOk(SQLitePCL.sqlite3, Int32) at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) Error Main: UnhandledException *** Error Report *** Version: 4.0.1.0 Command line: /system/EmbyServer.dll -programdata /config -ffdetect /bin/ffdetect -ffmpeg /bin/ffmpeg -ffprobe /bin/ffprobe -restartexitcode 3 Operating system: Unix 3.10.0.957 64-Bit OS: True 64-Bit Process: True User Interactive: True Processor count: 16 Program data path: /config Application directory: /system SQLitePCL.pretty.SQLiteException: IOError: disk I/O error SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown. at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) at EmbyServer.Program.RunApplication(ServerApplicationPaths appPaths, ILogManager logManager, IEnvironmentInfo environmentInfo, StartupOptions options) at EmbyServer.Program.Main(String[] args) Source: SQLitePCL.pretty TargetSite: Void CheckOk(SQLitePCL.sqlite3, Int32) at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) at EmbyServer.Program.RunApplication(ServerApplicationPaths appPaths, ILogManager logManager, IEnvironmentInfo environmentInfo, StartupOptions options) at EmbyServer.Program.Main(String[] args) UnhandledException SQLitePCL.pretty.SQLiteException: IOError: disk I/O error SQLitePCL.pretty.SQLiteException: Exception of type 'SQLitePCL.pretty.SQLiteException' was thrown. at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) at EmbyServer.Program.RunApplication(ServerApplicationPaths appPaths, ILogManager logManager, IEnvironmentInfo environmentInfo, StartupOptions options) at EmbyServer.Program.Main(String[] args) Source: SQLitePCL.pretty TargetSite: Void CheckOk(SQLitePCL.sqlite3, Int32) at SQLitePCL.pretty.SQLiteException.CheckOk(sqlite3 db, Int32 rc) at SQLitePCL.pretty.SQLiteDatabaseConnection.PrepareStatement(String sql, String& tail) at SQLitePCL.pretty.DatabaseConnection.PrepareStatement(IDatabaseConnection This, String sql) at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext() at System.Linq.Enumerable.TryGetFirst[TSource](IEnumerable`1 source, Boolean& found) at System.Linq.Enumerable.First[TSource](IEnumerable`1 source) at Emby.Sqlite.BaseSqliteRepository.CreateConnection(Boolean isReadOnly) at Emby.Server.Implementations.Data.SqliteUserRepository.Initialize() at Emby.Server.Implementations.ApplicationHost.GetUserRepository() at Emby.Server.Implementations.ApplicationHost.RegisterResources(FfmpegConfiguration ffmpegInfo) at Emby.Server.Implementations.ApplicationHost.Init() at EmbyServer.Program.InitAppHost(CoreAppHost appHost, ILogger logger) at EmbyServer.Program.RunApplication(ServerApplicationPaths appPaths, ILogManager logManager, IEnvironmentInfo environmentInfo, StartupOptions options) at EmbyServer.Program.Main(String[] args) [cont-finish.d] executing container finish scripts... [cont-finish.d] done. [s6-finish] syncing disks. [s6-finish] sending all processes the TERM signal. [s6-finish] sending all processes the KILL signal and exiting.
  5. Bonjour, bonsoir, je cherche un moyen de "débloqué" l'accès au dossier embyserver sur DSM via OSX, de base on ne peut pas, les dossiers système sont masqués, je ne maitrise pas encore le NAS à fond, si quelqu'un a une solution ça serait sympa. Merci. Hi i'm looking to access to the folder embyserver on DSM Synology with OSX, does anyone have a solution. Thanks.
  6. I'll try to keep this feature request short and simple. When the Emby server needs to transcode audio to make it compatible for the Emby client, it will use a hardcoded value for the bitrate that cannot be changed. For example, if the audio gets transcoded to Dolby Digital AC-3, it will always use a bitrate of 384 kb/s. This value cannot be changed, even though Dolby Digital AC-3 allows a maximum bitrate of 640 kb/s. Although 384 kb/s is a decent compromise between quality and data, it is very compressed and the quality is far from being transparent. The same thing applies to every other audio codec the Emby server may transcode to, such as AAC. So the request is simple, allow users to specify the bitrate that should be used for transcoding audio. Thanks, Charlie
  7. Hi, everybody. Did not find a similar question on the forum and created a topic. There is a server on Windows and Emby server installed. How can I change the link from localhost:8096 to localhost:8096/emby ? P.S. sorry for english, I use google translate =)
  8. When updating Google Chrome to the current version # 70x, I noticed that the EmbyServer interface images are not displayed. I waited more than 15 minutes and the screen does not display the images, even resetting Chrome and even the PC. In 69x version of Chrome and also in Edge, there is this problem.
  9. Hi guys, I have all my Videos and so on stored at a NAS (which cannt be used as Emby-server), therefore i thought about a workaround with a windows machine as an emby-server in front of the nas (which uses an smb-release to acces my media). Kodi on my shieldtv works great with that smb-path. how are my chances to get this done? Is anybody out there, that uses a similar solution? i´d be glad for every stone of contention
  10. ddluzelle

    ANSWERED Emby Server Windows

    Hi Emby, I'd like to ask for your help. We're not able to update Emby Server hosted to our Windows Server. We're not able to update emby server which is hosted in our Windows Server. Even if we have downloaded the latest version and was advised to restart after, still the update failed. What are the other steps we can do to update our Emby Server? Thanks.
  11. Hope someone can help me on this subject, It first started I totally lost the program to Emby for WMC the icon and program disappeared. so I decided reinstall it from the Emby website, I first I disabled the Anti-Virus program (Norton's) When I did this is the following error downloading. "Application Run" Security Warning see my attachment. I tried clearing one click cache. I tried Chrome to download it and Internet Explorer no luck. I thought it had to do something with internet? I have another computer in the other room and I can download the files on that computer. Thank You
  12. I apologize if this is not in the correct forum. I also apologize if this is already answered. I have two Linux Mint computers connected via Ethernet cable. A Cisco Linksys E1500 is the router between them. On Linux Mint 17.3 I installed, setup, and am running embyserver. The IP is x.x.x.1 (not the real address.) On the router, I set a Single Port Forwarding named emby as External Port 8096, Internal Port 8096, Protocol Both, IP Address x.x.x.1 (where that is the IP address of the server computer). On Linux Mint 18.3 I installed kodi (from the ppa:team-xbmc/ppa repository) following directions from http://kodi.wiki/view/HOW-TO:Install_Kodi_for_Linux This computer is IP x.x.x.2 (again, not the real address) In the kodi client I installed the EmbyCon add on. In the EmbyCon settings I set the Server Address to x.x.x.1 and the Server Port to 8096. Use HTTPS is off and Verify Certificate is OFF. When I click Detect Server it reports No Servers Detected. User name is set to "john" and the password is left blank. Device name is set to EmbyCon. On the server I added a user named "john" and left the password empty. (Actually I tried with and without passwords etc.) So... help, how do I broadcast from the server so that I can see the files (movies in this case) on the client? thank you
  13. Guardian Hope

    FIPS Validated Cryptography Fix

    After a very long period where I could not use Emby Server on Windows 10 Pro because the server was not registering with the http server as authorized with the OS (see http://emby.media/community/index.php?/topic/29931-emby-refusing-connections/ for all about that) I decided to give Emby Server on Windows another try primarily because the server needed direct access to my GPU which VMWare Workstation doesn't provide (although vSphere does) so I can stream out H.265 content to an rPi3 running OSMC. Works wonderfully by the way but I did encounter an issue with Emby Server which can easily be rectified. Emby Server, once I reinstalled the latest development build, threw an unhandled exception error so I browsed over to Emby Server's logs and saw that this is the fourth program I encountered which doesn't comply with FIPS validated cryptography and that's a problem in Windows 10 - especially if you have Trusted Platform computing enabled because you need it for one reason or another. However, the fix is easy: In MediaBrowser.ServerApplication.exe.config the following line needs to be added before the closing of the <runtime> tags: <enforceFIPSPolicy enabled="false"/> This disables the FIPS validation check for this program and allows it to run under Windows 10 on a system using a Trusted Platform Module enforcing FIPS cryptography. You may of course find the article on MSDN. On system not using a TPM, this change makes no difference to how the application is run. For reference, here was the exception log file: One or more errors occurred. System.AggregateException at System.Threading.Tasks.Task.WaitAll(Task[] tasks, Int32 millisecondsTimeout, CancellationToken cancellationToken) at MediaBrowser.ServerApplication.MainStartup.RunApplication(ServerApplicationPaths appPaths, ILogManager logManager, Boolean runService, StartupOptions options) at MediaBrowser.ServerApplication.MainStartup.Main() InnerException: System.Reflection.TargetInvocationException Exception has been thrown by the target of an invocation. at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at System.Security.Cryptography.CryptoConfig.CreateFromName(String name, Object[] args) at System.Security.Cryptography.MD5.Create() at MediaBrowser.Common.Extensions.BaseExtensions.GetMD5(String str) at MediaBrowser.Server.Startup.Common.ApplicationHost.GetCertificatePath(Boolean generateCertificate) at MediaBrowser.Server.Startup.Common.ApplicationHost.StartServer() at MediaBrowser.Server.Startup.Common.ApplicationHost.FindParts() at MediaBrowser.Common.Implementations.BaseApplicationHost`1.<Init>d__4.MoveNext() InnerException: System.InvalidOperationException This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms. at System.Security.Cryptography.MD5CryptoServiceProvider..ctor() Emby Server is now working but I would hate to have to re-add that line with every single update to Emby Server on Windows 10.
×
×
  • Create New...