Jump to content

Search the Community

Showing results for tags 'mpegts'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 1 result

  1. Hi! I've been running a Dockerized Emby server based on the official Docker image (currently at v4.2.1.0), to be accessed from Roku boxes I have laying about the house, using the BETA Roku app. I also have a TVHeadEnd deployment which is fully functional, which also renders all streams as MPEG-TS container with MPEG2 video and AC3 audio. The Emby server is configured to access TVH using the Emby TVHeadEnd plugin (v1.4.4.0). This has worked flawlessly for months, but now I've noticed that Emby is for some reason transcoding from MPEG2 to H264. While this isn't costing too much, it's not what I want. Plex and other clients are more than happy to play back the MPEG2 video streams without issue. However, Emby is choosing to transcode the stream because "container is not supported". This means that for some reason, Emby - either Roku or Server? - decides it doesn't like the MPEGTS container and requires a "transcoding". The issue here is that the "transcoding" should limit itself to repackaging, since both the audio and video streams are supported by the Roku device(s). As I said, this used to work perfectly in earlier server versions. Sadly, I don't know exactly when this got "broken" (so to speak). I only noticed this accidentally yesterday while showing a friend of mine the "stats for nerds". Can you help me figure out what's wrong? In my mind, if the container is not supported then Emby can definitely repackage the streams as it sees fit - what it shouldn't be doing is transcoding them as this is wasteful and unnecessary. Like I said before, neither Plex nor Roku's UPNP/DLNA application have any issue in playing back the raw MPEGTS/MPEG2/AC3 streams. I'll be happy to provide more details if required. Cheers!
×
×
  • Create New...