Jump to content

Search the Community

Showing results for tags 'osmc'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 15 results

  1. restalic12

    Installare Emby su OSMC

    Salve a tutti, ho installato Emby (repository.emby.kodi-1.0.4) su RPi 3 in cui è presente OSMC, ho avviato il plugin video e mi richiede di configurare il server inserendo l'IP fisso della RPi 192.168.1.xxx e la relativa porta standard 8096, non viene accettato. Come posso configurarlo correttamente? Vi ringrazio per il supporto.
  2. Hi, I'm having some problems to maintain sync between Kodi and Emby in my RPI3 (OSMC distribution) with Emby for Kodi plugin. I'm using Samba, so I could use "localhost" or "osmc" as a host, as both Emby and Kodi are running in the same machine, but for some reason it resets the host to an 192.168.1.x IP (not necessarily the current one) everytime I restart the server. That's happening with both "emby connect" and "manual" options. I've found something similar in these posts: https://emby.media/community/index.php?/topic/57270-emby-for-kodi-doesnt-find-my-server-after-kodi-restart/ https://emby.media/community/index.php?/topic/57243-kodi-keep-lan-address/ But I don't know where should I configure the host that Emby is sending to the plugin. In the dashboard is showing the internal IP address, but it has been always the same when using Raspbian or Retropie, and host settings were never lost. My environment: Hardware: Rapsberry PI 3, model B (UK Version) OS: OSMC 2018.08-2 Kodi: 17.6 Emby: 3.5.2.0 Emby for Kodi: 3.0.34 I don't know if I'm missing any configuration option in OSMC. I've read about option "cleanonupdate" that should be turned off in the advancedsettings.xml, but in fact this option doesn't exist in the (quite brief) advancedsettings.xml from OSMC. My last try was: Searching files with the IP address shown in the configuration. Found "data.txt" and "settings.xml" in /home/osmc/.kodi/userdata/addon_data/plugin.video.emby. Edited those files, replacing the IP by localhost, and save the changes. Set readonly permissions for these files (sudo chmod 0444) so they could be read, but couldn't be modified anymore. After restarting the server it's showing the host http://localhost:8096 in the configuration (what should really be) but a pop-up message appears with an emby error.
  3. livtyler

    Emby Crashing on Vero 4K

    Im using Vero 4k on the latest release, after some troubleshooting via the OSMC forums it was suggested it is not a Vero 4K problem but probably the Emby Add on for Kodi. When syncing my movies and tv shows it will crash multiple times which will cause the sad face crash. Eventually it does this a few times and it seems to import everything. However, all TV shows and movies crash on playback after a few seconds. Ive deselected force Artwork Caching and limited the download threads to 1, but still the error persists. logs are attached. Kodilog.txt
  4. karaskis

    Pi3 Crashes on library scan

    Hi All, My Pi3 is crashing on Emby's movie or TV library scan. Emby is not able to finish the activity (usually freezes around 70%) and I even lose SHH connection. To restart I have to unplug Pi. All files are on a ext4 external HDD with it's own power supply. I have performed a long fsck and HDD/data seems OK. I'm running on Version 3.2.19.0 on a clean (new) OSMC install and have used the official instructions to install Emby https://emby.media/c...l-instructions/ . Could anyone please take a look at the attached log? I can't find what's wrong. Log.txt
  5. Hi all :-) I'm a new user, trying to setup my Emby + Kodi environment. I've issues in library setup, during the "path substitution" phase, now integrated with library folders. The issue is that Emby "shared network folder" field seems to accept only UNC paths (\\server\share...), so any linux client tries to access the share via Samba instead of using NFS. My NAS exports shares both via SMB and NFS, but since I'm using some RaspberryPi as Kodi front-ends (OSMC distribution), I want to avoid using Samba, since it has an overhead on CPU. The only way I've find to end the library setup is by using UNC paths, but of course all clients try to access the share via Samba. Example, from kodi log: I've already tried to search for a solution on wiki and forum, but I've seen only threads (eg. https://emby.media/community/index.php?/forum/116-linux/)without solutions to get NFS works with Emby. It seems that it was supported without problem in the previous "path substitution" way: https://emby.media/community/index.php?/topic/24109-no-playback-with-beta-add-on/?p=235928 Is there any solution or workaround (even by edit manually some config file...) to pass to clients an NFS path instead of UNC, with the new library setup procedure? Thank you in advance. Bye, Edoardo
  6. Hi, I'm new to the Emby world but got my sever running on a Pi3 with OSMC. When I try to web play on Chrome I get only 2~3 seconds of playback and then some kind of buffering/loading that interrupts the movie. I believe this is due to my Pi3 transcoding limitation, is the anything I can do to solve this performance limitation when transcoding is needed? But the main issue is that I would like to use DirectPlay and so not suffer from transcoding but keep getting errors: Unknown Profile and Bitrate exceeds DirectPlay limit: media bitrate. Is this due to AC3 and DTS browser limitations? I've also tried a AAC mp4 and got the same problem. Any clues on how I solve these errors? Tks server Log.txt
  7. I just finished installing Emby server on my Raspberry Pi 3 using the guide here. Everything seems to work great, except I can't get anything to play when using my Android client. Server log is attached. I don't think it is a problem with the Android client, as I can get it to work when using my old server. I'm guessing I have done something wrong in setting up my new RPI3 server. Thanks for the help. server-63615369600.txt
  8. karaskis

    Videos won't play - Emby Server on OSMC

    Hi, I'm running Emby Server on a Raspberry Pi3 with OSCM. I was able to get it installed and running by following these instructions: https://github.com/douglasorend/osmc_install_emby And by accessing the url I added my OSMC library (drive connected to Pi3) perfectly. The problem is when I hit play nothing happens, both on browser and on the iOS app. I get a "loading" circle on the screen that disappears after 4 seconds but no playback and no error message. Bellow are the logs. Does anyone know how to fix this? Thanks Log_2.txt Log.txt
  9. Hello guys, i have a problem with my emby server and kodi ( a raspberry pi model 3b with OSMC ) I've installed the kodi emby addon, but i'm unable to reproduce any movie from Kodi i have the list of all movies, but when i try to reproduce one of those movie, nothing happen.. maybe someone here can help me.. i don't really know how to go ahead I tried with: Openelec OSMC Raspbian + kodi i was not able to run successfully the kodi emby addon in this moment my current setup is: Kodi emby addon 2.2.10 OSMC with Kodi 16.1 Emby server version: 3.0.5972.0 on Ubuntu 16.04 Attached you can find the kodi logs kodi.log Thank so much Cheers, Marco
  10. I have a ubuntu 15.10 vm running on esxi which is running emby. When I try and get my raspberry pi 2 running osmc to sync it fails and reboots itself. I did notice an issue with some of the files not looking at the right destination, they were looking for /mnt/media. I have mounted my synology nfs shares to the ubuntu vm. They have a path of mnt/media. I have set path substitution to nfs://192.168.1.10/volume1/media. I have attached the logs from the emby server. Not sure where else to test? I posted this originally in the wrong forum. Log.txt
  11. rowdybeans

    Can't do initial library scan OSMC Kodi

    I have moved this post to the kodi app section. Not sure how to delete this one. I have a ubuntu 15.10 vm running on esxi which is running emby. When I try and get my raspberry pi 2 running osmc to sync it fails and reboots itself. I did notice an issue with some of the files not looking at the right destination, they were looking for /mnt/media. I have mounted my synology nfs shares to the ubuntu vm. They have a path of mnt/media. I have set path substitution to nfs://192.168.1.10/volume1/media. I have attached the logs from the emby server. Not sure where else to test? I have moved this post to the kodi app section. Not sure how to delete this one. Log.txt
  12. Hello, I am running EMBY server Versie 3.0.5781.2 on WINDOWS 8.1 OSMC (OSMC_TGT_rbp2_20151027.img) on a RASPBERRY 2 with EMBY.KODI plugin (repository.emby.kodi-1.0.2.zip) Things seem to work nicely, and movies library metadata is synced to KODI. However, when it starts syncing my music library (+/- 35.000 tracks), KODI crashes around track 2500 and starts up again. Syncing starts then over, but crashes again and so on.... I don't seem to have this problem with EMBY.KODI plugin on KODI installed on a windows machine. Is the RPI2 not powerfull enough to run large libraries of music? But I don't have any problem either if I run plain KODI on the RPI2, or PLEX on the RPI2 pointing to the same music library Anybody with same experience? kind regards, Bart
  13. PeaceTrain

    Emby/Kodi on OSMC/RPi2 lags

    Hi, I have used Emby for Kody quite a time now but in the last weeks it didn't work well anymore. when I play a video it starts to lag after a little while, then it pauses. I stream the Videos over the Internet but my bandwidth cannot me the problem because I have 100Mb/s and with other clients it works well (Android, Webclient, ...) I have already reinstalled the Server and and the Raspberry with OSMC and have the current stable release Server and Emby for Kodi. Please give me some advice. Thanks PeaceTrain
  14. isaacsmith

    Media very slow to start on Raspberry Pi

    I have a couple Pi B+es running the latest OSMC (Kodi 15.2-RC2), using the Emby plugin version 1.1.39. Media syncs just fine, but playing any media takes 10-15 seconds before it starts playing. Looking at the logs, it seems that the plugin takes a long time to start up: <snip> 15:05:02 72559.093750 T:3025760816 DEBUG: OnPlayMedia plugin://plugin.video.emby/movies/9a7157f73151a9a670f35fa7aef238ed/?filename=test.mp4&id=9a7157f73151a9a670f35fa7aef238ed&mode=play 15:05:02 72559.093750 T:3025760816 DEBUG: CAnnouncementManager - Announcement: OnClear from xbmc 15:05:02 72559.093750 T:3025760816 DEBUG: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnClear 15:05:02 72559.101562 T:3025760816 DEBUG: CAnnouncementManager - Announcement: OnAdd from xbmc 15:05:02 72559.101562 T:3025760816 DEBUG: GOT ANNOUNCEMENT, type: 2, from xbmc, message OnAdd 15:05:02 72559.109375 T:3025760816 DEBUG: StartScript - calling plugin Emby('plugin://plugin.video.emby/movies/9a7157f73151a9a670f35fa7aef238ed/','8','?filename=test.mp4&id=9a7157f73151a9a670f35fa7aef238ed&mode=play') 15:05:02 72559.117188 T:2583688224 NOTICE: Thread LanguageInvoker start, auto delete: false 15:05:02 72559.117188 T:3025760816 DEBUG: WaitOnScriptResult - waiting on the Emby (id=18) plugin... 15:05:02 72559.117188 T:2583688224 INFO: initializing python engine. 15:05:02 72559.117188 T:2583688224 DEBUG: CPythonInvoker(18, /home/osmc/.kodi/addons/plugin.video.emby/default.py): start processing 15:05:04 72560.414062 T:2583688224 NOTICE: -->Python Interpreter Initialized<-- 15:05:04 72560.414062 T:2583688224 DEBUG: CPythonInvoker(18, /home/osmc/.kodi/addons/plugin.video.emby/default.py): the source file to load is "/home/osmc/.kodi/addons/plugin.video.emby/default.py" 15:05:04 72560.414062 T:2583688224 DEBUG: CPythonInvoker(18, /home/osmc/.kodi/addons/plugin.video.emby/default.py): setting the Python path to /home/osmc/.kodi/addons/plugin.video.emby:/home/osmc/.kodi/addons/script.module.requests/lib:/usr/lib/python2.7:/usr/lib/python2.7/plat-arm-linux-gnueabihf:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload:/usr/local/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages:/usr/lib/python2.7/dist-packages/PILcompat:/usr/lib/python2.7/dist-packages/gtk-2.0 15:05:04 72560.414062 T:2583688224 DEBUG: CPythonInvoker(18, /home/osmc/.kodi/addons/plugin.video.emby/default.py): entering source directory /home/osmc/.kodi/addons/plugin.video.emby 15:05:04 72560.421875 T:2583688224 DEBUG: CPythonInvoker(18, /home/osmc/.kodi/addons/plugin.video.emby/default.py): instantiating addon using automatically obtained id of "plugin.video.emby" dependent on version 2.1.0 of the xbmc.python api 15:05:04 72560.632812 T:3025760816 DEBUG: DialogProgress::StartModal called 15:05:04 72560.640625 T:3025760816 DEBUG: ------ Window Init (DialogProgress.xml) ------ 15:05:04 72560.640625 T:3025760816 DEBUG: Window DialogProgress.xml was already loaded 15:05:04 72560.640625 T:3025760816 DEBUG: Alloc resources: 0.18ms 15:05:11 72567.953125 T:2583688224 NOTICE: plugin.video.emby started 15:05:11 72567.960938 T:2583688224 NOTICE: Parameter string: ?filename=test.mp4&id=9a7157f73151a9a670f35fa7aef238ed&mode=play 15:05:12 72568.468750 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : === ENTER downloadUrl === 15:05:12 72568.539062 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : Header: {'Accept-Charset': 'UTF-8,*', 'Content-type': 'application/json', 'Accept-encoding': 'gzip', 'Authorization': 'MediaBrowser UserId="26c9f756a12c480dba75ed4b73894c6f", Client="Kodi", Device="PreK TV", DeviceId="FC677A3A41594842A2282BA940B41338", Version="1.1.39"', 'X-MediaBrowser-Token': '1c3709f0f98a4d1cb26f5cb759c5a89b'} 15:05:12 72568.601562 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : URL: http://10.99.1.252:8096/mediabrowser/Users/26c9f756a12c480dba75ed4b73894c6f/Items/9a7157f73151a9a670f35fa7aef238ed?format=json&ImageTypeLimit=1 15:05:12 72569.085938 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : ====== 200 Success ====== 15:05:12 72569.101562 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : Response: {<snip really long JSON response>} 15:05:12 72569.117188 T:2583688224 NOTICE: PLAY Called 15:05:12 72569.164062 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : === ENTER downloadUrl === 15:05:12 72569.179688 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : URL: http://10.99.1.252:8096/mediabrowser/Users/26c9f756a12c480dba75ed4b73894c6f/Items/9a7157f73151a9a670f35fa7aef238ed/Intros?format=json&ImageTypeLimit=1&Fields=Etag 15:05:12 72569.257812 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : Header: {'Accept-Charset': 'UTF-8,*', 'Content-type': 'application/json', 'Accept-encoding': 'gzip', 'Authorization': 'MediaBrowser UserId="26c9f756a12c480dba75ed4b73894c6f", Client="Kodi", Device="PreK TV", DeviceId="FC677A3A41594842A2282BA940B41338", Version="1.1.39"', 'X-MediaBrowser-Token': '1c3709f0f98a4d1cb26f5cb759c5a89b'} 15:05:12 72569.328125 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : URL: http://10.99.1.252:8096/mediabrowser/Users/26c9f756a12c480dba75ed4b73894c6f/Items/9a7157f73151a9a670f35fa7aef238ed/Intros?format=json&ImageTypeLimit=1&Fields=Etag 15:05:13 72569.429688 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : ====== 200 Success ====== 15:05:13 72569.453125 T:2583688224 NOTICE: EMBY DownloadUtils -> logMsg : Response: {u'Items': [], u'TotalRecordCount': 0} 15:05:13 72569.515625 T:2583688224 NOTICE: EMBY PlayUtils -> logMsg : Path exists. 15:05:13 72569.539062 T:2583688224 NOTICE: EMBY PlayUtils -> logMsg : File is direct playing. 15:05:13 72569.617188 T:2583688224 NOTICE: plugin.video.emby stopped 15:05:13 72569.617188 T:2583688224 INFO: CPythonInvoker(18, /home/osmc/.kodi/addons/plugin.video.emby/default.py): script successfully run 15:05:13 72569.625000 T:3025760816 DEBUG: WaitOnScriptResult- plugin returned successfully 15:05:13 72569.710938 T:3025760816 DEBUG: Loading settings for nfs://10.99.1.252/raid/shares/ccc/TV Media/Video/Misc/test.mp4 15:05:13 72569.804688 T:3025760816 DEBUG: CPlayerCoreFactory::GetPlayers(nfs://10.99.1.252/raid/shares/ccc/TV Media/Video/Misc/test.mp4) <snip> It seems to take several seconds for the Emby plugin to load and tell Kodi the video's URL, after which playback starts quickly. Both playing directly over NFS via Kodi and playing via Emby's UPNP feature starts almost instantly. Is the Pi just too slow for the plugin, or is something else going on? Is there some way I can speed things up?
  15. madkaz

    Fragen und Anregungen

    Hallo zusammen, seit einiger Zeit nutze ich Emby, auf einem PC als Server, mit Windows 10, Gbit Lan, viele TB an Filmen, TV Serien, Musik und Musikvideos dieser PC hat keinen eigenen Monitor und ist auch nicht der Schnellste (DuoCore mit 1.8 ghz). Ich habe einen weiteren PC mit Win 10 als Client, mit dem ich die Datenbanken pflege, auf diesem läuft auch Kodi. Weiter nutze ich in einem Heimkino einen Raspberry pi 2, mit OSMC und dem Emby Plugin, in meinem Wohn- und Schlafzimmer hängt jeweils ein Chromecast am TV. Die Chromecasts habe ich mir extra wegen Emby gekauft, und dachte anfangs, dass alles gut laufen würde. Leider erwies sich das als Trugschluss. Bei mkv Dateien 1080p ruckelt die Wiedergabe, bzw bricht sehr oft ab, und ich weiß nicht, ob es mein Fehler ist. Ich denke mal, dass mein Server einfach zu schwach ist, einen 1080p Film zu transkodieren und über das Netzwerk an den Chromecast zu schicken, ich frage mich aber, ob der Chromecast nicht stark genug ist einen solchen Film selbst abzuspielen, ohne das er transkodiert wird. wenn ja habe ich noch keine Möglichkeit entdeckt, dies zu tun. Gibt es eine spezielle Chromecast App, die ich auf das Gerät selbst laden kann, oder muss ich die Android App nutzen, kann ich dort das Transkodieren ausschalten? Mein Handy hat beim Abspielen von FullHD Material so gut wie nie Aussetzer oder Ruckler. Musik habe ich auch auf dem Server, ebenso Musikvideos. Während Emby die Interpreten Datenbank für Musik gut von selbst befüllt, muss ich dass bei den Musikvideos fast komplett von Hand machen. Sind überhaupt zwei Datenbanken notwendig ? U2 bleibt doch U2, egal ob als Song, als Konzert oder Clip. An meinen Raspberry pi habe ich eine Festplatte mit Musik angeschlossen, die ich ums verrecken nicht mit dem Emby Server verbinden kann. Sobald ich versuche in der Medienbibliothek diese Festplatte einzubinden bin ich wieder im Login Bildschirm. Von meinem Desktop PC kann ich jede Festplatte in Emby einbinden. Oftmals fehlen einzelne Fotos der Schauspieler bei Filmen und Serien, gibt es eine Möglichkeit diese nachladen zu lassen, ohne dies einzeln von Hand zu tun? Überhaupt ist die Datenbank oft ziemlich träge, das kann allerdings an der Masse meiner Filme und Serien liegen, vielleicht hat aber auch jemand einen Tipp für mich. Den Server aufzurüsten, mit einer SSD z.B. ist zwar geplant, aber zur Zeit habe ich genug andere Ausgaben und so muss das bis zum nächsten Jahr warten. Was mir bei Emby noch fehlt ist zum Beispiel, wenn ich die Seite eines Films aufrufe, dann sehe ich das Cover, ein Hintergrundbild, eine Inhaltsangabe, die Darsteller u.s.w, sogar Vorschläge, was ich mir noch angucken könnte, aber keinen Hinweis zu einem eventuell vorhandenen Soundtrack. So etwas fände ich total gut, das Cover eines OST Album, vielleicht mit der Möglichkeit, die Musik mit einem Klick sofort abzuspielen. Was mich noch freuen würde wäre, meine DVDs und BluRay's in die Sammlung zu integrieren, auch CD's und sogar Schallplatten, halt Sachen, die ich nicht auf Festplatte habe, würde sich noch jemand darüber freuen? Eine Frage hätte ich noch, wenn ich das richtig verstanden habe (mit meinem mangelhaften englisch) habe ich die Möglichkeit, Emby auch offline zu nutzen. Heißt das, ich habe dann meine Datenbanken zB. auf meinem Handy oder dem Desktop, ohne dass der Server eingeschaltet ist, und wenn ja, wie kriege ich das hin? Jedenfalls wünsche ich allen einen guten Start in die Woche Peter
×
×
  • Create New...