Jump to content

Search the Community

Showing results for tags 'metadata'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Thomas64

    Issue with updating Metadata?

    Apologies if this is submitted incorrectly - first post on these forums. I am having an issue updating Artist information on Videos - I enter the new information into the Artist field (multiples separated by ";"), click Save (either the top or bottom one), Emby says it has saved the item, but when I move to a different item and come back - the information is either totally missing, or only parts were saved. It appears to me that it doesn't accept anything appearing to be misspelled, so I turned spell check off in Chrome, no change. Same problem exists if using Firefox. Haven't tested with IE. Not sure when the issue could have appeared - I've not tried to edit metadata in a while. I am running the latest of everything (that I know of): Emby Version 3.0.6300.0 Mono 4.4.2 Linux Mint 17.3 Cinnamon Latest stable repository version of both Chrome 52.0.2743.116 and Firefox v48 All most recent level 3 and higher updates applied I looked through the latest entries in the Log, and see no type of failure message at the time I was trying to do this editing. Anyone else having this issue?
  2. DzonDou

    Missing music artists

    Dear Emby Community. I can not see artists and album artists in any of emby client (chrome, android, kodi) while I can see it in Metadata Manager tree. Songs and albums are showing property in all clients. It is fresh installation of Emby Server, version 3.0.64000.0 on Debian Jessie. I have proper ID3 tags (I suppose). Music is kept in mp3, wma and flac files. It is stored on xfs partition. I run emby as non-default user - changed EMBY_DATA variable. I have also changed location of EMBY_DATA folder. All file permissions are OK.
  3. I am trying to edit Metadata through the Metadata Manager. When using MS Edge I just get a spinny wheel when I save changes. Works just fine in Opera. Any thoughts anyone?
  4. Something new in the latest build... which is really, really annoying and I cannot find a setting to turn it off. When playing a TV show from the web UI, it's autplaying the next episode wether I want it to or not. I have been through every setting and menu both on the server and user and cannot find a way to turn it off... I don't like it, I don't want it. Also the legacy browsing issue within WMC classic is a huge pain... I actually like having a movies by genre in there... makes it easier to find specific types of films. But because of the non functioning 'collections' addition, and the unwanted 'Upcoming' addition under TV shows... neither of which can simply be turned off... I've had to turn of legacy browsing to get rid of those blights. The downside is that I also lose other things that I actually use and want... But it seems that I'm not allowed to 'choose' which I do and do not want... it's either nothing or 'you'll have what we tell you to have' Once again this is bad design, there needs to be some one in charge of the way the UI looks that understands what good design is, and sadly that doesn't seem to be the case. Here's another example of poor design Accessing the metadata before used to be quick and simple, now it's quick and simple only if you want to specifically change data OR images. here's what you used to do. Enter item or hover... click the menu dots, click edit... change metadata. If you forgot something, missed something... all you had to do was change it and save it once more... if you wanted to change images, you clicked the images tab and did what you needed to there... all done. Now it like this. Enter/Hover click menu dots select edit edit data save forget you need to change soemthing else repeat steps above change save remember you also need to change images repeat steps above It's gone from a couple of clicks to get at EVERYTHING to repeating the same multiple clicks over and over again to do the same things. The pop over UI shouldn't close until you want it too, and you should still be able to access images from it. Now I like the idea of the pop over, it should be quicker than the old way... but at the same time it's been made overly complicated instead. Which actually makes it more time consuming and harder to use. Another poor design choice comes further down the metadata info... Under People, it used to be very easy to see clear lines between cast and crew... Now as a personal thing, I don't want crew in there... it's just additional metadata to be collected that lacks information and images... and I don't care about the crew, I just like having cast and director.. So I delete the rest and lock of the metadata for people... after all that's why the feature is there. Now it's increasingly hard to determine which is which because the lines between types has been removed and the width of the information is so wide that it's kinda hit and miss if you are going to hit the right delete icon for the person you want. Adding back those seperation lines between typeswould be more than helpful.
  5. MarcusJ

    Can't See or Edit Metadata

    I've recently had issues getting emby to correctly handle collections. A suggestion was offered to delete the problematic collection folders in Emby-Server/data/collections. I did that and it seemed to work fine. It was a GREAT start to my day. Huge thanks to all of the folks that jumped in to help out! Since then I have gone through the movie and collection libraries and continued the process of manually assigning movies to collections (I had stopped this process because of the challenges I was having). I was able to successfully add some new collections today, while others showed the same symptoms as other movies had shown in the past when I was having the original problem. I treated these new problem collections the same way (deleted the named collection folders in Emby-Server/data/collections. After deleting several of them, I then re-scanned the entire library to allow emby to rebuild the folders correctly, which it seemed to be doing correctly. I did this multiple times - each time deleting 5-10 collection folders in Emby-Server/data/collections that were not functioning properly when attempting to add them to collections. The scans seemed to go very well - MUCH faster than prior scans - I mean like a drop from 8 hour scans over the last few days down to 20 minutes or less. I was encouraged by the fast scan times as I thought the system was cleaned up and functioning more efficiently. However, after the last couple scans when I have tried to open any of the metadata, nothing happens. For example, when I try to "Edit Info" on a collection or an individual movie while in the "Movies" or "Collections" libraries, it literally does nothing...no metadata pops up, and the screen simply stays on the same page of posters that I was on. When I try to open ANY metadata thru the Metadata Manager, I simply get the colorful spinning circle forever. No metadata ever opens. I've tried opening metadata for Collections and for individual movies while in the Metadata Manager and it behaves the exact same way - spinning circle of wait...No metadata ever appears. I have re-started the emby server multiple times, and have re-started my computer 3 times. I have re-scanned the libraries multiple times and have done two "Clean Database" functions. None of this has helped. The scans each time get faster. The last one was 8 mins. but the inability to see or edit metadata is the same...not happening. I am 99% certain this is not a bug of any kind. This is in my mind, a case of user-inflicted damage caused by my deleting files and making changes on the fly to emby-server folders to fix other issues. This has now somehow bitten me by confusing the server or getting elements out of sync with one another. I'm now at a stopping point as the core functionality of emby (for my needs) is not functional. Before I throw in the towel, is there anything I can do to refresh my system and potentially get it back on track? I hate to throw away 4+ months of nearly dedicated time getting this library in good working order, only to get here...Beyond frustrated...
  6. PScherrer

    Metadaten aus mkv-Dateien

    Hallo zusammen, Gibt es eine Möglichkeit die Metadaten (wenn im Internet nichts gefunden wird) aus dem mkv-container (zb. Tag Summary) auszulesen und diesen als Filmbeschreibung zu verwenden? Ich habe zB. eine Aufnahme welche nicht in den offiziellen TV-Datenbanken vorhanden ist, jedoch bei der Aufnahme die mkv-Datei mit Metadaten getagged. Wie bringe ich nun Emby dazu diese Metadaten zu verwenden? Danke
  7. plessers@gmail.com

    local actor images (.actors)

    Hello, My movies are organized in separate folders with movie name. In every folder, there is a subfolder ".actors" wich contains the images of the actors. This information is -together with the *.nfo file and other artwork- created by MediaElch http://www.kvibes.de/mediaelch/download/ This tools creates all the necessary information on disk, and can be read by KODI, PLEX, etc... I succeeded to configure EMBY to read the local *.nfo file, but the artwork for cast & crew remains empty. Currently my advanced metadata config is as follows: Is there a way in EMBY to incorporate this information? How to download actors artwork, preferably the local images? kind regards, Bart
  8. My EMBY Server is on a Win10 platform. I have a very large collection of HD movies as well as music and heavy metadata. When linking a lower powered device like a raspberry PI, the compelling of the DB crashes during the syncing process. I reduced the amount of threads and metadata a number of times only to sync my movie DB to it. Adding music (approx 250k songs with metadata and fan art) it just jams everything up. I am thinking of hosting my music files locally on the raspberry since storage is cheap as well as metadata so that it is less taxing on the machine and can pull music and metadata hopefully faster but at a minimum it would be able to still have an impressive GUI presentation. I would have to uninstall EMBY and reinstalling sync it. Omit the music and add it as root but how am i am able to have the meta data stored on that drive as well hopefully for both music and movies? I can omit the music portion as it seemed to be pretty solid without it although the sync took several hours, then add the external HD to root for music also. Please help me optimize these noncore zones using smaller lower power single board computers.
  9. I recently update emby to 3.0.6020 and have some new bugs. Some TV series doesn't show all the season even if they are there. I attached a serie (fortier) that show the problem but append on other tv series too. I attach a movie (underworld) that include all the title of the same series but should be count for 4 movies and not 1. The scheduled tasks run the scan media library and clean database this morning. I attached the log to troubleshoot more the issue. Thanks. server-63605692800.txt server-63605779197.txt server-63605779200.txt
  10. Hello together, I wanted to ask if it would be possible to have the possibility to create a Menu for Movies, which can be put together in metadata Manager by selecting different audio streams and subtitles to one of the menu entries. Maybe a pre selection for language and den show the created menu entries. Designwise background could be a blurred Backdrop pic, every menu point could show the backdrop more clear with some user defined text on it. Every menu entry den would choose the corresponding subtitles and audio streams. This way we could realize in Emby somthing like you see on your blu rays where der is Commentry on a movie, which is basically just a different Audio track. Or based on the language you choose the corresponding audio tracks are chosen. For example I have german movies with german audio and some forced subs for foreign language parts. If I watch that movie in english language there is no froced sub existing. It would also be good if the interface and metadata language could be define in user manager and that clients pick up that setting. something like this maybe simply: https://pmcvariety.files.wordpress.com/2014/07/apple-tv-lego-movie-itunes-extras.png Would be awsome if the coming versions of emby would support that
  11. acura4ever

    Library Metadata

    The option activated is "Save metadata and images as hidden files" but it is only for new files added. Actually, I didn't activated it when I first installed Emby, so all the "old" metadata is not hidden but newly added files are hidden. Can you fix this bug? Thanks.
  12. Hi All, So previously I was manually building the folder structure with as Collections but kept it in the movie folders. i.e. Let Me In Lethal Weapon Collection [boxsets] Life As We Know It Lifted Little Children ... ... Major League Collection [boxsets] etc However, Auto Boxsets plugin removes this manual requirement, I can just have movies listed out in the movie folder. For example, if I have all of the Men in Black movies in their individual Men in Black 1, 2, 3 (respectively) folders... Auto Boxsets logically groups these movies as a collection for you. So here is my problem. Auto Box Set plugin is working correctly, but it is creating the folders and metadata (backgrounds) on my C:\ drive which is a big no no. C:\ drive is my OS/Fast App drive so I don't want things like metadata to be stored there. Under Metadata manager I can see Collections but no option for me to edit the path and assign it to a data drive. Is this possible? How can I change this path? I want to change the path prior to removing my manual folder structure and allowing the plugin to group things logically. Also, the old structure and Auto Boxsets work together only through the browser interface. If you pull collections up under a device (IOS, Android, Roku) only collections grouped by Auto Boxsets show. So basically, you have to configure your library to only use the Auto Boxsets functionality if you want device access. Thanks! Draz
  13. Gregzilla

    Metadata Not showing in Series Folder

    My metadata is not showing in my series folder on my TV. Everything else is fine and all of the metadata is showing when I view it on the emby page and in my individual folders. This has only occurred since the last update. Please could you help as it is driving me mad?
  14. Hi, When in the library and clicking "identify" for a particular show, do the items returned come from the different metadata sources (omdb, tvdb, moviedb)? Upon selecting one, does the metadata come from that source or does it come the source selected on the metadata page of the "manage server" section? Thanks!
  15. I have just finished setting up my Emby server for the first time, and I'm loving it! But I'm facing an issue: all my videos are showing a very very long duration (length). The files are all in individual folders, with no metadata file in it. Emby accessed all the content and downloaded artworks fine. As I've read, video length is extracted (and is ignored from <runtime> inside a .nfo file). The major issue is that during playback I can't skip the video, since the bar is way too long. Most of videos are .mkv, but the issue is present in other filetypes too. What I've tried (and had no success): - Refreshing library; - Refreshing individual metadata in the Metadata Manager; - Completely reinstalling Emby Server; - Forcing a <runtime> tag in the video NFO file; - Installing stable, beta and dev releases. Anyone had the same problem or have any idea how can I solve this?
  16. I've started using tags to help fine tune my parental control for kid's account, and it doesn't look like tags applied to series/seasons of television are inherited by seasons/episodes. Is this the correct behavior? If so, I believe it should change. Adding a tag to a series should propogate to child items of the series. Same goes for collections, although collections are way less important since there aren't nearly as many child files to manually add tags to.
  17. johnchimpo

    Duplicate episodes from Sonarr

    This problem started with an update received in the last month (I have been on beta release and since this occurred have changed to stable updates only). Currently running ver 3.1.14.0. This library has been in use with emby since appx 2011. Either sonarr or emby created this issue with a recent update, but I do not believe it was a bug just a kink in the config that I had slipped through all these years with no problem. The issue is a duplication of server data for each episode that exist in the library one with the UNC path and one with the local drive path. (i.e. \\media01\television\12 monkeys\season 01\ep1.mp4 and H:\television\12 monkeys\season 01\ep1.mp4). I have solved the problem going forward - the issue was that emby libraries were configured for the UNC path and sonarr was saving media, sending notifications and writing metadata using the local path. However, all the thousands of episodes that existed on the server prior to the fix are still duplicated. All the metadata for each duplicate file is the same, watch states, etc., but I'm lost for how to eliminate the duplicate entries. I've tried all the server tasks, checked every setting in the dashboard, dug through the server data files (where I can't find the server's metadata exists), read the logs (no permissions issues have popped up). Any genius ideas out there to save me from a complete re-add of the library?
  18. Nutellaeis

    Different metadata languages?

    Hello, Is it possible to have different languages for different libraries? I am german and have a lot of german movies but I also have some english ones which I would love to have in a english library with english descriptions for consistency.
  19. darthweder

    Replace Metadata

    Emby automatically recognized the new Battlestar Galactica as the series from the 1980's and so all of the metadata was wrong. I re-identified the show as the correct series and it changed the main picture and the pictures for the seasons, but when I refreshed the show it didn't replace all of the metadata. This includes the episode pictures, actors in episodes, etc. There used to be an option to replace the metadata when you hit refresh, rather than just updating the missing info. Where is that option now? Thank you for any help.
  20. Hi Team, I would like to be able to force all my content to refresh its metadata regularly, I was unable to find a way to schedule this task. I was also unable to find a way to force refresh entire libraries, attempting to refresh folders that contained local metadata did nothing. The only way I have found to force a refresh successfully is to refresh each title individually, and with a library of over ten thousand titles this is undesirable. If this functionality is already available, please aid me in finding it as I was unsuccessful. If not could this be added? Perhaps a task that can be scheduled to do a forced overriding refresh on the entire library? Many thanks for any help. Cheers.
  21. I detected this several weeks ago but I only had time to report it now. I'm running Emby 5930 (latest stable). Can't remember the exact Emby version when the problem started but since some time now (maybe two months) my library scans went from around 2:30mins to around 12-14 mins. Today I was checking the logs and I saw tons of exceptions while contacting musicbrainz.org since the site is returning a 503 error for many requests from Emby: 2016-04-19 21:32:01.4539 Info HttpClient: HttpClientManager GET: http://www.musicbrainz.org/ws/2/release/?query="(2001)+Just+Push+Play" AND arid:3d2b98e5-556f-4451-a3ff-c50ea18d57cb 2016-04-19 21:32:01.6613 Error HttpClient: Error getting response from http://www.musicbrainz.org/ws/2/release/?query="(2001)+Just+Push+Play" AND arid:3d2b98e5-556f-4451-a3ff-c50ea18d57cb *** Error Report *** Version: 3.0.5930.0 Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 3.10.0.327 Processor count: 4 64-Bit OS: True 64-Bit Process: True Program data path: /var/lib/emby-server Mono: 4.2.1 (Stable 4.2.1.102/6dd2d0d Wed Jan 13 16:44:34 UTC 2016) Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe One or more errors occurred. System.AggregateException at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f9d6de48790 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f9d6de46760 + 0x000b3> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f9d6de466c0 + 0x00093> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f9d6de46670 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f9d6de46dd0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<SendAsyncInternal>c__async4.MoveNext () <0x4154ae50 + 0x01055> in <filename unknown>:0 InnerException: System.Net.WebException The remote server returned an error: (503) Service Unavailable. at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0x415e0320 + 0x001a3> in <filename unknown>:0 at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (IAsyncResult iar, System.Func`2 endFunction, System.Action`1 endAction, System.Threading.Tasks.Task`1 promise, Boolean requiresSynchronization) <0x7f9d6ded3dd0 + 0x00088> in <filename unknown>:0 2016-04-19 21:32:01.6626 Error App: Error in MusicBrainz *** Error Report *** Version: 3.0.5930.0 Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh Operating system: Unix 3.10.0.327 Processor count: 4 64-Bit OS: True 64-Bit Process: True Program data path: /var/lib/emby-server Mono: 4.2.1 (Stable 4.2.1.102/6dd2d0d Wed Jan 13 16:44:34 UTC 2016) Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe One or more errors occurred. MediaBrowser.Model.Net.HttpException at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<SendAsyncInternal>c__async4.MoveNext () <0x4154ae50 + 0x01833> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f9d6de48790 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f9d6de46760 + 0x000b3> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f9d6de466c0 + 0x00093> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f9d6de46670 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f9d6de46dd0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<SendAsync>c__async1.MoveNext () <0x415453f0 + 0x00215> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f9d6de48790 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f9d6de46760 + 0x000b3> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f9d6de466c0 + 0x00093> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f9d6de46670 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f9d6de46dd0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<Get>c__async0.MoveNext () <0x415ca1c0 + 0x00174> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f9d6de48790 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f9d6de46760 + 0x000b3> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f9d6de466c0 + 0x00093> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f9d6de46670 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f9d6de46dd0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Providers.Music.MusicBrainzAlbumProvider+<GetMusicBrainzResponse>c__async5.MoveNext () <0x41e95c00 + 0x0068e> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f9d6de48790 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f9d6de46760 + 0x000b3> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f9d6de466c0 + 0x00093> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f9d6de46670 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f9d6de46dd0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Providers.Music.MusicBrainzAlbumProvider+<GetReleaseResult>c__async2.MoveNext () <0x41eedab0 + 0x0020f> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f9d6de48790 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f9d6de46760 + 0x000b3> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f9d6de466c0 + 0x00093> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f9d6de46670 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f9d6de46dd0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Providers.Music.MusicBrainzAlbumProvider+<GetMetadata>c__async1.MoveNext () <0x41ee37b0 + 0x00533> in <filename unknown>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f9d6de48790 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f9d6de46760 + 0x000b3> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f9d6de466c0 + 0x00093> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f9d6de46670 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f9d6de46dd0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Providers.Manager.MetadataService`2+<ExecuteRemoteProviders>c__async8[TItemType,TIdType].MoveNext () <0x41e17950 + 0x00686> in <filename unknown>:0 InnerException: System.AggregateException One or more errors occurred. at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () <0x7f9d6de48790 + 0x00029> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) <0x7f9d6de46760 + 0x000b3> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) <0x7f9d6de466c0 + 0x00093> in <filename unknown>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) <0x7f9d6de46670 + 0x0003a> in <filename unknown>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () <0x7f9d6de46dd0 + 0x00017> in <filename unknown>:0 at MediaBrowser.Common.Implementations.HttpClientManager.HttpClientManager+<SendAsyncInternal>c__async4.MoveNext () <0x4154ae50 + 0x01055> in <filename unknown>:0 InnerException: System.Net.WebException The remote server returned an error: (503) Service Unavailable. at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) <0x415e0320 + 0x001a3> in <filename unknown>:0 at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (IAsyncResult iar, System.Func`2 endFunction, System.Action`1 endAction, System.Threading.Tasks.Task`1 promise, Boolean requiresSynchronization) <0x7f9d6ded3dd0 + 0x00088> in <filename unknown>:0 This is just an example for one request but my music library is around 20K songs so there are many more in the logs. I try to disable MusicBrainz as a metadata source and the library scans are back to "normal", taking just 2:30mins. Is anyone else also seeing this behavior or is just me? I'm not familiar with MusicBrainz, is it like opensubtitles that requires to have a user account to query the site? Cheers.
  22. Hi everyone, first post here so I hope this is in the right area. I just wanted to share a bit of an idea to gauge interest and opinions from the Emby community. Myself and a few friends are all loyal Emby Server users but have always had the problem of having to manually manage metadata for content we like to have available on our media centers, but is not indexed on The TVDB. This is content along the lines of: Sport (WWE, NBA, UFC) Adult films Training and course videos (CBT Nuggets, Linda, Khan Academy) Youtube videos / channels Music Videos Unfortunately with the TVDB's policy on some of the above, we have had to manually produce the metadata and generate our NFO files. To remedy this, I had thrown together a database / API and developed a quick and nasty scraper that would retrieve the data from our DB and generate the NFOs for us. This has been working quite well for us but unfortunately the metadata still had to be added and maintained in the database by the handful of us using it, which has now lead to the idea of making a more public database/site/api that everyone can use and everyone can contribute to. The idea, outside of what we use ourselves currently, is definitely in its infancy but it would essentially be a DB for everything else. So with that said, I thought I would just put this out there and see if there was any interest in the Emby community for an additional indexer/database.
  23. Wob76

    Metadata \ Art

    Hi, Just a couple of questions regarding metadata and artwork. 1. I added a show early to my collection, it scanned that it all fine, but when it did so the show did not have a thumb on fanart TV, it has since had a thumb added but I can't seem to get emby to pull it in, I have done a refresh, and even an identify and replace all images, but still no thumb. When I do edit images and select thumb, it doesn't show any options, despite it now being shown on Fanart.tv. I have confirmed the tvdb numbers match. Couple of questions in relation to that. a. How do I manually pull in the Thumb, without downloading and uploading it? b. Will Emby eventually pull in missing artwork automatically, like thumbs or anything else, if they become available online? 2. I have just done some reorganisation of my Movie collection in the hope it will help with Library Scans, I had all my movies in a single folder, I have now sorted them into year subfolders. After emby did a big rescan it seems to have had issues with year folders that only contained a single movie, is there a setting to make Emby ignore the folder name and old search based on the file name? Edit. 3. Just noticed another oddity, I have a folder "Pirates of the Caribbean" which has all of the movies, rather than see each movie, emby has created a single movie in the database "Pirates of the Caribbean: At World's End" will all three movies listed as Video Tracks, this might link to the above, but how do I go about fixing it? Thanks, Wob
  24. I was using 3.0.5934.0 and metadata was being added when new episodes were recorded. Emby updated to 3.0.5970.0 and now metadata is not being added, have had to fall back on MCM to add metadata. This is Windows 7 Pro x64. Kodi 15.2. Kodi add on 2.2.10. I am attaching the latest log. There are quite a few other logs I can provide if necessary. Can someone please help! Thanks for reading! server-63599605206.txt
  25. I currently have my Emby media stored across multiple drives. When initially setting up Emby I read here on the forums that is preferable to have direct file paths set and then use the path substitution feature, I think it was to allow for direct playback. All is working well this way but now I need to replace the hard drives, I would like to do this with fewer, larger capacity drives which means some of the media cannot be in the same location as it was before. Is there any way to change the file paths of certain media folders but retain all of the downloaded meta data for those files. For example on Plex this was achieved by adding the new file paths while keeping the old ones, forcing a re-scan whereby it would match the old metadata to the new file locations, then removing the old, now obsolete, file paths. I believe if I had my metadata stored as NFO files in the media folders this would be possible? However I do not do this as I prefer to keep my metadata on the solid state boot drive for better performance as the media drives are not constantly spinning (the server auto sleeps). Thanks in advance for any and all assistance.
×
×
  • Create New...