Jump to content

Search the Community

Showing results for tags 'Library'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. Hi folks, Short question: How do I convert the old "LastPlayedDate" datetime field in the "userdata" table in library.db into the newer "LastPlayedDateint" integer field? Long question: I had emby installed on my FreeNAS for a while, and in December I wanted to update the FreeNAS version and at the same time consolidate my jails into my docker VM on ESX on another server. Unfortunately, emby in docker for me seemed to cause a lot of DB corruption in library.db about 24 hours after the library had finished being scanned and I started to watch stuff. Looking in the logs didn't yield anything spectacularly wrong or obvious. So I deleted it and started again, with no luck - the same corruption. In the end, I'd recreated/re-downloaded the container about 5 times, set local and remote storage for config (NFS, samba, etc), use another docker vm on a faster/different disk - seems no matter what I did, it still had issues. I even ran a memtest on the ESX server, which as you may know takes aaaaaages! (during which I had to rely on Netflix and ::shudder:: DVDs!) Long story short, I ended up creating a dedicated emby VM and copied across the config. At that time, v4 was released, so it did an upgrade on the databases, then I ran a library scan. After a few days, I decided it was stable enough that I removed the emby jail in FreeNAS and cleaned away all the config files (after making a final backup!). As per the instructions on how to manually backup and restore, I'm now at the point where I'd like to re-import my watched data. But... It looks like the upgrade or something else along the way changed the field type on the lastplayeddate from a datetime to an integer in the userdata table. So, what is the process of converting the datetime fields into an int? Is this SQLite or emby specific? I've exported the old table to an SQL file, so I can apply any formulas or do other processing easily. In case it matters, I'm a programmer by day, IT enthusiast by night, so I'm OK if the answer is not sugar coated! Actually, I could just set that field to null in my exported file... What does emby use that field for anyway? I haven't ever seen a "last played" tag anywhere, and to be honest might be quite nice to actually have it displayed! Thanks in advance!
  2. Hi, I want to set up a more shiny UI and have been directed to emby. At the moment I'm browsing the smb share. So I've been playing around yesterday, scanning my movie share on my unRAID server. Looked nice as I left. Now I came back and the library is wiped clean. I imagine this is due to the fact that my media server is not running 24/7. The scheduler is set to scan the media library after 12 hours by default. The emby docker itself is running 24/7 on a bananaPi. SharpCifs.Smb.SmbException: SharpCifs.Smb.SmbException: Failed to connect: 0.0.0.0<00>/media.server.ip What is the right setting in my usecase. I think some check for the presence (e.g. ping) of the media server is needed before a library update is performed. Somebody with this usecase here?
  3. Hello, When refreshing metadata (with images replacement) on my French language movies, I can only found "English" versions of images in despite of my library setting is "Preferred download language : French". Par exemple, on the french movie "Patients (2017)", no images are found. When manually looking for the images, I can found sereval "French" tagged images : several "Primary" (at TMDB), one "Disc" and nearly all the rest at FanArt.tv But I can get this from Emby server setting only by manually using "Edit images", then checking "All languages". By automated way, only "English" and "no language" images are found. Applying a manual selection to my whole collection would be really painful. Regarding my library setting, the behavior I would expect would be to primary look for "French" image, then ideally, if none are found, use "English" of "no language" as a fallback option. Is there anything I missed in the setting? Or could it be a bug? My library structure is aligned with the naming recommendations (ex. : \Films\Patients (2017)\Patients (2017).avi ) I attached the logs just after I tryed to refresh my example move metadata (with images replacement). Thank you in advance for your help,
  4. I have a folder for Movies which is the only folder in a library called "All movies." This library has metadata scanning turned on. Under the Movies directory, I have a subfolder called "New" which I have a separate library pointed to (library is named New). Folder structure: -Movies ----New ----A ----B ----C etc. Library setup: All movies > "Movies directory" New > "New directory" Nothing is showing up in the New library. Can a file only exist in a single library?
  5. I recently wanted to try to add a 'Download' directory to show up as a library in Emby so I could watch freshly downloaded content. This content does not need to be scanned and scraped since a lot will not make it to the collection.... Therefore I created a library called 'Download' and tried the category 'Mixed content', this however led to many unwanted and non-existing content being added (for instance also to collections). So I decide to remove this library and re-created it with the category 'Home videos & photos'. Still the issues remained and I deleted it again. But then 2 buttons called 'Download' showed up in the Emby Home page. I did a 'Scan all Libraries' and 1 button disappeared. But there is still 1 button remaining. How can I get rid of this now?? My library view: And my Home view: Is there a way to manually strip this button from the home page? And: Is there a way to just add a library which will just list as a folder (no scraping whatsoever) ? Thanks, L
  6. Embury5000

    Empty Library

    On my Apple TV, after the update to v4 of Emby, I am no longer able to see the content of my TV Shows library. I have tried rebooting the server, reinstalling the server, removing and reinstalling the app, removing and recreating the TV Shows library, and still cannot see anything. I am able to the content of a library if I choose the TV Shows and give it any other name.
  7. daniel.bmyer

    Library Issue / Question

    Hi, is there a way to force a tv show series to be copied to a specific folder? Here's my issue. I have two folders, one called TV Series and one called TV Shows. TV Series is where I keep my full blu ray copies of tv shows I own on my Unraid Server. TV Shows is where I download episodes to temporarily to watch then delete. I'm not keeping these shows. However, here's where I run into a problem. Occasionally I will have the same show in both folders. For ex, I have Star Trek Discovery in TV Series as I have the complete season 1 blu ray there. IN TV Shows I have Star Trek Discovery as well for Season 2 episodes I download, watch then delete. Whenever I download an episode of Season 2 it gets copied to TV Series folder instead of TV Show folder. I tried renaming the folder in TV Series to something else, but then auto organize just creates a Star Trek Discovery folder there and copies the episode. I simply cannot get it to copy the episodes to the TV Shows folder. Any ideas / suggestions?
  8. dsmithp233

    Multiple sort capabilities

    Will Emby get the capability of multiple filters? Let's say that I want to see my music library A-Z by artist name then by release date. Currently in 4.0, it shows this: Has there been any thoughts or requests to do more sort capabilities than only one option? Thanks.
  9. Hi, After upgrading to v4, I made a mistake in creating duplicated new media libraries by clicking the Ok multiple times when it didn't seem to respond. Then I deleted the duplicated ones thinking the problem would be solved. Nope. While there is no more duplicated media libraries, all the earlier duplicated ones still appear in Metadata Manager and my home screen. I even deleted the new media library but all the duplicated media libraries are still in Metadata Manager and my home screen. For clarity's sake, here is a list of things that I've tried but nothing helped. 1. Delete duplicated media libraries 2. Delete the newly created media library 3. Scan all libraries and restart the Emby server (done multiple times) 4. Restore a backup done before upgrading to v4 (no longer a Premium user) If it's simply because Restore works only for Premium users, the solution is easy. I just want to make sure that before renewing my Premium membership. Any suggestions are welcome. Thanks! Aaron
  10. I currently use Plex and considering switching to Emby. I see that Plex uses a single movie folder with all the movies in it whereas Emby prefers separate folders for each movie. Can someone please elaborate on these two approaches and suggest if I should convert my existing library to separate folders for each movie?
  11. virtualburton

    Some Movies, but not all, not showing up

    Hi there - I'm new to Emby. Running server on MacMini with MacOS Mojave 10.14.2, using Safari to browse Emby on other Macs/ipads I created 3 new libraries when I set it up the first time - Movies, TV Shows and Downloads. I used Plex for years and had all of my media in those folders already. Each of those folders/drives has numerous sub-folders. Movies has Action, Comedy, Christmas, Kids, Other and Temp as sub-folders. Each of them is full of movies in misc. formats - .avi, .mp4, .mkv, etc. I added the libraries to Emby and everything seemed good, but then I went to watch a Western the other day and I can't find it in Emby. "Westerns" is a sub-folder of "Temp" since I hadn't filed it away and cleaned it up yet. At any rate, I cannot find any of the movies in the Westerns folder in Envy. They are on the disk, but not in Emby. I thought maybe it's because Westerns was a sub folder so I tried adding the folder "Westerns" to the "Movies" library, no change. I then thought maybe the folder structure was too deep so I moved the folder Movies/Temp/Westerns to just /Movies/Westerns but still don't see it. When I go to the Emby home page and select Movies then view by Folders it shows Action, Comedy, Christmas, Kids and Other but no Temp. I obviously tried re-scanning the whole library, just the Movies Library, etc, a bunch of times,. restarted the server, browsers, etc, same thing. The last thing I tried was adding a completely new library called "Westerns" so now I have Movies, TV Shows, Downloads and Westerns, now I have 4 libraries. When I set up the new Library added /Movies/Westerns as the only folder and annoyingly it showed nothing. The library is created, but has nothing in it. I must have angered the Envy gods because it does not want to playa. Western for me. Can anyone offer any suggestions or guidance on what is going wrong here? Thanks in advance,
  12. Hi, happy new year to everybody I was just wondering, how do you guys manage shared universes/series cross overs in your library? For example DCs Arrow-Universe. I've all the shows in my library, but currently I've to manually look up in which order I've to watch them. Is there a feature in emby that can help me with that? Can I merge these shows together in a set like I can with movies? Can I create a smart playlist based on the air date of the episodes? Is there any other way to watch spin-offs/crossovers in the correct order? How do you do it in your private library? Has anybody developed a system/workflow for this?
  13. I can't find a way to easily see which files still need to be converted. It would be great if Emby could give some sort of info or report about my media library. Things like: - how much of my media has already been optimised for playback - a "suggestion list" of files that should be optimised to avoid transcoding This info could be displayed on the server dashboard or in each library folder's info. This would also be very useful for new users who don't understand much about conversions, transcoding etc and could guide them into what they should do next to have the best possible experience. What do you think? Any ideas on how this could be best displayed?
  14. macwillard

    Music Library w/ Audio books flickering

    I recently installed the Emby server on my Windows 7 PC and have set up a Music library under which I have placed my audio book folders (all MP3 Audio files within their own folders). I use a Roku 2 to access Emby via the app from the Roku store. I can access and play the audio via the Roku, but when I do press play the background flickers between black, a rainbow color, and transitions between some combination of the two. All media on the screen appears and disappears, including but not limited to: buttons for Play and Stop, all images, and the entire Now Playing section at the bottom. When I back out of the Music library the images at my Home Screen continue to appear and disappear, and the background continues its psychedelic dance. My Windows 7 doesn't have this problem. Is this a known bug or did I set up my audio books incorrectly?
  15. Didn't see where you could do it already, so. It would be cool to be able to break down the update library task into individual tasks, IE just the dvr library at $int, tv library at $largerint, books at $daily, music at $weekly. user definable obviously.
  16. Seems that if you move Emby (Portable) everything is fine, except this reference to the library information? Everything else is detected in the correct new location, except this, and it only errors when you try to scan the library. Program data path: D:\Emby\programdata Application directory: D:\Emby\system System.IO.DirectoryNotFoundException: Could not find a part of the path 'E:\Emby\programdata\root\default\Movies'. Any Idea how I can fix this easily/quickly?
  17. Hello, I have a problem with scanning my library from the beginning of using Emby. As i found Plex and Kodi absolutely unusable for me, I have ended with Emby, where I done all settings and found all features I need. I am running portable version Emby on Windows 7 dedicated desktop computer, copied on non system magnetic hardrive, where also all my media are stored. As I am running Emby under non admin Windows account I have used NSSM to run emby as service under this account. My last reamaining problem is with scaning media. I have a lot of media divided into four libraries. Two for videos/movies, other two for photos/pictures. Everytime I start scaning, it fails. Average scan time is 15mins. As I do not care about watch data, I have deleted library.db and started Emby server again, but without luck. I have read some topics related to this problem, but I have not find solution there. I think there is some problem with my media, but as I have lot of media, it is not easy to check it all. Is there any feature how to find root casuse of problem? I have attached datalogs, but I am not able to find anything saying something like: Error while scaning file.... So I have no idea how to debug this. Thank you in advance with this issue. Log.txt Log_scan.txt
  18. Library folders in my admin panel don't have images anymore since a while. So i've tried to add them manually, however when i click on "Edit Images", the loading icon appear (And never fade-out) but the popup for editing the images is never shown. The only library with an image is the "Auto generated library" called Collection créated by the plugin Auto Box Set. When i clic on "Edit Images" for this item the popup appear as expected. The only error i've managed to found is displayed in the browser console when i click an the menu item "Edit Images". Uncaught (in promise) Error: null itemId at ApiClient.getItem (apiclient.js?v=3.5.2.0:1) at imageeditor.js?v=3.5.2.0:1 at Object.execCb (alameda.js?v=3.5.2.0:1) at defineModule (alameda.js?v=3.5.2.0:1) at Object.depFinished (alameda.js?v=3.5.2.0:1) at alameda.js?v=3.5.2.0:1 Tested on Chrome 69 and firefox 62.
  19. Hi, So I am faced with a problem and not sure what the right solution will be if there is one. Here is my setup: 5 users - Admin, Parents, Child, Sonos, Samsung/Shield I have multiple libraries setup: movies, cartoons, TV shows, music, pictures, adult content Access rights Admin has access to everything Parents: movies, TV Shows, pictures, collections Child: cartoons, collections Sonos: music, collections Samsung/Shield: movies, TV Shows, collections The problem I am facing is with the search. Even when I am logged in with Child account the search results returned contain actors/people from all libraries including the adult one. That kind of defeats the purpose of the separate library and accounts if those results are returned. My question is, am i doing something wrong? Is my setup wrong somehow or is this a bug? Thanks
  20. I would like the ability to group multiple libraries together so they appear as a single library from the main screen, but allowing me to dive down into the different libraries. For example, I have 3 music libraries - mine, my wife's, and kids music for the kids. I don't want all 3 visible from the main screen, but I would like a single entry called 'Family Music' or 'Music' that allows me to drill down into the different libraries. It would be helpful for seasonal libraries, like my Christmas and Halloween libraries.
  21. David

    Home videos & photos

    I used to be able to go into the emby plugin inside kodi and view all my emby libraries and it let me get to a library that is "Content type" "Home videos & photos". I keep random videos that don't sort into the movies and tv shows sections here. This option no longer is available to me. Is it something I've configured wrong with the newer versions of the plugin or could this be added back into the plugin? I'm currently running on version 3.1.32a in Kodi 18 Beta 4. Thank you,
  22. TheArchivist

    Relocate Media Library Metadata

    I recently had a scenario where I had my Media and the Emby Server (portable) on the same drive. I relocated the Emby Server (portable) to a new drive. It correctly targeted the new location for ProgramData (../ProgramData) without configuration. However, the existing libraries (Movies, TV Shows) still had their metadata configured for the old location. The only solution to fix this was to remove the libraries and recreate them. This takes a considerable amount of time and bandwidth. Please add the ability to relocate a library's metadata location, or detect that the ProgramData location has changed. I imagine this feature would be good for both the Portable and Standard server implementations. P.S. - Emby is a great product and I am a proud monthly supporter!
  23. Hello, On both a Mac OS and a Linux server I have observed the following behavior a couple of times. Both are running v 3.5.3.0 of the Server. In Server Settings, chose Library, Rename. Renamed from "TV" to "1. TV" and from "Movies" to "2. Movies". Only renamed the library and did not change or rename the underlying folders. Did not change any other settings. In each case this triggered a full rescan of the library, and discarded all shows/episodes/movies that had previously existed (the client displays no contents). Seems an unnecessary waste of resources when only changing the label for the library display. Cannot tell if it is doing a full metadata rebuild - the shows reappear pretty slowly, but they seem to be fully populated with metadata when they do reappear (summaries, images, actors, etc. all present). Just FYI, in case this is a bug.
  24. There used to be a tab in Libraries to setup path substitution, but now it's nowhere to be seen. Where did it go to? I can't find it anywhere and can't use external players without it. Previous: Now:
  25. el_pedriyo

    Not updating library

    Hello, I just wanted to know how can I get my library updated automatically when added a film to it, I have the real time monitoring enabled, but when I tried copying a file inside the library, the movie is not appearing without doing a manual refresh of it. Any idea? Kind regards, Pedro
×
×
  • Create New...