Jump to content

DSM 6 to DSM 7 Emby Migration Instructions


cayars

Recommended Posts

8 hours ago, VicSupaNov said:

Hey guys I've been scrolling through this forum because I finally upgraded to DSM 7 on my DS920+. I've seen people mentioning different things to do to fix emby. I'm not good at ssh and putty etc.... Is there a newest fix to solve my emby no longer working?

Yes, go to the first post.  Download the video and watch it.  It shows the full migration process minus two command you do through putty/ssh.  While watching the video, also look at the instructions in that post and you'll see they match and you'll see where the 2 putty commands come into play that don't show in the video.

Instead of typing those commands just copy/paste them so you won't have any typos.

The instructions are perfect as is IF you previously had Emby (DSM6) installed at /volume1/Emby and the new (DSM7) install is at /volume1/@appdata/EmbyServer (both are the defaults).

As long as you don't touch or delete the DSM 6 Emby install at /volume1/Emby you can redo the migration process over and over so don't worry if you think you did something wrong.  Just start over and do it again.

If you hit any snags/issue post them here or send me a PM and I can remote in via AnyDesk and give you a hand as I've done well over 100 migrations at this point. It would be our pleasure to assist you if needed.

The migration may seem like a lot of steps but it's really not hard if you follow the steps.  You've already installed DSM 7 so you can check that one off the list. :)

Carlo

Edited by cayars
Link to comment
Share on other sites

LastCarbon

Thanks for the awesome guide cayars. My migration went smoothly. I did run into an issue with my SSL cert which I was able to resolve. I had a task set up that used openssl to convert the default Let's Encrypt Synology certs to a pfx file however the pem file names changed under DSM7. I also had to save the pfx file somewhere else Emby kept complaining that it didn't have access to /usr/syno/etc/certificate/system/default/ anymore. Figured I would just mention it here in case anyone else runs into the same issue.

Ended up with a command like this for the task:
openssl pkcs12 -export -out /volume1/wherever-you-want-the-cert-to-go/cert.pfx -inkey RSA-privkey.pem -in RSA-cert.pem -certfile RSA-fullchain.pem -passout pass: Your-Password

Edited by LastCarbon
  • Thanks 1
Link to comment
Share on other sites

rhummer
2 hours ago, LastCarbon said:

Thanks for the awesome guide cayars. My migration went smoothly. I did run into an issue with my SSL cert which I was able to resolve. I had a task set up that used openssl to convert the default Let's Encrypt Synology certs to a pfx file however the pem file names changed under DSM7. I also had to save the pfx file somewhere else Emby kept complaining that it didn't have access to /usr/syno/etc/certificate/system/default/ anymore. Figured I would just mention it here in case anyone else runs into the same issue.

Ended up with a command like this for the task:
openssl pkcs12 -export -out /volume1/wherever-you-want-the-cert-to-go/cert.pfx -inkey RSA-privkey.pem -in RSA-cert.pem -certfile RSA-fullchain.pem -passout pass: Your-Password

Thanks for the info. I just started looking into my ssl issue and I run a similar script to generate the pfx!

  • Like 1
Link to comment
Share on other sites

17 hours ago, LastCarbon said:

Thanks for the awesome guide cayars. My migration went smoothly. I did run into an issue with my SSL cert which I was able to resolve. I had a task set up that used openssl to convert the default Let's Encrypt Synology certs to a pfx file however the pem file names changed under DSM7. I also had to save the pfx file somewhere else Emby kept complaining that it didn't have access to /usr/syno/etc/certificate/system/default/ anymore. Figured I would just mention it here in case anyone else runs into the same issue.

Ended up with a command like this for the task:
openssl pkcs12 -export -out /volume1/wherever-you-want-the-cert-to-go/cert.pfx -inkey RSA-privkey.pem -in RSA-cert.pem -certfile RSA-fullchain.pem -passout pass: Your-Password

Glad the migration guide worked out well for you.  

How often do you need to run that script for the cert?
I'm spoiled as I don't need to touch any certs stuff after the initial install. I'm using a cert generated by Cloudflare.
This to me is the way to go as the cert isn't going to expire anytime soon. Plus you get all the nice features Cloudflare offers.

 

Link to comment
Share on other sites

Phoenix10

followed instructions everything seemed ok apart from the fact every time i try and open emby it says its manually stopped pulling my hair out dont know what i am doing wrong

Link to comment
Share on other sites

Phoenix10
On 06/07/2021 at 00:42, cayars said:

absolute legend Cayars remote sorted my system after hours of pulling my hair out thought i was going to launch my desktop out of the window at one point simple when you know how,I think the saying is you dont know what you dont know 

 

  • Like 1
Link to comment
Share on other sites

It's our pleasure to assist customers like this. I'm glad we got you system back up and running for you.

Happy streaming!

Link to comment
Share on other sites

rhummer
6 hours ago, cayars said:

Glad the migration guide worked out well for you.  

How often do you need to run that script for the cert?
I'm spoiled as I don't need to touch any certs stuff after the initial install. I'm using a cert generated by Cloudflare.
This to me is the way to go as the cert isn't going to expire anytime soon. Plus you get all the nice features Cloudflare offers.

 

I personally have it setup to run everynight since I setup the default cert to use LetsEncrypt to generate the cert. I could push it to every 2 months or the day before the cert expires. 

  • Like 1
Link to comment
Share on other sites

LastCarbon
8 hours ago, cayars said:

Glad the migration guide worked out well for you.  

How often do you need to run that script for the cert?
I'm spoiled as I don't need to touch any certs stuff after the initial install. I'm using a cert generated by Cloudflare.
This to me is the way to go as the cert isn't going to expire anytime soon. Plus you get all the nice features Cloudflare offers.

 

I have the script set to run once a month. It's been trouble free for the most part, I actually forgot about the script until the update.

  • Like 1
Link to comment
Share on other sites

e2zippo

Hey! So I just upgraded to DSM7.

I followed every step in the guide but I can't login, not with emby connect or my local account.

Any ideas? @cayars

Edit: So something appears to have gone wrong. 

I could login with the user "emby" but everything else is gone, my settings, users and library.

Edit2: Managed to solve it, copied the files and changed ownership again, now it seems to be all good!

 

Edited by e2zippo
Link to comment
Share on other sites

I was just going to offer remote support to do exactly what you just did. :)

Glad you got it worked out!

  • Like 1
Link to comment
Share on other sites

gob00

So I am slowly and painfully working through this upgrade process. Following the steps as much as I can...

My current sticking point is that when I run this command:

cp -rv /volume1/Emby/* /volume1/@appdata/EmbyServer

Its says the target is not a directory (target 'volume1/@appdata/EmbyServer' is not a directory)

Any tips on how to solve this? Note that I have zero experience in SSH, as I'm sure is the case with most users. So things will have to be spelt out fairly simply! Most of the advice here seems to assume people will have this, hence the general confusion I feel...

Anyways- help would be appreciated :)

Edit: I should add that I MAY not have had the most recent Emby version before I updated. Hopefully this doesn;t mean I am doomed...

Edited by gob00
Link to comment
Share on other sites

Hi it sounds like you skipped at least one step in the process.
That folder would be created when you reinstall Emby Server on DSM7.

Try going back and start from the step right after updating DSM 7.
If you are still having a problem send me a PM and I can remote in and give you a hand with this.
Carlo

Link to comment
Share on other sites

magicdelux

I have just updated to DSM7 and wanted to follow the update instructions for Emby.

On my system there is no directory "/volume1/Emby/". Could it be deleted when uninstalling Emby? Or could the configuration be in a different folder?

Link to comment
Share on other sites

Just answered this in your other thread.

Link to comment
Share on other sites

tcichowicz

I want to upgrade my (2) DS1520+ devices to DSM 7. Both are running Emby Server. If I don't want to migrate them as stated in this thread, can I just (backup Emby Sever Config with Plugin) uninstall Emby Server from NAS . Upgrade NAS to DSM7 - Then Install fresh Emby Server from new repository - then just do a restore from my OLD Emby install that was on DSM 6.2.4 Update2 ?

 

   I am just totally confused with the video and the VirtualDSM update??

EDIT: What isn't clear is that the latest Emby version 4.6.4.0 - and the DSM7 version is already available from Synology within Control Panel Update/Restore.

So I'm already at the latest version on DSM 6.2.4 Update2 - I don't have to do that..

I can just uninstall EMBY, and do the DSM7 update on my nas (no Manual downloads of either Emby or DSM7)

So the whole video is really about that. And it shows deleting a user (internal ?) video that I don't have on my system.

EDIT2:  sorry I now see that was a group NOT a User .. (video)

Edited by tcichowicz
Link to comment
Share on other sites

gob00
On 01/11/2021 at 12:09, cayars said:

Hi it sounds like you skipped at least one step in the process.
That folder would be created when you reinstall Emby Server on DSM7.

Try going back and start from the step right after updating DSM 7.
If you are still having a problem send me a PM and I can remote in and give you a hand with this.
Carlo

Hi Carlo,

Thanks for the reply. I had missed the Emby uninstall, I just updated the existing package- once I did this it all worked fine. Thanks for the help!

g

  • Like 1
Link to comment
Share on other sites

Great to hear.

Glad you got it all working.

Link to comment
Share on other sites

DrHermel

Hello, yesterday i wanted to update my Synology DS416play to DSM 7 with Emby.

 

Start with DSM 6.2.4 - 25556 and Emby 4.6.4.0 

1. Stop and Deinstall Emby

2. Download newest DSM 7.01 - 41890 => Install

3. Download Emby 4.6.4.0 for DSM 7

Tried manualy Install downloaded Version - Error, unsupported file format

Then senn that now emby is in the packagemanager => Tried to download and to install => Failed "Package cant be installed"

 

Does anybody knows how i can install emby on my system? Dont want work. If you are German you can write im German because i´m German too but i think to write in english is better on that forum.

 

Thank you

 

Link to comment
Share on other sites

mad_cow

I have a question.

- IF my metadata is all stored in the .nfo files 

- AND I make a server configuration backup with the Emby Backup plugin.

Is that sufficient to do a full restore in DSM7 as well? Or will I miss some data?

Link to comment
Share on other sites

fran6v

My own experience of 7.01 migration on Emby has been awful... And with Domoticz as well... Those two applications are almost the only reasons for me to have a Synology NAS...

Unfortunately, I had not seen and read your tutorial before starting ! I am now locked with no access to my video files on Emby, certainly an access issue.

This is what I did update Emby on the latest version on 6.2, then upgrade to 7.01. At which point I uninstalled Emby and installed the 7.0 version of Emby which I found on the Emby site. Since I couldn't access my media drives on the NAS, despite allowing access to the Emby user, under shared folders, I deleted the Emby directory, the Emby user.... unsintalled-reinstalled and nothing has changed ! can't access the NAS media directory !

Now i am thinking of going back to 6.2, which seems a very tough road

Link to comment
Share on other sites

@mad_cow @fran6v

Check to see if you still have /volume1/Emby 

If you do go back to post one and follow the instructions there.  As long as you still have the DSM 6 Emby (above link) you can redo the migration process over and over.

If by chance you have multiple volumes it's possible you could have installed Emby on a different volume.  So if you don't find it at /volume1/Emby try /volume2/Emby until you do find it.
Then just substitute that path in the instructions.

Link to comment
Share on other sites

DrHermel

Hello - Update to my Problem.

I dont get Emby installed, so i got on putty - login with admin and searched all folders with named with Emby and deleted them on Volume1 (the only Volume installed) then i restartet the Synology Station and tried again ... cant install - s there a Problem with DSM 7.01 and the actual emby Package on the store? Cant find an older DSM7 Version of emby to try that. All Versions which i can download for trying to install manually - error, unsupported file format.

Link to comment
Share on other sites

fran6v

Thanks for your prompt reply, but I cleaned the Emby traces pretty well, nothing is left...I found an interim solution which was to use a windows PC that was running on another application , the installation of Emby took no ore than 15 Mn, and fixes my problem for now. 

Link to comment
Share on other sites

DrHermel

So, last update - worked

Dont know what problem but i think there was some Dataissue or old files i´ve net found. So I decided to reset my Nas - Worked

Ive pressed the Reset Button for about 4-5 sekonds "biep" - then again for 4-5 sekonds - "biep, biep" and installed DSM new, all Data was on the Volume, then installed emby - worked.

Now i have to scan the folders and so on an than i use it again like in DSM 6   🙂

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...