Jump to content

Search the Community

Showing results for tags 'subtitles'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • Emby Premiere Purchase/Subscription Support
    • Feature Requests
    • Tutorials and Guides
  • Emby Server
    • General/Windows
    • Android Server
    • Asustor
    • FreeBSD
    • Linux
    • NetGear ReadyNAS
    • MacOS
    • QNAP
    • Synology
    • TerraMaster NAS
    • Thecus
    • Western Digital
    • DLNA
    • Live TV
  • Emby Apps
    • Amazon Alexa
    • Android Mobile
    • Android TV / Fire TV
    • Emby Theater
    • iOS
    • Apple TV
    • Kodi
    • Raspberry Pi
    • Roku
    • Samsung Smart TV
    • Sony PlayStation
    • LG Smart TV
    • Web App
    • Windows Media Center
    • Plugins
  • Language-specific support
    • Arabic
    • Dutch
    • French
    • German
    • Italian
    • Portuguese
    • Russian
    • Spanish
    • Swedish
  • Community Contributions
    • Ember for Emby
    • Fan Art & Videos
    • Tools and Utilities
    • Web App CSS
  • Other
    • Non-Emby General Discussion
    • Developer API
    • Hardware
    • Media Clubs
    • Legacy Support

Blogs

  • Emby Blog

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. schmitty

    MKS subtitles

    Hi, Could support be added for MKS subtitles?
  2. Whenever I go into, for example, Game of Thrones and put to edit subtitles and simply click search, it finds lots of exact matches for my language (portuguese) and I simply click in download and it works. However, if I run the subtitle downloader task (or let it run every 15 minutes) it does nothing to the subtitles. I must always download by hand.
  3. stevedallas

    Subtitles - cannot get them

    I am a newby but I've searched these forums. I know I am making a newby mistake and would like help. I have created a user login in open subtitles and have provided my login name and password in emby. I have (I think) checked all of the correct boxes in each library's settings, but still no subtitles. There are no subtitle files in each recording's folder. I'm attaching a screen grab from my latest recording attempt. Please help! Thanks, Steve
  4. Hi, let me start off by saying that Emby its the best streaming server out there! Nice job and keep going! I think it would be great to have an automatic feature that convert's .pgs subtitles inside .mkv files to .srt. Let me give you an example of use case that's actually what I'm dealing right now: I have a 55" LG 4K TV and i'm using the Emby app whis is beautiful btw. I have several 4K HEVC BluRay movies in .mkv files in the server that have .pgs subtitles and different audio tracks for langs., the thing is that for me to be able to watch those movies I had to turn off all the transcoding options in my user profile. If I turn on the transcoding options, it tries to burn the subtitles by transcoding the Video file. I think that instead of transcoding the video file, it should be doing something like converting those .pgs existing subtitles to .srt files that are compatible with most DLNA devices. I think it would be awsome if we could cron this to run on the less server busy hours so the .srt file is ready to play whenever is needed instead of doing it on the fly when maybe there's no enough CPU resources.
  5. Hello, Hebrew subtitles are not displayed correctly in my emby server either in the web player or in the LG TV app. the problem is essentially the same as was previously reported here for iOS: https://github.com/MediaBrowser/Emby/issues/3137 (probably an issue with left-to-right languages in general) for example this is a text from a hebrew srt file: 23 00:04:57,124 --> 00:05:00,999 ?מה קורה .אני לא שומע אתכם this is a screenshot from the emby player - note the misplaced punctuation: this is a screenshot from VLC player where the same subtitle file is displayed correctly: can this be fixed ?
  6. I've a problem with misaligned/scaled subtitles (vobsub) with some of my media. I attached a screenshot showing that the subtitles burnt in during transcoding are not centered. It looks like the scaling of the subtitles is a bit off. This might cause the misalignment. I figured out, that the issue only come up when I crop letterboxed media to get the actual or intended aspect ratio of my media files while rendering. I also tested if anamorphic rendering has any influence to this problem, but the issue seems to be not affected by this, Emby is handling this (mostly) with no issues. A external player like VLC is handling this correctly. I'm on Emby 3.5.2.0 running in a Docker container. But the issue is not related to this specific version of Emby. I'm pretty sure this issue come up with a Emby update a while ago, but I cannot reproduce with which version this issue came up anymore. Additionally I'm using the Web App with Firefox 62. Thanks, Peter ffmpeg-transcode-bc828121-46c9-46a9-90d7-7b148a231c10.txt embyserver.txt
  7. I noticed Emby Server is not recognizing the 'Forced' flag for internal subtitles in a MP4 container. Here is an example, you can see from Subler that Track 5 is subtitles and they are checked as 'Forced'. However in Emby Server it is showing the subtitles as "No" for Forced.
  8. The Arabic subtitles Don't appear Well on The Android App Is There any Solution Please !?
  9. When I modify the size of the subtitles in configuration, it doesn't actually change, it stays too big for my screen. I have made the same change in the web client and there the size does change, but not for emby theater (https://emby.media/emby-theater.html) Is this a bug or am I doing something wrong? It happens for every movie/tvshow and also it happens in the same movies/tvshows that DO change their subtitles sizes in the web client, so I don't think it has anything to do with the subtitles themselves. I am running latest emby theater connected to a version 3.5.2.0 emby server. Thanks in advance.
  10. spikemixture

    Specific Folder to d/l Subtitles

    Emby appears to be doing a very good job of d/l my missing subtitles. How can I point it to look for subtitles in a certain folder - being either /TV covering many folders or /theTVshow/ Thank you gurus....
  11. Hey guys, System : linux Nixos unstable 18.09pre149044.6afd19e699c (Jellyfish) Emby : emby-3.4.1.0 Mono : mono-4.6.2.16 Just installed Emby on Nixos unstable, and after the server start, I updated Opensubtitles plugin to the latest version, then tried to get some sub. However, either manually or through the scheduled activation, Emby doesn't download subtitles. Logs are filled with this error : 2018-08-20 22:21:15.658 Error App: Error downloading subtitles *** Error Report *** Version: 3.4.1.0 Command line: /nix/store/r0x1b5r1pzx6dlgl1m9svy0wm600i4mp-emby-3.4.1.0/bin/MediaBrowser.Server.Mono.exe -ffmpeg /nix/store/3x79jnw873iz7dvk5vjnndrf672y8zks-ffmpeg-3.4.4-bin/bin/ffmpeg -ffprobe /nix/store/3x79jnw873iz7dvk5vjnndrf672y8zks-ffmpeg-3.4.4-bin/bin/ffprobe Operating system: Unix 4.14.62.0 64-Bit OS: True 64-Bit Process: True User Interactive: False Mono: 4.6.2 (Stable 4.6.2.16/ac9e222 Tue Aug 7 21:30:57 UTC 2018) Processor count: 4 Program data path: /var/lib/emby/ProgramData-Server Application directory: /nix/store/r0x1b5r1pzx6dlgl1m9svy0wm600i4mp-emby-3.4.1.0/bin System.IO.FileNotFoundException: Could not load file or assembly or one of its dependencies. File name: 'System.IO.Compression, Version=4.1.1.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' at OpenSubtitles.OpenSubtitleDownloader+<GetSubtitlesInternal>d__23.MoveNext () [0x001af] in <73f6d839a7164c41803da6f678f0b78e>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0004e] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in <fb768d43fe23485fbb071afcff849fe2>:0 at MediaBrowser.Providers.Subtitles.SubtitleManager+<DownloadSubtitles>d__18.MoveNext () [0x000db] in <0ce351e20fef483992a40df10c7c6183>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0004e] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () [0x00000] in <fb768d43fe23485fbb071afcff849fe2>:0 at MediaBrowser.Api.Subtitles.SubtitleService+<>c__DisplayClass14_0+<<Post>b__0>d.MoveNext () [0x00099] in <05cb8e86881643b1a0a06329f1d5f9f1>:0 System.IO.FileNotFoundException at OpenSubtitles.OpenSubtitleDownloader+<GetSubtitlesInternal>d__23.MoveNext () [0x001af] in <73f6d839a7164c41803da6f678f0b78e>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0004e] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1+ConfiguredTaskAwaiter[TResult].GetResult () [0x00000] in <fb768d43fe23485fbb071afcff849fe2>:0 at MediaBrowser.Providers.Subtitles.SubtitleManager+<DownloadSubtitles>d__18.MoveNext () [0x000db] in <0ce351e20fef483992a40df10c7c6183>:0 --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0004e] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in <fb768d43fe23485fbb071afcff849fe2>:0 at System.Runtime.CompilerServices.ConfiguredTaskAwaitable+ConfiguredTaskAwaiter.GetResult () [0x00000] in <fb768d43fe23485fbb071afcff849fe2>:0 at MediaBrowser.Api.Subtitles.SubtitleService+<>c__DisplayClass14_0+<<Post>b__0>d.MoveNext () [0x00099] in <05cb8e86881643b1a0a06329f1d5f9f1>:0 I know that Nixos is not supported, but do you have any clue why this is crashing like that ? Thanks a lot for your help, Sterfield
  12. george.smathers

    Subtitle Not Displaying Emby Beta Roku

    I am unable to get subtitles stored in external .srt files to display on my Roku streaming stick, I'm using Emby Beta Channel because the Beta version corrected the onerous screen flicker issue. I've tried all the user options for subtitles on the server: - Default - smart - Only forced subtitles - always play subtitles - no subtitles. None of these work. Subtitles embedded using ffmpeg display ok. Am I missing some setting or is this a beta problem? Any suggestion is appreciated.
  13. Hello, A few months ago i've opened an issue regarding the punctuation problem in iOS & tvOS for the Hebrew languages, you can see the issue here: https://github.com/MediaBrowser/Emby/issues/3137 In the last Beta version i saw that this issue is partialy resolved, now the punctuation appears in the correct way, but sometimes there is a '-' in the end of the line instead of a dot, see photo for example: But when i play the video in the Chrome browser on my Mac i have the punctuation problem, see photo for example: Here is the Subtitles file: Escape Plan 2 Hades 2018 - Bluray-1080p-LEGi0N.heb.forced.srt.zip Here is Emby Server log file: Server_Logs.zip Thanks, Idan
  14. Hello Emby team, First of all, thank you for your work, it's just amazing, you're amazing. My proposition is experimental, I don't know if it could work, if it needs a lot+lot of work or just a lot. I discovered RoboSubSync which proposes to "Fix an unsynchronized subtitle in any language according to an already synced subtitle in english, with the help of some advanced algorithm magic..." Here the GitHub page I found this idea super hyper cool. It could provide a lot of movies to different languages speakers. In my case I have a lot of rare DVDs ripped with English subtitles that I want to share with my friends and family through my Emby server, unfortunately they doesn't speak or read English. And I suppose I'm not the only one in this situation. In general other subtitles languages exist for a movie with English subtitles but it's globally unsync and asks a lot of work to resync it. Having a RoboSubSync plugin or functions inside Emby would make an happier world. Or perhaps the solution would be make RoboSubSync as a website, the users would then upload their subtitles to sync, they will selects some settings and will then download the sync subtitles. A little bit like the pdf>jpg converter websites for example. What do you think about those ideas ? Anyone convinced it could be really great ? Who has the superskills to make this dream a reality without too much energy ? Have a nice day or night! LJZA
  15. As the title says, the android app isn't playing subtitles on synced content. Subtitles work on non-synced stuff, and I went to where the file itself is stored and the file has the embedded subtitle track in it, and it works in a different media player. It also shows up as an option in the subtitle selection menu, but they just don't show up when selected.
  16. I really like using Emby to manage my movie and TV libraries, and to provide remote access to them. When I'm home, for various reasons, I use Kodi as my player, rather than one of the Emby apps. I use the Emby for Kodi add-on, the Embuary skin, and configure them for native/direct play over nfs to my nas. I have both Emby and Kodi configured to store subtitles alongside the video files. Emby is configured to download external srt subtitles from opensubtitles.org for movies and episodes that have neither external subtitles already, nor subtitles encoded into the video file itself. I only need/use English subtitles. All of that works beautifully most of the time. When doing direct-play in Kodi, it will use the embedded subtitle found in the video container file, or the external *.eng.srt file downloaded and saved by Emby. When I notice that subtitles are out-of-sync with the video, one of the nice ways I can solve that within Kodi is to use their mechanism for picking and downloading a new srt subtitle file from opensubtitles.org. I pick a file that I think will more closely match the video file I have, download it, and continue to play the video to test the new subtitles. It usually only takes one or two tries to find a subtitle file that is perfectly synchronized. However, Emby saves subtitle files as *.eng.srt and Kodi saves them as *.en.srt. So, after choosing and downloading an in-sync subtitle file in Kodi, I now have two subtitle files on disk--one that is in sync with the video (named *.en.srt) and one that is out-of-sync with the video (named *.eng.srt). Although Kodi saves the file using the 'en' tag, it seems to also recognize files that use the 'eng' language tag in their names. It seems to prefer the *.en.srt file if available, either because that's the naming standard it uses when it saves, or because that file is newer, I'm not sure which. I'm not sure how Emby decides which file to use as the English subtitle file when streaming, but if it picks the same one it saved, it will be the out-of-sync one. All of this would be solved though, if Emby and Kodi both used the same language tag standard. Kodi seems to be using either ISO 639-1, or the IANA Language Subtag Registry. I'm not sure which because both of those use 'en' as the code for English. Emby, on the other hand, seems to be using ISO 639-2. There are quite a few different standards for language tags. See the tags I've given this topic for some of them. The only guidance I could find when searching for preferred standards for this type of use came from W3C in this document: https://www.w3.org/International/questions/qa-lang-2or3 Their recommendation is to use the IANA Language Subtag Registry instead of ISO 639-1 or ISO 639-2. If that's the case, then I think Kodi is correct to us 'en' instead of 'eng'. Thanks so much for any help with this. I hope that Emby and Kodi can get on the same page for which language tags to use when naming srt files.
  17. Mentalblaze

    Show subtitles as default

    I have an LG with WebOs 3.7 and the Emby app. The app works pretty well now and I have only configuration issues now. Main problem is to get the Emby app to show subtitles by default. It works fine on my Xbian Kodi with the Emby app. But Here I always have to select a subtitle.
  18. BonanzaGroove

    Forced and messed up subtitles

    Hi there, I want to report about a playback issue. I will be using the suggested format for my bug report. Media Playback Issues Please create a topic in the community.See this very topic. Describe the problem in your own words, including what you're trying to accomplish, and where you're getting stuck. Make sure to indicate which Emby App you're using. If you're using a browser, then please indicate what browser you're using.With a fresh install of the Emby Server on a Windows 10 laptop, serving a LG Smart TV webOS app through Ethernet links relayed through a local same-subnet router. Starting to play back a video, a mkv file with 2 different subtitles embedded, with the subtitles set to "Off" Emby still forcibly displays one of the subtitles, and if I try to switch between Off and the two subtitles, the playback ends up with the subtitles displayed multiple times on the screen. It could or could not be related, but the Emby LG app hangs several times while trying to switch off the subtitles. It also hangs on the Home page. If you saw error messages, please tell us what they were. If the problem is difficult to explain, please include screenshots that demonstrate the issue.There are no specific error messages. Please attach the server log from the time frame the activity occurred. See the section below titled Emby Server Logs. Please supply the full and complete log file, and avoid attempting to extract relevant sections. Everything is relevant to us. If a server transcoding log was also generated during playback (in the server logs folder), please attach that as well. Emby Server Logs There are multiple ways to access Emby Server log files. Logs can be accessed directly within the server's web interface by navigating to Help -> Logs - I have got the logs, where I reproduced the issues in a fresh session starting at 22:58 time stamp. How to Post Log Files - I am really sorry, but I do not want to attach my log files for the public to see. I am nevertheless ready to share it with the developers through direct PMs. Let me know. Thanks.
  19. Hi there, a request for Emby Server. I have been using Download and Sync very much lately to minimize transcoding, the only thing I don't seem to find is an option to convert the movie/episode with multiple audio tracks and keeping their metadata so one can select the transcoded version and different languages within the transcoded version. This feature would be greatly appreciated.
  20. How would I go about handling a file with multiple (english) subtitles? Assuming the subtitles of a file look like this: Track 1: language: english name: full subtitles default: yes Track 2: language: english name: only songs default: no Track 3: language: english name: commentary default: no I sadly only get the attached result. The name field is ignored. Is there a setting to change this?
  21. Hi, I’d love that audio and subtitles choice would be saved per show, according to what you select on the last episode you watched. The main audio/subtitles parameters is a good point but there are many cases it is not enough and you need to adjust audio and subtitles at the beginning of every episodes. For example i like to watch Casa de Pale in Spanish with french subtitles, The Big Bang Theory in English with french subtitles, French TV shows in french without subtitles, ....
  22. Hi, Is it possible to change the three letter code that emby uses to download subtitles? Namely the code for Serbian language that emby uses is SRP but the only source that emby can download subtitles from (opensubtitle.org) uses code SCC for Serbian language (http://www.opensubtitles.org/addons/export_languages.php) and that leaves emby with no results. Now I've found a workaround for this in regards to scheduled subtitle download (editing subtitles.xml) but is it posible to also change somewhere the code used for manual search or even better to correct this in some future version permanently? I'm currently using Emby on Synology DSM but the issues existed on Windows version also. This was also reported here some years ago (post #6) https://emby.media/community/index.php?/topic/7703-problem-downloading-dutch-subtitles-wrong-language-code/?hl=serbian#entry208092 Thanks
  23. Hi Guys, I am running Emby and Plex on the same Ubuntu 16.04 Server and using the same media files and am running into this issue. Compared to Plex These are using the same media file and same subtitle file. What this appears to me is that Emby is not using the fonts on the Linux box and assuming everything is in default language. Both of these are set to direct play and not transcoding. Is there something I need to so in order to install alternate language fonts in there? My wife is Thai, so she wants the Thai subtitles and I prefer Emby over Plex. All I could find in the log files was a whole bunch of this in the transcode file while I was testing stuff: [Parsed_subtitles_1 @ 0x837460] Glyph 0xDC0 not found, selecting one more font for (Droid Sans Fallback, 700, 0) Seems like it is not finding relevant items and falling back to Droid Sans Font. Been searching and googling for a couple of hours.. come up with no fix so far. Can Anybody point me in the right direction? Thanks PS: On a side note.. anyway to get the auto subtitle downloads to store in the actual media folder like the artwork? Even with the setting set to store in media files... it keeps it in the /var/lib/emby/metadata/... section
  24. Hi, I've been running emby server version 3.3.1.0 since the last 1 year or so and so far it has been working fine. Recently, the subtitles that it is downloading are not moved to the media folder. It remains in /var/lib/emby-server/metadata/library/xx/xxxxx/filename.eng.srt It somehow doesn't move the subtitles to media folder after download it. I've googled and found this link, but I can't find the last option "Save subtitles into media folders". This is only happening in the last couple of weeks. Any help is appreciated.
  25. CarlosLima

    Caption Syncronia

    The Emby Server, when playing movies, is often out-of-sync subtitles. I have not found where I can fix this, ie synchronize the caption with the audio. I override all available options, but the caption remains out of sync. Is this feature not available on Emby Server? Thank you.
×
×
  • Create New...