Jump to content
StLDreiling

Xbox One Creators Update issues?

Recommended Posts

delicac

Thanks for fixing the crash after 15 seconds - this is now working. However, one major change I have noticed, when playing a movie from my XBOX One it is no longer using direct play, but transcoding everything. This seriously degrades quality. Has anyone else noticed this? I haven't changed any config paramters on the XBOX or Server. Thanks Chris

Share this post


Link to post
Share on other sites
CBers

However, one major change I have noticed, when playing a movie from my XBOX One it is no longer using direct play, but transcoding everything. This seriously degrades quality. Has anyone else noticed this? I haven't changed any config paramters on the XBOX or Server. Thanks Chris

Read the previous page or two.

Share this post


Link to post
Share on other sites
delicac

OK - confirmed. Anything with AC3 if transcoding, all other audio types appear to be fine

  • Like 1

Share this post


Link to post
Share on other sites
JBL

Huge thanks to the devs for implementing the fixes and workarounds! 

 

When using Emby on my XB1, content is no causing the app to crash back to the dashboard after like 15secs.

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

Share this post


Link to post
Share on other sites
FrostByte

Thanks for the feedback !

 

Was the workaround to remux audio so it won't Direct Play anymore since the problem originally  seemed to be with video that DP'd?  Either that, or there is a problem because mine will no longer DPs AC3, XB1 is set to bitstream Dolby Digital

Share this post


Link to post
Share on other sites
CBers

Was the workaround to remux audio so it won't Direct Play anymore since the problem originally  seemed to be with video that DP'd?  Either that, or there is a problem because mine will no longer DPs AC3, XB1 is set to bitstream Dolby Digital

 

According to Luke:

 

You need to look at your xbox audio settings. We simply query the system and it tells us if ac3 is supported or not.

 

As you are probably aware, the Xbox can play AC3 (or at least remux it on the fly), so not sure why Emby can't Direct Play and let the Xbox deal with it.

 

At the very least, it will take the load, however small that load is, off of the PC running the Emby server.

Share this post


Link to post
Share on other sites
FrostByte

I haven't changed my XB1 settings or setup though :)  Just checked and audio output is still set to Dolby Digital so it appears the app isn't detecting the setting anymore and just remuxes everything to AAC now.

 

Tried again today to play the movie Crouching Tiger with AC3 which used to Direct Play fine back before the Creator's Update, then after the XB1 update the app would crash at ~`15 seconds trying to DP. 

 

Steps: since app version 116 it no longer DPs but the server remuxes AC3 played content to AAC and Direct Streams the AAC and then the XB1 converts it back to AC3 when streaming to my receiver.

 

 

592527c910641_Crouching.jpg

 

Server and remux logs.

 

https://pastebin.com/QA8xWuh6

 

https://pastebin.com/S9f0jLvK

 

Emby app version 1.1.122.6

Emby server version 3.2.17.11 beta

XB1 OS version 10.0.15063.3054  

Share this post


Link to post
Share on other sites
chef

I haven't changed my XB1 settings or setup though :) Just checked and audio output is still set to Dolby Digital so it appears the app isn't detecting the setting anymore and just remuxes everything to AAC now.

 

Tried again today to play the movie Crouching Tiger with AC3 which used to Direct Play fine back before the Creator's Update, then after the XB1 update the app would crash at ~`15 seconds trying to DP.

 

Steps: since app version 116 it no longer DPs but the server remuxes AC3 played content to AAC and Direct Streams the AAC and then the XB1 converts it back to AC3 when streaming to my receiver.

 

 

592527c910641_Crouching.jpg

 

Server and remux logs.

 

https://pastebin.com/QA8xWuh6

 

https://pastebin.com/S9f0jLvK

 

Emby app version 1.1.122.6

Emby server version 3.2.17.11 beta

XB1 OS version 10.0.15063.3054

So the file played though fro start to finish?

 

Are these settings automatically enabled or do I have to change something in the Xbox profile.

 

At the risk of getting my comment remove again, I am just having a heck of time.

 

It is okay since I ask Alexa to play movies on Xbox one, but I would like to help and not sure why it isn't working for me like it is for you :)

Share this post


Link to post
Share on other sites
FrostByte

Yes, it completes to the end now though by Direct Stream instead of Play.  I guess that's better than crashing or freezing though :)

 

In the XB1 control panel settings I have audio set to bitstream Dolby Digital through HDMI.

 

On the XB1 Emby app I haven't changed any settings, so they are either the default or are inherited from the Server.

 

I didn't realize Alexa worked on the XB1, thanks

 

Edit: aren't the XB1 profile settings for DLNA only?  I haven't touched anything on the server specific to XB1 playback

Edited by FrostByte

Share this post


Link to post
Share on other sites
chef

Yes I was confused, the settings for playback in the server are for DLNA purposes.

 

The Alexa app I mentioned is a home brew skill to control emby casting, which is Xbox movies and tv app, nothing special. But there is an Alexa app somewhere on the community tracker being developed.

 

I will make sure the settings on my Xbox one match yours and then try again!

Share this post


Link to post
Share on other sites
gaminkake

Is there a fix to this issue?  I'm running Emby server 3.2.17.0-35.1 and 5 minutes in XB1 crashes.  

Share this post


Link to post
Share on other sites
chef

Share this post


Link to post
Share on other sites
chef

Guys just some feedback here.

 

I was able to maneuver away from the frozen video, back into the emby UI previously. However when attempting to play Lego batman movie this afternoon (DTS audio, h264 video) when the video paused I had no control over the UI and had to quit the application.

 

If it helps I also set my playback rates at the lowest 1080p stream in the Theater settings.

Share this post


Link to post
Share on other sites
m-joy

Can someone explains the audio output of the app? My receiver always says DTS since xbox audio output is set to dts... But what is the actual audio when i play some dtshd or truehd content for example?

Share this post


Link to post
Share on other sites
chef

Can someone explains the audio output of the app? My receiver always says DTS since xbox audio output is set to dts... But what is the actual audio when i play some dtshd or truehd content for example?

I'm going to try to answer this one, i might be wrong.

 

Xbox one can't handle Truehd or dtshd so the server will transcode the audio to something it can handle like AAC or previous to the last Xbox update AC3.

 

There is an option in the Xbox audio settings for passthru so it could happen that when using optical audio the DTS could be passing through to your reciever with DTS or dtshd.

 

I think this is correct but I may stand corrected.

Edited by chef

Share this post


Link to post
Share on other sites
FrostByte

Check your log file folder on the server and see if there is a remux file for the movie you played.  On my setup Emby server is converting everything to AAC and then the XB1 coverts it again to Dolby Digital which is what I have it set to bitstream.  It used to Direct Play AC3, but no longer does since version 116 I think

Share this post


Link to post
Share on other sites
CBers

Check your log file folder on the server and see if there is a remux file for the movie you played. On my setup Emby server is converting everything to AAC and then the XB1 coverts it again to Dolby Digital which is what I have it set to bitstream. It used to Direct Play AC3, but no longer does since version 116 I think

Is Luke still looking at this, or are we stuck with this now?

Share this post


Link to post
Share on other sites
FrostByte

The last comment I recall is where he said that he was contacting MS for support and was doing a temp workaround until then

  • Like 1

Share this post


Link to post
Share on other sites
chef

Check your log file folder on the server and see if there is a remux file for the movie you played. On my setup Emby server is converting everything to AAC and then the XB1 coverts it again to Dolby Digital which is what I have it set to bitstream. It used to Direct Play AC3, but no longer does since version 116 I think

I only had Dolby Digital option or stereo. Because I'm going straight to my lg tv it only allowed me to choose stereo. Guess I have to look into new audio equipment. Xbox still is having issues.

  • Like 1

Share this post


Link to post
Share on other sites
CBers

With the latest (Stable) release, v1.1.136, the app is still remuxing AC3 to AAC:

 

Stream mapping:
  Stream #0:0 -> #0:0 (copy)
  Stream #0:1 -> #0:1 (ac3 (native) -> aac (native))

@@7illusions Ember app is still Direct Playing.

  • Like 1

Share this post


Link to post
Share on other sites
7illusions

With the latest (Stable) release, v1.1.136, the app is still remuxing AC3 to AAC:

 

 

Stream mapping:
  Stream #0:0 -> #0:0 (copy)
  Stream #0:1 -> #0:1 (ac3 (native) -> aac (native))
@@7illusions Ember app is still Direct Playing.

Glad to hear that plyaback is fine in Ember on XB. However, I know that there are some quirks on the platform. I'm currently working on this and hopefully there will be a new version available in a not to distant future that resolves these issues and and also adds some nice to have features.

  • Like 2

Share this post


Link to post
Share on other sites
SWKerr

It would be great if this app got fixed.  It was very stable before the creators update but since it has been useless.  Thankfully I have a FireTV on each set with an X1 but I would prefer the Emby X1 app worked.

 

Currently the X1 app will freeze at some point during playback and I will have to kill it.  Most are h.265 mp4 files that play fine everywhere else.  The same files will play on the X1 via DNLA without a problem. 

Share this post


Link to post
Share on other sites
CBers

It would be great if this app got fixed. It was very stable before the creators update but since it has been useless. Thankfully I have a FireTV on each set with an X1 but I would prefer the Emby X1 app worked.

 

 

You could try @@7illusions Ember for Emby app.

 

https://emby.media/community/index.php?/topic/43798-release-notes/

 

There is also a beta channel if you want.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...