Jump to content

Arctic Zephyr: From Ashes


Guardian Hope
 Share

Recommended Posts

I think Guardian Hope had included the changes you made to git. The odd thing is that in git appears fine but when i download it the file has the 2 strange spaces.

Link to comment
Share on other sites

Guardian Hope

icon.png

Arctic Zephyr: From Ashes

3.2.01

"It Would Never Be the Enterprise Without a .01 Release"

 

Yes, that is what this update has been nicknamed because there's always something that doesn't work in the .00 releases.

 

Addresses the issues above. I do not know how this would happen as Git and the zips uploaded come from the exact same source.

 

Available on Emby Beta Repository

Available via Git (Link in first post)

Enterprise CDN: https://embycdn.northebridge.com/AZFA/dormer/3.2.01/skin.arctic.zephyr.fromashes-3.2.01.zip

Emby Direct Link: http://www.mb3admin.com/downloads/addons/xbmb3c/kodi-beta-repo/skin.arctic.zephyr.fromashes/skin.arctic.zephyr.fromashes-3.2.01.zip

 

Changelog:

3.2.01 (3.2.01_bsrelease01) - "From Ashes Bluestone 3.2.01"
"It Will Never Be the Enterprise Without a .01 Release"
SkinSettings.xml space fixed (Contributor: papadcha [Emby Forums, Page 4])
Enhanced Skin Settings (Contributor: minus0 [Kodi Forums, Page 1])

In case you are wondering there is a little goof in the changelog that gives it the 3.0.01 designation but still says 3.0.00 but has 3.2.01bsrelease01 and the proper version in addon.xml.

 

Can't change it now; about to head to the airport

Edited by Guardian Hope
Link to comment
Share on other sites

How can I add more views for picture libraries besides thumbnails and list view?

I have added some views by <views></views> and included xml files for related views by <include></include> in mypics.xml but no luck :(

Link to comment
Share on other sites

@@denethor I think you must add the view.xml to includes.xml file. Maybe you should upload the changed files also to be included  (when all done well) by Guardian Hope to next update.

 

@@Guardian Hope. For the about problem I think that the that you assign a window ID outside the Kodi limits

When I change the window id to both Custom_Bluestone.xml and DialogButtonMenu.xml to one between 1100-1199 then the window appears.

 

The problem is that the window must be created correctly.

 

This is what appears when you clink on about.

 

56bb1c70d3c8c_ScreenShot20160210at131310

Edited by papadcha
Link to comment
Share on other sites

@@denethor I think you must add the view.xml to includes.xml file. Maybe you should upload the changed files also to be included  (when all done well) by Guardian Hope to next update.

 

 

 

I would happily do that but I don't think that its related with includes.xml. All view types already included in that file.

<include file="View_50_List.xml" />
    <include file="View_51_BigWide.xml" />
    <include file="View_52_BigList.xml" />
    <include file="View_53_Poster.xml" />
    <include file="View_54_Banner.xml" />
    <include file="View_55_Wall.xml" />
    <include file="View_56_MediaInfo.xml" />
    <include file="View_57_ExtraInfo.xml" />
    <include file="View_58_Cards.xml" />
    <include file="View_59_BannerWall.xml" />
    <include file="View_500_Thumbnails.xml" />
    <include file="View_503_Poster_Square.xml" />
    <include file="View_505_Wall_Square.xml" />
<include file="View_514_PosterShift.xml" />
 <include file="View_520_Gallery.xml" />
    <include file="View_155_BigWall.xml" /> 
    <include file="View_156_Cycle.xml" /> 
    <include file="View_157_Banner_Info.xml" /> 
Link to comment
Share on other sites

OK figured that out. Since we need to add view to picture library first thing you need to do is edit mypics.xml

Add your desired view to views with. (555 added)

<views>50,500,555</views>

than add views xml file to includes, again in mypics.xml

<include>View_555_Wall_Episodes</include>

Above was already figured that out by me. But next thing is you need go edit the actual views xml files which is View_55_Wall.xml for this case.

 

 

Add your desired content types in to <visible> tags  section of the view xml. (search for <include name="View_555_Wall_Episodes">) and that add 

 

" | substring(Container.FolderPath,plugin://plugin.image.mypicsdb/,left)" to the last:

<visible>Container.Content(movies) | Container.Content(tvshows) | Container.Content(seasons) | Container.Content(episodes) | Container.Content(sets) | Container.Content(files) | Container.Content(plugins)  | substring(Container.FolderPath,plugin://plugin.image.mypicsdb/,left)</visible>
 
 

and than you got Fanart Thumbs view in pictures library. Since this is specific to mypicsdb plugins picture libraries I am not sure to add pull request for the skin. But @@Guardian Hope let me know.

Edited by denethor
  • Like 1
Link to comment
Share on other sites

I'm getting the following error when trying to install the skin:

 

ERROR: CAddonInstallJob[skin.arctic.zephyr.fromashes]: could not read addon description of special://home/addons/skin.arctic.zephyr.fromashes

 

I tried the latest version both from the repository and using the zip file.

Any suggestions?

Link to comment
Share on other sites

I'm getting the following error when trying to install the skin:

 

ERROR: CAddonInstallJob[skin.arctic.zephyr.fromashes]: could not read addon description of special://home/addons/skin.arctic.zephyr.fromashes

 

I tried the latest version both from the repository and using the zip file.

Any suggestions?

 

I get the exact same error.  Doesn't matter how I try to install the skin.

Link to comment
Share on other sites

On what KODI version are you trying to install it?

 

I just reinstalled it without any problems.

Edited by papadcha
Link to comment
Share on other sites

I'm on 16 RC3. A clean reinstall solved the issue. But now when I try to edit the home menu nothing happens: the entries appear to be there in Skin Settings but not in the home menu.

Link to comment
Share on other sites

Can you be more specific. 

You must go to skin settings Customize home menu and add menu items - Change action to one you want and all will be done.

You may also select widget, submenus etc.

To me all of above works fine.

@@Guardian Hope @@denethor Dialog box in music to change view etc appears to be faulty. Also the music bars are too wide and hides the time, artist and album. Maybe must be place before the song title or after the album title. My knowledge is not too good to provide a solution. Maybe you guys could solve this issue.

 

PS You may also see the new font I installed. 

 

 
56c0cc0cc2f2d_ScreenShot20160214at83102p
Edited by papadcha
Link to comment
Share on other sites

 

 

@@Guardian Hope @@denethor Dialog box in music to change view etc appears to be faulty....My knowledge is not too good to provide a solution. Maybe you guys could solve this issue.

 

 

Hold it right there sir :) Thank you for thinking like that but believe me I'm not the droid you are looking for :) Yes I'm making progress on skinning but this is really premature, just baby steps. My learning phase strictly limited to 5-6 files or views of the skin.

 

For the issue; I always hate those bars since the introduction. Nobody cares those bars while browsing libraries and music playing in background they are just a noise to skin. And if your are in now playing mode probably artists slideshow or some visualisation might running on, so again there is no point to have those bars.

 

I will take a look at it, if (BIG IF) I can find the file that manages the bars I will get rid of them :) If @@Guardian Hope agrees on my idea I can post it on Git. But as Guardian I will be in Berlin for one week business trip.

Edited by denethor
Link to comment
Share on other sites

Ok I'm just lucky I think I found it. If anyone wants to get rid of that ugly equaliser 

 

Open Includes_Furniture.xml

 

Comment the lines as below with <!-- -->

<!-- <control type="image">
  <centertop>24</centertop>
  <width>auto</width>
  <height>auto</height>
  <texture colordiffuse="$VAR[ColourHighlight]">equaliser.gif</texture>
  <visible>!Player.Paused</visible>
</control> -->
Edited by denethor
  • Like 1
Link to comment
Share on other sites

 

Ok I'm just lucky I think I found it. If anyone wants to get rid of that ugly equaliser 

 

Open Includes_Furniture.xml

 

Comment the lines as below with <!-- -->

<!-- <control type="image">
  <centertop>24</centertop>
  <width>auto</width>
  <height>auto</height>
  <texture colordiffuse="$VAR[ColourHighlight]">equaliser.gif</texture>
  <visible>!Player.Paused</visible>
</control> -->

 

A step further for anyone want to keep these bars replace <width>auto</width> with <width>128</width>. There all also few lines below another same entry with only difference the gif file name "equaliser_stop.gif". Make the changes to this section too. Either use denethor's solution to remove the three lines when paused the player either mine to make line same as when player is active All credits to denethor.

 

@@denethor You are very good. My respect.

Edited by papadcha
  • Like 1
Link to comment
Share on other sites

I'm getting the following error when trying to install the skin:

 

ERROR: CAddonInstallJob[skin.arctic.zephyr.fromashes]: could not read addon description of special://home/addons/skin.arctic.zephyr.fromashes

 

I tried the latest version both from the repository and using the zip file.

Any suggestions?

 

I get the same error. Turning on Debug logging doesn't add any more info. This is a new install of Kodi 16RC3. I added Emby for Kodi addon and the Eunique skin. Thinking maybe something with the Eunique skin messed it up, I uninstalled/reinstalled Kodi and just added Emby for Kodi before trying to add AZ:FA. Same result.

 

It installed all the dependencies, but failed to install the skin.

Link to comment
Share on other sites

If you haven't install anything worth trying to delete the folder according to your os mentioned in the following link.

http://kodi.wiki/view/Userdata

 

Removes everything from add-on, user settings, passwords etc. and I think that an uninstall doesn't remove it.

Edited by papadcha
Link to comment
Share on other sites

Uninstalling Kodi asks if you want to remove that folder, at least in Windows. But, I uninstalled again and made sure that folder was gone. Installed Kodi, installed beta repository and tried to install skin. Failed again. This is on Windows 8.1 Pro, Kodi 16.0-RC3 Git:20160204-b587e98 using Kodi Emby Beta Addons v1.0.4 repository and version 3.2.01 of the skin.

Link to comment
Share on other sites

Guardian Hope

Okay, I returned from my trip yesterday morning and I see there's a lot to catch up on in this thread. I will take a look at everyone's suggestions/problems/etc. over the coming days and we'll see what can be done.

 

Special thanks to everyone holding the fort down while I was away on business :)

Link to comment
Share on other sites

Okay, I returned from my trip yesterday morning and I see there's a lot to catch up on in this thread. I will take a look at everyone's suggestions/problems/etc. over the coming days and we'll see what can be done.

 

Special thanks to everyone holding the fort down while I was away on business :)

 

Welcome back :)

 

A few people having problems installing skin after Kodi upgrade,

Mine been fine but im running on SATV so might be a issue on other devices. 

 

Edit:

People having issues installing all skins on Kodi 16 final so not a AZ issue it seems. 

Edited by nekromantik
Link to comment
Share on other sites

Nice looking skin.

 

I only got chance to have a quick look on Kodi (Jarvis) in Windows 10. I'm going to see if it works on Android TV later. It wouldn't install from the zip but works fine extracting the folder and putting it in manually.

Link to comment
Share on other sites

MischaBoender

I just recently setup a new HTPC with KodiBuntu (updated 16 RC 3), Emby Server, Emby for Kodi and the Arctic Zephyr: From Ashes skin. Everything is working pretty good, but I do have an issue with the skin. I really don't like the orange and tried to change it to blue. In the skin's settings I've change the highligh color to blue and saved it, but the skin does not apply the new color (even tried a reboot).

 

I've seen post in this thread about the same issue and some have even supplied a xml that should fix it, but I've also seen skin releases dated after the posts containing the fixed xml. I'm not sure if the issue should already be fixed in the release, or that I should apply the fixed xml.

Link to comment
Share on other sites

Guardian Hope

Okay, after reviewing everyone's suggestions and issues I have assembled a list for what will likely be the biggest update to From Ashes yet. The "Spring Update," otherwise known as 3.2.1 (or 3.2.10 if you're really technical) features a whole hosts of changes and should finally get the theme off of legacy back-code. I anticipate a March release but I much prefer to say Soon. Work has already started on 3.2.1 and below you will find a preliminary list of the changes planned. I intend to lock the changes in on Friday meaning suggestions after that won't make it into 3.2.1 so if you have anything you want to see now is the time.

 

3.2.10 (3.2.10_bsrelease01) - "From Ashes Bluestone 3.2.1"
  • Arctic Zephyr: From Ashes "Spring Update"
  • Fixed Errors In Changelog
  • Replaced all instances of AZ Skin Helper with "regular" Skin Helper
  • Blue Accents New Default ("From Ashes" Style)
  • Orange Accents Now "Exploded" Style
  • New Icon Suite
  • Resolved Pink Text to Now Use Color Accents
  • About From Ashes Page Implemented
  • American Flag Now Used to Represent English Audio and Subtitles in Info Screen
  • Enhanced Music Hub Experience
  • New Watch Status Indicators
  • New Poster Wall View (By: bigbadrabbit [Kodi Forums])
  • Enhancements to Video Info Dialog Screen
  • Fix for System Information Screen
  • Optimizations to Reduce Install Size
  • Miscellaneous Changes and Enhancements for Jarvis

 

For those having Install Issues: This appears to be an issues with Kodi Jarvis and not the Arctic Zephyr: From Ashes but I will do further investigating. In the meantime there are several options available. You can download the source from Git, extract, and copy the files to %AppData%\Kodi\addons (make sure the folder with the theme contents is named skin.arctic.zephyr.fromashes or you'll be in for a world of hurt [applies to all OS's]) or you can try to install the zip file from the CDN which is created to properly install and is exactly the same zip file you get when you do it through the repository.

 

Additionally, I advise that you check your file system permissions. I have seen users post here with errors that were related to permissions. 

 

Finally, until we know whether it's truly Kodi Jarvis and an issue Team Kodi needs to fix, there's not much I can do except how to tell you to manually install it.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...