Jump to content

Theme: blue neon night


speechles
 Share

Recommended Posts

I may have spoken too soon.  I have a file that all of a sudden isn't directplaying anymore.  Here's what I see in the log.  Thoughts?

 

2016-01-04 19:37:29.5172 Info App: Profile: Roku, Path: \\PC\Converted Recordings\Converted Recordings\Beyond the Tank\Beyond the Tank-S01E02-Episode 2.mp4, isEligibleForDirectPlay: True, isEligibleForDirectStream: True
2016-01-04 19:37:29.5172 Info App: Profile: VideoCodecProfile, DirectPlay=false. Reason=Roku.VideoFramerate Condition: LessThanEqual. ConditionValue: 30. IsRequired: False. Path: \\PC\Converted Recordings\Converted Recordings\Beyond the Tank\Beyond the Tank-S01E02-Episode 2.mp4

And here is the media info from Emby:

 

EDIT: Do you think it has something to do with the framerate (of 60 whereas the log above seems to be expecting <=30)?  I noticed another file isn't directplaying either... it has a framerate of just over 30.  Other files with framerates that are 29 point something directplay just fine.  Thoughts?

 

568b12a039bc5_Capture.png

Edited by LehighBri
Link to comment
Share on other sites

Yeah, the roku has a max limit of ~30fps. It is the roku4 which can playback at up to 60fps but only in hevc/h265.

 

For the files just above 30fps but below 31fps, you can enable the "auto direct-play flash" option. As well as allowing FLV videos to attempt direct play this allows the max framerate to become 31. This will let those close to 30fps play fine now. Youtube flv videos are always 30.01 or something weird in their framerate ratio is why this option allows this.

 

Sent from my Nexus 7 using Tapatalk

Link to comment
Share on other sites

Yeah, the roku has a max limit of ~30fps. It is the roku4 which can playback at up to 60fps but only in hevc/h265.

 

For the files just above 30fps but below 31fps, you can enable the "auto direct-play flash" option. As well as allowing FLV videos to attempt direct play this allows the max framerate to become 31. This will let those close to 30fps play fine now. Youtube flv videos are always 30.01 or something weird in their framerate ratio is why this option allows this.

 

Sent from my Nexus 7 using Tapatalk

 

OK great, thanks.  Note though that these aren't FLV files... they are MP4 files.  I think by turning on the "Skip Remux" option in MCEbuddy made my framerate detection get all out of whack.  I turned that back on and am going to re-convert the file in issue to see if that fixes the framerate (for other files with framerate in the 29 something direct play works great).

Link to comment
Share on other sites

It isnt the fact it allows the FLV container. Its the fact it ups the h264/mpeg4 framerate to an upper limit of 31fps. This will allow your mp4 and mkv to also take advantage of the raised limit. The video may freeze at some point on the roku, it may not. In a few tests of mine using h264 in FLV this caused the video to hang on the retrieving screen. I would have to exit out and resume with "force transcoding" to watch the rest. This allows you to test them and see if its alright for your encoding method. Even though the framerate ratio isnt truly aligned and wonky this will let it still work.

Edited by speechles
Link to comment
Share on other sites

It isnt the fact it allows the FLV container. Its the fact it ups the h264/mpeg4 framerate to an upper limit of 31fps. This will allow your mp4 and mkv to also take advantage of the raised limit. The video may freeze at some point on the roku, it may not. In a few tests of mine using h264 in FLV this caused the video to hang on the retrieving screen. I would have to exit out and resume with "force transcoding" to watch the rest. This allows you to test them and see if its alright for your encoding method. Even though the framerate ratio isnt truly aligned and wonky this will let it still work.

 

OK thanks.  For those in the 30s I'm OK.  But I still have some files that MCE buddy is converting to a framerate much higher (I have some in the 60s, and one below with 58).  All of my files start as WTV in WMC from my HDHomeRun Extend, and then I use MCEbuddy to convert to MP4 using their "MP4 High Quality" profile.  Any reason why something is converting to such a high framerate?  Doesn't make sense to me.  I'll try converting using their "MP4 Normal"  vs. their high quality profile to see if that makes a difference.

 

568baa14ab15c_Capture.png

Edited by LehighBri
Link to comment
Share on other sites

If the source is recorded cable or ota, then it is probably the dource. My cable broadcasts vary in framer ate from 24 to 60, even in the same show. I had to use the original "roku" preset in mcebuddy to convert it correctly to 29.97.

Link to comment
Share on other sites

New version:

33f2c806472723ddad3da6f850bf8038.jpg

 

* Add exit confirmation dialog

* Add preference to control exit confirmation

 

Update your rokus, for sideloading nowtv users see first post of this thread.

 

Edit: Also fixed an issue with the standard theme. If using that theme, some of the text would not be returned to monochrome. Now it does and keeps the intended look. Two independent themes. One with colors, one entirely monochrome

Edited by speechles
  • Like 2
Link to comment
Share on other sites

@@LehighBri I found something interesting. The only part of this video shown below is the framerate of 60fps will make it transcode.. But what if, we "force directstream" on it? Does it allow direct play at 60fps on my roku3? The answer is.. YES! It actually plays perfectly.

KO79JKE.png

This should make you much happier because now in the preferences is an option called "Max Framerate" you can leave this at its default of 30, or set it at 31, 60, or 61. The 31 is for those oddball slightly over 30fps ones. The 61 is for those slightly over 60fps. This might not work for you, but it just might. It seems the new roku firmware has hidden talents or something.

1d2a3838d52a8239b61f1959b5cfd9cd.jpg

1f0be6a6d81ca097074e336afb351307.jpg

As you can see next to the "more..." option is shown both the playmethod and the max framerate.

New version:
* Add max framerate setting in preferences
* Have capabilities respect this new framerate

Get in the usual fashion, and be suprised. This may make LiveTV on the roku at 60fps possible. Need people to test their 60fps videos and see what results they get. Please reply back in this thread. Thanks ;)

 

Edit: Tested a slew of 480p, 720p and 1080p videos with ~60fps and I've found no issues. They all direct played. I am using the 61fps option. This should make sports and such much more enjoyable. Wonder if Netflix and Amazon will take advantage of this in their roku apps too.

Edited by speechles
  • Like 1
Link to comment
Share on other sites

@@speechles - fantastic work!  I'm sure that would have fixed my issues (where framerates come back all over the place after MCEbuddy converts WTV to MP4).

 

I hate to say it though but I decided the Roku was just too much of a headache for me, and instead I replaced it with an Apple TV 4 which I'm thrilled with.  The big issue I had on the Roku was the fact that I had to literally convert my entire set of WMC WTV recordings into MP4 format which took forever.  I did try both Plex and Emby to play back the WTV files directly (via transcoding), but it took FOREVER for playback to start (and forget what happens if you need to skip or fast forward).

 

With the apple tv, I'm able to playback WTV files via Plex directly nearly instantly, skip instantly, etc.  I know the price difference is significant, but it works for me.  Best of luck in continuing to build out this app though!

 

Keep up the great work though.  I don't want to turn this thread into an ATV vs. Roku comparison.  It's just what worked for my needs.

Edited by LehighBri
Link to comment
Share on other sites

Are the previous 16 posts related to fps related ONLY to live tv AND or recordings for live tv?

 

I haven't dove into any of that stuff, yet.

 

I only use OTA tv for sports and local news so my only other "cord" is the internet.

Link to comment
Share on other sites

The earlier posts were diagnosing his media as to blame. We went a few rounds, and he felt "the juice wasn't worth the squeeze" to correct his media. But after further invesigation I found things have changed. The os7 firmware has unmentioned benefits besides just the scene graph api. We can go about this in a different way perhaps.

 

The fps setting will act globally for your entire library. The roku3 plays them at 60fps, but I've noticed in high bitrates in 1080p@60fps you lose lipsync and the audio drifts ahead of the video. For a 3 minute movie trailer by the end of it I had drifted at least 5-6 seconds behind the audio. This was just one trailer this occured on. All others at 1080p@60fps play perfect on my roku3. Maybe it was just a poorly encoded trailer. But, at 720p@60fps even with high bitrates I cant break lipsync. The roku4 should be able to play 1080p@60fps without issue (and not just hevc/h265, h264 and mpeg4 as well).

 

Please test this against your media to confirm further. Thanks. :)

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles
Link to comment
Share on other sites

I would like to relay results but I have no idea what I am looking for.

 

There was one 2 nights ago that the audio got ahead of itself a little but I chalked that up to goofy encode.

This was only in the last 1/2 of the 30 minute episode

This was in a series from the same encoder and it was only one out of 6 so far.

 

I am pretty sure it was this one.

This may have actually been watched on 1/3/2016

 

Media Info
Video
CodecH264
ProfileHigh
Level41
Resolution1280x720
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.97602
Bitrate2509 kbps
Bit depth8 bit
Pixel formatyuv420p
Ref frames4
CABACYes
Audio
CodecAAC
ProfileLC
Layoutstereo
Channels2 ch
Sample rate48000 khz
DefaultYes
Containermkv
S01E05.720p.Remux.
Link to comment
Share on other sites

Yeah, that one is probably like the trailer I have. Something wonky in the encode causes the audio to drift faster. This is caused by either: the renderer cannot keep up with the video as quickly as it can the audio, or the person encoding it caused it.

 

If it cannot keep up it has to start dropping frames. If this doesnt help it catch up it will start to drift. The video will lag behind the audio. At the end of playing, because audio finishes first you will notice the video speeds up and no audio plays at the end. This would mean the system is maxed out. But.. If it doesnt do this speeding-up at the end after the audio cuts out it is the media encoding causing it.

 

If at a certain point in the video you heard a glitch, a mechanical sounding click that isnt supposed to be there. This is from the encoder splicing out commercials, or cutting two recordings together. Likely both our issues are the result of sloppy encoding.

 

Until we see lots of files consistently failing in this way it seems the likely cause. Make sure to ramp your "max framerate" to 61 in the meantime and test a few 60fps videos you may have too. The tablo app for roku also has support for 60fps. This means good things.

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles
Link to comment
Share on other sites

@@farside847 It should allow that. Change "max framerate" to 61 and give it a try.

 

Sent from my Nexus 7 using Tapatalk

Link to comment
Share on other sites

 

I would like to relay results but I have no idea what I am looking for.

 

There was one 2 nights ago that the audio got ahead of itself a little but I chalked that up to goofy encode.

This was only in the last 1/2 of the 30 minute episode

This was in a series from the same encoder and it was only one out of 6 so far.

 

I am pretty sure it was this one.

This may have actually been watched on 1/3/2016

 

Media Info
Video
CodecH264
ProfileHigh
Level41
Resolution1280x720
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.97602
Bitrate2509 kbps
Bit depth8 bit
Pixel formatyuv420p
Ref frames4
CABACYes
Audio
CodecAAC
ProfileLC
Layoutstereo
Channels2 ch
Sample rate48000 khz
DefaultYes
Containermkv
S01E05.720p.Remux.

 

 

I watched another episode from this series from the same encoder last night.

There was an intermittent high pitched "screech" now an then but there was no auido sync loss.

 

 

This is just FYI ----

I did go back to the episode that is quoted here. 

I played it back in all of the fps rates and the audio was worse. 

Echoey mostly with loss.

I don't see any reason to look at anything in your app to figure this out.

A bad or goofy encode happens now and then.

Link to comment
Share on other sites

Just posting some recon here.

 

This is transcoding when auto@61fps is selected. I guess that setting is default? 

It will direct stream @61fps if I swap it over.

Roku 4

Your 2.19

Roku 7.0 Build 8863

 

Tell me when to stop with recon posting if I get redundant,

 

Audio
Languageeng
CodecAAC
ProfileLC
Layoutstereo
Channels2 ch
Sample rate48000 khz
DefaultYes
Video
CodecH264
ProfileHigh
Level31
Resolution1280x718
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.97602
Bitrate4110 kbps
Bit depth8 bit
Pixel formatyuv420p
Ref frames2
Subtitle
Languageeng
CodecSRT
DefaultYes
ForcedNo
ExternalNo
Link to comment
Share on other sites

Sort of. The framerate setting is the max it can direct play while directstreaming. So the auto@61fps means you have auto-detect selected for a playmethod and 61 is the maximum framerare it will allow before framerate will cause transcoding. This lets files which otherwise would play fine if it werent for the framerate play directly. You can still "Force directstream" on it and make it play at 60fps even if it had "directstream@30fps" showing. The fps setting only applies to "auto" not any of the forced playmethods. Primarily h264 and mpeg4 this will allow 60fps in multiple resolutions. I have more testing to do with 60fps files but new roku2, roku3, roku4, and the 2nd generation nowtv should be capable of 60fps video now.

 

That file should directplay even on auto. Sometimes though, Ive noticed this too it will transcode. Did you make sure to raise the max video bitrate?

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles
Link to comment
Share on other sites

"Did you make sure to raise the max video bitrate?"

 

I am not sure where to do this at.

So no.

Link to comment
Share on other sites

In the preferences found at the very bottom of the home screen. The same place the rest of the settings are found. With roku4 you can set this as high as it goes to 50. The first post of this thread I added a section that explains the other options.

 

Sent from my Nexus 7 using Tapatalk

Link to comment
Share on other sites

Well duh.

I never paid much attention to that setting.

 

I cranked it to 50 and that file is NOT transcoding now.

 

Glad you are here to explain to me the stuff I bought!

Link to comment
Share on other sites

http://bbb3d.renderfarming.net/download.html

 

Ok, the fhd 1080p 60fps version in this link works, but... On my roku3 this plays waay out of sync. So appears the roku3 may not have enough "ummmppphhh" to do fhd 1080p@60fps at 4Mb/sec. The roku4 should have enough power to do this. The roku3, new roku2 and new nowtv v2 do have enough power for 720p@60fps and below though. They just cant shoot for the moon like a roku4 can.

 

@@mikeraburn

 

Can you download the movie at the download link above? Specifically the 2d fhd 1080p 60fps version, not from http. So you will need to use the magnet or torrent link. If this plays normally and you find no issues please let us know here. Also try the 4k@60fps version too. The roku4 should natively play this too. This will confirm the roku4 is as awesome as I bet it is. Thx.

 

Also....

 

0a633b27fd431d124d965defcfb74ef7.jpg

 

d14d842a66958cf69b25aa92306cc589.jpg

 

New version:

* add test for roku4 - h264/mpeg4 at 4k

* add framerate to info line in descriptions

 

 

This will let you enable h264 in 3840x2160 to auto-detect as direct play rather than having to "force directstream". This is just a test option like the hd audio passthru setting. It may not work..yet..but in the future roku may allow this so its an option. The framerate is also visible now on description screens. This should make it easier to control things. Does for me. :)

Edited by speechles
Link to comment
Share on other sites

Change it to yes. This will allow you to stream those codecs h264/MPEG4 in 3840x2160. The 2D 4k version of big bunny in 60fps is encoded in h264 at level 5.2. Ive cranked support for h264 level up to 5.2 rather than 5.1 in the app.

 

This opens up the full capability of your roku4.

 

Sent from my Nexus 7 using Tapatalk

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...