Jump to content

Theme: blue neon night


speechles

Recommended Posts

Has anyone had the random error when transcoding a file and playing it back on the roku through this version of the app, the video crashes out of the app and trying to play the file again, even from the begining, causes the same crash as well? I just had this happen when I tried to rewind on a show I was watching, which was being transcoded on the server from AAC audio to MP3, and the application crashed out hard. Each time I went back to try and resume the show it would crash. Even trying to restart the show over again it would crash. I could play any other file, just not this one. Strange.... 

Link to comment
Share on other sites

@@JakeByr,

 

Did you update your firmware on your roku? This isnt the roku reboot issue is it?

Does it crash out right away soon as transcoding starts?.. Or.. Randomly while playing it reaches a spot and just crashes?

Can you paste the media info shown in the web client for that file?

Which roku model?

Are you sure the file was complete and not damaged? Do you trust the source it came from? Do other clients play the file without issue?

Is there any other files with this behavior?

Just a few (giggle) questions.. Heh

 

As a side-note, I haven't experienced this exact thing. I have had it freeze on me. Where it gets stuck on the retrieving bar. Then I press up arrow to exit. Then resume always works to resume for me. This occurs rarely for me and usually when the server is scanning. If you are overly aggresive with the rewind button it could cause the roku to reboot. When you ff/rew it has that 3 step speed thing it does. Then press play to resume from that point. I have several files in all flavors of codecs and containers. I only use a roku3.

 

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles
Link to comment
Share on other sites

I have a roku 3 and the firmeware actually just updated today while I was messing around with this. I posted in the other thread on here about having to update to a newer version of ffmpeg and build it from source on my server. The file plays fine on my kodi setup it's on the roku that it crashes. After the first crash the file refused to play, "no way, no how!" It would crash the entire app at every step of trying to play the file. The container is mkv for the tv show and the audio is aac which had to be recoded into MP3 since I do not have a digital HDMI receiver to decode the 5,1 audio back down to stereo. I do trust the file as I've watched/finished watching the file on the kodi setup. 

Link to comment
Share on other sites

If you "force directstream" in the "more..." options does it play? Is it aac in 5.1?

 

The force directstream might not work. It also might play but without any audio. You can also try "force transcoding". Just to test. After doing these tests, change the play method back to auto. Also can you paste the mediainfo for that problem mkv here? You can find it in the web client view for that file. Thanks. ;)

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles
Link to comment
Share on other sites

mikeraburn

Has anyone had the random error when transcoding a file and playing it back on the roku through this version of the app, the video crashes out of the app and trying to play the file again, even from the begining, causes the same crash as well? I just had this happen when I tried to rewind on a show I was watching, which was being transcoded on the server from AAC audio to MP3, and the application crashed out hard. Each time I went back to try and resume the show it would crash. Even trying to restart the show over again it would crash. I could play any other file, just not this one. Strange.... 

 

That JUST happened to me with the same file properties. Weird.

BUT I was able to get back into the app and play the file.

I thought I fat fingered the remote,

 

IF it happens to me again I will make a note and look at the log and post it for translation,

Link to comment
Share on other sites

Odd.. Are you using the fix from BigBri41 or server version 3.0.5781.6? The fix that would stop the roku rebooting when transcoding files over 2 hours in length. If so, you need to undo this it may be causing it. The recent roku firmware fixes this now. The server change can be reverted.

 

I am using server version 3.0.5781.5 (without any hls fixes) with roku firmware version 7.0 build 9044 and see no problems.

 

Here is the .dll from my version zipped up for windows users: http://ereader.kiczek.com/MediaBrowser.Api.zip

 

 

 

Sent from my Nexus 7 using Tapatalk

Link to comment
Share on other sites

mikeraburn

Odd.. Are you using the fix from BigBri41 or server version 3.0.5781.6? The fix that would stop the roku rebooting when transcoding files over 2 hours in length. If so, you need to undo this it may be causing it. The recent roku firmware fixes this now. The server change can be reverted.

 

I am using server version 3.0.5781.5 (without any hls fixes) with roku firmware version 7.0 build 9044 and see no problems.

 

Here is the .dll from my version zipped up for windows users: http://ereader.kiczek.com/MediaBrowser.Api.zip

 

 

 

Sent from my Nexus 7 using Tapatalk

I have the following

WIN - Emby Server 3.0.5781.6

Roku 4 - 7.0 build 8863 (no update as of now)

Link to comment
Share on other sites

You can try replacing the dll you have with the one I put above if you are on windows. This should let you get the old behavior back. I dont think @@Luke (he can clarify) has reverted the roku changes yet from the server code. The ironic part is just after luke fixes it temporarily at the server level, the next day roku fixes the firmware...It's like raaaiin on your wedding day.. But seriously, the issue hopefully is this simple. Please test and see. :)

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles
Link to comment
Share on other sites

mikeraburn

I will try that if it happens again.

 

I really think I fat fingered the remote.

 

Thank ya!

Edited by mikeraburn
Link to comment
Share on other sites

@@mattm I dont think the official roku client has wake on lan implemeted. I can look at porting over some code from rarflix's implementation. Not sure when I can get to this since this is a busy time the next two weeks. It will be addressed though when I get a chance.

 

Sent from my Nexus 7 using Tapatalk

Wow, that would be great, thanks.

Link to comment
Share on other sites

This is the only info Emby shows me: 

 

Media Info
Containermkv
Path\\192.168.0.10\Data\TheBrig\Emby\mnt\TVshows\Suits\Season 5\Suits - 05x09 - Uninvited Guests.mkv

 

I did try force transcode and force stream but each option at that time when working with that file would crash the roku app straight to the main roku menu. 

Link to comment
Share on other sites

mikeraburn

I will try that if it happens again.

 

I really think I fat fingered the remote.

 

Thank ya!

 

I went in and looked at the ERROR logs and the only ERROR I saw was not being able to hit The Movie Data Base.

That went on and on and on and on.

 

So I did in fact fat finger my remote, maybe.

 

But I did get speechles's file in case it is an ERROR and not pudgy digits.

Link to comment
Share on other sites

  • 2 weeks later...
fraenhawk

@@speechles I'm very excited to read about your branch (and possibly improvements to the official as well). I have 3 HTPCs in my house. The kids and master bedroom ones could easily be replaced with a Roku 2 (2015) model (but the living room needs optical out - or I buy a new HDMI receiver). I borrowed a co-worker's Roku 3 a few months ago just to see what the Emby interface was like on it and the main problem I had were those described earlier in this thread regarding Live TV and switching channels (first channel would work, but would never release/change to another). Otherwise I liked the interface better than EMC. Sounds like you've worked all of that out over time and it might be time to give it another shot.

Link to comment
Share on other sites

mikeraburn

@fraenhaw

 

As you may or may not know the Roku4 has an optical out.

 

I use it with with my low end Boston TVeeOne and it works for me.

 

I think this is still true, Roku has some issues with there Audio Settings for those who are audiophiles and have higher end system than me.

 

We have a Roku 3 and a 4 that hit a server.

I swear the 4 does a better job clarity wise but it could the 2 different tvs.

 

Instead of getting a new HDMI receiver I would stick with the HTPC in the main room, if it was me.

 

As for Live TV, I cannot speak to that.

I have a Mohu antenna hooked to my tv and I get all the SIX channels that I need.   

Link to comment
Share on other sites

mikeraburn

With the outage on January 1 I noticed it took longer than usual to retrieve and start playing locally stored media.

 

I manually sign into my one and only server.

 

Why would the outage cause a delay for playback of local media stored on my network server using a Roku4?

 

Prior to knowing of the outage I rebooted the the server, rebooted routers, rebooted Roku4, and even replaced a cat5 cord thinking I had something fubared here locally.

 

I do have emby premier. 

The only thing I KNOW I use it for is downloading locally stored media from the server to android devices for playback on VLC from time to time.

I haven't done any of that for over a week.
Link to comment
Share on other sites

I believe its due to the inability of the server to send usage statistics. Basically it doesnt look like the apps at fault or the roku. It appears server lag caused by the downtime. I see several (slow) in my logs, right after a failure to send usage stats. There was a pronounced lag before the server would stream something. This affected both direct and transcoded streams. Maybe @@Luke knows better where to place the blame? O_o? Very odd behavior I agree.

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles
Link to comment
Share on other sites

mikeraburn

Stuff happens.

We depend on the internet so much nowadays.

 

I just thought it is odd that local streaming would be affected.

 

The delay was in no way a big deal.

I needed to replace that cat5 cord anyway.

 

The server software worked fine after it got around the fact it couldn't "phone home".

 

Scrappers worked fine and the new Sherlock was not interrupted at all.

 

I still have Kodi on that server if needed as a back up and openlec on a pi2 also.

Link to comment
Share on other sites

Hope everybody had their merry christmas and happy new year. Got a message earlier today about the slideshow preference.

 

https://github.com/MediaBrowser/Emby.Roku/pull/113

 

Corrected that issue. Also changed the icon back from christmas to normal. Added 3 settings for delete: Recordings, TV, or ALL. An administrator must change these, normal users cannot. You can see the *ADMIN* tag next to your username on the "Options" row at the bottom of the homescreen. If this appears that user can alter the delete settings in the app. The user trying to delete must have delete ability. These options must be set on the server, in user preferences. This ensures two levels of security against accidental deletion, from either children, or a friend accessing your server remotely. If using the delete options, make sure to always sign out after use. Also make sure the preference "Remember user?" is set to no. This will force users to login on app start.

 

New version:

* correct slideshow registry names

* new delete options

 

Update your rokus, those sideloading reget the zip. Any issues shout them out.

 

Sent from my Nexus 7 using Tapatalk

Edited by speechles
Link to comment
Share on other sites

LehighBri

Hi there - I'm new to using this app and love it thus far (fixed my Roku directplay issue that's been driving me crazy!).

 

One question.  In some of the screenshots earlier in this thread, there's an overlay on a playing video that shows whether a video is transcoding or direct playing.  Is there a shortcut to get that to appear?  I can't seem to figure it out with my roku remote buttons.

 

Thanks and keep up the great work here!

Link to comment
Share on other sites

Happy2Play

Hi there - I'm new to using this app and love it thus far (fixed my Roku directplay issue that's been driving me crazy!).

 

One question.  In some of the screenshots earlier in this thread, there's an overlay on a playing video that shows whether a video is transcoding or direct playing.  Is there a shortcut to get that to appear?  I can't seem to figure it out with my roku remote buttons.

 

Thanks and keep up the great work here!

You mean this one?  Press the ok button while playing media.

 

56395b2d14a21_IMG_20151103_180631910.jpg

Link to comment
Share on other sites

LehighBri

One more question from me as I'm new to this addon.  In going through all the settings, there are a bunch about audio and transcoding.  e.g. convert to AAC or MP3, etc etc.  Is there a guide or wiki or recommendation on when to/not to use these?  Ideally I'm trying to get all of my content to direct play, but in the case I need to transcode, an example question would be what should I do... transcode to AAC or MP3?  I have a Roku 2 (2015 version).

 

Appreciate all the help.

Link to comment
Share on other sites

I can explain them sure:

 

Convert DTS to AC3: this will help older roku models with systems that do not support DTS. The firmware versions in the older hardware is to blame. Newer rokus it should say you dont need to care about this setting.

 

Convert MPEG4 to h264: this is a personal preference and disabling this may lead to poor video quality. This will certainly ease the cpu duties though but at the risk of blocky video. This is useful for xvid/divx avi files and will pass the native mpeg4 stream.

 

Convert MP2/MP3 to AAC: this is once again a personal preference. This is again for those with xvid/divx avi files which use mp2/mp3 audio. In this case disable this option and save your cpu a few cycles. This will allow native mp2/mp3 audio to stream rather than converting to aac.

 

Unknown Audio: this is mostly for livetv streams. This will suggest the codec to be assumed when watching livetv. Changing this to ac3 will certainly help transcoding keep surround sound.

 

Default Audio: this is the codec we start with. If no other codec appears useful this is our fallback codec. You can choose ac3 to keep surround in everything.

 

Convert AAC to MP3: this one is for warbly sound and poor audio. If you experience issues with stereo aac enable this option to use mp3 instead.

 

Force surround: this one completes the surround audio. If this option is enabled when transcoding all aac will become ac3. This is a companion setting to the aac to mp3 option and will override what is used there.

 

All the other options should hopefully be self explanatory. I tried to put verbose text for every option but you only get so much with the roku. So hopefully this is enough to get you started.

 

You can also use the "more..." option when available on any screen with a play button. You can change the play methods in this way. If you believe an item can direcstream when the auto-detection is always transcoding you can prove it. Turn on force directstream and try to play it. If it pretty much immediately returns back to the pre-play screen it had to transcode. The roku hardware is refusing it directstreamed. It may also reboot your roku, or other odd behaviors. This is at the users own risk. But none of this will permanently damage your roku in any way. So experiment, and find the best settings for you. Have fun. Enjoy emby.

 

Note: If you can "prove it" that an item is being transcoded that should'nt please let us know. If the auto-detection is always transcoding, but choosing force directstream plays it please post here about it. This helps pay-it-forward and helps other users down the road with better auto-detection. Thanks for your contribution.

Edited by speechles
  • Like 2
Link to comment
Share on other sites

@@Happy2Play nice, thats where it should be. Appreciate the forethought. I notice the code blocks dont play nice with tapatalk so I've changed it to a quote block.

 

Sent from my Nexus 7 using Tapatalk

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...