Jump to content

Ytrailers not working?


Allan Cameron
 Share

Recommended Posts

plaidstallion

This was working for a bit but seems to have stopped working again today.

Edit: It seems to work when I invoke the task manually but not when new items are scanned into the library.

Edited by plaidstallion
Link to comment
Share on other sites

  • 3 weeks later...
3 hours ago, dcol said:

How long will this one last? Can't more permanent changes be made? MCM doesn't seem to have this issue.

How long is a piece of string. No idea. It's dependent on YouTube not changing things. Sounds like you're already using something else any way? 

Link to comment
Share on other sites

I use Media Center Master and it works but is mostly manual downloading trailers. It also pulls in iTunes trailers if they exist.

Will ytrailers go get the trailers of movies that already have been added to the library, or do I have to scan the library to pick them up?

Link to comment
Share on other sites

4 hours ago, dcol said:

How long will this one last? Can't more permanent changes be made? MCM doesn't seem to have this issue.

You realize Google (YT) is doing this most likely on purpose for the very purpose of breaking things like this, right?

Link to comment
Share on other sites

40 minutes ago, ebr said:

You realize Google (YT) is doing this most likely on purpose for the very purpose of breaking things like this, right?

Hasn't broke MCM and there hasn't been an update to that program in a long time.

Link to comment
Share on other sites

plaidstallion

My youtube-dl instance running in a docker container works fine also and even a simple little bash script I improved on functions technically. TinyMediaManager sometimes has problems with youtube but can pull from some other sources instead. This plugin (when it works) is more consistent and of course automated though. ...Plus money was paid for this.

 

Also, thanks for the update. Testing now.

Edited by plaidstallion
Link to comment
Share on other sites

24 minutes ago, plaidstallion said:

My youtube-dl instance running in a docker container works fine also and even a simple little bash script I improved on functions technically. This plugin (when it works) is more consistent and of course automated though. ...Plus money was paid for this.

youtube-dl is updated regularly because older versions break for the same reason being discussed here.

https://stackoverflow.com/questions/63816790/youtube-dl-error-youtube-said-unable-to-extract-video-data

Edited by roaku
Link to comment
Share on other sites

plaidstallion

 

30 minutes ago, roaku said:

youtube-dl is updated regularly because older versions break for the same reason being discussed here.

https://stackoverflow.com/questions/63816790/youtube-dl-error-youtube-said-unable-to-extract-video-data

Fair enough. Tinymediamanager stays functional most of the time too though.

All of the other things mentioned are free...

Edited by plaidstallion
Link to comment
Share on other sites

plaidstallion
On 2/6/2021 at 4:25 PM, radeon said:

1.6.6.4 is just up now. ūüôā¬†

I dropped the new dll in the plugin folder last night and restarted my docker container. No go with automatic pulls or by manually activating the task.

Link to comment
Share on other sites

23 minutes ago, plaidstallion said:

I dropped the new dll in the plugin folder last night and restarted my docker container. No go with automatic pulls or by manually activating the task.

Any errors in the server log? 

 

Link to comment
Share on other sites

Ytrailers is erroring all over the place once again. Here is an example.This plugin is useless. Works for a day or so when an update comes in then errors. I am going to remove it for good this time. And don't use the excuse that YT changes things, because my other downloaders have no issues. Obviously the method of getting the trailer is wrong.

2021-02-12 09:09:20.493 Error App: YTrailers - Error
    *** Error Report ***
    Version: 4.6.0.22
    Command line: N:\Emby\system\EmbyServer.dll
    Operating system: Microsoft Windows 10.0.17763
    Framework: .NET Core 3.1.11
    OS/Process: x64/x64
    Runtime: N:/Emby/system/System.Private.CoreLib.dll
    Processor count: 16
    Data path: N:\Emby\programdata
    Application path: N:\Emby\system
    System.MissingMethodException: System.MissingMethodException: Method not found: 'MediaBrowser.Model.Entities.MediaUrl[] MediaBrowser.Controller.Entities.BaseItem.get_RemoteTrailers()'.
       at YTrailers.Search.YouTubeSearch.Search(BaseItem item, CancellationToken cancellationToken)
       at System.Runtime.CompilerServices.AsyncMethodBuilderCore.Start[TStateMachine](TStateMachine& stateMachine)
       at YTrailers.Search.YouTubeSearch.Search(BaseItem item, CancellationToken cancellationToken)
       at YTrailers.Search.LocalYTrailersVideoDownloader.GetYTrailerVideoUrl(BaseItem item, CancellationToken cancellationToken)
       at YTrailers.Search.LocalYTrailersVideoDownloader.DownloadYTrailerForItem(BaseItem item, CancellationToken cancellationToken, ILibraryManager libraryManager)
    Source: test
    TargetSite: Void MoveNext()
   

Link to comment
Share on other sites

6 minutes ago, dcol said:

Ytrailers is erroring all over the place once again. Here is an example.This plugin is useless. Works for a day or so when an update comes in then errors. I am going to remove it for good this time. And don't use the excuse that YT changes things, because my other downloaders have no issues. Obviously the method of getting the trailer is wrong.

2021-02-12 09:09:20.493 Error App: YTrailers - Error
    *** Error Report ***
    Version: 4.6.0.22
    Command line: N:\Emby\system\EmbyServer.dll
    Operating system: Microsoft Windows 10.0.17763
    Framework: .NET Core 3.1.11
    OS/Process: x64/x64
    Runtime: N:/Emby/system/System.Private.CoreLib.dll
    Processor count: 16
    Data path: N:\Emby\programdata
    Application path: N:\Emby\system
    System.MissingMethodException: System.MissingMethodException: Method not found: 'MediaBrowser.Model.Entities.MediaUrl[] MediaBrowser.Controller.Entities.BaseItem.get_RemoteTrailers()'.
       at YTrailers.Search.YouTubeSearch.Search(BaseItem item, CancellationToken cancellationToken)
       at System.Runtime.CompilerServices.AsyncMethodBuilderCore.Start[TStateMachine](TStateMachine& stateMachine)
       at YTrailers.Search.YouTubeSearch.Search(BaseItem item, CancellationToken cancellationToken)
       at YTrailers.Search.LocalYTrailersVideoDownloader.GetYTrailerVideoUrl(BaseItem item, CancellationToken cancellationToken)
       at YTrailers.Search.LocalYTrailersVideoDownloader.DownloadYTrailerForItem(BaseItem item, CancellationToken cancellationToken, ILibraryManager libraryManager)
    Source: test
    TargetSite: Void MoveNext()
   

Are you running Emby server Beta, or Stable? 

@radeon

 

  • Like 1
Link to comment
Share on other sites

18 minutes ago, dcol said:

Ytrailers is erroring all over the place once again. Here is an example.This plugin is useless. Works for a day or so when an update comes in then errors. I am going to remove it for good this time. And don't use the excuse that YT changes things, because my other downloaders have no issues. Obviously the method of getting the trailer is wrong.

2021-02-12 09:09:20.493 Error App: YTrailers - Error
    *** Error Report ***
    Version: 4.6.0.22
    Command line: N:\Emby\system\EmbyServer.dll
    Operating system: Microsoft Windows 10.0.17763
    Framework: .NET Core 3.1.11
    OS/Process: x64/x64
    Runtime: N:/Emby/system/System.Private.CoreLib.dll
    Processor count: 16
    Data path: N:\Emby\programdata
    Application path: N:\Emby\system
    System.MissingMethodException: System.MissingMethodException: Method not found: 'MediaBrowser.Model.Entities.MediaUrl[] MediaBrowser.Controller.Entities.BaseItem.get_RemoteTrailers()'.
       at YTrailers.Search.YouTubeSearch.Search(BaseItem item, CancellationToken cancellationToken)
       at System.Runtime.CompilerServices.AsyncMethodBuilderCore.Start[TStateMachine](TStateMachine& stateMachine)
       at YTrailers.Search.YouTubeSearch.Search(BaseItem item, CancellationToken cancellationToken)
       at YTrailers.Search.LocalYTrailersVideoDownloader.GetYTrailerVideoUrl(BaseItem item, CancellationToken cancellationToken)
       at YTrailers.Search.LocalYTrailersVideoDownloader.DownloadYTrailerForItem(BaseItem item, CancellationToken cancellationToken, ILibraryManager libraryManager)
    Source: test
    TargetSite: Void MoveNext()
   

It looks like you're seeing this error because you're running a non-release version of Emby that's made breaking API changes.

 

  • Like 1
Link to comment
Share on other sites

27 minutes ago, dcol said:

4.6.0.22 beta

I think @radeon and other plugin developers, tend to target the Stable releases, as the beta servers can easily break things.

Hopefully this is a simple fix, as it seems to be Emby related rather than YouTube, but I am no coder. 

Thanks. 

 

  • Like 1
Link to comment
Share on other sites

15 minutes ago, dcol said:

Had the same release when ytrailers was updated and working for a few days.

I'm telling you what the error message says.

Link to comment
Share on other sites

plaidstallion
1 hour ago, radeon said:

i dont support any betas

I run stable (latest) official docker container and having issues too. I haven't combed the logs yet.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...