Jump to content

Ytrailers not working?


Allan Cameron
 Share

Recommended Posts

Allan Cameron

I just did a fresh install windows 10 and ytrailers seams to do nothing.

 

I run it and it just finishes right away. Maybe my key is no longer good? Not sure why if that's the case. I bought one twice already.

 

Thanks

Edited by Allan Cameron
Link to comment
Share on other sites

Allan Cameron

Hey, Pm me a debug log after it's been run and I'll take a look

 

Thanks, Message set

Link to comment
Share on other sites

Last resort have you tried email via the product email.

 

Don't have this plugin but this does not look right.

2020-03-21 19:06:58.014 Info App: YTrailers Key: null

2020-03-21 19:06:58.562 Info App: YTrailers Registration Status - Registered?: False - Too few parameters set
  • Like 1
Link to comment
Share on other sites

Allan Cameron

 

Last resort have you tried email via the product email.

 

Don't have this plugin but this does not look right.

2020-03-21 19:06:58.014 Info App: YTrailers Key: null

2020-03-21 19:06:58.562 Info App: YTrailers Registration Status - Registered?: False - Too few parameters set

 

I have only sent him a PM here as he asked me to. I don't think he's on here often.

Thanks H2P.. will send him an email from his website tomorrow if i don't hear anything by then.

Right now i am having to use TinyMediaManager to grab trailers. Works well and is free software but would be nice to get this working so its all in one place... Emby!

Edited by Allan Cameron
  • Like 1
Link to comment
Share on other sites

Heya, sorry, been a bit mad with all this covid stuff. Rolling out new systems etc.

 

That looks to me like you haven't entered your licence key

Link to comment
Share on other sites

Allan Cameron

Heya, sorry, been a bit mad with all this covid stuff. Rolling out new systems etc.

 

That looks to me like you haven't entered your licence key

 

But i have, i sent you my info i enter.

 

post-532-0-01656200-1585578091_thumb.jpg

 

If you keep records you will see i have bought a  licence key twice after the last big update you made when the server made some big changes.

Whats the next step? Can you give me another key to try?

Edited by Allan Cameron
Link to comment
Share on other sites

  • 6 months later...

I haven't seen YTrailers working for a few weeks now. Is there an update?

I tried forcing Ytrailers in Scheduled tasks? Library scan doesn't seem to do it. There should be a manual way to retrieve a trailer.

Edited by dcol
Link to comment
Share on other sites

I noticed that ytrailers.dll was not in the plugin folder anymore. Guess that's why it wasn't working.

Thanks for the update

Link to comment
Share on other sites

Ytrailers is still not working. Had to get the latest 10 movies manually from youtube. Tried a library scan, scheduled scan, restart. Still not working.

Link to comment
Share on other sites

13 hours ago, dcol said:

Ytrailers is still not working. Had to get the latest 10 movies manually from youtube. Tried a library scan, scheduled scan, restart. Still not working.

Works absolutely fine for me. Have you updated from the site manually? You need to be posting debug logs if you want decent help. 

Link to comment
Share on other sites

I may have placed the dll in the wrong plugin folder causing the latest update to delete it. It is in the programdata/plugin folder now. I will see if that was the issue.

Shame that your plugin cannot be included in the regular plugins catalog.

Thanks

Link to comment
Share on other sites

  • 1 month later...

ytrailers not working again @radeon

Here is what I get over and over again in the logs for every movie

2020-12-05 02:04:52.660 Error App: Error downloading trailer for New York Stories
    *** Error Report ***
    Version: 4.6.0.6
    Command line: C:\Emby\system\EmbyServer.dll
    Operating system: Microsoft Windows 10.0.17763
    Framework: .NET Core 3.1.8
    OS/Process: x64/x64
    Runtime: C:/Emby/system/System.Private.CoreLib.dll
    Processor count: 16
    Data path: C:\Emby\programdata
    Application path: C:\Emby\system
    System.Net.Http.HttpRequestException: System.Net.Http.HttpRequestException: Response status code does not indicate success: 429 (Too Many Requests).
       at System.Net.Http.HttpResponseMessage.EnsureSuccessStatusCode()
       at System.Net.Http.HttpClient.GetStringAsyncCore(Task`1 getTask)
       at VideoLibrary.YouTube.GetAllVideosAsync(String videoUri, Func`2 sourceFactory)
       at VideoLibrary.ServiceBase`1.GetAllVideosAsync(String videoUri)
       at VideoLibrary.ServiceBase`1.GetAllVideos(String videoUri)
       at YoutubeExtractor.DownloadUrlResolver.GetDownloadUrls(String videoUrl, Boolean decryptSignature)
       at YTrailers.Search.YouTubeSearch.Search(BaseItem item, CancellationToken cancellationToken)
    Source: System.Net.Http
    TargetSite: System.Net.Http.HttpResponseMessage EnsureSuccessStatusCode()

Link to comment
Share on other sites

Error means the requests needs to be throttled as to many requests gets your ip blocked for x amount of time.  Luke had to do the same thing in the TMDB plugin.

Edited by Happy2Play
Link to comment
Share on other sites

Do you mean that ytrailers made too many youtube requests? It does seem as though some of the movies did in fact have a trailer. There are some movies that just don't have a trailer and it seems the requests for those are repeated.

Link to comment
Share on other sites

1 minute ago, dcol said:

Do you mean that ytrailers made too many youtube requests? It does seem as though some of the movies did in fact have a trailer. There are some movies that just don't have a trailer and it seems the requests for those are repeated.

I don't know exactly how the plugin gets the trailer url but can assume directly for TMDB or from already fetched metadata (but if it were your already fetched metadata there would be no limit), don't believe YouTube is queried at all.  But I have only experienced that error from TMDB. 

Link to comment
Share on other sites

I think this error is a result of a ytrailer request to where ever not TMDB. There were 100's of them yesterday. I don't think this is normal.

Link to comment
Share on other sites

But all this plugin is doing in using the user applied YouTube trailer assigning on TMDB.  So a request throttle will have to be added so you are not spamming.

Link to comment
Share on other sites

There already is a throttle in place. I'm assuming YouTube have just changed their limits or something. They change a lot, a lot of the time. 

 

@Happy2Play is bang on the money, I don't make any requests to tmdb, I just use the already existing data within emby for YouTube trailers. 

The plugin won't be making requests if their isn't a trailer listed against a given movie. The only possibility is invalid YouTube trailers against the movies. 

The other thing is it's throttled per run but if you're running the plugin every hour then you're likely to trigger the limit that way. Just have it set to run once daily or even weekly. The new item detection will pick up your new movies as they're added. 

Another thing is that's all assuming something else on your network isn't slamming YouTube like a Kodi plugin or something. 

I run this plugin on my live emby server and am not having this issue. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...