Jump to content

Archive - Samsung Smart TV App - Public Alpha Test


chessdragon136

Recommended Posts

chessdragon136

New version - v0.340 released: @@c0m3r @@CBers

  • Correct model number should show in dashboard
  • Users can now enter a hostname instead of an IP -> For users who want to change the setting you need to run the app, and on the Users page press the BLUE button - this should quit the app, and you can relaunch it and re-enter your server settings. If it does not exit, you must manually exit the app - DO NOT LOG IN - PLEASE LET ME KNOW if the blue button does NOT exit the app..

Please note I have not done any design work for people using this app with a server that is NOT in the local area network. I do not know if it works, and there are no transcoding profiles so I can't imagine playback will be nice either... 

 

And before anyone asks, I CANNOT under any circumstances that I currently know of use a full qwerty keyboard. That is why, just like users passwords, they are saved so you only go through the initial pain once. sorry but it is the best I can do. 

 

Lost of caps there, sorry.. 

Edited by chessdragon136
  • Like 3
Link to post
Share on other sites

Not sure Genres are working correctly, at least for me.

 

This is what is displayed for TV and Movies:

 

IMG_20140331_210237.jpg

 

IMG_20140331_210259.jpg

 

I think the numbers (172, 192, 152) relate to the Movies in each Genre, as they appear in the Dashboard:

 

Capture843.jpg

 

So looks like just the images aren't being displayed.

Edited by CBers
Link to post
Share on other sites
chessdragon136

Ok think I have the culprit - Re-update please and let me know -> Have added a reference screenshot

 

Also, is your Main Menu bar always stuck to the bottom of the menu like that (compare to my screens for compare)

 

Sorry

Edited by chessdragon136
Link to post
Share on other sites

Are you connecting to a server outside your local area network then? Must admit I haven't tested that this would work - If not just assign the local ip address of the server..

And yes I can try create a toggle between ip and URI entry but I don't know how Javascript handles external connections (usually blocks them)

 

All of the ones in my home are local obviously but I have been playing with getting it set up for my brother. Working quite well in main apps and wanted to give it a go with this.

 

EDIT - thanks for the update, will give it a whirl.

Edited by c0m3r
Link to post
Share on other sites
chessdragon136

Another New Version - v0.350

  • Genre views are now implemented (And it contains my first attempt at a graphic! Go check it out lol)

Enjoy

Edited by chessdragon136
  • Like 1
Link to post
Share on other sites
chessdragon136

Ok Thanks

 

And look at the below - Your menu items are rooted to the bottom of the menu bar area where mine hover vertically centrally

Is it like that on all your pages? 

 

5339de700679b_Untitled.png

Link to post
Share on other sites
coolspot

I got this installed and it worked well in the quick test I did of video playback.  I had a couple initial problems during setup.  The first has already been solved after reading through the rest of the posts, but I had to go into the Tools menu to find the Developer menu as my blue D button didn't do anything.  No biggie.

 

I did have some problems with password entry, and I'm not sure if this is more of a samsung problem or what.  I had problems using the default password entry as I would push a "7" for "r".  A list of letters and words  appeared across the top and I would push the "enter" button "between the four arrow keys to select "r" and it just started back over.  Not choosing the "r".   I ended up finding I could change my password entry to use the old cellphone text method of pushing the 7 four times to get the "r" and got my password entered correctly"

 

Hope I explained that well enough.

Link to post
Share on other sites
ginjaninja

@@chessdragon136

Great to see you are developing a samsung client, thank you. I will test it out this weekend if the developer install works on my 2012 e series.

If not, could be the reason I need to splash out on evolution kit.

For all our sakes I wish you all the best on this project. Made my week this has. And its only tuesday!

 

 

Sent from my GT-I9505 using Tapatalk

Link to post
Share on other sites
gillmacca

Having a problem with my password. My password contains a zero, but when i press zero on my remote, it just enters a space, no menu appears at the top for zero

Link to post
Share on other sites

Having a problem with my password. My password contains a zero, but when i press zero on my remote, it just enters a space, no menu appears at the top for zero

you have to press TTX/MIX to change input type to numeric

 

@chessdragon - excellent editions to the app! it's coming on nicely!!! :-D

Edited by Rowlett
Link to post
Share on other sites
chessdragon136

I did have some problems with password entry, and I'm not sure if this is more of a samsung problem or what.  I had problems using the default password entry as I would push a "7" for "r".  A list of letters and words  appeared across the top and I would push the "enter" button "between the four arrow keys to select "r" and it just started back over.  Not choosing the "r".   I ended up finding I could change my password entry to use the old cellphone text method of pushing the 7 four times to get the "r" and got my password entered correctly"

 

Hope I explained that well enough.

 

Honestly, I'm still a bit confused -> Any chance of a photo or two showing this please? It sounds like a Samsung problem but I'm not 100% sure

Link to post
Share on other sites

Ok Thanks

 

And look at the below - Your menu items are rooted to the bottom of the menu bar area where mine hover vertically centrally

Is it like that on all your pages? 

 

5339de700679b_Untitled.png

 

The placement of the menu on mine is the same as CBers,at the bottom.

 

All files are playing fine but I presume you cannot get DTS audio playing through the app.

  • Like 1
Link to post
Share on other sites

All files are playing fine but I presume you cannot get DTS audio playing through the app.

I think that info display should be better utilized to show played content information, such as bitrate, and output audio type

 

Sent from my HTC Butterfly using Tapatalk

Link to post
Share on other sites
chessdragon136

DTS Audio - what currently happens, does the file play with no audio or not play at all or something else?

Can you also provide me the Audio Codec Specs from the web interface please.

Link to post
Share on other sites

All files are playing fine but I presume you cannot get DTS audio playing through the app.

I have DTS playing through the app.

 

I think the TV just converts it to stereo though, as that's what my Sonos PlayBar sees it as.

Link to post
Share on other sites

DTS Audio - what currently happens, does the file play with no audio or not play at all or something else?

Can you also provide me the Audio Codec Specs from the web interface please.

 

Yes DTS plays with the audio coming through as only 2 channel pcm 

 

Audio Info:
 
Language eng

Codec DCA

Profile DTS

Layout 5.1

Bitrate 1536 kbps

Sample Rate 48000 khz

Default Yes

 

Dolby Digital 5.1 comes through ok.

Edited by Yogi
Link to post
Share on other sites

@@chessdragon136 - just noticed that I don't get the green circles with the number count in, as per your genre image - should I?

 

Also, there's no WATCHED indicator - will that come in time?

Link to post
Share on other sites
chessdragon136

@@Yogi - That is good. I have just tried to implement DTS and sadly I have no idea if it works. Can you update the app and play the file, then whilst playing hit info. I need to know all that is there please  - Thank you

 

@@CBers -> Yes you should see it.. Are the numbers anywhere on the screen (they were in your previous screenshots when the background image wasnt working..) 

Link to post
Share on other sites

@@CBers -> Yes you should see it.. Are the numbers anywhere on the screen (they were in your previous screenshots when the background image wasnt working..)

Yes, the numbers are in the genre display, but no green circle background.

 

What about WATCHED status?

Link to post
Share on other sites
chessdragon136

Are the numbers in the right place - top right? - New version pushed out so try that, but i'm doubtful it will work.

 

And watched isn't in yet, nor any other indicators - not much point if I cant make this one work! 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...