Jump to content

Archive - Samsung Smart TV App - Public Alpha Test


chessdragon136

Recommended Posts

chessdragon136

Recognition

Before I get into all the details I just wanted to say thanks to the following people who have been instrumental in the app so far in terms of support and technical knowledge:

@@Tikuf @@CBers @@Luke @@AdrianW @@DaN @@Rowlett @@7illusions @@Cheesegeezer

 

Need to Know Information before Use

This is an alpha version of the program I have been developing for the last 4 months or so. As such do not expect much to work, expect crashes, and expect many bugs.. I have tested this myself an believe it to be stable but I can only test so much.

 

There are also many things not implemented / supported!

 

Requirements:

A Samsung TV / DVD / Bluray Player (Anything which has Samsung's Smart Hub) 

Supported Devices - TV's / Samsung Smart Devices with Smart Hub D series (2011) and up (C Series WILL CRASH the TV

 

Install procedure

On the Samsung device load up the Smart Hub and press red to login, and login with the details "develop", password "000000" -> Once logged in, press the blue button and there should be a developer menu. In there select "Setting Server IP" and it will ask for an IP address, enter the IP 92.232.122.228 Once that's done select "User Application Synchronisation" and hopefully it will connect and download my app to the tv. If the above doesnt work, try the below (Thanks AdrianW)

 

The setup on my TV (F-series plasma) was slightly different - here's the steps:

  • Open the main menu and scroll down to "Smart Features" and press enter
  • Select "Samsung Account"
  • Select "Log In"
  • In the Email field enter "develop" - no need to enter a password (the password field is inaccessible)
  • Press Login
  • Exit from the menu
  • Press the Smart Hub button on the remote and scroll to Apps
  • Select "More Apps" (at the bottom of the screen)
  • Select "Options" at the top right
  • Select "IP Setting"
  • Enter the IP address
  • Exit and then select "Start App Sync" from the Options menu - this will download the app 
  • Once the app has downloaded it will appear on the "More Apps" screen
  • Select the App
  • You will then have to enter your MB Server's IP address and port number (these are visible on MBT's Network settings page and on the  Advanced tab of MBC's config page).

Reporting

  • Please post in this thread - Use the reference images 2 posts below to compare what you see to what I have if you have any questions...
  • I will keep a list of reported bugs in the next post - Please check this before reporting. 
  • Please detail your TV Model & File Information (Can be found using the web interface of MB3 from a PC), and screenshots and or the key presses entered to generate the fault where appropriate.
  • Make your posts easy to read - Will result in me making faster fixes
  • If you want to request Features you are welcome but in honesty I am still at an early stage in this so they may take a long time to come in.. 
  • I WILL NOT RESPOND TO PM's

Keys & Useful Info

  • Pressing the INFO button will show a very quickly made help page which lists most key presses I could remember! 
  • Pressing the TOOLS button will get you to the top tool bar (Think I may have actually forgotten to mention that in my help pages!!

I won't say much more than that as I want to use this test as a user test to see if the Key mappings I have done match what people expect...

 

Thank you for testing! 

Edited by chessdragon136
  • Like 20
Link to post
Share on other sites
chessdragon136

How the hell @@Luke - Are you a robot? I couldn't even get my reserved posts in before you! (Thanks for the edit Luke)

 

And I didn't until last night when I realised I need to test with many many users the code I have, but I am pretty confident it is stable.

Also it seems it will take me a long long time to get it onto the Samsung marketplace (I'm talking 3-6 months once my code is finalised, so that Idea went out the window) 

Edited by chessdragon136
  • Like 1
Link to post
Share on other sites

How the hell @@Luke - Are you a robot? I couldn't even get my reserved posts in before you! 

 

And I didn't until last night when I realised I need to test with many many users the code I have, but I am pretty confident it is stable.

Also it seems it will take me a long long time to get it onto the Samsung marketplace (I'm talking 3-6 months once my code is finalised, so that Idea went out the window) 

 

I moved my post so you can have your reserved spots :)

  • Like 1
Link to post
Share on other sites

Hi guys,

 

I'm pleasantly surprised by this Alpha release! I really mean this. I followed the install procedure of AdrianW and MediaBrowser 3 for Samsung installed flawless. Of course it's alpha and a lot have to be done but it looks very promising! I think I have to find how this all works. I'm not familiar with MediaBrowser Server. I'm a Plex user at the moment but I'm following this project a bit. Chessdragon136 congratulations on your alpha release!    

  • Like 1
Link to post
Share on other sites

This is great news (except for the samsung store issue). Well done on getting to this stage so quickly and looking forward to future updates.

Link to post
Share on other sites
rickster53

I'm able to login with the "develop" id and password, but hitting the blue button on my Samsung remote after that does not do anything---ie. no developer menu.  I have a Samsung model UN60ES8000 TV and MB identifies it as an E/F-series on the dashboard.  Any suggestions?

 

EDIT: Just wanted to add that MB3 DLNA Push To works with this TV as does Samsung's Allshare which allows me to pull content from my PC...

Edited by rickster53
Link to post
Share on other sites
rickster53

Have you tried the other instructions listed underneath?

yes, but the alternate instructions don't seem to apply to my TV as I don't have a "Smart Features" option anywhere in my Main Menu

Link to post
Share on other sites
chessdragon136

The only other one I know of is to go to the Smart Hub, press Red (Login) and then Blue (Settings)?

Link to post
Share on other sites
rickster53

The only other one I know of is to go to the Smart Hub, press Red (Login) and then Blue (Settings)?

... as I mentioned I could login to "develop" via Smart Hub and red login button.  After login, it says "develop" is logged in and I have Red (login.logout) Green (wallpaper) and Yellow (account management) icons at the bottom of the Smart Hub screen.  A blue icon is not present nor does hitting the blue button on the remote do anything.  Probably something unique with my TV...

 

EDIT:  This model TV was releasd in March 2012 and I purchased it in May of that year...

Edited by rickster53
Link to post
Share on other sites
chessdragon136

I think you need to have a google and see if you can find any instructions - SamyGo is the best place for it...

My only other suggestion is to logout of develop and login with develop and password 111111

 

Sadly I don't own an E series TV so I'm having difficulties diagnosing - @@Yogi If you would be so kind and have the time can you try please and report back? (It was you who had the E series wasn't it, if not -> Sorry!)

Edited by chessdragon136
Link to post
Share on other sites
rickster53

Password 111111 behaves the same as 000000---so no luck with that.  My initial Google of this turned up a step by step instruction manual for Samsung developers here http://www.samsungdforum.com/Guide/art00013/index.html   

 

If you scroll down the document it's plain to see that there's a Blue button (D) for Settings which never shows up on my Smart Hub screen and the layout of my screen seems to be slightly different too.  Perhaps all Smart Hubs are not CREATED equally!  I'll keep poking around to see if I can find anything out.  In the mean time, perhaps Yogi or some other E-series users can chime in on how they're doing...  By the way my software version is 1054 which is the latest for my TV.

 

Thanks for trying to help out!  I was really psyched about what you've done and I'm sure this will be solved at some point...

Link to post
Share on other sites
chessdragon136

Well hopefully @@Yogi can help out -> Else just try for yourself hitting all possible buttons as it will be there somewhere, it must be 

The documentation you linked is for 2011 (D series) tv's, which is what I have, and the alternate instructions I know work for F series.. Samsung change their smart hub yearly it seems..

 

Do keep an eye on here and If I find anything I'll try remember to tag you in the post.

 

Sorry I can't help you out. 

Link to post
Share on other sites
chessdragon136

Collections are not supported yet :( I didn't know they would show up under Movies? 

Is this navigation from a Media Collection, the Movies Main Menu bar, or both please?

Link to post
Share on other sites

Collections are not supported yet :( I didn't know they would show up under Movies?

Is this navigation from a Media Collection, the Movies Main Menu bar, or both please?

Both.

Link to post
Share on other sites
chessdragon136

Ok is fixed for next release (Not saying its supported just that when navigating it will show films as films and ignore collections (as it should be for those views anyway)

  • Like 1
Link to post
Share on other sites

Only 6 items displayed on latest TV and Movies. Is that by design?

 

I have movies missing from a Media Folder that are shown in the Dashboard. Images to follow.

 

I have the Pixie Hollow Games and The Pirate Fairy movies in my Kids Movies folder.

 

They appear in the Dashboard:

 

Screenshot_2014-03-30-20-17-18.png

 

but not in the Smart app:

 

IMG_20140330_201814.jpg

 

I haven't checked all movies again all folders, but the missing movies are part of a collection so perhaps there's a connection.

 

TIA

 

.

Edited by CBers
Link to post
Share on other sites

@@chessdragon136 and @@rickster53 I will have a look later today after work and report back with some findings.

 

The last version was all working fine,I could login and navigate around using all buttons ok,anything in particular that needs testing.

Edited by Yogi
Link to post
Share on other sites

 Thanks for the app works great on MKV files. Other than the inability to play DVD rips  Video_TS folders.  Hopefully it will be a feature added in the future. Thanks again

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...