Jump to content

Emby Asustor Package


Luke
 Share

Recommended Posts

I tried a new approach and installed Emby on my Ubuntu Server Virtual Machine. Almost exactly the same happens here, if I add the photo library. It seems Emby doesn't like some .jpg files and some .mov files. But I can see no pattern, it takes photos from the same day made with the same camera without problems. And on my Ubuntu server there is not this "Error creating port map" every 10 Minutes.

If you want to have one of the jpgs, Emby doesn't like - no Problem, just pm me an email where to send to.

Best regards and I hope my investigation supports your efforts in developing this great software!

Link to comment
Share on other sites

I mean like described in post #75 - but here another example from the ubuntu version:

2017-10-07 13:43:33.650 Error App: Image Provider - Error reading image tag for /media/fotos/2009-Privat/2009-06-Bochum/IMG_0262.JPG
	*** Error Report ***
	Version: 3.2.33.0
	Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -restartpath /usr/lib/emby-server/restart.sh
	Operating system: Unix 4.10.0.35
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: False
	Mono: 4.8.1 (Stable 4.8.1.0/22a39d7 Wed May  3 05:22:31 UTC 2017)
	Processor count: 1
	Program data path: /var/lib/emby-server
	Application directory: /usr/lib/emby-server/bin
	System.Exception: Cannot change named node
	  at TagLib.File.Create (TagLib.File+IFileAbstraction abstraction, System.String mimetype, TagLib.ReadStyle propertiesStyle) [0x0010d] in <97ad579930424cb99e555e6c2b8e514a>:0 
	  at TagLib.File.Create (TagLib.File+IFileAbstraction abstraction) [0x00000] in <97ad579930424cb99e555e6c2b8e514a>:0 
	  at Emby.Photos.PhotoProvider.FetchAsync (MediaBrowser.Controller.Entities.Photo item, MediaBrowser.Controller.Providers.MetadataRefreshOptions options, System.Threading.CancellationToken cancellationToken) [0x0005d] in <88c13529ac7f4287a538d66198f82e03>:0 
	System.Exception
	  at TagLib.File.Create (TagLib.File+IFileAbstraction abstraction, System.String mimetype, TagLib.ReadStyle propertiesStyle) [0x0010d] in <97ad579930424cb99e555e6c2b8e514a>:0 
	  at TagLib.File.Create (TagLib.File+IFileAbstraction abstraction) [0x00000] in <97ad579930424cb99e555e6c2b8e514a>:0 
	  at Emby.Photos.PhotoProvider.FetchAsync (MediaBrowser.Controller.Entities.Photo item, MediaBrowser.Controller.Providers.MetadataRefreshOptions options, System.Threading.CancellationToken cancellationToken) [0x0005d] in <88c13529ac7f4287a538d66198f82e03>:0 
Link to comment
Share on other sites

 

In other news, your Emby Server will notify you of new stable releases, but if you'd like to try beta builds you can grab them from github: https://github.com/MediaBrowser/Emby/releases

 

The latest build comes with an exciting improvement - VA API hardware transcoding support.
 
Important - when enabling this you may need to update the the VA API device setting to it's new default value:
/dev/dri/renderD128

 

Just tested emby-server-asustor_3.2.33.4_x64.apk and have some comments and minor errors.

 

Info: VA API settings need to be updated for a upgrade. The settings is correct for a fresh new installation.

 

Under new installation: Add TV library --> Season 0 display name. Please give some help text for the purpose of the field.

 

Looked into the translation of the Danish language file da.json. Several text entry are reset to English from v3.2.30.25 to v3.2.33.4. Possible reason are corrections of the English text. Is that correct, else there are some error.

 

 

For the control/control.json file: To be compliant with Asustor Developer's Guide the used ports must be listed in the "register", "port" section. The section need to be updated to "T8096,T8920".

 

For the problem with saving data in APKG_PKG_DIR under a upgrade, use the upgrade section in pre-uninstall.sh script to copy data to APKG_TEMP_DIR. Then use post-install.sh to copy the data back. This is only for data saved in APKG_PKG_DIR.

 

Missing some information for a uninstall with total cleanup of the user and group Emby.

 

Do you want the issues here, on Github or both places?

 

@@Luke

Link to comment
Share on other sites

 

 

Info: VA API settings need to be updated for a upgrade. The settings is correct for a fresh new installation.

 

FYI - we're not really worried about this because it only affects the small handful of people in this topic who installed the testing builds. I mentioned earlier that you'd need to manually update the setting in order to use VA API.

Link to comment
Share on other sites

 

 

 Several text entry are reset to English from v3.2.30.25 to v3.2.33.4. Possible reason are corrections of the English text. Is that correct,

 

yes that is correct and they need to be translated again by the translators.

Link to comment
Share on other sites

  • 3 weeks later...

Emby Server 3.2.34 for Asustor is up for download on our website. As part of our promise, Asustor builds are immediately available following the new release. 


 


Enjoy.


Link to comment
Share on other sites

Is there a tutorial how to update? do i have to do this manually?

 

You just install the .apk again. We are trying to get this released into the asustor app store. thanks.

Link to comment
Share on other sites

freeflight29

hello

 

i've just installed emby-server-asustor_3.2.35.0_x64 on my as6404t, i encounter the same issue. emby server not reachable after less than 1 or 2 min. Then i have to turn off and turn on the app and the server is reachable for a few moment.

i thought i've read something about how to collect log. i will search and post them if it can help ? 

 

Thanks

server-63645084034.txt

Edited by freeflight29
Link to comment
Share on other sites

hello

 

i've just installed emby-server-asustor_3.2.35.0_x64 on my as6404t, i encounter the same issue. emby server not reachable after less than 1 or 2 min. Then i have to turn off and turn on the app and the server is reachable for a few moment.

i thought i've read something about how to collect log. i will search and post them if it can help ? 

 

Thanks

 

yes you can learn how to grab an emby server log here:

https://emby.media/community/index.php?/topic/739-how-to-report-a-problem/

 

Thanks.

Link to comment
Share on other sites

Emby Server 3.2.36 for Asustor is up for download on our website. As part of our promise, Asustor builds are immediately available following the new release. 


 


Enjoy.


Link to comment
Share on other sites

freeflight29

 

Emby Server 3.2.36 for Asustor is up for download on our website. As part of our promise, Asustor builds are immediately available following the new release. 

 

Enjoy.

 

Hello,

 

i would to enjoy but i have the same issue, emby worked a few moment and came inaccessible. AS6404T with Emby Server 3.2.36 for Asustor.

when i restart the app emby is accessible again for a few moment and unreachable.

 

regards

server-63645259590.txt

Edited by freeflight29
Link to comment
Share on other sites

freeflight29

Please attach a log from 3.2.36, thanks.

i didn't know if it's the right log, i take it from "expert" admnistration interface.

 

i see that i have to connect with my root account and go to the path /volume1/.@plugins/AppCentral/mediabrowser/bin/ProgramData-Server/logs

the probleme is i haven't the folder "mediabrowser" ..... see attachment 

 

Could you tell me if it's the right path ? (sorry but i'm beginner)

post-244236-0-58535000-1509661703_thumb.png

Edited by freeflight29
Link to comment
Share on other sites

freeflight29

ok, 

 

this time i take it the log from "/home/emby/log" and i activate debuging

 

the situation: 

 

1- i uninstall  old emby version with the asustor user interface 

2- i delete the folder emby server "/volume1/.@plugins/AppCentral/emby-server"

3- i install latest emby version 3.2.36

4- emby stop working after a few moment

5- i copy the log from "/home/emby/log"

 

i hope it could help.

 

ps1: is it normal ? when i delete emby '/volume1/.@plugins/AppCentral/emby-server", when i reinstall emby, i haven't the initial setup, it's like there is all information and configuration still there.

 

ps2: when i go to appcentral in all application and search emby i have the 3.2.32.0 version "installed" and i can't remove it via app central. is it normal ? it"s a screen bug i reinstall 3.2.36 and i saw in "all apps" version 3.2.32 "installing"

server-63645000445.txt

post-244236-0-16913100-1509664475_thumb.png

Edited by freeflight29
Link to comment
Share on other sites

That log is actually still from 3.2.35. Try grabbing the update again from the website. Refresh the page in your browser just in case. thanks.

Link to comment
Share on other sites

 

Emby Server 3.2.36 for Asustor is up for download on our website. As part of our promise, Asustor builds are immediately available following the new release. 

 

Enjoy.

 

Thanks.

 

I got the version from Asustor, just popped up in the App Central as an update.

 

Needed to restart the NAS. Most likely from older versions. Will try a fresh install from App Central tomorrow.

Link to comment
Share on other sites

What version was in app Central? We have submitted our new package to try and replace the one that Asustor was providing themselves. Thanks.

Link to comment
Share on other sites

freeflight29

What version was in app Central? We have submitted our new package to try and replace the one that Asustor was providing themselves. Thanks.

hello,

 

This the 3.2.36 version.

 

thanks

post-244236-0-88869400-1509743344_thumb.png

Edited by freeflight29
Link to comment
Share on other sites

freeflight29

hello,

 

i tried de make a clean install so i :

 

1 - uninstall the 3.2.36 then the 3.2.25-r1 version 

2 - connect with winscp with root account

3 - delete the folder volume1/home/emby

4 - delete the folder /volume1/.@plugins/AppCentral/emby-server

5 - reinstall the 3.2.26 one

 

the emby server is unreachable

 

i uninstall the  3.2.26 and reinstall the 3.2.25-r1 and it's working with the 3.2.25-r1 but to old to work with the android app so i'm stuck....

Edited by freeflight29
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...