Jump to content

ASS/SSA subtitles not playing nice with Android/iOS/KODI


barat
 Share

Recommended Posts

barat

Hi,

 

As @@Luke asked for logs here - I'm making this thread in Synology section since I'm using server on DS916+

I have a problem with external ass subs.

Tried few clients (server restart before, tested in that order - might be useful info while reading logs), and that's what I've got:

 

Windows:
  • Emby Theater: ASS ok, Direct Playing
  • Chrome - ASS ok, Direct Streaming, F11 fullscreen OK
 
Raspberry:
  • Emby for Kodi- ASS shows, but no formating/color
  • Kodi directly from NAS share - ASS OK - just to check, that Pi/Kodi itself can handle it
 
Android:
  • App: Not playing movie at all - movie not starting, som other plays ok, and once after trying others tested file started but only with English subs, and after closing it - again not starting ...
  • Chrome: ASS OK, Direct Streaming, Fullscreen OK
  • VLC directly from NAS share without Emby - ASS OK
 
Ipad
  • App - transcoding 3.2 Mbps, no subs, even embedded English are not working
  • Chrome - Direct Streaming, ASS works, but not on fullscreen (I know, that subs in browser is some kind of hack - Luke explained me already in different thread)
  • Safari - same as Chrome
  • Ipad VLC directly from NAS - Video plays, I see english subs, but external ass are not available (no on list)
All tests made on same video file, transcoding in server set to not using VA API - only software.
Bellow I attach logs from this debug session.
If this will help, I can send link to tested video/subs (it's less than 300mb)

ffmpeg-remux-2b9e70bb-7c04-4f5d-8fad-b45472958b51.txt

ffmpeg-remux-20af0644-03d6-47aa-9c37-51620505dd21.txt

ffmpeg-remux-923d313f-12c8-4b5e-821d-633a37c9e8e1.txt

ffmpeg-remux-abc20902-069f-400a-a4d9-00a13c17bd83.txt

ffmpeg-remux-abf09d87-c4b6-4b74-b04f-b2c0674e7d8a.txt

ffmpeg-transcode-7ed88e21-482c-4990-b358-669f78c3df2e.txt

ffmpeg-transcode-1223dba0-0ba2-4da7-a12c-afa53a1a40cf.txt

ffmpeg-transcode-bcb65f5a-7982-414a-8685-07aa9ef18ee7.txt

server-63635074186.txt

server-63635117859.txt

Edited by barat
Link to comment
Share on other sites

barat

server-*4186 is before restart (added it just in case), server-*7859 is for all the cases... ffmpeg was just generated onebyone so I suppose that those are in order.

I was thinking, that in ffmeg logs there will be info about device. If you're not logging client device name then I'll try to make tests again and each tame save logs after scenario.

Edited by barat
Link to comment
Share on other sites

barat

Thanks ... hope that Android and iOS team can look at it as well, since this is problematic as well.

If You want, I can add Amazon Cloud Drive link to video on which I was testing.

Edited by barat
Link to comment
Share on other sites

barat

Send you over PM - I don't like to paste links to my Amazon Cloud Drive over the internet :)

Link to comment
Share on other sites

I tested this file in iOS. It is currently working just fine for me except for the fact that the subtitles are being burned in with transcoding. That is resolved for the next release of the app. However, there is one quirk due to an apple defect. The size and position is determined when the subtitles are enabled. If you rotate the device to change orientation, they will still be positioned based on the previous orientation. I'm looking for a hack or workaround but I don't want to hold up releasing a new version too much longer.

 

On android I do see some problems, they are resolved for the next release, however, the styles of the external .ass are not currently preserved. That's our defect and we'll resolve it in a future update. But it will at least play without any problems. thanks.

  • Like 1
Link to comment
Share on other sites

barat

Thanks, so now I need to wait for new Android/iOS apps, plus info from KODI addon team?

 

 

BTW. Is there a chance that VA API in DS916+ won't be crashing with ass/ssa? We had discussion about it while away:

https://emby.media/community/index.php?/topic/47312-ipad-app-no-playback-safari-and-android-ok/

 

Transcoding is OK ... but using hardware one would be awesome :)

 

Ah ... for iOS hack - maybe iOS is sending some event when rotating screen? Then on rotation there may be stop=>play? Feels like hack, but who knows? 

Link to comment
Share on other sites

barat

Thanks @@Angelblue05 ... realise will be in 1-2 weeks? If so, I can wait and no need to use "beta" :) For KODI it's not that critical since I see subs, only styles are missing.

Link to comment
Share on other sites

Angelblue05

Working on it as quickly as I can :) Unfortunately I haven't had as much free time as I'd want so I can't really give you a timeframe. But asap is my goal.

  • Like 1
Link to comment
Share on other sites

barat

@@Luke - just want to inform, that today I've updated Emby for iOS to 1.4.0 ... now ASS/SSA (external and inside mkv) plays fine, dashboard inform about Direct Streaming, and in logs there is info about remux (not transcoding) ... cpu usage is around 25% so it works pretty nice ... thanks :) I've tested it with software transcoding ... will try with VA API later. Server is 3.2.25.0-1 for Synology

 

Now lets wait for Android/Kodi :)

Edited by barat
Link to comment
Share on other sites

barat

Just want to confirm, that Android Mobile on HTC M8 (Marshmallow) displays ass/ssa (but without styles as @@Luke mentioned). Synchro is good, even after playing with timeline slider (with Chrome tv.emby.media subs lost sync). At least now Emby App for Android is usable.

Now I'm just waiting for Emby for Kodi release which wont be defaulting to srt :)

 

Thanks, because you're making a good job :)

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...