Jump to content

Ubuntu


Luke

Recommended Posts

Hi there, please attach the complete emby server log, thanks.

 

I have attached the log that kills the server when running the library scan

Log.txt

Link to comment
Share on other sites

The CoverArt Plugin crashes emby on ubuntu 18.04 for me on the same images over and over. If anyone else has the issue, try removing the plugin.

Link to comment
Share on other sites

The CoverArt Plugin crashes emby on ubuntu 18.04 for me on the same images over and over. If anyone else has the issue, try removing the plugin.

 

Hi, how are you determining this?

Link to comment
Share on other sites

I upgraded my Server to 18.04 and updated emby to 3.4.1 after that I started to have some crashes (very sporadically). At some point emby would always crash when looking into the collection folder so I decided to remove and add all libraries, which did not help, so i purged the emby install and installed 3.3.1.
I added all the libraries and it seemed to work fine, so I installed all plugins again, after which the crashes happened again any time I opened a folder where images for media were still missing. I turned on debug logging and the last lines would be

2018-05-15 09:18:37.268 Debug CoverArt: CoverArt using profile default for ***
2018-05-15 09:18:37.271 Debug CoverArt: Codec for *** is h264
2018-05-15 09:18:37.271 Debug CoverArt: CoverArt will create multi-image for ***. Children: 7

It has been stable for now, with the plugin turned off.

Edited by dobs
Link to comment
Share on other sites

Hello,

 

I don't know if this is a bug or permissions/configuration error but, I can not commit any changes to library configuration. I try to change settings via Library => TV or Movies => Manage Folders - whether it is changing fetchers, real-time processing, etc. then click the back arrow, and go back into configuration the settings I changed are unset.

 

I have checked permissions of 

/opt/emby-server
/srv/.config/emby
/etc/emby-server.conf

 and the systemd service, and they are all set correctly. I wonder if it could be because I have changed the default -programdata flag from /opt/emby-server to /srv/.config/emby in the emby-server.conf... the log has been attached.

Log.txt

Edited by schmitty
Link to comment
Share on other sites

I upgraded my Server to 18.04 and updated emby to 3.4.1 after that I started to have some crashes (very sporadically). At some point emby would always crash when looking into the collection folder so I decided to remove and add all libraries, which did not help, so i purged the emby install and installed 3.3.1.

I added all the libraries and it seemed to work fine, so I installed all plugins again, after which the crashes happened again any time I opened a folder where images for media were still missing. I turned on debug logging and the last lines would be

2018-05-15 09:18:37.268 Debug CoverArt: CoverArt using profile default for ***
2018-05-15 09:18:37.271 Debug CoverArt: Codec for *** is h264
2018-05-15 09:18:37.271 Debug CoverArt: CoverArt will create multi-image for ***. Children: 7

It has been stable for now, with the plugin turned off.

 

I ended up removing CoverArt probably a year ago due to it causing issues with library-related operations. I even tried using it again recently after a reformat and reinstall... still caused server issues, so I removed it again.

Link to comment
Share on other sites

Hello,

 

I don't know if this is a bug or permissions/configuration error but, I can not commit any changes to library configuration. I try to change settings via Library => TV or Movies => Manage Folders - whether it is changing fetchers, real-time processing, etc. then click the back arrow, and go back into configuration the settings I changed are unset.

 

I have checked permissions of 

/opt/emby-server
/srv/.config/emby
/etc/emby-server.conf

 and the systemd service, and they are all set correctly. I wonder if it could be because I have changed the default -programdata flag from /opt/emby-server to /srv/.config/emby in the emby-server.conf... the log has been attached.

 

Try pausing a second or two before you go back into the library.

Link to comment
Share on other sites

I ended up removing CoverArt probably a year ago due to it causing issues with library-related operations. I even tried using it again recently after a reformat and reinstall... still caused server issues, so I removed it again.

 

It doesn't cause problems, it's just that it requires significant cpu resources to generate the images.

Link to comment
Share on other sites

Try pausing a second or two before you go back into the library.

The problem is the settings are not saving. I go back in to the Manage Folders configuration and the settings I altered are cleared again. I even tried disabling all users except the admin to make the changes. Still no luck.

Link to comment
Share on other sites

I have not been able to reproduce this but will continue to test for it. I would suggest trying again. Thanks.

Link to comment
Share on other sites

Hello.

My emby-server does not start.

Could you help me, please?

Ubuntu 16.04.4 LTS

 

Sorry, I'm using the google translate.

 



2018-05-23 13:21:48.879 Info Main: Application path: /opt/emby-server/system/EmbyServer.dll
2018-05-23 13:21:48.903 Info Main: Emby
Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb
Operating system: Unix 4.4.0.127
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Processor count: 4
Program data path: /var/lib/emby
Application directory: /opt/emby-server/system
2018-05-23 13:21:50.434 Info App: Application version: 3.4.1.0
2018-05-23 13:21:50.439 Info App: Loading assemblies
2018-05-23 13:21:50.678 Info App: File /var/lib/emby/plugins/IMVDb.dll has version 1.0.0.0
2018-05-23 13:21:50.702 Info App: File /opt/emby-server/system/plugins/IMVDb.dll has version 1.0.0.0
2018-05-23 13:21:50.727 Info App: File /var/lib/emby/plugins/OpenSubtitles.dll has version 1.0.1.0
2018-05-23 13:21:50.729 Info App: File /opt/emby-server/system/plugins/OpenSubtitles.dll has version 1.0.1.0
2018-05-23 13:21:50.766 Info App: File /var/lib/emby/plugins/Emby.Server.CinemaMode.dll has version 1.0.0.0
2018-05-23 13:21:50.805 Info App: File /opt/emby-server/system/plugins/Emby.Server.CinemaMode.dll has version 1.0.0.0
2018-05-23 13:21:50.849 Info App: Loading IMVDb, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby/plugins/IMVDb.dll
2018-05-23 13:21:50.850 Info App: Loading OpenSubtitles, Version=1.0.1.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby/plugins/OpenSubtitles.dll
2018-05-23 13:21:50.851 Info App: Loading Emby.Server.CinemaMode, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null from /var/lib/emby/plugins/Emby.Server.CinemaMode.dll
2018-05-23 13:21:50.851 Info App: Loading MediaBrowser.Api, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading MediaBrowser.WebDashboard, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading MediaBrowser.Model, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading MediaBrowser.Common, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading MediaBrowser.Controller, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading MediaBrowser.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading Emby.Photos, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading Emby.Server.Implementations, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading Emby.Server.MediaEncoding, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading Emby.Dlna, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading MediaBrowser.LocalMetadata, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading MediaBrowser.XbmcMetadata, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading Emby.Server.Connect, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:50.851 Info App: Loading Emby.Server.Sync, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
2018-05-23 13:21:51.436 Info SqliteUserRepository: Sqlite version: 3.23.1
2018-05-23 13:21:51.439 Info SqliteUserRepository: Sqlite compiler options: COMPILER=gcc-6.3.0,ENABLE_COLUMN_METADATA,ENABLE_DBSTAT_VTAB,ENABLE_FTS3,ENABLE_FTS3_PARENTHESIS,ENABLE_FTS3_TOKENIZER,ENABLE_FTS5,ENABLE_JSON1,ENABLE_PREUPDATE_HOOK,ENABLE_RTREE,ENABLE_SESSION,ENABLE_UNLOCK_NOTIFY,ENABLE_UPDATE_DELETE_LIMIT,LIKE_DOESNT_MATCH_BLOBS,MAX_SCHEMA_RETRY=25,MAX_VARIABLE_NUMBER=250000,OMIT_LOOKASIDE,SECURE_DELETE,THREADSAFE=1
2018-05-23 13:21:51.650 Info SqliteUserRepository: Default journal_mode for /var/lib/emby/data/users.db is wal
2018-05-23 13:21:51.658 Info SqliteUserRepository: PRAGMA synchronous=1
2018-05-23 13:21:51.745 Info AuthenticationRepository: Default journal_mode for /var/lib/emby/data/authentication.db is wal
2018-05-23 13:21:51.745 Info AuthenticationRepository: PRAGMA synchronous=1
2018-05-23 13:21:52.196 Info DeviceManager: Default journal_mode for /var/lib/emby/data/devices.db is wal
2018-05-23 13:21:52.196 Info DeviceManager: PRAGMA synchronous=1
2018-05-23 13:21:52.343 Info ActivityRepository: Default journal_mode for /var/lib/emby/data/activitylog.db is wal
2018-05-23 13:21:52.343 Info ActivityRepository: PRAGMA synchronous=1
2018-05-23 13:21:52.438 Info SqliteDisplayPreferencesRepository: Default journal_mode for /var/lib/emby/data/displaypreferences.db is wal
2018-05-23 13:21:52.438 Info SqliteDisplayPreferencesRepository: PRAGMA synchronous=1
2018-05-23 13:21:52.533 Info SqliteItemRepository: Default journal_mode for /var/lib/emby/data/library.db is wal
2018-05-23 13:21:52.534 Info SqliteItemRepository: PRAGMA synchronous=1
2018-05-23 13:21:52.658 Info SqliteNotificationsRepository: Default journal_mode for /var/lib/emby/data/notifications.db is wal
2018-05-23 13:21:52.659 Info SqliteNotificationsRepository: PRAGMA synchronous=1



After using the command: ln -/var/lib/emby-server /var/lib/emby

The server came back ..

Thank you!

Edited by ruinzaO
Link to comment
Share on other sites

I ended up retrying what you suggested with a fresh install, and it worked. Thanks.

Link to comment
Share on other sites

I have some troubles getting emby server on ubuntu with media files on a NAS. I mounted the nas folders on the ubuntu on /media/films etc. Then I used chown and chgrp for emby on that mount. Emby seems to work that way. If I add a film however on the NAS that has another owner, so I use a crontab to keep on changing the files to emby ownership. The problem is however that on the NAS also the ownership is changed to user 996 (probably emby from ubuntu?) . This is my lack of linux knowledge. But is there a way to keep on the NAS the original ownership and on the ubuntu mounted folders emby ownership?

Link to comment
Share on other sites

Hello guys.

can you help me?

My emby-server is in trouble =/

Ubuntu Server 16.04.4 LTS

 



2018-05-25 11:41:22.605 Info Main: Application path: /opt/emby-server/system/EmbyServer.dll
2018-05-25 11:41:22.631 Info Main: Emby
Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb
Operating system: Unix 4.4.0.127
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Processor count: 4
Program data path: /var/lib/emby
Application directory: /opt/emby-server/system
2018-05-25 11:41:22.690 Error Main: UnhandledException
System.IO.IOException: The system cannot open the device or file specified.

at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.Threading.Mutex.MutexTryCodeHelper.MutexTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Threading.Mutex.CreateMutexWithGuaranteedCleanup(Boolean initiallyOwned, String name, Boolean& createdNew, SECURITY_ATTRIBUTES secAttrs)
at EmbyServer.Program.Main(String[] args)
System.IO.IOException
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.Threading.Mutex.MutexTryCodeHelper.MutexTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Threading.Mutex.CreateMutexWithGuaranteedCleanup(Boolean initiallyOwned, String name, Boolean& createdNew, SECURITY_ATTRIBUTES secAttrs)
at EmbyServer.Program.Main(String[] args)



Edited by ruinzaO
Link to comment
Share on other sites

 

Hello guys.
can you help me?
My emby-server is in trouble =/
Ubuntu Server 16.04.4 LTS
 
2018-05-25 11:41:22.605 Info Main: Application path: /opt/emby-server/system/EmbyServer.dll
2018-05-25 11:41:22.631 Info Main: Emby
	Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb
	Operating system: Unix 4.4.0.127
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 4
	Program data path: /var/lib/emby
	Application directory: /opt/emby-server/system
2018-05-25 11:41:22.690 Error Main: UnhandledException
	System.IO.IOException: The system cannot open the device or file specified.
	
	   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
	   at System.Threading.Mutex.MutexTryCodeHelper.MutexTryCode(Object userData)
	   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
	   at System.Threading.Mutex.CreateMutexWithGuaranteedCleanup(Boolean initiallyOwned, String name, Boolean& createdNew, SECURITY_ATTRIBUTES secAttrs)
	   at EmbyServer.Program.Main(String[] args)
	System.IO.IOException
	   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
	   at System.Threading.Mutex.MutexTryCodeHelper.MutexTryCode(Object userData)
	   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
	   at System.Threading.Mutex.CreateMutexWithGuaranteedCleanup(Boolean initiallyOwned, String name, Boolean& createdNew, SECURITY_ATTRIBUTES secAttrs)
	   at EmbyServer.Program.Main(String[] args)
	

 

 

That's resolved on the beta channel. Thanks.

Link to comment
Share on other sites

That's resolved on the beta channel. Thanks.

 

Thanks for the reply, my friend.
I upgraded to the beta but unfortunately it did not work.
Now, besides not starting the logs are blank.
Any other suggestions?
Link to comment
Share on other sites

Please attach whatever log file is produced along with the terminal output. Thanks.

Link to comment
Share on other sites

Please attach whatever log file is produced along with the terminal output. Thanks.

After upgrading to beta, I reset the libraries and it seems to be no problem

Thank you friend.

Link to comment
Share on other sites

I've been unsuccessful in trying to upgrade from 3.3.1 to 3.4.1. I've tried uninstalling via apt-get remove. I reinstalled 3.3.1 deb package and tried upgrading to 3.4.1 by downloading the corresponding deb package. The app just crashes shortly after starting a stream. When I downgrade to 3.3.1 everything works as expected. Am I missing something? Logs attached.

5-26.log

Edited by robrhedrick
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...