Jump to content

Ubuntu


Luke

Recommended Posts

Turboschnecke

Out of the box no. But i can search the web for it. Docker contains everything or has it some other dependencies?

Edited by Turboschnecke
Link to comment
Share on other sites

robrhedrick

3.2.70 Crashes and is not usable... had to downgrade to 3.2.60.

```Jan 19 10:28:08 tv emby-server[2003]: 7ff32be78000-7ff32be82000 r--p 00000000 fd:00 1311733 /usr/lib/emby-server/bin/SQLitePCLRaw.provider.sqlite3.dll

Jan 19 10:28:08 tv emby-server[2003]: 7ff32be82000-7ff32be86000 r--p 00000000 fd:00 1311492 /usr/lib/mono/4.5/Facades/System.Runtime.dll
Jan 19 10:28:08 tv emby-server[2003]: 7ff32be86000-7ff32be92000 r--p 00000000 fd:00 1311717 /usr/lib/emby-server/bin/MediaBrowser.Common.dll
Jan 19 10:28:08 tv emby-server[2003]: 7ff32be92000-7ff32bf03000 r--p 00000000 fd:00 1311720 /usr/lib/emby-server/bin/MediaBrowser.Model.dll
Jan 19 10:28:08 tv emby-server[2003]: 7ff32bf03000-7ff32bffb000 rw-p 00000000 00:00 0
Jan 19 10:28:08 tv emby-server[2003]: 7ff32bffb000-7ff32c05a000 ---p 00000000 00:00 0
Jan 19 10:28:08 tv emby-server[2003]: 7ff32c05a000-7ff32c064000 rw-p 00000000 00:00 0
Jan 19 10:28:08 tv emby-server[2003]: 7ff32c064000-7ff32c068000 r--p 00000000 fd:00 1311723 /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe
Jan 19 10:28:08 tv emby-server[2003]: 7ff32c068000-7ff32c074000 rw-p 00000000 00:00 0
Jan 19 10:28:08 tv emby-server[2003]: 7ff32c074000-7ff32c075000 rw-s 00000000 00:19 3 /dev/shm/mono.2036
Jan 19 10:28:08 tv emby-server[2003]: 7ff32c075000-7ff32c078000 rw-p 00000000 00:00 0
Jan 19 10:28:08 tv emby-server[2003]: 7ff32c078000-7ff32c079000 r--p 00027000 fd:00 2630388 /lib/x86_64-linux-gnu/ld-2.26.so
Jan 19 10:28:08 tv emby-server[2003]: 7ff32c079000-7ff32c07a000 rw-p 00028000 fd:00 2630388 /lib/x86_64-linux-gnu/ld-2.26.so
Jan 19 10:28:08 tv emby-server[2003]: 7ff32c07a000-7ff32c07b000 rw-p 00000000 00:00 0
Jan 19 10:28:08 tv emby-server[2003]: 7ffc2cfab000-7ffc2cfb3000 ---p 00000000 00:00 0
Jan 19 10:28:08 tv emby-server[2003]: 7ffc2d789000-7ffc2d7aa000 rw-p 00000000 00:00 0 [stack]
Jan 19 10:28:08 tv emby-server[2003]: 7ffc2d7b5000-7ffc2d7b8000 r--p 00000000 00:00 0 [vvar]
Jan 19 10:28:08 tv emby-server[2003]: 7ffc2d7b8000-7ffc2d7ba000 r-xp 00000000 00:00 0 [vdso]
Jan 19 10:28:08 tv emby-server[2003]: ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]
Jan 19 10:28:08 tv emby-server[2003]: Native stacktrace:
Jan 19 10:28:08 tv emby-server[2003]: #011/usr/bin/mono-sgen(+0xcd694) [0x5564e58af694]
Jan 19 10:28:08 tv emby-server[2003]: #011/usr/bin/mono-sgen(+0x129dde) [0x5564e590bdde]
Jan 19 10:28:08 tv emby-server[2003]: #011/usr/bin/mono-sgen(+0x3c3b3) [0x5564e581e3b3]
Jan 19 10:28:08 tv emby-server[2003]: #011/lib/x86_64-linux-gnu/libpthread.so.0(+0x13150) [0x7ff32b4e3150]
Jan 19 10:28:08 tv emby-server[2003]: #011/lib/x86_64-linux-gnu/libc.so.6(+0x17edff) [0x7ff32b057dff]
Jan 19 10:28:08 tv emby-server[2003]: #011/usr/lib/emby-server/x86_64-linux-gnu/libEmbyMagickCore-6.Q8.so.2(ReadBlob+0xed) [0x7ff320c75add]
Jan 19 10:28:08 tv emby-server[2003]: #011/usr/lib/emby-server/x86_64-linux-gnu/libEmbyMagickCore-6.Q8.so.2(SetImageInfo+0x2df) [0x7ff320d2220f]
Jan 19 10:28:08 tv emby-server[2003]: #011/usr/lib/emby-server/x86_64-linux-gnu/libEmbyMagickCore-6.Q8.so.2(ReadImage+0xa1) [0x7ff320ca9c71]
Jan 19 10:28:08 tv emby-server[2003]: #011/usr/lib/emby-server/x86_64-linux-gnu/libEmbyMagickWand-6.Q8.so.2(MagickReadImage+0x6a) [0x7ff32109a88a]
Jan 19 10:28:08 tv emby-server[2003]: #011[0x408a7cf8]
Jan 19 10:28:08 tv emby-server[2003]: Debug info from gdb:
Jan 19 10:28:08 tv emby-server[2003]: =================================================================
Jan 19 10:28:08 tv emby-server[2003]: Got a SIGSEGV while executing native code. This usually indicates
Jan 19 10:28:08 tv emby-server[2003]: a fatal error in the mono runtime or one of the native libraries
Jan 19 10:28:08 tv emby-server[2003]: used by your application.
Jan 19 10:28:08 tv emby-server[2003]: =================================================================
Jan 19 10:28:08 tv tvheadend[1503]: htsp: xx.xx.xx.50 [ tv | TVHclient4Emby-3.2.70.0 ]: Disconnected
Jan 19 10:28:08 tv systemd[1]: emby-server.service: Main process exited, code=exited, status=134/n/a
Jan 19 10:28:08 tv systemd[1]: Stopping User Manager for UID 999...
Jan 19 10:28:08 tv systemd[2031]: Stopped target Default.
Jan 19 10:28:08 tv systemd[2031]: Stopped target Basic System.
Jan 19 10:28:08 tv systemd[2031]: Stopped target Sockets.
Jan 19 10:28:08 tv systemd[2031]: Stopped target Paths.
Jan 19 10:28:08 tv systemd[2031]: Reached target Shutdown.
Jan 19 10:28:08 tv systemd[2031]: Starting Exit the Session...
Jan 19 10:28:08 tv systemd[2031]: Stopped target Timers.
Jan 19 10:28:08 tv systemd[2031]: Received SIGRTMIN+24 from PID 2098 (kill).
Jan 19 10:28:08 tv systemd[1]: emby-server.service: Unit entered failed state.
Jan 19 10:28:08 tv systemd[1]: emby-server.service: Failed with result 'exit-code'.
Jan 19 10:28:08 tv systemd[1]: Stopped User Manager for UID 999.
Jan 19 10:28:08 tv systemd[1]: Removed slice User Slice of emby.
Jan 19 10:29:03 tv systemd[1]: Starting Cleanup of Temporary Directories...
Jan 19 10:29:03 tv systemd-tmpfiles[2124]: [/usr/lib/tmpfiles.d/var.conf:14] Duplicate line for path "/var/log", ignoring.
Jan 19 10:29:03 tv systemd[1]: Started Cleanup of Temporary Directories.```

 

will only stay started for a few seconds.

 

```● emby-server.service - Emby Media Server

Loaded: loaded (/lib/systemd/system/emby-server.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Fri 2018-01-19 10:33:33 CST; 9s ago
Process: 2291 ExecStopPost=/usr/bin/emby-server clear (code=exited, status=0/SUCCESS)
Process: 2214 ExecStart=/usr/bin/emby-server start (code=exited, status=134)
Main PID: 2214 (code=exited, status=134)
CPU: 58ms

Jan 19 10:31:37 tv systemd[1]: Started Emby Media Server.
Jan 19 10:31:37 tv su[2214]: Successful su for emby by root
Jan 19 10:31:37 tv su[2214]: + ??? root:emby
Jan 19 10:31:37 tv su[2214]: pam_unix(su:session): session opened for user emby by (uid=0)
Jan 19 10:33:33 tv systemd[1]: emby-server.service: Main process exited, code=exited, status=134/n/a
Jan 19 10:33:33 tv systemd[1]: emby-server.service: Unit entered failed state.
Jan 19 10:33:33 tv systemd[1]: emby-server.service: Failed with result 'exit-code'.```

Link to comment
Share on other sites

Just a heads up to anyone running an Emby Server beta package from OBS. In the next week or two we will be retiring the OBS beta channel.

 

Our website download page has been updated with beta install instructions:

 

https://emby.media/download

 

At your convenience it is recommended that you switch over to the new installation process as we will no longer be publishing betas to OBS. 

 

If you're running a non-beta (stable) package from OBS, you can continue to do so for the time being.

 

Thanks !

Link to comment
Share on other sites

robrhedrick

We have a new unique setup that we are having some problems with... we recently added a new storage server with high-speed storage and 10Gig nic connectivity to our infrastructure. We also added a 10gig nic to the emby-server. The emby shares for TV and Movies now connect over cifs shares to the new storage server.

The emby server connectivity is:

Not bound to any specific ip address…

1 nic with default gateway in the DMZ (primary PUBLIC access to emby)

1 nic to 10gig storage network, no gateway, static routes

1 nic to internal network, no gateway, static routes

A.      When we join an emby client to the server via an internal client to the internal ip address, the “auto-conifg” of the emby server address changes to the 10gig nic ip address after a reboot.

B.      When an android tablet is added via the internal ip address and content is locally synced, once it leaves the local subnet it cannot connect via the programmed public ssl url .

Thoughts?

Link to comment
Share on other sites

robrhedrick

Also, there is a mix of kodi boxes and firesticks on the internal subnet that automatically see the emby server, after they connect, they show one of the other ip addresses as the "server" address... like the 10g nic ip, which they cannot access.

Link to comment
Share on other sites

Turboschnecke

Yesterday i installed the latest stable version of emby on Ubuntu 17.10 and it worked. Today emby always crash, when i try to login in the dashboard... Status always returns failed (code=killed,signal=ILL). How can i solve this problem?

The log file dont provide much infos. Just this 

HTTP GET http://IP:8096/emby/Users/7790daac6e374b90812d9eb1144dcbb/Views 

 and a UserAgent. But then it ends

Edited by Turboschnecke
Link to comment
Share on other sites

darrenkdean

  • Updated to Emby Server 3.2.70.0 yesterday AM. 
  • Remote firesticks had choppy/freezing playback so I decided to downgrade back to 3.2.60.0
  • Library did not want to update after downgrade, so a previous configuration prior to the upgrade was restored using the Backup Plugin
  • Libraries are now updated & functioning again, but when I click on Live TV it just spins
  • When I look at the logs I keep seeing this error: 
    • Info App: [TVHclient] HTSConnectionAsync.open: IPEndPoint = '[::1]:9982'; AddressFamily = 'InterNetworkV6'

      2018-02-04 19:49:43.828

  • I've tried uninstalling the TV Headend Plugin, Downgrading It, etc. etc., but can't seem to figure it out.  The Plugin configuration settings are correct (username/password).  The TV Headend Server is hosted on the same machine as the Emby Server.

Any thoughts?

 

Best-

 

Darren

Log.txt

Link to comment
Share on other sites

I have tried to update to the latest beta but get the following problems

 

sudo service emby-server stop
emby-server stop/waiting
iwm@xxxxx1 ~/Desktop $ sudo dpkg -i emby-server-deb_3.2.70.10_amd64.deb
(Reading database ... 241587 files and directories currently installed.)
Preparing to unpack emby-server-deb_3.2.70.10_amd64.deb ...
stop: Unknown instance: 
Unpacking emby-server (3.2.70.10) over (3.2.70.5) ...
dpkg: error processing archive emby-server-deb_3.2.70.10_amd64.deb (--install):
 unable to open '/opt/emby-server/share/icu/59.1/icudt59l/ibm-942_P12A-1999.cnv.dpkg-new': Operation not permitted
Processing triggers for libc-bin (2.19-0ubuntu6.14) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
 emby-server-deb_3.2.70.10_amd64.deb
 
I am running
 
RELEASE=17.3
CODENAME=rosa
EDITION="MATE 64-bit"
DESCRIPTION="Linux Mint 17.3 Rosa"
DESKTOP=MATE
TOOLKIT=GTK
GRUB_TITLE=Linux Mint 17.3 MATE 64-bit
 
Cheers
 
IanM
 

 

Link to comment
Share on other sites

@@iwm, you could try deleting this file and then updating again:

/opt/emby-server/share/icu/59.1/icudt59l/ibm-942_P12A-1999.cnv.dpkg-new
Link to comment
Share on other sites

 

@@iwm, you could try deleting this file and then updating again:

/opt/emby-server/share/icu/59.1/icudt59l/ibm-942_P12A-1999.cnv.dpkg-new

 

Tried again that with following result

 

iwm@xxxx1 ~/Downloads $ ls
emby-server-deb_3.2.70.11_amd64.deb
iwm@xxxx1 ~/Downloads $ sudo dpkg -i emby-server-deb_3.2.70.11_amd64.deb
(Reading database ... 241587 files and directories currently installed.)
Preparing to unpack emby-server-deb_3.2.70.11_amd64.deb ...
emby-server stop/waiting
Unpacking emby-server (3.2.70.11) over (3.2.70.5) ...
dpkg: error processing archive emby-server-deb_3.2.70.11_amd64.deb (--install):
 unable to open '/opt/emby-server/share/icu/59.1/icudt59l/unit/sw.res.dpkg-new': Operation not permitted
Processing triggers for libc-bin (2.19-0ubuntu6.14) ...
Processing triggers for ureadahead (0.100.0-16) ...
ureadahead will be reprofiled on next reboot
Errors were encountered while processing:
 emby-server-deb_3.2.70.11_amd64.deb
 
iwm@xxxx1 ~/Downloads $ sudo rm /opt/emby-server/share/icu/59.1/icudt59l/unit/sw.res.dpkg-new
rm: cannot remove ‘/opt/emby-server/share/icu/59.1/icudt59l/unit/sw.res.dpkg-new’: No such file or directory
 
Then I tried the install again
 
Sorry that didn't work - Maybe I will backup settings for server and do a new install
 
Cheers
 
IanM
Link to comment
Share on other sites

alucryd

I couldn't reproduce. Could you try uninstalling the previous package before installing the latest one?

Link to comment
Share on other sites

  • 3 weeks later...

Hello, my emby server runs on Ubuntu 16.04 and it says there was an update to 3.3.0.0, but when I try apt dist-upgrade it does not update.

 

Repo not yet updated? I should be more patient? ;-)

Link to comment
Share on other sites

Hello, my emby server runs on Ubuntu 16.04 and it says there was an update to 3.3.0.0, but when I try apt dist-upgrade it does not update.

 

Repo not yet updated? I should be more patient? ;-)

 

@@AlpBen, how did you originally install?

Link to comment
Share on other sites

After upgrading from 3.2.70 to 3.3.0.0 Emby won't start anymore.

 

I downloaded the .deb file and unpacked it via dpkg (as stated in the official download page for Ubuntu on emby.media) but since then I haven't been able to get Emby started. When I enter "service emby-server start" I can see the process "EmbyServer" in top but after a few moments it goes away and I am not able to access the WebInterface at all.

Would like to a debug log but without WebInterface I do not really know how to do so.

 

Would it be possible to do a downgrade back to 3.2.70?

 

I am kinda lost over here, any hint would be appreciated.

 

Thanks a lot!

 

€dit: My bad! Had to access it via http instead of https because the folder in /var/lib was renamed from emby-server to just emby. This led to emby not finding my certificate anymore.

 

€dit2: Nevertheless, there is a problem in the main page of the WebInterface. Emby does not load all the images anymore. See screenshot:

 

post-245525-0-20036600-1519735048_thumb.png
 
Is it related to the renamed folder? Is a library rescan required to solve this?
 
€dit3: There is yet an other problem. I use Kodi + Emby for Kodi on a FTVS which worked flawlessly before the update to 3.3.0.0. Now I have to disable Check host-ssl certificate (or similar) in the settings otherwise it does not log in to the server and I don't know why. No changes were made to the certificate.
Edited by neik
Link to comment
Share on other sites

No, actually I have not.

Should I replace all metadata or just scan for new files?

 

What about the certificate issue?

Edited by neik
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...