Jump to content

Emby next gen


quickmic

Recommended Posts

6 hours ago, spon said:

(or make it as an option).

An option will not impact the current sync implementation.

Link to comment
Share on other sites

Is emby-next-gen compatible with the embuary skin on Matrix?

I know you have to make an .xml edit to make the skin show up in Matrix but after that does emby next gen 'emulate' or replace emby4kodi and leave all parts of the skin functional?

Link to comment
Share on other sites

Sysyphus_
On 5/4/2021 at 7:12 AM, quickmic said:

Please try the beta version and report if it fixes the issue.

 

Hello, I've tried the beta version. It correct the bug, I'm now connected every time. But I not seen my connected avatar in the upper right corner with embuary and on parameter page user and server address are not show. But I think it's due to beta version.

Many thanks for the help and your very good job.

  • Thanks 1
Link to comment
Share on other sites

On 5/3/2021 at 7:26 PM, Nosepull said:

Yeah, for my internet radio streams I indeed solved the issue by giving the streams the fake artist "Radio". For my usecase this is a viable workaround.

However, IMHO it is not good that the plugin fails more or less silently in such cases. Wouldn't it be possible to give those missing artists an obviously false fake artist like "NOARTIST" or something like that, sticking out in Kodi. Then it's up to the user to fix the metadata.

Was it synced in 4.x without Artist info? I tried some approaches, but it not easy to inject fake data.

Link to comment
Share on other sites

I fact I had given up on the old plugin long ago, because of all kinds of sync weirdness. So I have no comparision.

  • Like 1
Link to comment
Share on other sites

One request: Could you kind of standardize the version numbering? As I see it, there is a beta repo and a stable repo. The stable repo is outdated, but the beta repo seems to be outdated, too, because you can manually download version 5.2.07.

And I just noticed that even for 5.2.07 there seem to be different build versions...

Why not just keep the beta repo updated?

Thanks for your work!

Link to comment
Share on other sites

I release experimental versions as pre-review. Usually there it's a work in progress version. e.g. 5.2.07 (experimental): Core change is node re-implementation and it still needs work. Favorites nodes still needs an update.

As soon as finished, I push it in beta repo. The current beta 5.2.06 has Kodi 18 issues, that's why I haven't pushed it already in stable repo.

Stable repo releases are fully tested with different Kodi version (18 and 19), Different devices (libreelec, osmc, PC, Android) in both modes. Native and plugin and lot's more.

 

 

Edited by quickmic
Link to comment
Share on other sites

I finally took the plunge and upgraded my two Android boxes to Matrix and next-gen (using Add-on mode for the first time also... always used Native in the past). All seems good so far... just have a few questions.

1. When something new is added to the library (eg. Movie), the old version of the addon used to refresh the kodi library on the fly. Now I need to back out of the movie library and go back in to see the newly added movie. Is this by design? Is there a way to turn this auto-refresh on?

2. Widgets also don't update unless I restart Kodi or Reload the skin. Eg. "Recently added movies". By design?

Thanks!!

Link to comment
Share on other sites

No, not by design. Not sure which version you are using. There are lot's of improvements since 5.1.7 (stable version). You can try beta or experimental.

Link to comment
Share on other sites

8 minutes ago, quickmic said:

No, not by design. Not sure which version you are using. There are lot's of improvements since 5.1.7 (stable version). You can try beta or experimental.

Interesting. I'm curious if it's the skin that I'm using. I'll do a bit more testing.

edit: I'm using the latest beta version.

Edited by knewknow
  • Like 1
Link to comment
Share on other sites

4 hours ago, knewknow said:

Interesting. I'm curious if it's the skin that I'm using. I'll do a bit more testing.

edit: I'm using the latest beta version.

Just tested this @quickmicwith a new copy of Matrix and Emby-NG on a Windows laptop for testing. Using default skin. This time I used native mode so that it was different than my Android installs.

- added new movie
- checked emby server to ensure it was added
- waited on the movie library screen (wall) for about 15 minutes. Library screen was not updated with newly added movie.
- exited to home menu on kodi and immediately back into movie library, and it showed up in the list.

- checked the newly added movie widget on the home screen. Newly added movie did not show up
- checked emby server and the movie was showing under latest movies
- restarted kodi, and the movie was showing in the widget

Thanks!

Link to comment
Share on other sites

8 hours ago, knewknow said:

Just tested this @quickmicwith a new copy of Matrix and Emby-NG on a Windows laptop for testing. Using default skin. This time I used native mode so that it was different than my Android installs.

- added new movie
- checked emby server to ensure it was added
- waited on the movie library screen (wall) for about 15 minutes. Library screen was not updated with newly added movie.
- exited to home menu on kodi and immediately back into movie library, and it showed up in the list.

- checked the newly added movie widget on the home screen. Newly added movie did not show up
- checked emby server and the movie was showing under latest movies
- restarted kodi, and the movie was showing in the widget

Thanks!

Please check if the websocket connection is online. -> send a (text) message from emby-server to Kodi.

Link to comment
Share on other sites

18 hours ago, quickmic said:

Please check if the websocket connection is online. -> send a (text) message from emby-server to Kodi.

Thanks @quickmic. How do I do this? I’ve looked everywhere in the settings and can’t seem to find this option...

Edit: disregard, I found the option and the text message was received.

Edited by knewknow
Link to comment
Share on other sites

5 hours ago, knewknow said:

Thanks @quickmic. How do I do this? I’ve looked everywhere in the settings and can’t seem to find this option...

Edit: disregard, I found the option and the text message was received.

Very good, so the realtime communication between server and Kodi is online.

Please send me a kodi.log (via PM), I'll check for errors.

Link to comment
Share on other sites

Is it possible that emby-next-gen conflicts somehow with the internal picture viewer of Kodi?

I noticed that I cannot watch my photo library any longer for some time (roughly about the time I started using emby-next-gen).  System is Ubuntu 20.10 (now 21.04) with Kodi 19.0 and 19.1 and the 5.2.07 version of the plugin. Pictures are added "conventionally" as a normal path media source in Kodi. When trying to watch a picture everything is fine until I want to see the picture fullscreen. Then the picture is displayed very dark, almost indscernibly. (The "info" overlay, however, has the normal brightness.) Dia shows are not even started.

Though the pictures are not accessed via the Emby server and the plugin, the log shows that the plugin somehow takes over:

2021-05-12 18:19:08.893 T:30844    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/fileserver/Photos/2000/00 Misc/pic.jpg', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 1}, 'MonitorMethod': 'Player.OnPlay'} 

This happens with all pictures. I rule out that something is wrong with all my JPEGs. Displaying the pictures e.g. with the "picture slideshow screensaver" works perfectly.

I also tried viewing the pictures directly via the plugin from the Emby server. This does not work also, the screen simply stays black and the log says:

2021-05-12 18:22:14.676 T:31174    INFO <general>: initializing python engine.
2021-05-12 18:22:14.753 T:31181    INFO <general>: Skipped 1 duplicate messages..
2021-05-12 18:22:14.753 T:31181    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': 'http://127.0.0.1:57578/150480/Images/Primary', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-12 18:22:15.411 T:31176    INFO <general>: CPythonInvoker(80, /home/kodi/.kodi/addons/script.embuary.helper/plugin.py): script successfully run
2021-05-12 18:22:15.428 T:31176    INFO <general>: Python interpreter stopped
2021-05-12 18:22:15.439 T:31174    INFO <general>: CPythonInvoker(79, /home/kodi/.kodi/addons/script.embuary.helper/plugin.py): script successfully run
2021-05-12 18:22:15.455 T:31174    INFO <general>: Python interpreter stopped

I switched to another Skin, and I disabled the Embuary helper plugin, as this seems to somehow be called when a picture is shown.  

Any ideas?

Link to comment
Share on other sites

I'm using the emby picture functions, so I've to perform a test.

Basically, there shouldn't be any conflict. Also I'm not using embuary helper addon. I'll check that too.

 

Link to comment
Share on other sites

I tested picture functionally. With default skin everything is working fine:

 

2021-05-13 12:13:45.938 T:22509    INFO <general>: INFO: EMBY.library.Library: --<[ retrieve changes ]
2021-05-13 12:13:46.794 T:22455   ERROR <general>: Unable to lookup host: 'folder.jpg'
2021-05-13 12:13:46.801 T:22455   ERROR <general>: CCurlFile::Exists - Failed: Couldn't resolve host name(6) for http://folder.jpg/
2021-05-13 12:13:49.015 T:22464    INFO <general>: CPythonInvoker(1, /home/quickmic/.kodi/addons/service.xbmc.versioncheck/resources/lib/runner.py): script successfully run
2021-05-13 12:13:49.093 T:22464    INFO <general>: Python interpreter stopped
2021-05-13 12:13:49.951 T:22437    INFO <general>: Loading skin file: MyPics.xml, load type: KEEP_IN_MEMORY
2021-05-13 12:14:38.106 T:22437    INFO <general>: Loading skin file: SlideShow.xml, load type: KEEP_IN_MEMORY
2021-05-13 12:14:38.128 T:22614    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/1977 Dezember/1977 Dezember - 002.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 1}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:14:39.427 T:22616    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/1977 Dezember/1977 Dezember - 003.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:14:40.126 T:22617    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/1977 Dezember/1977 Dezember - 004.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:14:40.725 T:22618    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/1977 Dezember/1977 Dezember - 003.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:14:43.504 T:22600   ERROR <general>: Unable to lookup host: 'folder.jpg'
2021-05-13 12:14:43.511 T:22600   ERROR <general>: CCurlFile::Exists - Failed: Couldn't resolve host name(6) for http://folder.jpg/
2021-05-13 12:14:46.476 T:22437    INFO <general>: Loading skin file: DialogButtonMenu.xml, load type: KEEP_IN_MEMORY
2021-05-13 12:14:47.640 T:22437    INFO <general>: Stopping player
2021-05-13 12:14:47.640 T:22437    INFO <general>: Storing total System Uptime
2021-05-13 12:14:47.640 T:22437    INFO <general>: Saving settings
2021-05-13 12:14:47.647 T:22437    INFO <general>: Saving skin settings
2021-05-13 12:14:47.648 T:22437    INFO <general>: Stopping all
2021-05-13 12:14:47.648 T:22437    INFO <general>: ES: Stopping event server
2021-05-13 12:14:47.929 T:22478    INFO <general>: ES: UDP Event server stopped
2021-05-13 12:14:48.257 T:22437    INFO <general>: stopping upnp
2021-05-13 12:14:48.527 T:22463 WARNING <general>: WARNING: EMBY.entrypoint.Service: ---<[ EXITING ]

 

embuary helper addon not tested yet.

Link to comment
Share on other sites

13 minutes ago, quickmic said:

I tested picture functionally. With default skin everything is working fine:

 


2021-05-13 12:13:45.938 T:22509    INFO <general>: INFO: EMBY.library.Library: --<[ retrieve changes ]
2021-05-13 12:13:46.794 T:22455   ERROR <general>: Unable to lookup host: 'folder.jpg'
2021-05-13 12:13:46.801 T:22455   ERROR <general>: CCurlFile::Exists - Failed: Couldn't resolve host name(6) for http://folder.jpg/
2021-05-13 12:13:49.015 T:22464    INFO <general>: CPythonInvoker(1, /home/quickmic/.kodi/addons/service.xbmc.versioncheck/resources/lib/runner.py): script successfully run
2021-05-13 12:13:49.093 T:22464    INFO <general>: Python interpreter stopped
2021-05-13 12:13:49.951 T:22437    INFO <general>: Loading skin file: MyPics.xml, load type: KEEP_IN_MEMORY
2021-05-13 12:14:38.106 T:22437    INFO <general>: Loading skin file: SlideShow.xml, load type: KEEP_IN_MEMORY
2021-05-13 12:14:38.128 T:22614    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/1977 Dezember/1977 Dezember - 002.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 1}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:14:39.427 T:22616    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/1977 Dezember/1977 Dezember - 003.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:14:40.126 T:22617    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/1977 Dezember/1977 Dezember - 004.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:14:40.725 T:22618    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/1977 Dezember/1977 Dezember - 003.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:14:43.504 T:22600   ERROR <general>: Unable to lookup host: 'folder.jpg'
2021-05-13 12:14:43.511 T:22600   ERROR <general>: CCurlFile::Exists - Failed: Couldn't resolve host name(6) for http://folder.jpg/
2021-05-13 12:14:46.476 T:22437    INFO <general>: Loading skin file: DialogButtonMenu.xml, load type: KEEP_IN_MEMORY
2021-05-13 12:14:47.640 T:22437    INFO <general>: Stopping player
2021-05-13 12:14:47.640 T:22437    INFO <general>: Storing total System Uptime
2021-05-13 12:14:47.640 T:22437    INFO <general>: Saving settings
2021-05-13 12:14:47.647 T:22437    INFO <general>: Saving skin settings
2021-05-13 12:14:47.648 T:22437    INFO <general>: Stopping all
2021-05-13 12:14:47.648 T:22437    INFO <general>: ES: Stopping event server
2021-05-13 12:14:47.929 T:22478    INFO <general>: ES: UDP Event server stopped
2021-05-13 12:14:48.257 T:22437    INFO <general>: stopping upnp
2021-05-13 12:14:48.527 T:22463 WARNING <general>: WARNING: EMBY.entrypoint.Service: ---<[ EXITING ]

 

embuary helper addon not tested yet.

 

Another test with Titan Skin (including embuary helper addon). Also no issues found.

 

2021-05-13 12:29:22.443 T:24138    INFO <general>: CPythonInvoker(26, /home/quickmic/.kodi/addons/script.embuary.helper/default.py): script successfully run
2021-05-13 12:29:22.633 T:23004    INFO <general>: Loading skin file: SlideShow.xml, load type: KEEP_IN_MEMORY
2021-05-13 12:29:22.642 T:24138    INFO <general>: Python interpreter stopped
2021-05-13 12:29:22.652 T:24155    INFO <general>: initializing python engine.
2021-05-13 12:29:22.682 T:24189    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/2019 F1 (Singapore)/DSC_0023.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 1}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:29:22.871 T:24139    INFO <general>: CPythonInvoker(27, /home/quickmic/.kodi/addons/script.embuary.helper/default.py): script successfully run
2021-05-13 12:29:23.076 T:24139    INFO <general>: Python interpreter stopped
2021-05-13 12:29:23.477 T:24155    INFO <general>: CPythonInvoker(28, /home/quickmic/.kodi/addons/script.embuary.helper/plugin.py): script successfully run
2021-05-13 12:29:23.655 T:24155    INFO <general>: Python interpreter stopped
2021-05-13 12:29:24.370 T:24201    INFO <general>: initializing python engine.
2021-05-13 12:29:24.445 T:24205    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/2019 F1 (Singapore)/DSC_0024.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:29:24.849 T:24201    INFO <general>: CPythonInvoker(29, /home/quickmic/.kodi/addons/script.embuary.helper/plugin.py): script successfully run
2021-05-13 12:29:24.948 T:24214    INFO <general>: initializing python engine.
2021-05-13 12:29:25.049 T:24201    INFO <general>: Python interpreter stopped
2021-05-13 12:29:25.050 T:24215    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/2019 F1 (Singapore)/DSC_0025.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:29:25.527 T:24214    INFO <general>: CPythonInvoker(30, /home/quickmic/.kodi/addons/script.embuary.helper/plugin.py): script successfully run
2021-05-13 12:29:25.706 T:24214    INFO <general>: Python interpreter stopped
2021-05-13 12:29:25.781 T:24227    INFO <general>: initializing python engine.
2021-05-13 12:29:25.808 T:24228    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/2019 F1 (Singapore)/DSC_0026.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:29:26.241 T:24227    INFO <general>: CPythonInvoker(31, /home/quickmic/.kodi/addons/script.embuary.helper/plugin.py): script successfully run
2021-05-13 12:29:26.410 T:24227    INFO <general>: Python interpreter stopped
2021-05-13 12:29:27.152 T:24240    INFO <general>: initializing python engine.
2021-05-13 12:29:27.213 T:24252    INFO <general>: INFO: EMBY.hooks.player.Player: [ OnPlay ] {'item': {'file': '/mnt/storage0/pictures/2019 F1 (Singapore)/DSC_0027.JPG', 'type': 'picture'}, 'player': {'playerid': 2, 'speed': 0}, 'MonitorMethod': 'Player.OnPlay'} 
2021-05-13 12:29:27.629 T:24240    INFO <general>: CPythonInvoker(32, /home/quickmic/.kodi/addons/script.embuary.helper/plugin.py): script successfully run
2021-05-13 12:29:27.789 T:24240    INFO <general>: Python interpreter stopped
2021-05-13 12:29:29.779 T:24278    INFO <general>: initializing python engine.
2021-05-13 12:29:30.890 T:24279    INFO <general>: Skipped 1 duplicate messages..
2021-05-13 12:29:30.890 T:24279    INFO <general>: CPythonInvoker(34, /home/quickmic/.kodi/addons/script.skinshortcuts/default.py): script successfully run
2021-05-13 12:29:31.072 T:24279    INFO <general>: Python interpreter stopped
2021-05-13 12:29:31.347 T:24278    INFO <general>: CPythonInvoker(33, /home/quickmic/.kodi/addons/script.skin.helper.widgets/plugin.py): script successfully run
2021-05-13 12:29:31.481 T:24278    INFO <general>: Python interpreter stopped
2021-05-13 12:29:31.781 T:23004    INFO <general>: Loading skin file: DialogButtonMenu.xml, load type: KEEP_IN_MEMORY

 

 

Link to comment
Share on other sites

Thanks once again to @quickmic for the quick feedback. I disabled (though not uninstalled) your plugin and the problem persists, so it might be unrelated.

Using the built-in Kodi functions, my photos are displayed too dark. At least this worked until a few weeks ago. Using the dynamic list provided by the Emby plugin gives black screens, with no helpful information provided in the log. I'm quite at a loss how to get the picture viewer functionality working again in one way or another. As I'm pretty much using a standard setup (Ubuntu packages on Intel hardware), I'm a bit perplexed where the problem lies...

EDIT:

Ok, now I tried around a bit. It seems that the Emby plugin is indeed not the culprit. If I want to see pictures in Kodi, it's always the same: dimmed picture (Kodi native) or black picture (Kodi native slideshow and Emby plugin). Sorry for your time!

Edited by Nosepull
Additional info
  • Like 1
Link to comment
Share on other sites

On 5/3/2021 at 7:26 PM, Nosepull said:

Yeah, for my internet radio streams I indeed solved the issue by giving the streams the fake artist "Radio". For my usecase this is a viable workaround.

However, IMHO it is not good that the plugin fails more or less silently in such cases. Wouldn't it be possible to give those missing artists an obviously false fake artist like "NOARTIST" or something like that, sticking out in Kodi. Then it's up to the user to fix the metadata.

This issue seems to have creeped back while I'm following your 5.2.07 pre-releases: Somehow this workaround does not work any longer,  the *strm-files with fake "artisit"-field no longer are available via the emby-next-gen plugin.

Link to comment
Share on other sites

I don't know if this is related, but it looks as if my Kodi library folder is filled up with (probably stale?) files from emby-next-gen:

drwxr-xr-x  3 kodi users 4096 Mai  2 05:59 'emby_Internet-Radio_(8c9daa1e2db7)'
drwxr-xr-x  3 kodi users 4096 Mai  2 07:03 'emby_Internet-Radio_(mediaserver)'
drwxr-xr-x  3 kodi users 4096 Mai  1 15:35 'emby_Internet-Radio_(e008e2663ede)'
drwxr-xr-x  3 kodi users 4096 Apr 19 17:18 'emby_Internet-Radio_(homeserver)'
drwxr-xr-x  3 kodi users 4096 Apr  3 09:53  embymusic8a05b0252259a1dbd62df97522638439
drwxr-xr-x  3 kodi users 4096 Apr  3 09:53  embymusic935caf68c9dfcb2c18cc334265e80a5a
drwxr-xr-x  3 kodi users 4096 Mai  9 06:18  emby_music_Internet-Radio
drwxr-xr-x  3 kodi users 4096 Mai  9 06:18  emby_music_Music
drwxr-xr-x  3 kodi users 4096 Mai  2 05:59 'emby_Music_(8c9daa1e2db7)'
drwxr-xr-x  3 kodi users 4096 Mai  2 07:03 'emby_Music_(mediaserver)'
drwxr-xr-x  3 kodi users 4096 Mai  1 15:35 'emby_Music_(e008e2663ede)'
drwxr-xr-x  3 kodi users 4096 Apr 19 17:18 'emby_Music_(homeserver)'

So there are entries defined by the name of my Emby instance (mediaserver), by the hostname where my Emby instance is running (homeserver), and other entry points. I have two libraries with music, one names "Music" (containing MP3s etc.) and one named "Internet-Radio" (containing only strm-files). IMHO there should only be two such folders and not 12?!

Link to comment
Share on other sites

(old) Nodes are never deleted, due to compatibility reason.

I recommend delete all nodes manually and restart Kodi. New nodes will be rebuild and you have a "clean" system.

 

 

Link to comment
Share on other sites

Just now, quickmic said:

(old) Nodes are never deleted, due to compatibility reason.

I recommend delete all nodes manually and restart Kodi. New nodes will be rebuild and you have a "clean" system.

 

 

What exactly do I have to delete? The whole library/music folder, or only those drawers starting with "emby"?

Link to comment
Share on other sites

50 minutes ago, Nosepull said:

This issue seems to have creeped back while I'm following your 5.2.07 pre-releases: Somehow this workaround does not work any longer,  the *strm-files with fake "artisit"-field no longer are available via the emby-next-gen plugin.

I'll check that, but I have an idea what's wrong.

Firstly please delete "old" nodes, I've to be sure you are use the correct selection...

Link to comment
Share on other sites

3 minutes ago, Nosepull said:

What exactly do I have to delete? The whole library/music folder, or only those drawers starting with "emby"?

you can delete the content of the library folder. kodi/userdata/library/*

Probably take a backup before. As mention, if a custom skin uses "old" nodes, the skin is broken and you have to reconfigure widgets, shortcuts... everything.

Edited by quickmic
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...