Jump to content

Emby next gen


quickmic

Recommended Posts

13 hours ago, quickmic said:

I think it's based on another issue. Can upload a full log and send it to me via PM.

sent...

Link to comment
Share on other sites

artichoke

Directories seem to be messed up for me. At the end of the log you can see I try to start playing "Exit_Through_the_Gift_Shop" but it's looking the the directory "Extra Ordinary (2019)/" instead. It might have been because I tried switching from add-on to native/direct paths in the settings. I switched it back for now, but it's still not working. I'll probably just do a Kodi DB wipe and it will all be fine.

I'm also curious why when I played Bob's.Burgers.S11E19 it directly played it, but when trying to play Exit_Through_the_Gift_Shop it seems to wants to play it differently? It prepends 76643-e12a714dbe6516ec9b88e9a2cf3563f3-10872601-stream-

kodi.log

Link to comment
Share on other sites

6 minutes ago, artichoke said:

Directories seem to be messed up for me. At the end of the log you can see I try to start playing "Exit_Through_the_Gift_Shop" but it's looking the the directory "Extra Ordinary (2019)/" instead. It might have been because I tried switching from add-on to native/direct paths in the settings. I switched it back for now, but it's still not working. I'll probably just do a Kodi DB wipe and it will all be fine.

I'm also curious why when I played Bob's.Burgers.S11E19 it directly played it, but when trying to play Exit_Through_the_Gift_Shop it seems to wants to play it differently? It prepends 76643-e12a714dbe6516ec9b88e9a2cf3563f3-10872601-stream-

kodi.log 173.43 kB · 0 downloads

Not sure, is this a valid path?

nfs://192.168.2.113/mnt/user/Movies/Extra Ordinary (2019)/76643-e12a714dbe6516ec9b88e9a2cf3563f3-10872601-stream-Exit_Through_the_Gift_Shop._2010_.Bluray-1080p_Proper.x264.DTS.mkv

 

Link to comment
Share on other sites

artichoke
9 minutes ago, quickmic said:

Not sure, is this a valid path?


nfs://192.168.2.113/mnt/user/Movies/Extra Ordinary (2019)/76643-e12a714dbe6516ec9b88e9a2cf3563f3-10872601-stream-Exit_Through_the_Gift_Shop._2010_.Bluray-1080p_Proper.x264.DTS.mkv

 

That file with the prepended 76643-e12a714dbe6516ec9 etc does not exist. I assumed it was being generated by Emby or this plugin. The nfs:// path does exist and used to work fine before I updated to Kodi 19 + emby next gen.

The actual file is "Exit Through the Gift Shop.(2010).Bluray-1080p Proper.x264.DTS.mkv", and it's in the "Exit Through the Gift Shop (2010)" folder, not that folder. Dunno if this plugin is messing up the file names or if Emby itself sent the wrong ones. Restarted Emby, same thing. Doing a Kodi DB reset now.

Link to comment
Share on other sites

1 minute ago, artichoke said:

That file with the prepended 76643-e12a714dbe6516ec9 etc does not exist. I assumed it was being generated by Emby or this plugin. The nfs:// path does exist and used to work fine before I updated to Kodi 19 + emby next gen.

The actual file is "Exit Through the Gift Shop.(2010).Bluray-1080p Proper.x264.DTS.mkv", and it's in the "Exit Through the Gift Shop (2010)" folder, not that folder. Dunno if this plugin is messing up the file names or if Emby itself sent the wrong ones. Restarted Emby, same thing. Doing a Kodi DB reset now.

ok, I'll check what's going wrong.

Link to comment
Share on other sites

artichoke
51 minutes ago, artichoke said:

Directories seem to be messed up for me. At the end of the log you can see I try to start playing "Exit_Through_the_Gift_Shop" but it's looking the the directory "Extra Ordinary (2019)/" instead. It might have been because I tried switching from add-on to native/direct paths in the settings. I switched it back for now, but it's still not working. I'll probably just do a Kodi DB wipe and it will all be fine.

I'm also curious why when I played Bob's.Burgers.S11E19 it directly played it, but when trying to play Exit_Through_the_Gift_Shop it seems to wants to play it differently? It prepends 76643-e12a714dbe6516ec9b88e9a2cf3563f3-10872601-stream-

kodi.log 173.43 kB · 1 download

After wiping DB and choosing native paths from the beginning, it seems to be working fine. So I guess it had to do with me changing from add on, to native path, and back to add on.

  • Like 1
Link to comment
Share on other sites

TheMasterMind025

@quickmic Does the "Emby Next Gen" addon take the "<criticrating>" field from a movie's NFO file and store it in Kodi as the "userrating"?  This is what's happening in my set up and I can't figure out if it's "Emby Next Gen" or my skin doing it (Titan Bingie Mod v2.0).  This is creating a problem with my Trakt integration.  The problems plays out like this....Emby Next Gen imports a new movie on sync -> Somehow the "criticalrating" value gets added as the "userrating" -> The Trakt addon runs to sync my collection and ratings -> The new movie gets added to my Trakt with a Trakt rating of 10 (Any "criticalrating" that's 10 is rated a 10).  This forces me to turn off the "Sync Rating" setting in Trakt.  

I'd like to keep skin I'm using and Emby Next Gen so I'm hoping to find a resolution to this issue.  Any help would be appreciated.

Link to comment
Share on other sites

misterkoat
On 5/1/2021 at 9:58 PM, quickmic said:

 

Which next-gen version are you using?

5.2 something. i downloaded it directly from a link you gave me. Most issues have since "sorted themselves out" apart from the lack of tags when starting music playback from widgets.

Link to comment
Share on other sites

On 4/18/2021 at 10:05 PM, quickmic said:

You are using the older 4.x version.

Please try this version:

https://embydata.com/downloads/addons/xbmb3c/repo-install/Public testing/plugin.video.emby-next-gen-5.2.07-build 55 (ex11).zip

As you are using Kodi 18.X, you must sideload the plugin/manual install via zip file.

If you give it a shot, it requires a FULL DB REBUILD of Kodi-db.

 

Also you can use the 5.1.7 version from emby-Kodi stable repository, but it has some limitations.

Is this the latest version? Thanks

Link to comment
Share on other sites

7 hours ago, misterkoat said:

5.2 something. i downloaded it directly from a link you gave me. Most issues have since "sorted themselves out" apart from the lack of tags when starting music playback from widgets.

Yes, it's known issue. Not sure if I can solve it. Seems Kodi deals differently with Music Song widgets. Could be also an issue of custom widgets. I performed a few tests, but didn't find a solution yet.

Link to comment
Share on other sites

15 hours ago, Sysyphus_ said:

Hello,

First things first : thank you all for the amazing work. I know it's a lot of work.

I write this message to bring to your attention a problem I have since I use  Emby NextGen with Kodi Matrix. I seems that EmbyNextGen won't connect every time to mu Emby server on the Kodi launch. It seem to be arbitrary, some time the connexion works, sometime not. I send a lot of time to discover why, looking at logs, starting a new fresh Kodi install, disabling all firewall, but I don't have any clue of what happening... It took me a while for me to realize the problem because Kodi works fine, but all my medias watched been randomly synchronized to Emby Server.

You will found attached two logs. One with Kodi starting and Emby NexGen who don't connect. I another with the an ok startup.

I hope you can help me, I'm an professional IT so you can ask me technical things if it's can help you.

Thank you in advance

kodi.embyok.log 68.16 kB · 1 download kodi.embyerror.log 57.34 kB · 1 download

Please try the beta version and report if it fixes the issue.

 

Link to comment
Share on other sites

7 hours ago, spon said:

Is this the latest version? Thanks

No it's https://embydata.com/downloads/addons/xbmb3c/repo-install/Public testing/plugin.video.emby-next-gen-5.2.07-build 165 (ex24).zip

You can find the latest experimental version on page one of this thread:

https://emby.media/community/index.php?/topic/90781-embyforkodi-5xx-preview/#comments

  • Like 1
Link to comment
Share on other sites

10 hours ago, TheMasterMind025 said:

@quickmic Does the "Emby Next Gen" addon take the "<criticrating>" field from a movie's NFO file and store it in Kodi as the "userrating"?  This is what's happening in my set up and I can't figure out if it's "Emby Next Gen" or my skin doing it (Titan Bingie Mod v2.0).  This is creating a problem with my Trakt integration.  The problems plays out like this....Emby Next Gen imports a new movie on sync -> Somehow the "criticalrating" value gets added as the "userrating" -> The Trakt addon runs to sync my collection and ratings -> The new movie gets added to my Trakt with a Trakt rating of 10 (Any "criticalrating" that's 10 is rated a 10).  This forces me to turn off the "Sync Rating" setting in Trakt.  

I'd like to keep skin I'm using and Emby Next Gen so I'm hoping to find a resolution to this issue.  Any help would be appreciated.

 

Emby Next Gen uses information from Emby server and not directly from nfo files. In native mode it is possible that Kodi or a custom skin reads extends info from NFO files.

Do you use the Kodi trakt plugin, cause I think you should do that. The Emby server trakt plugin should to the sync.

Edited by quickmic
Link to comment
Share on other sites

TheMasterMind025
7 hours ago, quickmic said:

 

Emby Next Gen uses information from Emby server and not directly from nfo files. In native mode it is possible that Kodi or a custom skin reads extends info from NFO files.

Do you use the Kodi trakt plugin, cause I think you should do that. The Emby server trakt plugin should to the sync.

I do use the Kodi Trakt plugin.  I also have the Trakt plugin on my Emby Server.  The problem occurs on the Kodi side.  The problem occurs when a new movie is added by Emby Next Gen.  When Emby Next Gen adds a new movie to my Kodi Library, the Movie's User Rating value is replaced by the Critical Rating value.  Once the import is complete, my Kodi Trakt plugin will run a sync because a new item has been added to my library.  It will add the new Movie to my Trakt collection and it will sync the new User Rating value to my Trakt.  I provided an example of the situation below.  I don't want my Movie's User Rating value being replaced by the Critical Rating.  This would stop this problem from occurring.  I'd just like to find out which addon is performing that action.  My guess is that it's the Emby Next Gen addon which is why I asked here.  I also think this issue is related the to Ratings for RT setting issue that was recently closed.

Example:  https://imgur.com/a/PUufSlc

Link to comment
Share on other sites

1 hour ago, TheMasterMind025 said:

I do use the Kodi Trakt plugin.  I also have the Trakt plugin on my Emby Server.  The problem occurs on the Kodi side.  The problem occurs when a new movie is added by Emby Next Gen.  When Emby Next Gen adds a new movie to my Kodi Library, the Movie's User Rating value is replaced by the Critical Rating value.  Once the import is complete, my Kodi Trakt plugin will run a sync because a new item has been added to my library.  It will add the new Movie to my Trakt collection and it will sync the new User Rating value to my Trakt.  I provided an example of the situation below.  I don't want my Movie's User Rating value being replaced by the Critical Rating.  This would stop this problem from occurring.  I'd just like to find out which addon is performing that action.  My guess is that it's the Emby Next Gen addon which is why I asked here.  I also think this issue is related the to Ratings for RT setting issue that was recently closed.

Example:  https://imgur.com/a/PUufSlc

Thanks for the example, I've another question.... I'm not an expert in ratings 🙄

Emby server shows 5.6 (I think that's the critical rating?) and 29% (user rating). Kodi is showing 29 (what is oblivious wrong, I assume it should be 2.9), anyway.

...so the plugin should sync 5.6 to Kodi, correct?

I'll check the Kodi DB structure for options...

Link to comment
Share on other sites

TheMasterMind025
18 minutes ago, quickmic said:

Thanks for the example, I've another question.... I'm not an expert in ratings 🙄

Emby server shows 5.6 (I think that's the critical rating?) and 29% (user rating). Kodi is showing 29 (what is oblivious wrong, I assume it should be 2.9), anyway.

...so the plugin should sync 5.6 to Kodi, correct?

I'll check the Kodi DB structure for options...

As I understand it, the Emby Server sources their rating information from the MovieDb and Omdb.  The rating with the star (5.6 in my example) represents the IMDb rating and the tomato rating (29% in my example) is the Rotten Tomato critic's score.  I'm not 100% sure what these variables are called internally on the Emby side.  That's why I keep referencing what I see in my NFO file.  I provided an example below of what displays in my NFO file and what's in the Kodi ratings table for this movie.

Snippet from NFO:

<rating>5.6</rating>
<year>2020</year>
<sorttitle>war with grandpa</sorttitle>
<mpaa>PG</mpaa>
<imdbid>tt4532038</imdbid>
<tmdbid>425001</tmdbid>
<premiered>2020-08-27</premiered>
<releasedate>2020-08-27</releasedate>
<criticrating>29</criticrating>

Kodi Rating's Table for War with Grandpa:

rating_id media_id media_type rating_type rating votes
924 517 movie default 5.6 Null
925 517 movie tomatometerallcritics 2.9 Null

 

Link to comment
Share on other sites

TheMasterMind025
9 minutes ago, quickmic said:

Just checked KodiDB structure.

Possible options are:

userrating

MPAA Rating -> I think that FSK in Germany?

votes

-> https://kodi.wiki/view/Databases/MyVideos

I pulled up the movie's record on the Kodi Movie table.  The "userrating" field has a value of 29.  This is what's causing the problem.

Screenshot:  https://imgur.com/a/c0V8TRj

Link to comment
Share on other sites

I'll perform a couple of tests... Manipulating the DB manually and see what's the effects.

Which value should be synced to trakt? tomatometerallcritics? Currently seems 2.9 is synced (wrongly, due to comma issue)

Edited by quickmic
Link to comment
Share on other sites

TheMasterMind025
1 minute ago, quickmic said:

I'll perform a couple of tests... Manipulating the DB manually and see what's the effects.

Which value should be synced to trakt? tomatometerallcritics? Currently seems 2.9 is synced (wrongly, due to comma issue)

I don't want any of these values synced to my Trakt.  Having Emby Next Gen add the IMDb and Rotten Tomatoes ratings to the Kodi Ratings table seems fine.  The problem occurs when the Movie file's "userrating" field gets messed with.  From the quick glance I made at the Kodi Trakt plugins code, it seems like they use the "userrating" field when keeping ratings in sync between Kodi and Trakt.  My Trakt ratings should represent the personal ratings I provide to the movie and not the Rotten Tomato score.  In an ideal world, an option would be added to Emby Next Gen so that the Rotten Tomato score doesn't replace the "userrating" (Basically, reopening the ticket I referenced above).

I think the old Kodi for Emby add on used to replace the "userrating" value so the Rotten Tomato score could display on widgets in specific skins.  However, this doesn't work well for Trakt integration.  This is why I would suggest an optional toggle instead of changing the function completely.  I'm not sure how many users prefer the current implementation.

Link to comment
Share on other sites

I can add a toggle option to disable userrating sync. That's not a problem.

The plugin is just syncing data from Emby server to Kodi. From that point, Kodi is in charge. If there are any issues after sync, there is nothing I can do.

I'll fix the digits in userrating and add a toggle option. I hope this helps.

  • Like 1
Link to comment
Share on other sites

Has anyone else had the problem with a single play being scrobbled to Trakt twice? I only experience this when using Emby-next-gen (version 5.1.17) whereas with the old Emby addon (4.x something) a play of an episode/movie is only scrobbed once, like desired.

None of my Kodi clients have the Trakt plugin installed, only using the Trakt plugin in Emby. All Kodi clients are using the Native method.

Edited by aaearon
add more info.
Link to comment
Share on other sites

6 minutes ago, aaearon said:

Has anyone else had the problem with a single play being scrobbled to Trakt twice? I only experience this when using Emby-next-gen (version 5.1.17) whereas with the old Emby addon (4.x something) a play of an episode/movie is only scrobbed once, like desired.

None of my Kodi clients have the Trakt plugin installed, only using the Trakt plugin in Emby. All Kodi clients are using the Native method.

Yes, will be fixed in next beta.

  • Like 1
Link to comment
Share on other sites

54 minutes ago, TheMasterMind025 said:

Basically, reopening the ticket I referenced above

Ticket reopened...

  • Like 1
Link to comment
Share on other sites

7 hours ago, TheMasterMind025 said:

I don't want any of these values synced to my Trakt.  Having Emby Next Gen add the IMDb and Rotten Tomatoes ratings to the Kodi Ratings table seems fine.  The problem occurs when the Movie file's "userrating" field gets messed with.  From the quick glance I made at the Kodi Trakt plugins code, it seems like they use the "userrating" field when keeping ratings in sync between Kodi and Trakt.  My Trakt ratings should represent the personal ratings I provide to the movie and not the Rotten Tomato score.  In an ideal world, an option would be added to Emby Next Gen so that the Rotten Tomato score doesn't replace the "userrating" (Basically, reopening the ticket I referenced above).

I think the old Kodi for Emby add on used to replace the "userrating" value so the Rotten Tomato score could display on widgets in specific skins.  However, this doesn't work well for Trakt integration.  This is why I would suggest an optional toggle instead of changing the function completely.  I'm not sure how many users prefer the current implementation.

As far as ratings, I've been trying to use Kodi as my front end now, specifically because of it's ability to display MetaCritic, Rotten Tomatoes, IMDB, TMDB ratings. I much prefer the Emby front end in almost all other aspects, but having those ratings is vital to me so I've made the switch. So with that said, I'd vote to not change (or make it as an option). 

I will add for anyone reading this that Kodi front end is working well for movies, but pretty terribly for TV shows as the naming convention that I use for specials in Emby (which works perfectly) is not working at all in Kodi. All specials are correctly listed under specials, as well as under all seasons. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...