Jump to content

Emby next gen


quickmic

Recommended Posts

22 hours ago, quickmic said:

you can delete the content of the library folder. kodi/userdata/library/*

Probably take a backup before. As mention, if a custom skin uses "old" nodes, the skin is broken and you have to reconfigure widgets, shortcuts... everything.

This worked, thank you. Maybe you could add some functionality "Restore library nodes" or something like that in the plugin menu?

Link to comment
Share on other sites

Just installed fresh Kodi 18.9 (19.1 not available on xbox yet) and Emby-Next-Gen 5.1 on my xbox. Went through the setup wizard and I can access movie lists but when I go to play it, it never starts. I can see on the server dashboard that it says that the movie is trying to play direct and gets about 2 sec in then restarts.

In addition to this, Emby Next Gen never seems to get the default Kodi interface setup right - The Movies main section is empty and I have to browse the file list via the addon to play movies. Is this intended?

In contrast - I tried Emby Con and that both worked as direct play and installed a modified version of the default interface.

Is Next Gen still not in a stable place or am I missing something?

 

Note: I tried the latest nextgen beta but it fails to even log into the local server on initial setup.

Edited by strichmo
Link to comment
Share on other sites

2 hours ago, strichmo said:

Just installed fresh Kodi 18.9 (19.1 not available on xbox yet) and Emby-Next-Gen 5.1 on my xbox. Went through the setup wizard and I can access movie lists but when I go to play it, it never starts. I can see on the server dashboard that it says that the movie is trying to play direct and gets about 2 sec in then restarts.

In addition to this, Emby Next Gen never seems to get the default Kodi interface setup right - The Movies main section is empty and I have to browse the file list via the addon to play movies. Is this intended?

In contrast - I tried Emby Con and that both worked as direct play and installed a modified version of the default interface.

Is Next Gen still not in a stable place or am I missing something?

 

Note: I tried the latest nextgen beta but it fails to even log into the local server on initial setup.

Well, I have no xbox for tests but I assume it should also work straight as on other devices.

Can you send me a kodi.log file?

Link to comment
Share on other sites

Hi, since I've upgraded to Kodi 19 on my Nvidia Shield Android TV and started using this next gen Kodi add-on my trailers won't play.

The trailers are locally stored on the server and do work with the Kodi 18 and the previous Emby for Kodi plugin. They also work on the iOS, Android and Web apps.

I did complete removed Kodi and started from a fresh install of the Kodi app and the Emby add-on and then of course also a library scan from scratch.

 

I've tried both the stable (5.1.17) and the beta (5.2.07). Both with the same result. I didn't do a library rescan/repair after installing the beta add-on.

Here's a log file from Kodi in debug mode: https://paste.kodi.tv/uhitavujaw

I couldn't see any related logs on the Emby server so my guessing is that it already goes wrong in Kodi. Because when I play a trailer from my Android app I do see related logs.

 

Could someone please have a look? I really liked watching trailers directly in Kodi!

Link to comment
Share on other sites

On 15/05/2021 at 16:55, quickmic said:

Well, I have no xbox for tests but I assume it should also work straight as on other devices.

Can you send me a kodi.log file?

Unfortunately I cannot help any further at this point: I've realised I don't need Kodi for Xbox as I can cast to the TV with DLNA or to our Chromecast. Vastly simplifies things.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
On 5/20/2021 at 6:36 PM, red_ said:

Hi, since I've upgraded to Kodi 19 on my Nvidia Shield Android TV and started using this next gen Kodi add-on my trailers won't play.

The trailers are locally stored on the server and do work with the Kodi 18 and the previous Emby for Kodi plugin. They also work on the iOS, Android and Web apps.

I did complete removed Kodi and started from a fresh install of the Kodi app and the Emby add-on and then of course also a library scan from scratch.

 

I've tried both the stable (5.1.17) and the beta (5.2.07). Both with the same result. I didn't do a library rescan/repair after installing the beta add-on.

Here's a log file from Kodi in debug mode: https://paste.kodi.tv/uhitavujaw

I couldn't see any related logs on the Emby server so my guessing is that it already goes wrong in Kodi. Because when I play a trailer from my Android app I do see related logs.

 

Could someone please have a look? I really liked watching trailers directly in Kodi!

 

Do you mean the cinemamode for Trailers? It only works in addon-mode, not native.

Edited by quickmic
Link to comment
Share on other sites

4 hours ago, quickmic said:

 

Do you mean the cinemamode for Trailers? It only works in addon-mode, not native.

No, I mean when clicking on Trailer in the information screen of a movie in Kodi. 

And yes, I'm running in addon-mode.

Link to comment
Share on other sites

have a problem with my database. i install this addon and after connection with my emby server

i have all movies in Kodi. 

if i add some more movies to emby server, kodi will not automatically update, i dont see my new movies

in kodi, only on emby server.

reboot not help. 

i use the embuary (matrix) skin. update over the sidemenu, update database, helps also not.

Edit:
i ve this problem only with emby-next-gen (LibreELEC / PI4). on my other system with kodi 18.1 and emby-con

all is fine

Edited by noxx
Link to comment
Share on other sites

Well, next-gen uses two types of sync. One is the realtime sync (Kodi online) the other is the "regular" sync on Kodi startup.

Both can handle updates, I'm supprised that both are not working.

First, please test the realtime communication. Send a (text) message to Kodi from the Emby server. If this is not working, there is somethin wrong with the websocket communication.

 

Link to comment
Share on other sites

As of 5.3.2 I still have massive problems with the plugin as it does not reliably connect to Emby. In fact the connection is so unreliable that it is close to unusable for everyday use. Even on the first boot more often than not the connection fails and I have to restart Kodi and/or Kodi several times until it works. (It is trial and error.) I also have the impression that the situation was better a few releases ago.

I use Ubuntu 21.04, Kodi 19.1 from Team-XBMC repo, and Emby as a Podman/Docker container, both on the same device (i.e. the plugin connects to localhost).

Also restarting the plugin does not seem to do anything, the log only shows the following line and nothing more:

2021-06-04 06:30:54.307 T:24529    INFO <general>: CPythonInvoker(20, /srv/kodi/.kodi/addons/plugin.video.emby-next-gen/events.py): script successfully run

 

error.txt

Link to comment
Share on other sites

2 hours ago, Nosepull said:

As of 5.3.2 I still have massive problems with the plugin as it does not reliably connect to Emby. In fact the connection is so unreliable that it is close to unusable for everyday use. Even on the first boot more often than not the connection fails and I have to restart Kodi and/or Kodi several times until it works. (It is trial and error.) I also have the impression that the situation was better a few releases ago.

I use Ubuntu 21.04, Kodi 19.1 from Team-XBMC repo, and Emby as a Podman/Docker container, both on the same device (i.e. the plugin connects to localhost).

Also restarting the plugin does not seem to do anything, the log only shows the following line and nothing more:



2021-06-04 06:30:54.307 T:24529    INFO <general>: CPythonInvoker(20, /srv/kodi/.kodi/addons/plugin.video.emby-next-gen/events.py): script successfully run

 

error.txt 3.96 kB · 0 downloads

The issue in the log indicates Kodi/Next-gen plugin comes from an incorrectly (Kodi/Plugin) shutdown. The websocket is still running in the background and is blocking the network port.

The question is, why "Kodi" crashed in the first place?

 

Can you send me a full kodi.log after:

Docker container shutdown/restart (not hibernate etc.) -> Kodi and next-gen should start correctly in this case and wait till the first crash happens.

Send me the kodi.old.log (and probably the kodi crash log) as well as the kodi.log.

 

 

Edited by quickmic
Link to comment
Share on other sites

On 6/4/2021 at 8:35 AM, quickmic said:

The issue in the log indicates Kodi/Next-gen plugin comes from an incorrectly (Kodi/Plugin) shutdown. The websocket is still running in the background and is blocking the network port.

The question is, why "Kodi" crashed in the first place?

 

Can you send me a full kodi.log after:

Docker container shutdown/restart (not hibernate etc.) -> Kodi and next-gen should start correctly in this case and wait till the first crash happens.

Send me the kodi.old.log (and probably the kodi crash log) as well as the kodi.log.

 

 

Well, in my case Kodi has definitely not crashed before, as the problem also happened after a fresh reboot and the log files did not show anything. I only can guess that there might be a race condition between Kodi and Emby starting up at the same time (startup delay option in the plugin has been set to a few secs)?! Whatever, as I said the problem persisted for quite some time and lots of reboots, but when I tried to get a fresh log for you, a miracle happend (?!?). The plugin suddenly offered me to continue a sync which was presumably not completed at the last run (I didn't see this window for weeks), and after that, the problem has no longer appeared for the last few days. I don't know if some plugin update was in between, as I auto-update it, now running 5.3.2 (last time I checked it was at 5.3.0).

However, isn't there some possibility to  get rid of blocked websockets by means of the server side plugin? So Emby could disconnect broken client connections from the server side of things?

Link to comment
Share on other sites

2 hours ago, Nosepull said:

However, isn't there some possibility to  get rid of blocked websockets by means of the server side plugin? So Emby could disconnect broken client connections from the server side of things?

Unfortunately it's not that easy. Please try setup a startup delay in next-gen settings, also configure Kodi to wait for networks -> somewhere in Kodi settings.

Link to comment
Share on other sites

damagedspline

I went over the thread and tried it out. I must say that the kodi integration (19.1) is working flawlessly on my setup.

Is there an easy way to switch Emby profiles within this plugin? I want to avoid duplicating kodi profiles as beside that s parameter, they have the exact same config...

 

 

Link to comment
Share on other sites

21 hours ago, damagedspline said:

I went over the thread and tried it out. I must say that the kodi integration (19.1) is working flawlessly on my setup.

Is there an easy way to switch Emby profiles within this plugin? I want to avoid duplicating kodi profiles as beside that s parameter, they have the exact same config...

 

 

Currently it's only possible to add an additional user to a session, but not switching the profiles.

 

Link to comment
Share on other sites

On 6/7/2021 at 1:37 AM, quickmic said:

Unfortunately it's not that easy. Please try setup a startup delay in next-gen settings, also configure Kodi to wait for networks -> somewhere in Kodi settings.

Hi, I did both of these and it still never syncs after the initial library build. I've reset my database several times now and each time it shows what I've recently added. However, after that it fails to update any new additions.

Link to comment
Share on other sites

6 hours ago, Mister D said:

Hi, I did both of these and it still never syncs after the initial library build. I've reset my database several times now and each time it shows what I've recently added. However, after that it fails to update any new additions.

Well, I'll check that. I have an idea, why it's not syncing 😉

  • Thanks 1
Link to comment
Share on other sites

Good afternoon, forgive my bad English, but I translate with the google translator

I have installed Emby Next Gen and I think I have done well because it has scanned all emby libraries, but what I can't do is put the different accesses in the menu.

Could you help me?

Thanks.

Greetings.

Link to comment
Share on other sites

1 minute ago, kevylluma said:

Good afternoon, forgive my bad English, but I translate with the google translator

I have installed Emby Next Gen and I think I have done well because it has scanned all emby libraries, but what I can't do is put the different accesses in the menu.

Could you help me?

Thanks.

Greetings.

Do you want to customize Kodi's menus/homescreen? This can only be done with custom skins and not with Kodi's default skin.

  • Thanks 1
Link to comment
Share on other sites

6 minutes ago, quickmic said:

Do you want to customize Kodi's menus/homescreen? This can only be done with custom skins and not with Kodi's default skin.

Thanks for your help.

If I know that it can only be done with skins, I'm using Arctic Zephyr (Mod 2) but I don't know how to put accesses in the menu for my emby libraries.

The local kodi libraries can do it, but the emby libraries don't.

Greetings.

Link to comment
Share on other sites

8 minutes ago, kevylluma said:

Thanks for your help.

If I know that it can only be done with skins, I'm using Arctic Zephyr (Mod 2) but I don't know how to put accesses in the menu for my emby libraries.

The local kodi libraries can do it, but the emby libraries don't.

Greetings.

Basically, when you customize the main menu you can also select plugins. Browse to next-gen plugin and go from there.

I'll upload a how-to video in the next days if you cannot find a solution.

Also, use the latest beta version 5.3.2 before you start customizing the skin. There are several node changes.

  • Thanks 1
Link to comment
Share on other sites

6 minutes ago, quickmic said:

Basically, when you customize the main menu you can also select plugins. Browse to next-gen plugin and go from there.

I'll upload a how-to video in the next days if you cannot find a solution.

Also, use the latest beta version 5.3.2 before you start customizing the skin. There are several node changes.

ok, I'm going to investigate why I am doing something wrong since version 5.1.17 is installed, it is the only one that comes out.

And I'll wait for that video to see how it is configured.

Thank you.

Regards.

Link to comment
Share on other sites

1 minute ago, kevylluma said:

ok, I'm going to investigate why I am doing something wrong since version 5.1.17 is installed, it is the only one that comes out.

And I'll wait for that video to see how it is configured.

Thank you.

Regards.

You can use emby kodi beta repository from here:

http://kodi.emby.tv/

5.3.2 will be the next stable version.

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...