Jump to content

Plugin - Iconic Image Enhancer


roaku

Recommended Posts

7 hours ago, Byebye said:

custom image file
Customize the image display position, spacing, size

possible?

There are no images involved in the icon badges, but custom fonts for the icons is being worked on for a future release.

The screenshot here should give you an idea of the badge customization options:

 

Edited by roaku
Link to comment
Share on other sites

DarKni8

I am not able to change icon on 4.6.7.0. Any way to  troubleshoot?

Like i have changed it to this

image.png.52785eeddc57211d6ba4d9e9ea9d3aef.png

 

End result is

image.png.02f42c550eae8bbb35a57eae3d682661.png

Edited by DarKni8
Link to comment
Share on other sites

2 hours ago, DarKni8 said:

I am not able to change icon on 4.6.7.0. Any way to  troubleshoot?

Like i have changed it to this

image.png.52785eeddc57211d6ba4d9e9ea9d3aef.png

 

End result is

image.png.02f42c550eae8bbb35a57eae3d682661.png

You're modifying the icon for the general badge preview, not the icon for an actual rule.

Go to the actual rule you want to edit in the rules section of the config and click its icon to get the icon selector for that rule.

Link to comment
Share on other sites

DarKni8
1 hour ago, roaku said:

You're modifying the icon for the general badge preview, not the icon for an actual rule.

Go to the actual rule you want to edit in the rules section of the config and click its icon to get the icon selector for that rule.

But there is no option to edit

 

image.png.83756a4c8b93f53a6c44b0fe349b4247.png

 

 

Ok , this is strange, the icon is being inherited from other library's rule

Edited by DarKni8
Link to comment
Share on other sites

Posted (edited)
15 minutes ago, DarKni8 said:

But there is no option to edit

 

image.png.83756a4c8b93f53a6c44b0fe349b4247.png

 

 

Ok , this is strange, the icon is being inherited from other library's rule

Don't edit the rule. Click the icon on the left side of that rule's row.

Look at the screenshots here, 'selecting a rule icon' in particular:

 

Edited by roaku
  • Like 1
Link to comment
Share on other sites

DarKni8
1 hour ago, roaku said:

Don't edit the rule. Click the icon on the left side of that rule's row.

Look at the screenshots here, 'selecting a rule icon' in particular:

 

Thanks for helping me patiently, it worked. Your plugin is awesome.

  • Thanks 1
Link to comment
Share on other sites

  • 2 weeks later...
mixXxim

Thanks for the plugin, made a donation and now activated.
Question: I can't find a selection for the number of channels183528586_AnfrageChannelanzahl01.jpg.d30a9ad8cfd85dd8c95ed97d066e3ced.jpg Type: Audio

1544485851_AnfrageChannelanzahl.thumb.jpg.2ce17b8d77cd29e08f130d573a0fea81.jpg

Thanks very much

Link to comment
Share on other sites

Posted (edited)
1 hour ago, mixXxim said:

Thanks for the plugin, made a donation and now activated.
Question: I can't find a selection for the number of channels183528586_AnfrageChannelanzahl01.jpg.d30a9ad8cfd85dd8c95ed97d066e3ced.jpg Type: Audio

1544485851_AnfrageChannelanzahl.thumb.jpg.2ce17b8d77cd29e08f130d573a0fea81.jpg

Thanks very much

Hi, thanks for registering!

I don't think 'Channels' is implemented, but I think 'ChannelLayout' should work for you in this case with a value of '7.1'.

Edited by roaku
Link to comment
Share on other sites

mixXxim

Thanks for the answer.

Question: Can I use placeholders?
Example: DisplayTitle: (Default)
So that only the audio stream with the content "(Default)", i.e. the first one, is displayed.
If not, how can I limit the selection to one, the first audio stream?

838322919_IconicPlatzhalter(Default).thumb.jpg.524853d6967c49b94406eeb2eceae3d9.jpg

Thanks

Link to comment
Share on other sites

12 minutes ago, mixXxim said:

Thanks for the answer.

Question: Can I use placeholders?
Example: DisplayTitle: (Default)
So that only the audio stream with the content "(Default)", i.e. the first one, is displayed.
If not, how can I limit the selection to one, the first audio stream?

838322919_IconicPlatzhalter(Default).thumb.jpg.524853d6967c49b94406eeb2eceae3d9.jpg

Thanks

 

If the string '(Default)' is *part* of the value of DisplayTitle, then the plugin will match that string, even if there are other characters in the string before or after.

There's no way to explicitly limit a check to a particular MediaStream. You would need to find some combination of properties for the MediaStream that are unique to it.

Link to comment
Share on other sites

For those of you living on the edge, I just pushed a 4.7 beta compatible version of Iconic to the catalog.

If you're running Emby 4.7, you should see an option to install Emby 2.0.1.0 (Beta) in the version dropdown of the Catalog Page for Iconic.

Let me know if you have any issues with it.

 

@horstepipe

  • Thanks 2
Link to comment
Share on other sites

On 12/17/2021 at 10:37 AM, roaku said:

Unfortunately, new registrations can take up to 24 hours before they fully activate. If you still don't have full access after that time period, please let me know.

I've gone over this with the Emby team a few times and there doesn't seem to be anything I can do about it from the plugin side.

I activated Premiere yesterday morning, but I'm getting the same thing on the top of my Iconic UI page. 

Can you help?

Link to comment
Share on other sites

1 hour ago, budd said:

I activated Premiere yesterday morning, but I'm getting the same thing on the top of my Iconic UI page. 

Can you help?

Did you register Iconic in addition to the Premiere activation?

And did you use the same email for both Premiere and Iconic registration?

Link to comment
Share on other sites

Well, I guess that might be the problem. I don't even see a button to register Iconic?

I'm guessing it's supposed to be somewhere as plain as day.. but I don't see anything. The options on the plugin are "Configure" and "Uninstall" and the configure page only has 1 instance of register if I do a ctrl+f, and it's in the message "Unregistered versions of Iconic are limited to one rule match/badge per Movie."

 

Edit: nevermind, I see it on the plugin install page now.. Well, that answers that question.

Edited by budd
Link to comment
Share on other sites

10 minutes ago, budd said:

Well, I guess that might be the problem. I don't even see a button to register Iconic?

I'm guessing it's supposed to be somewhere as plain as day.. but I don't see anything. The options on the plugin are "Configure" and "Uninstall" and the configure page only has 1 instance of register if I do a ctrl+f, and it's in the message "Unregistered versions of Iconic are limited to one rule match/badge per Movie."

 

Edit: nevermind, I see it on the plugin install page now.. Well, that answers that question.

Ok, I see your registration now. Thanks!

Let's start the countdown clock. :)

Link to comment
Share on other sites

Registration was immediate for me, as soon as I paid.

Just couldn't find the place to register.

 

Thanks! :D

 

Edit: Maybe not? The Unregistered banner is at the top, but the plugin says it's registered. It's only matching 1 rule per film now.

It's bedtime for me anyway, so I'll check tomorrow and hopefully it's sorted on the backend.

Edited by budd
Link to comment
Share on other sites

9 hours ago, budd said:

It's bedtime for me anyway, so I'll check tomorrow and hopefully it's sorted on the backend.

If it still isn't working then, try blanking out your Premiere key and saving and then re-pasting it and saving again.  See if that "wakes it up".

Link to comment
Share on other sites

@ebr I did that this morning, but it's still showing the unregistered banner and only matching 1 rule.

Is the banner expected up there even if it's registered?

Link to comment
Share on other sites

It looks like the plugin has picked up registration and the banner at the top is gone and is now matching multiple rules. 

Just took a bit of time.

Thanks!

  • Like 1
Link to comment
Share on other sites

ohmadruga

Hi,

I've registered for this plugin using a different e-mail from the one that holds the Emby Premiere key/subscription. Will that be a problem regarding activation?

Link to comment
Share on other sites

1 hour ago, ohmadruga said:

Hi,

I've registered for this plugin using a different e-mail from the one that holds the Emby Premiere key/subscription. Will that be a problem regarding activation?

@ebr  would need to help you with this.

  • Like 1
Link to comment
Share on other sites

3 hours ago, Sknight117 said:

Where can I find the download link for v2.0?

Iconic releases are installed through the Emby catalog.

Link to comment
Share on other sites

Posted (edited)

For those on Emby Server 4.7 beta, you should have access to a new Iconic 2.1.0 beta through the catalog.

I haven't been able to test on Windows or Synology yet, but Ubuntu/Debian and FreeBSD are looking pretty good.

Here are the changes:

  • 'New Release' Rule - Show an Icon based on # months since Library Added date [I wanted this]
  • Status Rule for TV Shows - Show an Icon based on a show's Continuing/Ended Status [ @tmb4016, Reddit request]
  • Folder Specifier for Movies and TV Libraries - Optionally restrict rules to Library subfolder(s) @horstepipe
  • MediaStream Rule - CodecTag Property added to property options @CyberPoison
  • Collection Rule - Updated to support any collection wildcard (*) @Asdepique777
  • Material Icons - Updated with more icons [thanks Emby]

 

This won't be officially released until after Emby 4.7 is and will only be available for 4.7+.

And as always, you should back up your Iconic configuration xml before updating.

There are quite a few underlying changes to enable some of these features, so please let me know if anything doesn't work/stops working as expected.

For Windows users, Windows has been finicky about rendering the fonts in the past, so let me know if that comes up again. Thanks.

Also, I've been working on custom fonts, but I don't have it figured out yet, so it won't be part of this release.

Edited by roaku
Link to comment
Share on other sites

chander421

Thanks for this great plugin! Would like to registrate for unlocking the full app but my premiere key is linked to an old email that'not my paypal email... How could this be resolved?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...