Jump to content

Plugin - Iconic Image Enhancer


roaku

Recommended Posts

roaku
1 minute ago, cayars said:

Yes .14 beta.
Is it not compatible with the beta?

Sometimes it is, sometimes it isn't.

I don't try to code to the very fast moving, un-roadmapped targets that are Emby betas.

If you wanted to check the log and share what you see I might be able to provide some insight into what's wrong, but I won't try to fix it until the problem is in a stable release.

 

Link to comment
Share on other sites

That's fine. Just thought I'd ask.
Appreciate the response.

Link to comment
Share on other sites

horstepipe

hey

any chance adding an option like "filename does NOT contain" ? 🙂

Link to comment
Share on other sites

roaku
12 minutes ago, horstepipe said:

hey

any chance adding an option like "filename does NOT contain" ? 🙂

It's been requested and will happen eventually. Sorry I haven't gotten to it yet.

  • Like 1
Link to comment
Share on other sites

horstepipe
On 10/22/2021 at 5:56 PM, roaku said:

It's been requested and will happen eventually. Sorry I haven't gotten to it yet.

nice to hear, thank you very much for the plugin at all, it is very handy!

Link to comment
Share on other sites

GrimReaper

Is there a way to make plugin not automatically update to v2

Could you post modified v1 dll with "Do not update" switch maybe? 

I rather like apply-to-all approach, recreating each rule per library gets old pretty quickly with no rule-duplication capability, and I grew somewhat tired of replacing updated version with v1 dll on a regular basis each time upon going online for Premiere verification. 

Link to comment
Share on other sites

roaku
21 minutes ago, GrimReaper said:

Is there a way to make plugin not automatically update to v2

Could you post modified v1 dll with "Do not update" switch maybe? 

I rather like apply-to-all approach, recreating each rule per library gets old pretty quickly with no rule-duplication capability, and I grew somewhat tired of replacing updated version with v1 dll on a regular basis each time upon going online for Premiere verification. 

I thought users could select the plugin version they wanted to use from a dropdown selector in the catalog entry for a plugin.

If that's not the case, I'd make a feature request to Emby to add that feature.

The plugin version updating isn't in my control.

In the immediate term with 2x, if you're comfortable editing xml, you could activate each library you want, then open iconic.xml and copy/paste the rules section from the library you're happy with to the new ones.

Edited by roaku
Link to comment
Share on other sites

GrimReaper
18 minutes ago, roaku said:

I thought users could select the plugin version they wanted to use from a dropdown selector in the catalog entry for a plugin.

If that's not the case, I'd make a feature request to Emby to add that feature.

The plugin version updating isn't in my control.

Tbh have no idea, I never installed it from Catalogue but been always doing it manually since the early beta days, likely there is a version dropdown, as with any other plugin. However, mine gets updated upon every going online (regardless of server Auto-updates off), as with any other plugin pushed-update.

20 minutes ago, roaku said:

In the immediate term with 2x, if you're comfortable editing xml, you could activate each library you want, then open iconic.xml and copy/paste the rules section from the library you're happy with to the new ones.

Thanks, will do. 

Link to comment
Share on other sites

roaku
5 minutes ago, GrimReaper said:

Tbh have no idea, I never installed it from Catalogue but been always doing it manually since the early beta days, likely there is a version dropdown, as with any other plugin. However, mine gets updated upon every going online (regardless of server Auto-updates off), as with any other plugin pushed-update.

You should try using the catalog to install the version you want and see if Emby will stick with that.

Link to comment
Share on other sites

GrimReaper
1 minute ago, roaku said:

You should try using the catalog to install the version you want and see if Emby will stick with that.

Will try and see what gives. 

Link to comment
Share on other sites

horstepipe
On 10/22/2021 at 5:56 PM, roaku said:

It's been requested and will happen eventually. Sorry I haven't gotten to it yet.

Hey

can you give a rough ETA about that? I was just seeing that the original request is some time ago. If you say that it is more low prio and that it will probably take months, I‘ll take a look into renaming my files to „German“ and „English“

best regards

Link to comment
Share on other sites

roaku
2 hours ago, horstepipe said:

Hey

can you give a rough ETA about that? I was just seeing that the original request is some time ago. If you say that it is more low prio and that it will probably take months, I‘ll take a look into renaming my files to „German“ and „English“

best regards

Yes, it will be awhile, so looking into alternatives is a good idea.

  • Thanks 1
Link to comment
Share on other sites

horstepipe
On 10/27/2021 at 11:49 PM, roaku said:

Yes, it will be awhile, so looking into alternatives is a good idea.

thanks!

do you have any solution in mind for episodes which do not have an image? E.g. :

bobs.thumb.PNG.1fc6d7b16768e213eed834b68609796d.PNG

here you see directly that episode 4 is english, but you don't see it for episode 5 as there's no picture yet.

I know that's most likely something you can't do anything about 🙂

Link to comment
Share on other sites

roaku
2 hours ago, horstepipe said:

thanks!

do you have any solution in mind for episodes which do not have an image? E.g. :

bobs.thumb.PNG.1fc6d7b16768e213eed834b68609796d.PNG

here you see directly that episode 4 is english, but you don't see it for episode 5 as there's no picture yet.

I know that's most likely something you can't do anything about 🙂

Ya, sorry. The only solution there is to add the missing episode images.

  • Agree 1
Link to comment
Share on other sites

horstepipe

would it be posible to add ["average bitrate" is higher / lower than "value"] as a rule? We could mark high bitrate movie with that option so people are directly aware.

Edited by horstepipe
Link to comment
Share on other sites

roaku
1 hour ago, horstepipe said:

would it be posible to add ["average bitrate" is higher / lower than "value"] as a rule? We could mark high bitrate movie with that option so people are directly aware.

If 'average bitrate' is a property Emby gives me access to, then you should get this when I implement the Operators feature (=,!=,<,>,etc.).

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...