Jump to content
Vinnie Sims

Safe To Update To New DSM 6.2.2-24922 Update 2 With Emby Server?

Recommended Posts

Vinnie Sims

Hello!

 

I just have a question about updating my Synology NAS and if it is safe to update it to the new DSM 6.2.2-24922 update 2 with my Emby Server running on it. The DSM update was just released https://www.synology.com/en-us/releaseNote/DS918+ on the 4th of July.

 

The only reason why I ask this is because I've updated, restarted, and shutdown my NAS is the past, and I've often gotten times where I could not run Emby after the update, restart, or shutdown was complete, but I don't know if it could have done something with this https://emby.media/community/index.php?/topic/73984-emby-on-synology-ds918-won’t-run-after-restart-shutdown/ that I posted a little while ago and solved the issue on.

 

So, since my NAS just received the update as of today, despite it being released on the 4th of July, I have yet to download and install it because I want to know if it is safe to do so for Emby and my NAS so that I don't have the same problem like I did before in the past from the second link I shared above. Plus, what to do (precautions) before I download and install the update on my NAS for the Emby Server.

 

Anything would be appreciated.

 

Thanks!

Edited by Vinnie Sims

Share this post


Link to post
Share on other sites
Luke

@@FrostByte have you updated?

Share this post


Link to post
Share on other sites
DarWun

Hello!

 

I just have a question about updating my Synology NAS and if it is safe to update it to the new DSM 6.2.2-24922 update 2 with my Emby Server running on it. The DSM update was just released https://www.synology.com/en-us/releaseNote/DS918+ on the 4th of July.

 

The only reason why I ask this is because I've updated, restarted, and shutdown my NAS is the past, and I've often gotten times where I could not run Emby after the update, restart, or shutdown was complete, but I don't know if it could have done something with this https://emby.media/community/index.php?/topic/73984-emby-on-synology-ds918-won’t-run-after-restart-shutdown/ that I posted a little while ago and solved the issue on.

 

So, since my NAS just received the update as of today, despite it being released on the 4th of July, I have yet to download and install it because I want to know if it is safe to do so for Emby and my NAS so that I don't have the same problem like I did before in the past from the second link I shared above. Plus, what to do (precautions) before I download and install the update on my NAS for the Emby Server.

 

Anything would be appreciated.

 

Thanks!

 

Over the weekend I updated DSM from 6.2.2-24922 to 6.2.2-24922-2 on my DS918+. For whatever reason, I was never offered the update to 6.2.2-24922-1 that was issued in June. Apparently Synology pulled it shortly after release...not sure why. So far, with Update 2 I have had no issues with Emby. I did a quick search of the Synology forums to see what problems were being reported by users. I found a couples posts from users that had desktop icons that didn't update properly. For users reporting the issue, the desktop icons seemed to repopulate on their own over a couple of days.

Share this post


Link to post
Share on other sites
Vinnie Sims

Over the weekend I updated DSM from 6.2.2-24922 to 6.2.2-24922-2 on my DS918+. For whatever reason, I was never offered the update to 6.2.2-24922-1 that was issued in June. Apparently Synology pulled it shortly after release...not sure why. So far, with Update 2 I have had no issues with Emby. I did a quick search of the Synology forums to see what problems were being reported by users. I found a couples posts from users that had desktop icons that didn't update properly. For users reporting the issue, the desktop icons seemed to repopulate on their own over a couple of days.

 

 

@@DarWun - Thanks for your feedback! When you updated, did you shutdown the Emby Server and then restart it after the update was complete? Also, have you noticed any problems with Emby or your NAS so far?

Share this post


Link to post
Share on other sites
FrostByte

I've been running the update 2 with no Emby issues.

 

I didn't stop Emby before the update.  The Synology update did its own thing during the night (I have DSM updates set to auto), rebooted itself and the NAS and Emby have worked perfect since.

Edited by FrostByte

Share this post


Link to post
Share on other sites
Vinnie Sims

@@FrostByte - Thanks for your feedback. I’m going to wait it out a few more days and see what other people think for both the Synology and Emby side of things.

Share this post


Link to post
Share on other sites
DarWun

@@DarWun - Thanks for your feedback! When you updated, did you shutdown the Emby Server and then restart it after the update was complete? Also, have you noticed any problems with Emby or your NAS so far?

 

@@Vinnie Sims Yes I did. I also updated Emby after the Synology DSM update was completed without issue. I currently have a number of issues with Emby Beta 4.20.24 (and .25) on the Synology platform (i.e. Live TV recording using HDHomerun does not work, Emby for Kodi sync with server updates is wonky, there are LoaderException errors in the log that may or may not be platform related). But these issues existed prior to the DSM update and are being investigated.

Edited by DarWun

Share this post


Link to post
Share on other sites
Vinnie Sims

@@DarWun - Thanks for your feedback!

Share this post


Link to post
Share on other sites
notla49285

I didn't even think about considering this and updated to Update 2 anyway whilst Emby was running (didn't shut it down first). I let the NAS do it's thing, rebooted by itself with the updated software, the Emby service started again with no issues and seems to be running fine since. I've been on various bits of the Emby dashboard and streamed a couple of things to test and all is well.

 

I'm running a DS918+.

Share this post


Link to post
Share on other sites
Smaky

I updated to DSM 6.2.2-24922 Update 2 a few days ago. Did the update without even considering Emby at all. Have seen no other issues besides the media montoring not working (even after following the advice on the existing thread on this topic), but that is unrelated to the update as I was experiencing this before it.

Share this post


Link to post
Share on other sites
Vinnie Sims

@@Smaky - Thanks for your feedback!

Share this post


Link to post
Share on other sites
Vinnie Sims

Has anyone tried updating to DSM 6.2.2-24922 Update 3 with Emby successfully working? I got a notification to update last week, but just wanted to wait to see if anyone else has updated yet. 

Share this post


Link to post
Share on other sites
FrostByte

Has anyone tried updating to DSM 6.2.2-24922 Update 3 with Emby successfully working? I got a notification to update last week, but just wanted to wait to see if anyone else has updated yet. 

 

Yes, I've been running on it for awhile now with no issues.

 

Next update though, you go first and let us know ;)

Edited by FrostByte

Share this post


Link to post
Share on other sites
Vinnie Sims

Yes, I've been running on it for awhile now with no issues.

 

Next update though, you go first and let us know ;)

 

 

Thanks for the answer!

Haha...

  • Like 1

Share this post


Link to post
Share on other sites
Smaky

I updated to update 3 with no issues pretty much since it was made available. No issues since then.

Share this post


Link to post
Share on other sites
notla49285

I've also been running Update 3 since it was released and had no issues, been streaming locally and remotely along with a bit of library management.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...