Jump to content


Photo

ET restarts all files after 1-2 minutes if skip to next episode is pressed on remote

Theater Windows 7 Restarts

  • Please log in to reply
91 replies to this topic

#1 Spotta OFFLINE  

Spotta

    Advanced Member

  • Members
  • 124 posts
  • Local time: 05:19 PM

Posted 10 December 2018 - 04:56 PM

I'm having the issue mentioned in the title.

Emby Server 3.5.3.0 x64 Portable on Win 10 1803. 

Emby Theater 3.0.5 on Win 7 x64

This does not happen on the Web App, iOS devices or ET on rPi, Just on the Windows 7 ET. Normally between 1 and 2 minutes the file just restarts back to the beginning again 

Last happened around 20:29 tonight

Logs: https://www.dropbox....erver.txt?dl=0 


Edited by Spotta, 27 June 2019 - 04:22 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156879 posts
  • Local time: 12:19 PM

Posted 10 December 2018 - 05:16 PM

Hi, what video settings have you configured in the app?



#3 Spotta OFFLINE  

Spotta

    Advanced Member

  • Members
  • 124 posts
  • Local time: 05:19 PM

Posted 10 December 2018 - 05:34 PM

5c0edb677b370_20181210212418.jpg

 

5c0edb7946d3a_20181210212430.jpg

 

5c0edb8d7d296_20181210212437.jpg

 

5c0edba052a7b_20181210212444.jpg

 

5c0edbb581fcf_20181210212449.jpg



#4 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 10 December 2018 - 05:45 PM

What exactly happens? Does it simply skip back to the beginning, or a full restart?

#5 Spotta OFFLINE  

Spotta

    Advanced Member

  • Members
  • 124 posts
  • Local time: 05:19 PM

Posted 10 December 2018 - 05:49 PM

I don't have to press play again, it just goes back to beginning and starts playing again. I'll try and get a video of it in the morning.



#6 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 10 December 2018 - 05:53 PM

No need for a video. I'm wondering what the log will show. It may just cancel out if it's just restarting, but let's see. Here's how to make a log.

https://emby.media/c...ng-for-theater/

#7 Spotta OFFLINE  

Spotta

    Advanced Member

  • Members
  • 124 posts
  • Local time: 05:19 PM

Posted 10 December 2018 - 06:14 PM

Cheers, command added, I'll grab some logs in the morning. 



#8 pmac OFFLINE  

pmac

    Advanced Member

  • Members
  • 655 posts
  • Local time: 12:19 PM
  • LocationOntario, Canada

Posted 10 December 2018 - 06:32 PM

I'm having the same issues on my machine. It's been going on for quite some time.



#9 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1386 posts
  • Local time: 06:19 PM

Posted 10 December 2018 - 06:48 PM

No need for a video. I'm wondering what the log will show. It may just cancel out if it's just restarting, but let's see. Here's how to make a log.

https://emby.media/c...ng-for-theater/

log will show nothing, cause the file gets restarted by ET and the log gets over written

 

these 2 minutes are very suspicious

cause i had the exact problem with the exact 2 minutes if i used the app_command code for channel up on my remote

https://emby.media/c...143#entry580215

this is fixed now


Edited by daedalus, 10 December 2018 - 06:49 PM.


#10 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 10 December 2018 - 07:04 PM

log will show nothing, cause the file gets restarted by ET and the log gets over written

these 2 minutes are very suspicious
cause i had the exact problem with the exact 2 minutes if i used the app_command code for channel up on my remote
https://emby.media/c...143#entry580215
this is fixed now


Yeah, I was thinking the same, but I just wanted to cover the bases.

#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156879 posts
  • Local time: 12:19 PM

Posted 10 December 2018 - 10:35 PM

Yup sounds like an errant button press potentially.

#12 Spotta OFFLINE  

Spotta

    Advanced Member

  • Members
  • 124 posts
  • Local time: 05:19 PM

Posted 11 December 2018 - 02:53 AM

I think you've almost nailed it, except I never use the channel buttons to skip to the next episode (I never knew you could) but I do use the skip to next episode button indicated below

 

5c0f5e8a63ba6_embyskip.png

 

but never accidentally - only when I intend for Emby to skip the credits and play the next episode. So is this a bug?


Edited by Spotta, 11 December 2018 - 04:05 AM.


#13 Spotta OFFLINE  

Spotta

    Advanced Member

  • Members
  • 124 posts
  • Local time: 05:19 PM

Posted 11 December 2018 - 08:33 AM

Confirmed. Playing a file is fine, but every time you use the next episode button on the remote to go to the next one then it restarts after approx 1 - 2 minutes.

mpv log attached. I stopped playing about 6 seconds after it restarted. 

Attached Files



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156879 posts
  • Local time: 12:19 PM

Posted 11 December 2018 - 05:50 PM

Interesting. @Doofus can you reproduce that?



#15 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 11 December 2018 - 05:53 PM

I'll play around with it, when I get a chance.
  • Spotta likes this

#16 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 11 December 2018 - 10:17 PM

Ok, my reproduction steps

 

  1. Start playing video
  2. Drag the slider close to the end
  3. Press skip forward in the overlay. It skips to the next episode

It's playing correctly. 

 

Repeated test, this time I used control-f, for step 3. At around 2 mins, it jumped back to the start.



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156879 posts
  • Local time: 12:19 PM

Posted 12 December 2018 - 01:30 AM

Ok, my reproduction steps

 

  1. Start playing video
  2. Drag the slider close to the end
  3. Press skip forward in the overlay. It skips to the next episode

It's playing correctly. 

 

Repeated test, this time I used control-f, for step 3. At around 2 mins, it jumped back to the start.

 

Thanks, so that corroborates. Can you be more specific about times though? I just went through this twice and couldn't get it to happen using the control-f method.



#18 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 12 December 2018 - 02:08 AM

Thanks, so that corroborates. Can you be more specific about times though? I just went through this twice and couldn't get it to happen using the control-f method.

 

It's a bit intermittent. The first time I just tried, it wouldn't do it. I skipped back far enough to jump to the episode before it then tried it again, and it reproduced. With one video it happened at 1:30 and another one at 46 seconds. That second one, jumped around a few times, but not to the beginning. It was hard to see what it was actually doing. I also have play next video automatically, enabled. Once you reproduce it, then it's pretty consistent until you stop playback, completely. 



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 156879 posts
  • Local time: 12:19 PM

Posted 14 December 2018 - 12:02 AM

When you skip to the end and press ctrl-f, how far did you skip to?



#20 Guest_asrequested_* OFFLINE  

Guest_asrequested_*
  • Guests

Posted 14 December 2018 - 12:15 AM

When you skip to the end and press ctrl-f, how far did you skip to?

 

Nothing precise, just a few minutes before the end. I just drag it close, and ctrl+f until the next episode begins. The first time you do it, it plays correctly. But if you ctrl+b back to the beginning of the previous video then drag to the end and ctrl+f to the next video, that usually makes it happen. So I think it might happen when you ctrl+f to a third video. I didn't test that. It's just a theory.







Also tagged with one or more of these keywords: Theater, Windows 7, Restarts

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users