Jump to content

ET restarts all files after 1-2 minutes if skip to next episode is pressed on remote


Spotta
 Share

Recommended Posts

I'm having the issue mentioned in the title.

Emby Server 3.5.3.0 x64 Portable on Win 10 1803. 

Emby Theater 3.0.5 on Win 7 x64

This does not happen on the Web App, iOS devices or ET on rPi, Just on the Windows 7 ET. Normally between 1 and 2 minutes the file just restarts back to the beginning again 

Last happened around 20:29 tonight

Logs: https://www.dropbox.com/s/eivx960s4khhzre/embyserver.txt?dl=0 

Edited by Spotta
Link to comment
Share on other sites

I don't have to press play again, it just goes back to beginning and starts playing again. I'll try and get a video of it in the morning.

Link to comment
Share on other sites

daedalus

No need for a video. I'm wondering what the log will show. It may just cancel out if it's just restarting, but let's see. Here's how to make a log.

 

https://emby.media/community/index.php?/topic/50975-how-to-enable-mpv-logging-for-theater/

log will show nothing, cause the file gets restarted by ET and the log gets over written

 

these 2 minutes are very suspicious

cause i had the exact problem with the exact 2 minutes if i used the app_command code for channel up on my remote

https://emby.media/community/index.php?/topic/46763-theater-mpv-test/page-143&do=findComment&comment=580215

this is fixed now

Edited by daedalus
Link to comment
Share on other sites

Guest asrequested

log will show nothing, cause the file gets restarted by ET and the log gets over written

 

these 2 minutes are very suspicious

cause i had the exact problem with the exact 2 minutes if i used the app_command code for channel up on my remote

https://emby.media/community/index.php?/topic/46763-theater-mpv-test/page-143&do=findComment&comment=580215

this is fixed now

Yeah, I was thinking the same, but I just wanted to cover the bases.

Link to comment
Share on other sites

I think you've almost nailed it, except I never use the channel buttons to skip to the next episode (I never knew you could) but I do use the skip to next episode button indicated below

 

5c0f5e8a63ba6_embyskip.png

 

but never accidentally - only when I intend for Emby to skip the credits and play the next episode. So is this a bug?

Edited by Spotta
Link to comment
Share on other sites

Confirmed. Playing a file is fine, but every time you use the next episode button on the remote to go to the next one then it restarts after approx 1 - 2 minutes.

mpv log attached. I stopped playing about 6 seconds after it restarted. 

Theater-mpv-log.txt

Link to comment
Share on other sites

Guest asrequested

Ok, my reproduction steps

 

  1. Start playing video
  2. Drag the slider close to the end
  3. Press skip forward in the overlay. It skips to the next episode

It's playing correctly. 

 

Repeated test, this time I used control-f, for step 3. At around 2 mins, it jumped back to the start.

Link to comment
Share on other sites

Ok, my reproduction steps

 

  1. Start playing video
  2. Drag the slider close to the end
  3. Press skip forward in the overlay. It skips to the next episode

It's playing correctly. 

 

Repeated test, this time I used control-f, for step 3. At around 2 mins, it jumped back to the start.

 

Thanks, so that corroborates. Can you be more specific about times though? I just went through this twice and couldn't get it to happen using the control-f method.

Link to comment
Share on other sites

Guest asrequested

Thanks, so that corroborates. Can you be more specific about times though? I just went through this twice and couldn't get it to happen using the control-f method.

 

It's a bit intermittent. The first time I just tried, it wouldn't do it. I skipped back far enough to jump to the episode before it then tried it again, and it reproduced. With one video it happened at 1:30 and another one at 46 seconds. That second one, jumped around a few times, but not to the beginning. It was hard to see what it was actually doing. I also have play next video automatically, enabled. Once you reproduce it, then it's pretty consistent until you stop playback, completely. 

Link to comment
Share on other sites

Guest asrequested

When you skip to the end and press ctrl-f, how far did you skip to?

 

Nothing precise, just a few minutes before the end. I just drag it close, and ctrl+f until the next episode begins. The first time you do it, it plays correctly. But if you ctrl+b back to the beginning of the previous video then drag to the end and ctrl+f to the next video, that usually makes it happen. So I think it might happen when you ctrl+f to a third video. I didn't test that. It's just a theory.

Link to comment
Share on other sites

Guest asrequested

For comparison, are you able to reproduce on the web version http://tv.emby.media

 

Thanks.

 

Ok, so I have inconsistency. The videos I was able to make it happen with were recorded TV. They are 1080i MPEG2. In the web version, they of course get transcoded, and I was unable to reproduce the problem. I thought that may be due to them being transcoded. So I tested playing some archived shows in the desktop app. I was unable to reproduce the problem. So I'm not sure where to go, with that.

 

@@Spotta what videos are getting this with?

Link to comment
Share on other sites

I'm getting it with every video I try it with which are mainly .mkv both 720 & 1080,  h264 & h265.

I can't try with Emby recordings as I've had to go back to WMC due to my other issue https://emby.media/community/index.php?/topic/66077-watching-in-progress-recordings/ which is going nowhere.

I can test some more and provide additional logs / media details if it would help.

Edited by Spotta
Link to comment
Share on other sites

Guest asrequested

I'll to do a little more extensive testing, if I get enough time. I should probably use the same mpv build that you are, too. I may grab theater from Git and run it as a portable with none of my tweaks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...