Jump to content
markdj

Terribly slow/long loading on devices using Emby

Recommended Posts

markdj

It's really hard to get the log because it's running over 1MB in size. Rebooting will probably fix the issue, but then the issue will disappear for a while. I've included multiple logs and I hope that they are useful.

 

I've started with running Emby after enabling the Log file (which took about 2 minutes I think), then tried to change the status of the very first episode of Justified. After 5 minutes of waiting and no update I decided to just upload the log.

 

Edit: still trying to grab some of the log file of Emby itself, but it's soooooo huge that this might take a while. (Edit edit: don't think it's gonna work, it's practically killing Chrome :P)

 

Edit 2: after a reboot I get the following message (see photo). Might have something to do with it?

kodi.log

log.txt

log-2018-10-03-12.12.51.zip

post-170439-0-89094600-1538569433_thumb.jpg

Edited by markdj

Share this post


Link to post
Share on other sites
Angelblue05

I am still looking into this. Thanks for your logs. You do have a lot of updates, but it should not have any effect on opening settings, etc.

 

And yeah your log is getting big because I said no Kodi debug, lol. It's not needed. Only the add-on debug is needed, which you enable in the add-on settings > advanced.

Share this post


Link to post
Share on other sites
Angelblue05

I think I finally managed to replicate the issue. At least I hope. Stay tuned.

  • Like 1

Share this post


Link to post
Share on other sites
Angelblue05

Can you try this build and let me know if the issue persists? I can't seem to make it happen again. Make sure auto-update is disable so the custom build doesn't get overwritten by the beta repo version.

 

plugin.video.emby-3.1.26b.zip

Share this post


Link to post
Share on other sites
markdj

Just installed it and will check back after work in about 11 hours or so, that should give it enough time to replicate it if it still exists.

  • Like 1

Share this post


Link to post
Share on other sites
markdj

As of right now it seems to work :) Will test further tonight!

  • Like 1

Share this post


Link to post
Share on other sites
markdj

Sorry about that. Have tested it the last few days and the problem seems to be fixed :) Can I set it back to auto-update again now?

Edited by markdj
  • Like 1

Share this post


Link to post
Share on other sites
markdj

Any idea when the fix will be implemented in the new versions?

Share this post


Link to post
Share on other sites
Angelblue05

Today. Thanks for your patience as I am fixing a few more things.

  • Like 1

Share this post


Link to post
Share on other sites
markdj

It seems the issue has returned. While not as long (up to a minute now for playback) it still takes a few seconds after a simple reboot. It happens after the system has been on for a while (>a day).

  • Like 1

Share this post


Link to post
Share on other sites
highonascii

5bc8cab6a3911_embysetting.png

It seems the issue has returned. While not as long (up to a minute now for playback) it still takes a few seconds after a simple reboot. It happens after the system has been on for a while (>a day).

Can you test something for me that I am testing? In the emby addon settings change playback to only force http and force transcode like in picture above... On my pc things fly open now with pc being on 24/7 and not restarting kodi... I would like to see if this helps people with the "slow down" issue. Thanks

Share this post


Link to post
Share on other sites
markdj

5bc8cab6a3911_embysetting.png

Can you test something for me that I am testing? In the emby addon settings change playback to only force http and force transcode like in picture above... On my pc things fly open now with pc being on 24/7 and not restarting kodi... I would like to see if this helps people with the "slow down" issue. Thanks

 

 

Tried it just now but still slow as ever.

Share this post


Link to post
Share on other sites
highonascii

Tried it just now but still slow as ever.

Weird... I haven't been able to recreate the slow down since it was fixed but when I tried the above setting it seemed even faster loading... Dang was hoping that would help everyone... Thanks for trying for me none the less :D

Share this post


Link to post
Share on other sites
sualfred

To everyone who is facing the slowness issue:

 

Please check if you have the Skin Helper Script installed and if yes, please disable it temporary and let us know if this solves the issue.

 

Addons -> Installed addons -> Context menus -> Skin Helper Service

Edited by sualfred
  • Like 1

Share this post


Link to post
Share on other sites
Glyde62

To everyone who is facing the slowness issue:

 

Please check if you have the Skin Helper Script installed and if yes, please disable it temporary and let us know if this solves the issue.

 

Addons -> Installed addons -> Context menus -> Skin Helper Service

Says can't be disabled as it's used by embuary skin

 

Sent from my HTC_M10h using Tapatalk

Share this post


Link to post
Share on other sites
sualfred

Hmm I thought disabling works. In that case just delete it manually from your Kodi installation. It can be found in your userdata/addons folder and is called "script.skin.helper.service".

You can reinstall it afterwards via install from repository.

 

By the way:

I'm currently working on removing this dependency and it won't be required in the future anymore.

Edited by sualfred
  • Like 2

Share this post


Link to post
Share on other sites
markdj

Will give it a try later today. Any reason as to why this might cause the slowdown?

Share this post


Link to post
Share on other sites
sualfred

It's gathering additional informations and stuff from fanart.tv/themoviedb/etc. This is expensive and could cause all this troubles. 

Share this post


Link to post
Share on other sites
markdj

Just deleted the folder, also didn't have the option to uninstall/disable. Will report later, since it takes a while before the slowdown happens.

  • Like 1

Share this post


Link to post
Share on other sites
markdj

Well, it seems it's also slow to begin with now. But, still not as bad as it was the first time.

Share this post


Link to post
Share on other sites
highonascii

To everyone who is facing the slowness issue:

 

Please check if you have the Skin Helper Script installed and if yes, please disable it temporary and let us know if this solves the issue.

 

Addons -> Installed addons -> Context menus -> Skin Helper Service

Testing now

Share this post


Link to post
Share on other sites
sualfred

Please also try to remove:

 

- skin.helper.backgrounds

- script.module.metadatautils (cannot be found in Kodi. Has to be deleted manually)

 

I've noticed that these two are still doing jobs even without the main skin helper script.

Edited by sualfred

Share this post


Link to post
Share on other sites
markdj

By the way: does this also apply if you're using a different skin?

Share this post


Link to post
Share on other sites
sualfred

Yep. These addons are running as service and are active in all skins.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...