Jump to content
markdj

Terribly slow/long loading on devices using Emby

Recommended Posts

horstepipe

@@sualfred

Will your replacement of these addons still provide the rotten tomatoes/meta critic infos in the movie database?

This is very helpful so please don’t remove it :-)

 

(You have to enter an omdb api key in the metadatautils addon to make them show up fast afaik)

Share this post


Link to post
Share on other sites
sualfred

No, because stuff like this is what makes everything expensive.

Share this post


Link to post
Share on other sites
sualfred

Any results from you guys? Haven't heared back if removing those addons made things better and I'm curious.

Share this post


Link to post
Share on other sites
Glyde62

Watching a few shows tonight let you know if it slows down after watching a few shows

 

Sent from my HTC_M10h using Tapatalk

Share this post


Link to post
Share on other sites
horstepipe

No, because stuff like this is what makes everything expensive.

argh I expected that.

So you see no chance that Emby server itself will provide these information?

It already has a rotten tomatoes addon, wouldn't it be possible to make use of the information in the skin?

Edited by horstepipe

Share this post


Link to post
Share on other sites
sualfred

Nope. Just imagine that every input, every new focused item will query again and again and again. As long as Kodi doesn't support multiple rating providers outside of just one dialog it won't come back.

  • Like 1

Share this post


Link to post
Share on other sites
horstepipe

Nope. Just imagine that every input, every new focused item will query again and again and again. As long as Kodi doesn't support multiple rating providers outside of just one dialog it won't come back.

understood, but one last try :-)

maybe the addon could just make the query if you enter the movie information view? In this case you wouldn't have that bunch of queries when you browse your movie list

Share this post


Link to post
Share on other sites
sualfred

Not possible.

Share this post


Link to post
Share on other sites
Glyde62

Watching a few shows tonight let you know if it slows down after watching a few shows

 

Sent from my HTC_M10h using Tapatalk

 

Seemed to go ok tonight, Watched 2 tv episodes and a movie and all started fairly quickly

  • Like 1

Share this post


Link to post
Share on other sites
sualfred

Thx, please keep us posted

  • Like 1

Share this post


Link to post
Share on other sites
markdj

Please also try to remove:

 

- skin.helper.backgrounds

- script.module.metadatautils (cannot be found in Kodi. Has to be deleted manually)

 

I've noticed that these two are still doing jobs even without the main skin helper script.

 

I don't have the first one, but just deleted the second one. Will report later.

  • Like 1

Share this post


Link to post
Share on other sites
horstepipe

understood, but one last try :-)

maybe the addon could just make the query if you enter the movie information view? In this case you wouldn't have that bunch of queries when you browse your movie list

  

Not possible.

I don’t want to be a pain in your neck, but didn’t you mention here that it would be possible?

 

https://emby.media/community/index.php?/topic/62504-fetch-rotten-tomatoes-from-emby-instead-of-kodi-plugin-second-try/page-1&do=findComment&comment=617598

Share this post


Link to post
Share on other sites
markdj

Not sure if removing the add-ons is really working. It seems to load a little faster (10 seconds or so), but I remember it starting things within seconds before the issue arrived. Still much better than before though.

Share this post


Link to post
Share on other sites
sualfred

@@markdj

 

Have you tried Kodi 18 Leia? The nightlies are working great and I already use them as daily driver for my systems. Just to be sure that it's not related to your LE setup.

And what kind of box do you use?

Share this post


Link to post
Share on other sites
markdj

I haven't and I won't unfortunately. Last time I tried a beta version of Kodi it kept messing up my systems with bugs and glitches. I don't have time to wait for fixes and help development with that I'm afraid.

I use a Shield and RPi3, but I tested the removal of add-ons on the Pi.

Share this post


Link to post
Share on other sites
sualfred

Please test the removal on the Shield. The RPi3 is too low powered to return valid results.

 

Afaik you can install Kodi Leia next to Krypton on Android devices.

 

Please understand that it's required to have useful results (like a difference beteween v17 and v18 or clean install) to see what's causing it. If you "refuse" to try it it's impossible to get more information to narrow down the problem.

Edited by sualfred

Share this post


Link to post
Share on other sites
markdj

Please test the removal on the Shield. The RPi3 is too low powered to return valid results.

 

Afaik you can install Kodi Leia next to Krypton on Android devices.

 

Please understand that it's required to have useful results (like a difference beteween v17 and v18 or clean install) to see what's causing it. If you "refuse" to try it it's impossible to get more information to narrow down the problem.

 

Both the Pi and the Shield started videos around the same time (around 3 seconds) so I don't think that's the problem here. But I will try it with the Shield as well, sure.

 

As I said I unfortunately don't have time to try things out. It cost me way too much time in the past and all it gets me is an angry girlfriend and me being frustrated because I have to keep fixing broken things. I'm sure there will be someone around who has Leia or wants to try it and has the same issues, but I won't be the one I'm sorry to say :) Not that I don't want to help but I have a baby on the way and a full-time job and I want to do more useful stuff in my spare time.

Edited by markdj

Share this post


Link to post
Share on other sites
sualfred

I have a little daughter right next to me and also go to work each day. We aren't the one that are facing this issue, it's you. The Kodi integration is a community driven project without any charge. From Emby users shared to Emby users. You only have the option to do what we asked for to help you or to live with the problem and hope that it's solves by itself by a miracle. That's how things work, sorry.

 

Please let us know if the addon removal did something on your shield.

Edited by sualfred

Share this post


Link to post
Share on other sites
markdj

Nah, also still pretty slow on the Shield (=>10 seconds).

Share this post


Link to post
Share on other sites
JoshFink

I was away for a couple of days. If I pieced together a couple of posts this is what I got that you want us to try.

 

Disable Skin Helper Service

Delete skin.helper.backgrounds

Delete script.module.metadatautils

 

For metadatautils I need to go through the file system and delete this manually. 

Is this correct? I have a Shield. I'll try and get to this and then see how it works over the next day. 

Share this post


Link to post
Share on other sites
sualfred

Yep, but you can delete the skin helper service too. It won't work without the dependency.

Share this post


Link to post
Share on other sites
JoshFink

Yep, but you can delete the skin helper service too. It won't work without the dependency.

 

Sounds good. I just did all that and restarted. We'll see how it goes. 

Share this post


Link to post
Share on other sites
JoshFink

So far everything seems to be running great on 3 of my devices. I’m going to check again today.

Share this post


Link to post
Share on other sites
sualfred

I purchased a Shield as test device just to try to investigate on my end. It has arrived today and hopefully I get time to check it in the evening.

  • Like 1

Share this post


Link to post
Share on other sites
sualfred

So, no slowness at all. Playback starts within 1-3 seconds. Tested with the latest Kodi 18 nightly.

 

@@markdj

Since it seems that you are the only user that is still facing it - and on two different devices - I assume it's a local problem of your setup. Maybe the network connection, hibernation of HDDs in your server or similar things.

Edited by sualfred

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...