Jump to content
Luke

New FreeNAS Package for testing

Recommended Posts

Luke

 

 

boxset wasn't installed automatically

 

What do you mean? this is never installed automatically. it has always been something you have to manually install.

Share this post


Link to post
Share on other sites
Barlog9511

What do you mean? this is never installed automatically. it has always been something you have to manually install.

 

yes I know, but other plugins were installed after I recover from backup, but auto boxset wasn't

 

But now is everything OK :)

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback.

Share this post


Link to post
Share on other sites
sluggo45
/usr/local/opt/emby-server/bin/ffmpeg -analyzeduration 3000000 -fflags +discardcorruptts+fillwallclockdts -f mpegts -i "http://127.0.0.1:8096/LiveTv/LiveStreamFiles/69aeb06adbcb455390986ee46ccdc5fc/stream.ts" -map_metadata -1 -map_chapters -1 -threads 0 -sn -codec:v:0 libx264 -pix_fmt yuv420p -preset veryfast -crf 23 -maxrate 8000000 -bufsize 16000000 -profile:v high -level 4.1 -x264opts:0 subme=0:me_range=4:rc_lookahead=10:me=dia:no_chroma_me:8x8dct=0:partitions=none -force_key_frames "expr:gte(t,n_forced*3)" -vf "yadif=0:-1:0" -vsync cfr -codec:a:0 aac -strict experimental -ac 2 -ab 384000 -af "volume=2" -f segment -max_delay 5000000 -avoid_negative_ts disabled -start_at_zero -segment_time 3  -individual_header_trailer 0 -segment_format mpegts -segment_list_entry_prefix "hls/a70f5fa56875e1c19a9488986fb1ac44/" -segment_list_type m3u8 -segment_start_number 0 -segment_list "/var/db/emby-server/transcoding-temp/a70f5fa56875e1c19a9488986fb1ac44.m3u8" -y "/var/db/emby-server/transcoding-temp/a70f5fa56875e1c19a9488986fb1ac44%d.ts"

Shared object "libx264.so.152" not found, required by "libavcodec.so.58"

I  still can't win with the beta. Also .44 seems to be using some custom stuff for mpegts so I can't use the port of ffmpeg either.

 

How can I switch/insure I am on the right quarterly distro for packages? My iocage jail still has libx264.so.155 which is the default and the only one in the repo now.

Edit: with the port built ffmpeg I get this error with live tv:

mpegts @ 0x819c71000] [Eval @ 0x7fffffffce70] Undefined constant or missing '(' in 'discardcorruptts'
[mpegts @ 0x819c71000] Unable to parse option value "discardcorruptts+fillwallclockdts"
[mpegts @ 0x819c71000] Error setting option fflags to value +discardcorruptts+fillwallclockdts.
http://127.0.0.1:8096/LiveTv/LiveStreamFiles/acf333e8d9ea45e499e0fd0226015112/stream.ts: Invalid argument
Edited by sluggo45

Share this post


Link to post
Share on other sites
Luke

You're not going to be able to use the port-built ffmpeg because we've added some customizations. Can you just follow our install instructions? Thanks.

Share this post


Link to post
Share on other sites
sluggo45

I've followed them to the letter Luke. The only thing I tried different was adding the ffmpeg port in the iocage jail. My libx264 pkg in the jail is .155 and the version Emby expects to link to is .152. I didn't change that deliberately, that's how the jail set up from scratch.

Share this post


Link to post
Share on other sites
makarai

It's most likely because your jail get the latest pkgs and not the quarterly. So change to the quarterly train and your good to go. 

 

 

I would do the following:

 

delete your jail and start from scratch. 

open the shell in freenas

 

and get the json file

cd /tmp
wget https://raw.githubusercontent.com/MediaBrowser/iocage-amd64/master/emby-server.json 

 open the json file with your favorite tool and change latest to quarterly

"packagesite": "https://pkg.freebsd.org/FreeBSD:11:amd64/quarterly",

continue with 

iocage fetch -P --name emby-server.json ip4_addr="vtnet0|192.168.122.3/24"

and so on
Edited by makarai

Share this post


Link to post
Share on other sites
sluggo45

Yeah, I was trying to avoid that, but just gave up and did it anyway. Seems to have worked. Still testing a few things.

 

Perhaps the json pkg file in the OP should be updated to reflect this? I did download it again this am and it's still marked as "latest". Not sure why it's just me that had this problem (or is it)?

Share this post


Link to post
Share on other sites
makarai

 

What are all these extra params for?

defaultrouter="192.168.0.1" vnet="on" allow_raw_sockets="1" boot="on"

 

 

I am coming back to this from further light reading about the vnet implementation and about other jails, vnet is needed for anything that relies on a MAC address (OSI layer 2 networking, e.g. igmp proxy, multicast etc), (apparently other software also has an issue with this https://forums.freenas.org/index.php?threads/plex-jail-metadata-video-playing-problem-in-11-2-beta3.69960/#post-482947) (which will only properly work when going freenas beta3 or newer).

Share this post


Link to post
Share on other sites
Luke

Ok great, thanks.

Share this post


Link to post
Share on other sites
Luke

Ok yes we'll update that, thanks !

Share this post


Link to post
Share on other sites
Luke

Where is your change request?

Share this post


Link to post
Share on other sites
Luke

At this point the instructions are identical. Can we consolidate to one topic to avoid confusion?

Share this post


Link to post
Share on other sites
makarai

Where is your change request?

 

valid point! I am braindead

"packagesite": "https://pkg.freebsd.org/FreeBSD:11:amd64/quarterly",
Edited by makarai

Share this post


Link to post
Share on other sites
Luke

Thanks.

Share this post


Link to post
Share on other sites
sluggo45

If you turn vnet on - which is a good idea for Emby, as it is with Plex - then you also need to set the adapter for ip4 to vnet0, not change it as outlined in the OP.

Share this post


Link to post
Share on other sites
sluggo45

Sorry, cross-posted in the other thread but missed we're consolidating them.

 

The instructions in the OP need to be updated; if vnet is enabled for an iocage jail the jail interface for ip4 needs to be set to the vnet interface as well - if you change it to one of your primary adapters as instructed you won't get networking to work in the jail.

 

The example line in the OP is actually correct, it's the instruction below it that is wrong.

 

It might be something in the latest betas but I discovered using vnet for an iocage Emby jail is necessary; I had a number of problems downloading metadata and subtitles, for example, when I first re-created my jail today using my host adapter. Something about sharing the host MAC address causes problems. I believe Plex has the same exact issue.

Edited by sluggo45

Share this post


Link to post
Share on other sites
Luke

Thanks for the info !

Share this post


Link to post
Share on other sites
Luke

@@makarai, how would you suggest modifying the instructions based on this?

Share this post


Link to post
Share on other sites
sluggo45

Hope you don't think I'm being nit-picky; just want to make this easier for others:

 

In the OP:

iocage fetch -P --name emby-server.json ip4_addr="vtnet0|192.168.122.3/24" defaultrouter="192.168.0.1" vnet="on" allow_raw_sockets="1" boot="on"

"vtnet0" (first occurrence) should be "vnet0". The latter is the default vnet interface and, assuming you are only creating a jail for Emby, should be the only one.

 

Next the instructions under it:

Replace vtnet0 with your primary network interface (ifconfig will print them). vtnet0 should be set to a real network interface, like eth0. vtnet0 is just the name of the virtualized network interface in our test VM.

Maybe your VM interface really is vtnet0 but in any case this line should be omitted or updated; users should set ip4_addr= to vnet0 if they enable vnet as instructed. The other additions at the end of the line, as @@makarai pointed out in the other thread, are for the following reasons (which may be helpful to point out?):

 

Default gateway needs to be set for vnet

enabling raw sockets is needed for things like multicast (and allowing ping, etc. inside the jail, though that is less important)

boot on just sets the jail to autostart at boot.

 

All good recommendations.

 

With iocage - and I believe this is a change from the old Warden jails - setting a jail ip to a host adapter means the jail will share the MAC address of the host adapter. If that adapter is the same one FreeNAS uses that can cause some weird connection problems for the plugin - timeouts looking for api.opensubtitles, metadata download issues for the same reason, etc.  I haven't completely traced it but I believe it's a problem with routers that do MAC-based port forwarding (like a lot of them do) - so if you forward ports to Emby for external access that's one issue because the return path can get screwed up, though there may be other reasons it's a problem.

 

Finally it'd be good to have the beta instructions for people creating new jails who want to use it:

wget https://raw.githubusercontent.com/bott0r/iocage-plugin-emby-beta/master/emby-server-beta.json

Though you can always update it inside the jail after you install the release.

 

Edit: Since lots of people, especially FreeNAS users, use reverse proxies, maybe mention that there's an option in the Emby advanced settings now for Secure connection mode? You can choose "Handled by reverse proxy" which appears to be new. I assume this just means Emby will allow forced secure connections without installing a local cert. because it knows the reverse proxy is doing that, but perhaps you could elaborate Luke?

Edited by sluggo45

Share this post


Link to post
Share on other sites
Luke

 

 

Edit: Since lots of people, especially FreeNAS users, use reverse proxies, maybe mention that there's an option in the Emby advanced settings now for Secure connection mode? You can choose "Handled by reverse proxy" which appears to be new. I assume this just means Emby will allow forced secure connections without installing a local cert. because it knows the reverse proxy is doing that, but perhaps you could elaborate Luke?

 

Correct, that's exactly it.

Share this post


Link to post
Share on other sites
makarai

I agree, with what sluggo said. Since the text is a copy of your first version and a shared ip approach was used there.


So basically change the text and say you need to use the virtual interface vnet0 and perhaps include a freenas beta 3 requirement.

Edited by makarai

Share this post


Link to post
Share on other sites
makarai

If you turn vnet on - which is a good idea for Emby, as it is with Plex - then you also need to set the adapter for ip4 to vnet0, not change it as outlined in the OP.

 

You are right, at first the instructions were using a shared ip approach (outlined by luke) , and i did not change the wording  :( bad copy and pasting. I fixed it now here.

 

We probably should also have the requirement that freenas beta3 should be used so there are no problems with creating the vnet adapter and bridging it to the NIC.

Edited by makarai

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...