Jump to content
SenatorIvy

Mouse cursor reappears on media change, does not disappear

Recommended Posts

Luke

Same here, it happens to me 90% of the time I open Theatre, even after a fresh reboot.

 

Nothing changed with my Win7.

 

I just alt-tab with the remote 2-3 times until the cursor goes away. This only works in the opening window when I launch Theatre, if I try that during playback it doesn't work and I have to either move the cursor or re-launch Theatre.

 

This happens regardless if Theatre is the only app running or not.

 

You're saying it happens during playback? Something must be stealing focus then as I've never seen that happen before.

Share this post


Link to post
Share on other sites
infinitereality

Figured I'd chime in on this, as I am having similar issue with the cursor.  I use Harmony to control ET and my cursor never hides at all.  Doesn't matter if I'm going thru the menu or watching media, it's always there.  My only solution is to move cursor to the right of the screen to mostly hide it. 

 

Any ideas why?  Not really a big issue, but when I turn projector, receiver, etc completely off and back on again, cursor defaults to center again and have to move it.

Share this post


Link to post
Share on other sites
shpitz461

@infinitereality, did you try pressing the button on the remote 2-3 times (with 1 second delay between presses)? for me pressing it 2-3 times makes the cursor go away without using a mouse or keyboard with a touch-pad.

  • Like 1

Share this post


Link to post
Share on other sites
shpitz461

I don't think it relates to mpv since the cursor appears on-screen while navigating Theatre and will not go away. Sometimes alt-tab can make it go away (1-3 times), sometimes a mouse move has to take place for it to hide.

Share this post


Link to post
Share on other sites
infinitereality

I'll give the alt-tab a shot and see if that solves it.  If so I'll add it to the onscreen command on the Harmony and be set! 

 

If not, I'll add that line to the mpv.conf and see if that helps

 

Thanks!!

Share this post


Link to post
Share on other sites
Guest asrequested

But it may help to keep focus. Can't hurt to try it.

Share this post


Link to post
Share on other sites
shpitz461

Sure, will try. Any specific ontop-level setting?

Share this post


Link to post
Share on other sites
Guest asrequested

That's for iOS. Just use ontop

Share this post


Link to post
Share on other sites
shpitz461

No helpie, here's the video I promised I'll make.

 

https://1drv.ms/u/s!AjpdSoNAIKe2at0tH1sI1zVJsMw

 

I didn't talk cause everyone is still asleep. Toward the end, I show how I press my alt-tab remote button twice and the cursor finally goes away.

 

This is the setting I added to mpv.conf:

ontop
no-window-dragging
Edited by shpitz461

Share this post


Link to post
Share on other sites
Guest asrequested

Can you check that Theater isn't overriding it? If you window the app, and launch another app, does Theater stay on top?

Share this post


Link to post
Share on other sites
shpitz461

I'll try later, the little one is watching a movie.

 

The cursor issue doesn't happen 100% of the time, sometimes when I launch Theatre the cursor auto-hide on its own.

Share this post


Link to post
Share on other sites
shpitz461

Ok, I set Theatre to window mode (Windows taskbar is showing), then open notepad via start menu, notepad is in focus showing on top of Theatre.

 

Same with Windows explorer.

 

I removed the settings from the conf file and it behaves the same.

 

If I set Theatre to full screen (Windows taskbar is not showing) then any app that I open is placed behind Theatre and I can't bring the app into the view, it always stays behind Theatre.

Edited by shpitz461

Share this post


Link to post
Share on other sites
Guest asrequested

So, theater has it's own rule for that. I thought that might be the case.

Share this post


Link to post
Share on other sites
infinitereality

I tried the tab-alt thing and it works! Once I did it, watched some media without issues. Closed out ET and reloaded and cursoy came back but went away without like it should without using any keys.

 

I haven't turned everything off with Harmony off button yet, but will try that tomorrow.

Share this post


Link to post
Share on other sites
shpitz461

Yeah, for me, sometimes the cursor will auto-hide on its own when I launch ET, but many times it does not, this happens randomly as far as I can tell.

Share this post


Link to post
Share on other sites
infinitereality

Tried turning it everything off and back on, cursor appears in middle of the screen as normal. Tab-cntl a couple of times and goes away,so at least that makes life a little easier.

 

Fixing to add that line and will report back.

Share this post


Link to post
Share on other sites
shpitz461

Another weird thing that is happening lately, sometimes, is this:

 

I start playing a video, the OSD appears on screen, after a few seconds the filename (top-left) and clock (top-right) go away, but the bottom bar with the elapsed time stays forever. If I stop play and then play again, same thing with the OSD.

Share this post


Link to post
Share on other sites
Luke

Another weird thing that is happening lately, sometimes, is this:

 

I start playing a video, the OSD appears on screen, after a few seconds the filename (top-left) and clock (top-right) go away, but the bottom bar with the elapsed time stays forever. If I stop play and then play again, same thing with the OSD.

 

I haven't seen this but will do some testing for it, thanks.

Share this post


Link to post
Share on other sites
Mopar_Mudder

I have the same issue with the cursor. It is stuck in the middle of the screen, if I move it slightly it will then hide. Also when watching a movie in Theater I can see just a slight sliver of the task bar at the bottom of the screen, which is really anoying, it never used to do this and I haven't changed anything.

Share this post


Link to post
Share on other sites
shpitz461

As for the taskbar, try to switch between windowed and full-screen/maximize and see if that helps (using a mouse).

 

The cursor issue is annoying but alt-tab usually fixes it, sometimes it doesn't so i just close Theatre and relaunch it and then alt-tab works.

Share this post


Link to post
Share on other sites
infinitereality

I've tried the tab-alt, and usually works,  but sometimes takes quite a few times.  Also noticed that if the cursor is in the middle of the screen when I first switch to ET, it'll never go away.  I have to move it, usually below the folders and hen the tab-alt will work.  If I switch between TV and HTPC after I have successfully hidden the cursor, when I go back to HTPC it comes back again.  I still find it quicker to just move the cursor to the lower right hand of the screen so I don't have to see it for the rest of the day.

Share this post


Link to post
Share on other sites
narb77

Figured I'd chime in on this, as I am having similar issue with the cursor.  I use Harmony to control ET and my cursor never hides at all.  Doesn't matter if I'm going thru the menu or watching media, it's always there.  My only solution is to move cursor to the right of the screen to mostly hide it. 

 

Any ideas why?  Not really a big issue, but when I turn projector, receiver, etc completely off and back on again, cursor defaults to center again and have to move it.

 

Hi All.  I am having the exact same issue reported above.  I use a Harmony Remote & try not to dig the Keyboard/mouse out of the drawer if possible.  Currently having to move the cursor once on every start-up to make it go away.

 

I have tried to Alt/Tab work around but I can't seem to get it to work.  I have also not yet tried to On Top mpv work around as I feel it will have other implications.

 

Has anyone found a solution to this problem?

Share this post


Link to post
Share on other sites
shpitz461

Hi All.  I am having the exact same issue reported above.  I use a Harmony Remote & try not to dig the Keyboard/mouse out of the drawer if possible.  Currently having to move the cursor once on every start-up to make it go away.

 

I have tried to Alt/Tab work around but I can't seem to get it to work.  I have also not yet tried to On Top mpv work around as I feel it will have other implications.

 

Has anyone found a solution to this problem?

 

If the alt-tab trick doesn't work (it sometimes doesn't even after pressing alt-tab 2-3 times in a row), most of the time i close ET and reopen it and then do alt-tab 1-3 times and it works. In some rare cases only a reboot helps the cursor, without ever using a mouse.

Share this post


Link to post
Share on other sites
Wilky13

Hi All. I am having the exact same issue reported above. I use a Harmony Remote & try not to dig the Keyboard/mouse out of the drawer if possible. Currently having to move the cursor once on every start-up to make it go away.

 

I have tried to Alt/Tab work around but I can't seem to get it to work. I have also not yet tried to On Top mpv work around as I feel it will have other implications.

 

Has anyone found a solution to this problem?

Same for me.

 

Wake HTPC via Logitech Elite remote.

Launch ET via Logitech remote.

Navigate ET play media, the whole time ET is open the mouse cursor is stuck in the middle of the screen, never fades. Have to get up, find the mouse in a drawer, and move it out of the frame.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...