Jump to content
mutu310

BlurN — Blu-Ray Release Notifications

Recommended Posts

CBers

@@Lighthammer

I've had this plugin installed FOREVER and I finally went back and tinkered with the settings to figure out why it doesn't work.

 

Nothing looks out of place.

Here are screen shots:

5e48449d30209_BlurN1.png

 

And here's the configuration:

5e4845681815c_BlurN3.png

 

The top part looks corrupted because, as you can see, it continues to "spin" trying to load. I've been able to set all the settings before but they never hold. Its always reset when I go back to configure it again.

 

The addon is acting like its either corrupt or looking for something.

 

Is there something I am missing or is this in fact a broken plugin?

 

Do we assume that this plugin is now dead/not fixable? If so should it not be removed from the plugin catalogue?  :(

 

Getting the same as above.

 

@@Luke / @@ebr - suggest you remove this from the plugin catalogue for the time being, or until @@mutu310 is available again.

  • Like 3

Share this post


Link to post
Share on other sites
cayars

3.5 Months later and it's still just spinning and doing exactly as mentioned above.

Share this post


Link to post
Share on other sites
mutu310
Posted (edited)
On 7/17/2020 at 11:10 AM, cayars said:

3.5 Months later and it's still just spinning and doing exactly as mentioned above.

 

Yes, it is. Thing is this plugin was fully working. Emby had changes to it that broke my code. I asked multiple times what I need to change to rectify the issues and I never got a satisfying response. I mean, if *I* was responsible for the Emby project and made changes that broke plugins, I'd go to their open source code and make pull requests to rectify the issues. But I've asked for support and I got zilc. Maybe this rant here changes something. I'm ready to fix things and make new features if I am advised what I need to do to fix the code, and I'm not talking pointers but actual code and covering all issues.

Edited by mutu310

Share this post


Link to post
Share on other sites
mutu310

@Luke @ebr please read previous post.

Share this post


Link to post
Share on other sites
Luke

Sorry I must have missed it. Can you point me to that? Thanks.

Share this post


Link to post
Share on other sites
mutu310
Sorry I must have missed it. Can you point me to that? Thanks.

Point you to what please?
Here is the source: https://github.com/MarkCiliaVincenti/MediaBrowser.Channels.BlurN

Some things changed and I can't find the problem because I'm unable to debug properly. Can you please make a pull request? I will remain actively working on this project if we can get it working again.
  • Like 2

Share this post


Link to post
Share on other sites
BKKK

My regular bump to this thread so it not forgotten 🙁

Share this post


Link to post
Share on other sites
Luke
On 7/18/2020 at 2:14 PM, mutu310 said:


Point you to what please?
Here is the source: https://github.com/MarkCiliaVincenti/MediaBrowser.Channels.BlurN

Some things changed and I can't find the problem because I'm unable to debug properly. Can you please make a pull request? I will remain actively working on this project if we can get it working again.

@mutu310 What is the problem that needs looking at?

Share this post


Link to post
Share on other sites
cayars
Posted (edited)

Install the plugin and then try to configure it.  You'll get a spinning circle and never been able to do the initial config.

He's saying it was working fine but an Emby release broke it and he can't properly debug the problem so he needs a bit of help getting it back working again.

Edited by cayars

Share this post


Link to post
Share on other sites
Luke

Pull request submitted.

Share this post


Link to post
Share on other sites
mutu310
Posted (edited)
12 hours ago, Luke said:

Pull request submitted.

 

Thanks for the pull request; what is the minimum Emby version for it?

The problem with the pull request is that this won't fix BlurN... it will just make the configuration page work again. It won't get the scheduled tasks to work; that's the real problem, that there's three scheduled tasks which used to work and they're all broken now.

Also, logged in at the mb3admin portal again, but there's no packages section anymore. Where do I make new releases from?

Last but not least, where's the new NuGet repository?

Edited by mutu310
  • Like 1

Share this post


Link to post
Share on other sites
cayars

Maybe this was my bad. I thought you needed help getting past the spinning circle to actually config the plugin.  Did you expect Luke to go all through your code fixing it to work with the current release as if it's an Emby developed plugin?

On 7/18/2020 at 2:14 PM, mutu310 said:


Point you to what please?
Here is the source: https://github.com/MarkCiliaVincenti/MediaBrowser.Channels.BlurN

Some things changed and I can't find the problem because I'm unable to debug properly. Can you please make a pull request? I will remain actively working on this project if we can get it working again.

What type of problem are you having with debugging?  Maybe the better approach would be to help you get debugging working?

Share this post


Link to post
Share on other sites
mutu310
57 minutes ago, cayars said:

Maybe this was my bad. I thought you needed help getting past the spinning circle to actually config the plugin.  Did you expect Luke to go all through your code fixing it to work with the current release as if it's an Emby developed plugin?

What type of problem are you having with debugging?  Maybe the better approach would be to help you get debugging working?

Of course I did. I've been developing this plugin and most of my changes were related to fixing the plugin because changes in Emby broke the plugin, and now it's gotten to the point where absolutely nothing was working. It's not fair on plugin developers; it is quite frustrating when changes done by other people break code that was working. Yes, debugging would go a long way, you see without being able to debug and without knowing what changes were done in Emby, it would be quite a bit of a trial-and-error and two bottles of whiskey.

  • Like 1

Share this post


Link to post
Share on other sites
Luke
10 hours ago, mutu310 said:

 

Thanks for the pull request; what is the minimum Emby version for it?

The problem with the pull request is that this won't fix BlurN... it will just make the configuration page work again. It won't get the scheduled tasks to work; that's the real problem, that there's three scheduled tasks which used to work and they're all broken now.

Also, logged in at the mb3admin portal again, but there's no packages section anymore. Where do I make new releases from?

Last but not least, where's the new NuGet repository?

Minimum emby version = the version number of the nuget package you are using.

Share this post


Link to post
Share on other sites
mutu310
On 8/13/2020 at 12:37 PM, Luke said:

Minimum emby version = the version number of the nuget package you are using.

I can't even update the nuget package. What you changed was the JS code, surely I need a minimum emby version for that no? @chef

  • Like 1

Share this post


Link to post
Share on other sites
Luke
53 minutes ago, mutu310 said:

I can't even update the nuget package. What you changed was the JS code, surely I need a minimum emby version for that no?

In this case not necessarily, no.

Share this post


Link to post
Share on other sites
chef
Posted (edited)

It's JQuery again.

Guys we are moving away from JQuery. It isn't supported in the WebApp or dashboard.

 

 

@mutu310  BlurN is a wonderful addition to the catalog and it is well received by the community. I hope that you will find the time to 86 the JQuery and refactor to VanillaJS.

If there is anything I can do to help the migration, please let me know. It's easy enough, and if you are not entirely sure please see my github for some code examples for the JS, or PM me :)

 

github.com/chefbennyj1 :)

Edited by chef
  • Like 1

Share this post


Link to post
Share on other sites
GentleSoul

Still waiting like the plugin. 

Share this post


Link to post
Share on other sites
mutu310
On 27/08/2020 at 22:51, chef said:

It's JQuery again.

Guys we are moving away from JQuery. It isn't supported in the WebApp or dashboard.

 

 

@mutu310  BlurN is a wonderful addition to the catalog and it is well received by the community. I hope that you will find the time to 86 the JQuery and refactor to VanillaJS.

If there is anything I can do to help the migration, please let me know. It's easy enough, and if you are not entirely sure please see my github for some code examples for the JS, or PM me :)

 

github.com/chefbennyj1 :)

 

I PMed you @chef. I intend bringing this back to life.

Edited by mutu310
  • Like 2

Share this post


Link to post
Share on other sites
cayars

That's great news!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...