Jump to content


Photo

Restoring from Server Configuration backup doesn't work

backup restore migrate migration

  • Please log in to reply
4 replies to this topic

#1 filecore OFFLINE  

filecore

    Member

  • Members
  • 19 posts
  • Local time: 05:40 PM

Posted 29 December 2016 - 04:08 PM

I'm a premium supporter and have the Server Configuration backup. Due to some previous issues with Emby, and also for some other reasons, I decided to stop fighting with all the legacy crap on my media server, and did a fresh reinstall. I reinstalled onto a new drive, so I still have full access to the old system. However, restoring my backup via Server Config backup plugin didn't work.

 

Steps taken:

  1. Clean install of Windows 7
  2. Clean install of latest Emby Server (3.1.2.0)
  3. Fresh backup made on old Emby (3.0.6050.0)
  4. Install the backup plugin on new Emby
  5. Browse the backup - all users are seen, migration options are to create same-named users, options for plugin restore etc are all checked
  6. Press the restore button, accept the warnings
  7. Page refreshes and puts me on the Dashboard
  8. Check the Users and Plugins sections, nada

I've done this with Chrome but also tried in Firefox (after reading a similar thread). I also followed the migration guide for manual migration, but I was getting Syntax error at or near INSERT from DB Browser for SQLite, so I could get my plugins restored manually, but still no user accounts or media browsing data.

 

The only thing I can think is that there's some issue with paths (the old install is at Mediabrowser-Server unser %appdata%, while the new one is at Emby-Server) but it doesn't seem likely. Or then some weird permissions issue. Or the previously linked thread where user plasmon mentions that:

 

 

One thing is: in the Backup.log there is no mention of the "userdata" folder there is : "...\Emby-Server\config\users\" backed up into ...\users that's fine but no mention of were the userdata folder was backed up from.

 

I'll look into this a little further but it's doubtful. I'm out of ideas otherwise. Any help would be much appreciated.

Attached Files


Edited by filecore, 29 December 2016 - 04:11 PM.


#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15726 posts
  • Local time: 09:40 AM
  • LocationWashington State

Posted 29 December 2016 - 05:20 PM

Clean install of latest Emby Server (3.1.2.0)

Fresh backup made on old Emby (3.0.6050.0)

@Luke

@ebr

 

Well the old version uses a different database for userinfo.  Not sure if this is even possible importing old into new.


Edited by Happy2Play, 29 December 2016 - 05:22 PM.


#3 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46993 posts
  • Local time: 11:40 AM

Posted 30 December 2016 - 12:24 PM

Theoretically it should work but I'm sure coming from a version that old hasn't been tested.

 

Can you try updating your old version to current and then doing the backup and try restoring that?



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138077 posts
  • Local time: 12:40 PM

Posted 30 December 2016 - 01:15 PM

@Happy2Play using the backup plugin should be fine.

 

using the manual method should be fine too, delete library.db on new server and on next run it will import the contents of the userdata db file.



#5 filecore OFFLINE  

filecore

    Member

  • Members
  • 19 posts
  • Local time: 05:40 PM

Posted 02 January 2017 - 03:50 PM

Can you try updating your old version to current and then doing the backup and try restoring that?

 

I've had issues with updates before (I suspect my base version is too old, and causing some incompatibility - I've posted about issues with the license key working in tray icon mode but not in Windows Service mode, for example) but this time I decided to just bite the bullet and upgrade. It seemed to go perfectly fine (tray icon mode), and I made a backup with the config plugin.

 

When I restored this on the new instance, most things seem to be in place. Some settings were lost, but I literally just finished it a few minutes ago and it's currently rescanning the entire library, which tends to take a bit of time. I've noticed some small things missing so far: user profile images are all missing (not a big deal), and at least some settings are wrong, such as "hide this user from login screen" being set to defaults for all. I'm sure I'll discover others, and there might be issues with progress and saved state once the library scan is complete and I can launch the client. I'll update as and when I encounter things.







Also tagged with one or more of these keywords: backup, restore, migrate, migration

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users