Jump to content

screenplay for WebOS 2.0 and higher TVs


kwilcox
 Share

Recommended Posts

kwilcox

@@kwilcox can you not add this app to all locations? Emby is used in all countries.

Some regions have special controls.  It was a real Pita to get it approved for Brazil.  You literally have to go region by region and there are a hundred or so....

Link to comment
Share on other sites

johnbury

Great work! 

 

I have been following this thread for about a week (since tripping over it while trying to find out why my new LG TV keeps dropping off Emby's list of DLNA devices).  I installed it as soon as it made it to the store.  Really pleased thus far!

 

Cheers

Link to comment
Share on other sites

kwilcox

LG got back to me and told me how to change the QA version to Global Service Area support.  I have done that, cancelled the current QA version, and re-submitted a new version for QA.  So, screenplay v1.1.1 now awaiting QA, should be available on WebOS 2.0 and greater in all service areas if it gets accepted.

Edited by kwilcox
  • Like 2
Link to comment
Share on other sites

LG got back to me and told me how to change the QA version to Global Service Area support.  I have done that, cancelled the current QA version, and re-submitted a new version for QA.  So, screenplay v1.1.1 now awaiting QA, should be available on WebOS 2.0 and greater in all service areas if it gets accepted.

 

Great, can you tell me if it's already available in the store in Brazil?

Link to comment
Share on other sites

Kavalera

Is this mean that it will be available in whole world?

 

Изпратено от моят LG-H815 с помощта на Tapatalk

Link to comment
Share on other sites

cmarques

Is this mean that it will be available in whole world?

 

Изпратено от моят LG-H815 с помощта на Tapatalk

 

This is the idea.

  • Like 1
Link to comment
Share on other sites

kwilcox

I'm expecting a reject here btw because some areas might require native language support.  If that is the case, once I have the list, I'll eliminate those regions and resubmit.  Right now, settings are hardcoded to english.

Link to comment
Share on other sites

johnbury

@@kwilcox

 

I am really enjoying the work you have done. Do you want any odd behaviours reporting in this thread?

 

If so, here's what I have noted thus far plus any questions

 

1) In my setup,when I first navigate to my TV series, and select 'all tv', I cannot scroll to the end of my library using the left / right arrows. It stops after 25 arrow clicks. If I then click on an index letter (to move my selection on), I can then navigate all entries backwards and forwards. The limitation seems only when I first enter the 'all tv' view

2) is shaking the controller (to wake up the controller pointer) the only way to get the play / pause buttons?

3). The progress scroll bar in the play / pause area doesn't allow moving backward or forward through a program For me any attempt to use it restarts the current episode

4) although the 'watched program/series' tick s displayed appropriately, there is no 'unwatched episodes' count on program/season icons. Empty seasons and those with unwatched content therefore look the same

 

All a bit nit picky, but there you go FWIW!

 

Keep up the great work

 

Regards

 

John

Link to comment
Share on other sites

kwilcox

Hey thanks!  This is the official support thread for screenplay so here's where any issues that are uncovered should be posted. 

  • I'm aware of 1) already but have been too lazy to fix since I also found the "moving to the index first" workaround lol.  Since soemebody else noticed I guess I'll have to have a look.
  • For 2) you can define a color button to bring up player controls but you still need the mouse pointer active to use.  There's a button on the right side under the arrow keys for mine that brings up the pointer.  Also, you can stop a playing video by hitting the back (curved arrow pointing left) button.   
  • 3) this can be picky but it should work; I use it a lot on my webOS2 TV.  Try it with direct play off and on.  Is the behavior different?
  • 4) I don't think emby server has an "unwatched" icon but I can check.  screenplay does show new items in the catalog summary screen along with recently viewed and recommended categories.  Order is random however because its a callback function.
Edited by kwilcox
Link to comment
Share on other sites

#4) &UnplayedCount=item.UserData.UnplayedItemCount

  • Like 1
Link to comment
Share on other sites

johnbury

Ok, thanks for quick reply.

 

I'll try all of your suggestions / solutions and will get back to you.

 

Yes, I know there isn't an 'unwatched' icon, but EMBY shows a count of 'to be watched' episodes on a season 'icon' and a grand total in the series icon

 

Cheers

 

John

Link to comment
Share on other sites

johnbury

Also (by the way), I'm using the LG Store version (1.0.7?) so. Don't think I have direct play. I can wait!

 

Another observation is that I also get some odd sound artefacts... high pitch 'cheeps' such that my wife asked if I could hear birds. They happen randomly during most playbacks. I will forward file types if that helps.

 

Cheers

 

John

Link to comment
Share on other sites

kwilcox

I think I found the seek bug btw.  In webOS3 video.duration returns NaN (undefined value) if the video is paused.  That's a bug on their end that I can work around however.  Does your seekbar show something like "NaN:NaN" in the elapsed time area when you are dragging the seek bar?  When its working correctly, elapsed time should change as you drag the seek bar around.

 

I can't help your sound "chirps" unfortunately.  HTML5 audio decoding is handled by LG.  I just set up the <video> tag and hand it over to WebOS.  

 

Where in Lancashire are you btw?  I lived in Rochdale when I was a kid :)

Edited by kwilcox
Link to comment
Share on other sites

johnbury

Hi

 

Tried the seek thing again, and yes it does display NaN:NaN/N

 

Hope that helps

 

Cheers

 

John

Link to comment
Share on other sites

Also (by the way), I'm using the LG Store version (1.0.7?) so. Don't think I have direct play. I can wait!

 

Another observation is that I also get some odd sound artefacts... high pitch 'cheeps' such that my wife asked if I could hear birds. They happen randomly during most playbacks. I will forward file types if that helps.

 

Cheers

 

John

That will not happen when you have direct play. I have the same sound glitches when using streaming.

Edited by Brazer
Link to comment
Share on other sites

By the way Brazer, I'm so glad you have the same issues with auto-correct that I do!!

 

Cheers

Was not auto-correct, I am just a lousy speller and English is not my first language. Afrikaans is :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...