Jump to content

XPEnology Users Read Me


solabc16
 Share

Recommended Posts

Hi there @xuxull, what happened when you tried to start Emby Server? Thanks !

hi luke,

 

The server could not start. After I hit start button in Synology App Store, button title showed “starting” and then turned back to “start”.

Link to comment
Share on other sites

@@xuxulll would you mind attaching the server log here as well? Thanks !

hi, I have read the server log and finally get the problem solved. Another app occupied the default port 8096 which cause exit of emby server.

Link to comment
Share on other sites

  • 3 months later...

is there anyway to download the package and manually install.  it keeps stopping my download between 2%-10% then restarting .   bad connection behind the China Great Firewall.

Edited by Rp4000
Link to comment
Share on other sites

  • 2 weeks later...

Hey, i just added the repo for my haswell NL54 server and install the emby package.

But the package wont start. The diagnostic file is sendlogs_Synology-DS3615_synology_bromolow_3615xs_20191016T205713UTC.tgz

Thanks!

Link to comment
Share on other sites

Hey, i just added the repo for my haswell NL54 server and install the emby package.

But the package wont start. The diagnostic file is sendlogs_Synology-DS3615_synology_bromolow_3615xs_20191016T205713UTC.tgz

Thanks!

 

@@HansDampf

 

Is any Emby Server log created under

/var/packages/EmbyServer/target/var/logs

?

Link to comment
Share on other sites

Hey, i just added the repo for my HP NL54 server and installed the emby package and sended the logs sendlogs_FLORI-NAS_synology_bromolow_3615xs_20191027T080813UTC.tgz   

 

Thanks for your help!

Link to comment
Share on other sites

Hey, i just added the repo for my HP NL54 server and installed the emby package and sended the logs sendlogs_FLORI-NAS_synology_bromolow_3615xs_20191027T080813UTC.tgz   

 

Thanks for your help!

 

Hi there, why did you do that? Are you having a problem?

Link to comment
Share on other sites

Hey, i just added the repo for my HP NL54 server and installed the emby package and sended the logs

sendlogs_Syno-Olivier_synology_bromolow_3615xs_20191103T154254UTC.tgz 

Link to comment
Share on other sites

 

 

We trust you have received the usual lecture from the local System

Administrator. It usually boils down to these three things:

 

    #1) Respect the privacy of others.

    #2) Think before you type.

    #3) With great power comes great responsibility.

 

Password:

 

********************************************************************************

Script invoked as [./rundiags] by [root].

File Version : 4.2.1.0-1

********************************************************************************

 

This script will report on the currently installed package's configuration and

collect system information related to its performance and operation. PLEASE ONLY

USE AS DIRECTED BY SUPPORT

 

Type [yes] and press return to continue: yes

 

--------------------------------------------------------------------------------

 

Getting platform information:

 

  >> Platform    : Linux NASTY 3.10.105 #23739 SMP Tue Jul 3 19:47:13 CST 2018 x                                                                                                             86_64 GNU/Linux synology_bromolow_3615xs

  >> DSM Version : 6.2-23739 Update 0 [6.2|GM|2018/07/03|22:05:35]

 

--------------------------------------------------------------------------------

 

Getting hardware information:

 

  -> System...

./rundiags: line 304: 14702 Illegal instruction     (core dumped) ${lshw_binary}                                                                                                              -C system > ${output_file} 2> /dev/null

  FAILED

 

  -> Processor...

./rundiags: line 304: 14712 Illegal instruction     (core dumped) ${lshw_binary}                                                                                                              -C processor > ${output_file} 2> /dev/null

  FAILED

 

  -> Memory...

./rundiags: line 304: 14721 Illegal instruction     (core dumped) ${lshw_binary}                                                                                                              -C memory > ${output_file} 2> /dev/null

  FAILED

 

  ->  CPUinfo...

  OK

 

  ->  Looking for DRM devices...

  NONE

 

--------------------------------------------------------------------------------

 

Available version(s) of MONO:

  -> 5.18.0.240

 

Available version(s) of SQLITE:

  -> 3.29.0

 

Available version(s) of IMAGEMAGICK:

find: `/var/packages/EmbyServer/target/3rdparty/imagemagick/*': No such file or                                                                                                              directory

 

Available version(s) of FFMPEG:

  -> 0.0.0

  -> 4.0.3

 

--------------------------------------------------------------------------------

 

Validating version(s) of MONO:

 

  -> 5.18.0.240

./rundiags: line 497: 14800 Illegal instruction     (core dumped) $version/${com                                                                                                             ponent_chkstring_3rdparty[${i}]} &> ${output_file}

  FAILED

 

 

Validating version(s) of SQLITE:

 

  -> 3.29.0

  OK

 

3.29.0 2019-07-10 17:32:03 fc82b73eaac8b36950e527f12c4b5dc1e147e6f4ad2217ae43ad8                                                                                                             2882a88bfa6

 

Validating version(s) of IMAGEMAGICK:

 

find: `/var/packages/EmbyServer/target/3rdparty/imagemagick/*': No such file or                                                                                                              directory

Validating version(s) of FFMPEG:

 

  -> 0.0.0

  FAILED

 

/var/packages/EmbyServer/target/3rdparty/ffmpeg/0.0.0//bin/ffmpeg: line 187: 148                                                                                                             66 Illegal instruction     (core dumped) ${emby_ffmpeg} "$@"

 

  -> 4.0.3

./rundiags: line 497: 14882 Illegal instruction     (core dumped) $version/${com                                                                                                             ponent_chkstring_3rdparty[${i}]} &> ${output_file}

  FAILED

 

 

--------------------------------------------------------------------------------

 

Checking symlink for component MONO is valid and getting target:

  -> LOCAL : 3rdparty/mono/5.18.0.240

  -> ACTUAL: /volume2/@appstore/EmbyServer/3rdparty/mono/5.18.0.240

  PASSED

 

Checking symlink for component SQLITE is valid and getting target:

  -> LOCAL : 3rdparty/sqlite/3.29.0

  -> ACTUAL: /volume2/@appstore/EmbyServer/3rdparty/sqlite/3.29.0

  PASSED

 

Checking symlink for component IMAGEMAGICK is valid and getting target:

  FAILED

 

Checking symlink for component FFMPEG is valid and getting target:

  -> LOCAL : 3rdparty/ffmpeg/4.0.3

  -> ACTUAL: /volume2/@appstore/EmbyServer/3rdparty/ffmpeg/4.0.3

  PASSED

 

--------------------------------------------------------------------------------

 

Available version(s) of Emby Server:

  -> 4.2.1.0

 

--------------------------------------------------------------------------------

 

Validating Emby Server version(s):

 

  -> 4.2.1.0

./rundiags: line 605: 14998 Illegal instruction     (core dumped) ${pkg_default_                                                                                                             mono_root}/bin/ikdasm $version/EmbyServer.exe -assembly &> ${output_file}

  FAILED

 

 

--------------------------------------------------------------------------------

 

Checking symlink for Emby Server is valid and getting target:

  -> LOCAL : releases/4.2.1.0

  -> ACTUAL: /volume2/@appstore/EmbyServer/releases/4.2.1.0

  PASSED

 

--------------------------------------------------------------------------------

 

Searching for system provided version(s) of FFMPEG:

  -> /usr/bin/ffmpeg

  1 version(s) found.

 

Searching for system provided version(s) of FFPROBE:

  No versions found.

 

--------------------------------------------------------------------------------

 

Getting system provided FFMPEG version information:

 

  -> /usr/bin/ffmpeg

  OK

 

ffmpeg version 2.7.1 Copyright © 2000-2015 the FFmpeg developers

built with gcc 4.9.3 (crosstool-NG 1.20.0) 20150311 (prerelease)

configuration: --prefix=/usr --incdir='${prefix}/include/ffmpeg' --arch=i686 --t                                                                                                             arget-os=linux --cross-prefix=/usr/local/x86_64-pc-linux-gnu/bin/x86_64-pc-linux                                                                                                             -gnu- --enable-cross-compile --enable-optimizations --enable-pic --enable-gpl --                                                                                                             enable-shared --disable-static --enable-version3 --enable-nonfree --enable-libfa                                                                                                             ac --enable-encoders --enable-pthreads --disable-bzlib --disable-protocol=rtp --                                                                                                             disable-muxer=image2 --disable-muxer=image2pipe --disable-swscale-alpha --disabl                                                                                                             e-ffserver --disable-ffplay --disable-devices --disable-bzlib --disable-altivec                                                                                                              --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libmp3lame --disa                                                                                                             ble-vaapi --disable-decoder=amrnb --disable-decoder=ac3 --disable-decoder=ac3_fi                                                                                                             xed --disable-encoder=zmbv --disable-encoder=dca --disable-encoder=ac3 --disable                                                                                                             -encoder=ac3_fixed --disable-encoder=eac3 --disable-decoder=dca --disable-decode                                                                                                             r=eac3 --disable-decoder=truehd --cc=/usr/local/x86_64-pc-linux-gnu/bin/x86_64-p                                                                                                             c-linux-gnu-ccache-gcc --enable-yasm --enable-libx264 --enable-encoder=libx264

libavutil      54. 27.100 / 54. 27.100

libavcodec     56. 41.100 / 56. 41.100

libavformat    56. 36.100 / 56. 36.100

libavdevice    56.  4.100 / 56.  4.100

libavfilter     5. 16.101 /  5. 16.101

libswscale      3.  1.101 /  3.  1.101

libswresample   1.  2.100 /  1.  2.100

libpostproc    53.  3.100 / 53.  3.100

 

Getting system provided FFPROBE version information:

 

  No versions found.

 

--------------------------------------------------------------------------------

 

Listing open files for user [embysvr]:

 

./rundiags: line 816: 15112 Illegal instruction     (core dumped) ${lsof_binary}                                                                                                              +E -n -u ${pkg_user} &> ${output_file}

  FAILED

 

********************************************************************************

Diagnostic script run completed, the log can be viewed at the location below...

/var/packages/EmbyServer/scripts/utilities/logs/rundiags_20191104T223743UTC.log                                                                                                              

********************************************************************************

 

admin@NASTY:/var/packages/EmbyServer/scripts/utilities$ sudo ./sendlogs

 

********************************************************************************

Script invoked as [./sendlogs] by [root].

File Version : 4.2.1.0-1

********************************************************************************

 

This script will collect support logs into a single compressed archive and send

them to Emby over a HTTPS connection to assist with support issues, future

developemnts and package improvements. PLEASE ONLY USE AS DIRECTED BY SUPPORT

 

Type [yes] and press return to continue: yes

 

>> Creating archive...

SUCCESS

 

>> Sending archive...

-- Size: 212K

-- HTTP Status: 200

SUCCESS

 

>> Cleaning up...

SUCCESS

 

********************************************************************************

Upload completed successfully, please include this filename with your ticket...

sendlogs_NASTY_synology_bromolow_3615xs_20191104T224016UTC.tgz                                                                                                                               

********************************************************************************

 

admin@NASTY:/var/packages/EmbyServer/scripts/utilities$ sudo ./sendlogs

 

********************************************************************************

Script invoked as [./rundiags] by [root].

File Version : 4.2.1.0-1

********************************************************************************

 

This script will report on the currently installed package's configuration and

collect system information related to its performance and operation. PLEASE ONLY

USE AS DIRECTED BY SUPPORT

 

Type [yes] and press return to continue: yes

 

--------------------------------------------------------------------------------

 

Getting platform information:

 

  >> Platform    : Linux NASTY 3.10.105 #23739 SMP Tue Jul 3 19:47:13 CST 2018 x                                                                                                             86_64 GNU/Linux synology_bromolow_3615xs

  >> DSM Version : 6.2-23739 Update 0 [6.2|GM|2018/07/03|22:05:35]

 

--------------------------------------------------------------------------------

 

Getting hardware information:

 

  -> System...

./rundiags: line 304: 14702 Illegal instruction     (core dumped) ${lshw_binary}                                                                                                              -C system > ${output_file} 2> /dev/null

  FAILED

 

  -> Processor...

./rundiags: line 304: 14712 Illegal instruction     (core dumped) ${lshw_binary}                                                                                                              -C processor > ${output_file} 2> /dev/null

  FAILED

 

  -> Memory...

./rundiags: line 304: 14721 Illegal instruction     (core dumped) ${lshw_binary}                                                                                                              -C memory > ${output_file} 2> /dev/null

  FAILED

 

  ->  CPUinfo...

  OK

 

  ->  Looking for DRM devices...

  NONE

 

--------------------------------------------------------------------------------

 

Available version(s) of MONO:

  -> 5.18.0.240

 

Available version(s) of SQLITE:

  -> 3.29.0

 

Available version(s) of IMAGEMAGICK:

find: `/var/packages/EmbyServer/target/3rdparty/imagemagick/*': No such file or                                                                                                              directory

 

Available version(s) of FFMPEG:

  -> 0.0.0

  -> 4.0.3

 

--------------------------------------------------------------------------------

 

Validating version(s) of MONO:

 

  -> 5.18.0.240

./rundiags: line 497: 14800 Illegal instruction     (core dumped) $version/${com                                                                                                             ponent_chkstring_3rdparty[${i}]} &> ${output_file}

  FAILED

 

 

Validating version(s) of SQLITE:

 

  -> 3.29.0

  OK

 

3.29.0 2019-07-10 17:32:03 fc82b73eaac8b36950e527f12c4b5dc1e147e6f4ad2217ae43ad8                                                                                                             2882a88bfa6

 

Validating version(s) of IMAGEMAGICK:

 

Password:

find: `/var/packages/EmbyServer/target/3rdparty/imagemagick/*': No such file or                                                                                                              directory

Validating version(s) of FFMPEG:

 

  -> 0.0.0

  FAILED

 

/var/packages/EmbyServer/target/3rdparty/ffmpeg/0.0.0//bin/ffmpeg: line 187: 148                                                                                                             66 Illegal instruction     (core dumped) ${emby_ffmpeg} "$@"

 

  -> 4.0.3

./rundiags: line 497: 14882 Illegal instruction     (core dumped) $version/${com                                                                                                             ponent_chkstring_3rdparty[${i}]} &> ${output_file}

  FAILED

 

 

--------------------------------------------------------------------------------

 

Checking symlink for component MONO is valid and getting target:

  -> LOCAL : 3rdparty/mono/5.18.0.240

  -> ACTUAL: /volume2/@appstore/EmbyServer/3rdparty/mono/5.18.0.240

  PASSED

 

Checking symlink for component SQLITE is valid and getting target:

  -> LOCAL : 3rdparty/sqlite/3.29.0

  -> ACTUAL: /volume2/@appstore/EmbyServer/3rdparty/sqlite/3.29.0

  PASSED

 

Checking symlink for component IMAGEMAGICK is valid and getting target:

  FAILED

 

Checking symlink for component FFMPEG is valid and getting target:

  -> LOCAL : 3rdparty/ffmpeg/4.0.3

  -> ACTUAL: /volume2/@appstore/EmbyServer/3rdparty/ffmpeg/4.0.3

  PASSED

 

--------------------------------------------------------------------------------

 

Available version(s) of Emby Server:

  -> 4.2.1.0

 

--------------------------------------------------------------------------------

 

Validating Emby Server version(s):

 

  -> 4.2.1.0

./rundiags: line 605: 14998 Illegal instruction     (core dumped) ${pkg_default_                                                                                                             mono_root}/bin/ikdasm $version/EmbyServer.exe -assembly &> ${output_file}

  FAILED

 

 

--------------------------------------------------------------------------------

 

Checking symlink for Emby Server is valid and getting target:

  -> LOCAL : releases/4.2.1.0

  -> ACTUAL: /volume2/@appstore/EmbyServer/releases/4.2.1.0

  PASSED

 

--------------------------------------------------------------------------------

 

Searching for system provided version(s) of FFMPEG:

  -> /usr/bin/ffmpeg

  1 version(s) found.

 

Searching for system provided version(s) of FFPROBE:

  No versions found.

 

--------------------------------------------------------------------------------

 

Getting system provided FFMPEG version information:

 

  -> /usr/bin/ffmpeg

  OK

 

ffmpeg version 2.7.1 Copyright © 2000-2015 the FFmpeg developers

built with gcc 4.9.3 (crosstool-NG 1.20.0) 20150311 (prerelease)

configuration: --prefix=/usr --incdir='${prefix}/include/ffmpeg' --arch=i686 --t                                                                                                             arget-os=linux --cross-prefix=/usr/local/x86_64-pc-linux-gnu/bin/x86_64-pc-linux                                                                                                             -gnu- --enable-cross-compile --enable-optimizations --enable-pic --enable-gpl --                                                                                                             enable-shared --disable-static --enable-version3 --enable-nonfree --enable-libfa                                                                                                             ac --enable-encoders --enable-pthreads --disable-bzlib --disable-protocol=rtp --                                                                                                             disable-muxer=image2 --disable-muxer=image2pipe --disable-swscale-alpha --disabl                                                                                                             e-ffserver --disable-ffplay --disable-devices --disable-bzlib --disable-altivec                                                                                     Sorry, try again.

Password:

                ble-vaapi --disable-decoder=amrnb --disable-decoder=ac3 --disable-decoder=ac3_fi                                                                                                             xed --disable-encoder=zmbv --disable-encoder=dca --disable-encoder=ac3 --disable                                                                                                             -encoder=ac3_fixed --disable-encoder=eac3 --disable-decoder=dca --disable-decode                                                                                                             r=eac3 --disable-decoder=truehd --cc=/usr/local/x86_64-pc-linux-gnu/bin/x86_64-p                                                                                                             c-linux-gnu-ccache-gcc --enable-yasm --enable-libx264 --enable-encoder=libx264

libavutil      54. 27.100 / 54. 27.100

libavcodec     56. 41.100 / 56. 41.100

libavformat    56. 36.100 / 56. 36.100

libavdevice    56.  4.100 / 56.  4.100

libavfilter     5. 16.101 /  5. 16.101

libswscale      3.  1.101 /  3.  1.101

libswresample   1.  2.100 /  1.  2.100

libpostproc    53.  3.100 / 53.  3.100

 

Getting system provided FFPROBE version information:

 

  No versions found.

 

--------------------------------------------------------------------------------

 

Listing open files for user [embysvr]:

 

./rundiags: line 816: 15112 Illegal instruction     (core dumped) ${lsof_binary}                                                                                                              +E -n -u ${pkg_user} &> ${output_file}

  FAILED

 

********************************************************************************

Diagnostic script run completed, the log can be viewed at the location below...

/var/packages/EmbyServer/scripts/utilities/logs/rundiags_20191104T223743UTC.log

********************************************************************************

 

admin@NASTY:/var/packages/EmbyServer/scripts/utilities$ sudo ./sendlogs

 

********************************************************************************

Script invoked as [./sendlogs] by [root].

File Version : 4.2.1.0-1

********************************************************************************

 

This script will collect support logs into a single compressed archive and send

them to Emby over a HTTPS connection to assist with support issues, future

developemnts and package improvements. PLEASE ONLY USE AS DIRECTED BY SUPPORT

 

Type [yes] and press return to continue: yes

 

>> Creating archive...

SUCCESS

 

>> Sending archive...

-- Size: 212K

-- HTTP Status: 200

SUCCESS

 

>> Cleaning up...

SUCCESS

 

********************************************************************************

Upload completed successfully, please include this filename with your ticket...

sendlogs_NASTY_synology_bromolow_3615xs_20191104T224016UTC.tgz

********************************************************************************

 

admin@NASTY:/var/packages/EmbyServer/scripts/utilities$ sudo ./sendlogs

Sorry, try again.

Password:

sudo: 3 incorrect password attempts

admin@NASTY:/var/packages/EmbyServer/scripts/utilities$

 

 

 

 

hope this makes sense to you lol - this is why emby doesnt run natively on a 


HP ex490 - dual core processor with only 2meg of ram
Link to comment
Share on other sites

  • 1 month later...
Hello, 

my  problem, please help. 

Emby installs but does not start

Upload completed successfully,  this filename 

sendlogs_Diskstation_synology_bromolow_3615xs_20191211T043523UTC.tgz

                                                                                                          

vendor_id : GenuineIntel

cpu family : 6

model : 28

model name : Intel® Atom CPU  330   @ 1.60GHz

DSM Version : 5.2-5967

 

thx

twingos

 

rundiags_20191211T042743UTC.log

Edited by twingos
Link to comment
Share on other sites

  • 2 months later...
Hi, 

I have problem whis start server in my NAS.

Upload completed successfully,  this filename 

sendlogs_DiskStation_synology_bromolow_3615xs_20200305T092130UTC.tgz 

Thanks
Link to comment
Share on other sites

Hi, 

I have problem whis start server in my NAS.

Upload completed successfully,  this filename 

sendlogs_DiskStation_synology_bromolow_3615xs_20200305T092130UTC.tgz 

Thanks

Hi, what is the problem that you're having?

Link to comment
Share on other sites

Hi, what is the problem that you're having?

 

Hi, package setup successful but don't start.

After manual restart marked as stopped.

Thanks

Link to comment
Share on other sites

  • 2 weeks later...

Hi, package setup successful but don't start.

After manual restart marked as stopped.

Thanks

Same issue, file name sendlogs_NAS_synology_bromolow_3615xs_20200317T114000UTC.tgz

Link to comment
Share on other sites

Have updated the DSM to 6.2.2-24922 Update 6, and then reinstall the EMBY package, deleted the embysvr user, uninstall the package again and then reinstall the package. Still fail to start up.

5e71ec7bc04ac_.png

Link to comment
Share on other sites

BTW,the EMBY worked well before I made a clean reinstall of the DSM (didn't change the DSM version, 6.2.2-24922 update 4), After that the EMBY could not be started up again. :(

I really like EMBY server, and paid for a lifetime premiere license.

Please let me know what should I do to solve the issue. Thank you!

Edited by nickwzy
Link to comment
Share on other sites

@@Luke FYI

 

@@nickwzy, how can I help you? Were you able to restart the Emby package?

 

I think you're in the wrong thread here.

you are probably using a "normal" DSM version and not the currently available XPEnology DSM version

 

Can you please make sure via the Package Center that you have the correct source of Emby:

 

5e752a5ab3d6a_1.jpg

 

DSM 6.2.2-24922 Update 4 works fine.

 

Please make sure the above and maybe you can tell me why your drive is displayed critically (right)? Not that your volume crashed and therefore the start of the package is denied.

 

Just contact me again.

 

Many greetings,

Seger

 

Link to comment
Share on other sites

 

@@Luke FYI
 
@@nickwzy, how can I help you? Were you able to restart the Emby package?
 
I think you're in the wrong thread here.
you are probably using a "normal" DSM version and not the currently available XPEnology DSM version
 
Can you please make sure via the Package Center that you have the correct source of Emby:
 
5e752a5ab3d6a_1.jpg
 
DSM 6.2.2-24922 Update 4 works fine.
 
Please make sure the above and maybe you can tell me why your drive is displayed critically (right)? Not that your volume crashed and therefore the start of the package is denied.
 
Just contact me again.
 
Many greetings,
Seger

 

hi,Seger, I missed the "package_architecture" part. Now, the package is running. Thank you for your time.

Link to comment
Share on other sites

  • 2 weeks later...

hi im currently running version 4.3.1.0 how do i update to Version 4.4.0.40, i check and dont see any update on synology package

 

thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...