Jump to content
solabc16

XPEnology Users Read Me

Recommended Posts

solabc16

Hello @@ultimatevc

 

Theoretically we shouldn't have any issues getting Emby Server running on your platform.

 

To help us find out what is going on, can you run the diagnostics then the send logs utility.

 

Details are here on the wiki:-

 

https://github.com/MediaBrowser/Wiki/wiki/Synology-:-How-to-Run-Diagnostics

 

https://github.com/MediaBrowser/Wiki/wiki/Synology-:-How-to-Send-us-Support-Logs

 

Best

- James

Share this post


Link to post
Share on other sites
frogger

Hi,

 

I'm running a XPEnology DSM 6.1.3-15152 Update 8 on an older i7-920 bare metal rig.

The previous Emby version (which installed just fine using https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586)was running smoothly until I tried to install the 3.2.40 update today.

 

First off, updating to the latest version of Emby was not possible.The DSM package manager reported that the package download failed. The messages log contains the following corresponding errors:

2017-12-05T19:48:19+01:00 Helios synoscgi_SYNO.Core.Package.Thumb.Server_1_get[3527]: pkgimagetool.cpp:220 Wrong content type text/html; charset=UTF-8 in https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586/packages/synology/stable/3.2.40.0-1/EmbyServer_3.2.40.0-1_bromolow_thumb_72.png
2017-12-05T19:48:24+01:00 Helios synoscgi_SYNO.Core.Package.Installation_1_install[5088]: pkgserver.cpp:735 Warning: Failed to verify the package /volume1/@tmp/@synopkg/@download/EmbyServer/@SYNOPKG_DOWNLOAD_EmbyServer by MD5 ad9958e5c4e89c934236ad255d319ec1
2017-12-05T19:48:24+01:00 Helios synoscgi_SYNO.Core.Package.Installation_1_install[5088]: pkgserver.cpp:736 Warning: Failed to download EmbyServer from https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586/packages/synology/stable/3.2.40.0-1/EmbyServer_3.2.40.0-1_bromolow.spk
2017-12-05T19:48:24+01:00 Helios synoscgi_SYNO.Core.Package.Installation_1_install[5088]: pkgtool.cpp:1815 Failed to extract package INFO to /volume1/@tmp/qnWoZb
2017-12-05T19:48:24+01:00 Helios synoscgi_SYNO.Core.Package.Installation_1_install[5088]: pkgtool.cpp:1816 /bin/tar xf /volume1/@tmp/@synopkg/@download/EmbyServer/@SYNOPKG_DOWNLOAD_EmbyServer -C /volume1/@tmp/qnWoZb INFO --no-same-owner
2017-12-05T19:48:24+01:00 Helios synoscgi_SYNO.Core.Package.Installation_1_install[5088]: pkgtool.cpp:1862 Failed to query info
2017-12-05T19:48:24+01:00 Helios synoscgi_SYNO.Core.Package.Installation_1_install[5088]: pkgserver.cpp:747 Faild to download https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586/packages/synology/stable/3.2.40.0-1/EmbyServer_3.2.40.0-1_bromolow.spk

After some experimenting with the repo link I managed to download EmbyServer_3.2.40.0-1_bromolow.spk and successfully installed it manually.

I probably shouldn't have done that since Emby now refuses to start with no obvious errors in the log files. The start-stop-status log contains the following lines

[2017-12-05 20:50:20 UTC] Script called with action [status]...
[2017-12-05 20:50:20 UTC] >> PID file [/var/packages/EmbyServer/target/var/embysvr.pid] does not exist.
[2017-12-05 20:50:20 UTC] >> Emby Server is not running.
[2017-12-05 20:50:20 UTC] >> Exit status is [3].
[2017-12-05 20:50:20 UTC] Script called with action [log]...
[2017-12-05 20:50:20 UTC] >> Returning log file location [/var/packages/EmbyServer/target/var/logs/start-stop-status_20171205.log].
[2017-12-05 20:50:20 UTC] >> Exit status is [0].

Diagnostic files here: sendlogs_Helios_synology_bromolow_3615xs_20171205T205238UTC.tgz

 

Your help in fixing this issue is greatly appreciated!

 

 

Share this post


Link to post
Share on other sites
solabc16

Hello @@frogger

 

There's likely a couple of things going on here, firstly can you check that the certificate for the repository is still in place - see this post for details: https://emby.media/community/index.php?/topic/53177-cant-update-package-from-unknown-published/?p=514213.

 

it looks like a DSM update on a small number of systems has been causing the certificate to 'disappear'. We haven't been able to produce this so far on any of our test/development systems.

 

Best

- James

Share this post


Link to post
Share on other sites
frogger

Hi James,

 

thanks for the hint. Based on that, I did some more experimenting and while the certificate was still in place it pointed me something else.

 

For some unknown reason, DSM keeps adding a slash at the end of the URL.

While this doesn't cause any issues for FQDN-only URLs like https://synology.emby.media/, doing so for an URL with GET parameters (?package_repository=360efc6e-de72-4073-b603-2bfbd7001586/) points curl to an unavailable location.

 

Removing the trailing slash in /usr/syno/etc/packages/feeds and restarting the package manger solved the download issue.

As a consequence a XPenology compatible Envy package gets downloaded and installed, which also resolves the non-startup issue.

 

However, I've noticed that media will now more frequently hang for a couple of seconds when its being transcoded using the same resolution/bandwidth settings selected in the previous version.

Can you please advise an architecture parameter and/or transcoder setting that more closely matches my i7-920 CPU?

 

Alternatively, is there any way to download any previous version?

I understand that rolling back a version can cause all kinds of issues but it would be nice to have the option (like a simple direct download archive), even if it means loosing the meta-data and starting from scratch.
 

Again, thank you for your help!

Share this post


Link to post
Share on other sites
HaiToo

 

  The Celeron CPU,which one I select?  or it can't work under this architecture?

 

Logs:

       product: Intel® Celeron® CPU        E3200  @ 2.40GHz

       vendor: Intel Corp.

       physical id: 4

       bus info: cpu@0

       version: Intel® Celeron® CPU E3200 @ 2.40GHz

       slot: LGA775

       capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm xsave lahf_lm dtherm tpr_shadow vnmi flexpriority cpufreq

       configuration: cores=2 enabledcores=2 threads=2

 

thanks!!

Share this post


Link to post
Share on other sites
genous5201314

Please let me know what I need to get this working on my hardware.  Thanks.


 

my xpenology running on DSM6.02-8451


Edited by genous5201314

Share this post


Link to post
Share on other sites
matpez

Hi folks,

 

newby user here... 

 

Installed emby from  https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586

 

And now I can`t get it to start...

 

i did send log and this is file name  sendlogs_Synology_synology_broadwell_3617xs_20180310T144919UTC.tgz  

 

Now, what to do to get it started?

 

Thanks for your help in advance.

Share this post


Link to post
Share on other sites
matpez

Hi folks,

 

newby user here... 

 

Installed emby from  https://synology.emby.media/?package_repository=360efc6e-de72-4073-b603-2bfbd7001586

 

And now I can`t get it to start...

 

i did send log and this is file name  sendlogs_Synology_synology_broadwell_3617xs_20180310T144919UTC.tgz  

 

Now, what to do to get it started?

 

Thanks for your help in advance.

 

Found it!

 

If you take a look at this Wiki page - https://github.com/M...s-for-XPEnology, follow the instructions there and use the 'xpen-core2' alternate package architecture.

Share this post


Link to post
Share on other sites
Luke

Glad you worked it out.

Share this post


Link to post
Share on other sites
solabc16

Hello @@matpez

 

Sorry for the delay in responding, great job on getting it sorted and thanks for letting us know.

 

The 'xpen-core2' package is indeed the one optimised for your system.

 

For other readers with XPEnology based systems, here's a couple of useful resources to help with identifying Core 2 based systems....

 

 

 

Best

- James

Share this post


Link to post
Share on other sites
Beercules

FYI to anyone creating a XPENOLOGY server with EMBY

I am using a E3-1275v and it works flawlessly with EMBY, followed the default synology instructions for install package and have access to Intel transcoding due to my xeon have a IGP. 

 

DSM 6.1x using Juno loader. 

 

My Specs below:

Corsair 750d with 4 x HDD cages

ASUS PS10WS

Intel E3-1275 v6

8GB ECC memory

LSI 9118-8i flashed in IT mode without bios for quick reboots

16GB Kingston USB3.0 as boot loader (size of a thumbnail)

2 x intel 520 120GB SSD

8 x 1TB WD Black 

4 x 2TB Seagate 

850watt PSU

 

I use RAID1 for my SSDs and install all application on the SSD

I use SHR-2 for my 8 x 1TB WD black HDD (6TB usable) primary library drive

I use RAID10 for my 4 x 2TB Seagate HDD (4TB usable) backup drive

 

Only change I have made is to the transcoding folder, I pointed to /dev/shm so it won't trash my SSD. 

 

I love the streamlined look of Plex but EMBY by far has better performance, and options.

 

Thanks for all the hard work and supporting the Xpenology community. 

 

BEERCULES!

Share this post


Link to post
Share on other sites
solabc16

Hello @@Beercules

 

Thanks for the feedback, appreciated as always - great to hear h/w transcoding support is working for you on a DSM 6.1 based XPEnology system.

 

The default package will work well  on this CPU, although you may want to consider switching to the 'xpen-haswell' if you want to optimise further.

 

See https://github.com/MediaBrowser/Wiki/wiki/Synology-:-Custom-Package-Architectures-for-XPEnology for more details, and of course the opening post of this thread.

 

We'll likely add support for newer Intel microarchitectures later this year.

 

Best

- James

Share this post


Link to post
Share on other sites
Beercules

Hi James,

 

Thanks for the suggestion but I think that would be a downgrade for me, I have the latest Kaby Lake Xeon that has a much better IGP for transcoding.

I am currently working on a streamlined boot loader for my Xpenology that only has my dedicated hardware in it which will also include drivers for the latest IGP and Xeon processor, although I am considering moving Emby onto a dedicated server, just can't decided if I need ECC memory or not for the server. 

 

 

 

Beercules

Share this post


Link to post
Share on other sites
solabc16

Hello @Beercules

 

I think we may be at cross-purposes here, I'm referring to the software packages, which are optimised for different microarchitectures.

 

The default XPEnology package is optimised for the 'nehalem' microarchitecture, as discussed here: https://emby.media/community/index.php?/topic/40411-xpenology-users-read-me/?p=377703

 

As you have a newer processor with additional features, you may want to consider switching to the 'xpen-haswell' package, which will take advantage of those features.

 

Of course, dependent on your particular usage and workload, it may not prove significant - but good to know it's there, should you need it.

 

Best

- James

 

EDIT: I initially wrote the default XPEnology package is optimised for the 'ivybridgemicroarchitecture, where I of course meant 'nehalem'.

Edited by solabc16
  • Like 1

Share this post


Link to post
Share on other sites
anonbro

Hello,

 

I've installed Emby 3.3.1.0-1 on a brand new install of Xpenology with DSM 5.2-5967. The hardware running is a ex490 with 3 disks all running in basic mode with a volume on each disk.

The package is visible in the app list and I've used the specific link given in the OP.

 

However Emby doesn't want to start.

 

I've ./rundiags and ./sendlogs which gave me the following filename : sendlogs_San_Datacenter_synology_bromolow_3615xs_20180331T195847UTC.tgz

 

Let me know if can provide additionnal info.

 

Thanks for your help,

 

---EDIT - adding some details on my CPU

~ # cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 22
model name      : Intel(R) Celeron(R) CPU          450  @ 2.20GHz
stepping        : 1
microcode       : 0x38
cpu MHz         : 2194.767
cache size      : 512 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss tm pbe syscall nx lm constant_ts
c arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl tm2 s                                                             sse3 cx16 xtpr pdcm lahf_lm dtherm
bogomips        : 4389.53
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual

I don't see a Conroe specific package for Xpenology so I suppose I am out of luck for this setup ?

 

---EDIT 2 - Got it working

 

It runs OK with both xpen-core2-sse41 or xpen-core2.

I am not very familliar with extended CPU flags, is there a version that would run better on my setup between these two ?

 

Thanks,

rundiags_20180405T192356UTC.zip

Edited by anonbro

Share this post


Link to post
Share on other sites
solabc16

Hello All

 

Quick update, the XPEnology specific packages now support the DS916+ based loader - thanks to @@Joly0 for raising the issue.

 

Best

- James

Share this post


Link to post
Share on other sites
solabc16

Hello Again

 

As of stable release 3.5.0.0, XPEnology systems using the DS918+ based loader are also supported.

 

Best

- James

Share this post


Link to post
Share on other sites
Luke

Thanks James !

Share this post


Link to post
Share on other sites
Pepa pig

Hello, i am using a hp proliant g8 with Xpenology dsm 5.2-5967 update 8 runs flawless

 

e3-xeon 1260L

16gb of ram 

and had my server on a nvidia shied tv...but man what a diffrence 

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback !

Share this post


Link to post
Share on other sites
solabc16

Indeed, thanks @Pepa pig.

 

Best

- James

  • Like 1

Share this post


Link to post
Share on other sites
Pepa pig

Hello. Just updated to Dsm 6.2 o Man what a change that is. Works great. Emby server up to date and Just got a Emby premium account love it.. Only one thing thats not working for me. Is when i activate trailers for some strange reason the movie Will not play on my Sony xz premium. It stay's in loading mode

 

Thanks and regards

Share this post


Link to post
Share on other sites
Luke

Hello. Just updated to Dsm 6.2 o Man what a change that is. Works great. Emby server up to date and Just got a Emby premium account love it.. Only one thing thats not working for me. Is when i activate trailers for some strange reason the movie Will not play on my Sony xz premium. It stay's in loading mode

 

Thanks and regards

 

Hi, can we look at an example? Thanks !

Share this post


Link to post
Share on other sites
Pepa pig

Hi how do. i do that and i Just got a volley error also.. Gone cry now

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...