Jump to content
GlennNZ

FrontView+ [for Windows]iMon replacement, NowPlaying 2nd Screen

Recommended Posts

GlennNZ

What web browser are you using? I have tried both Edge and IE (on Windows 10).

 

EDIT: Just installed Chrome... Still no devices.

 

Where is FV+ Emby plugin supposed to be?? Its not in the normal spot, pehaps that is the problem...

 

C:\Users\Jason\AppData\Roaming\Emby-Server\plugins\ <---- No FV+ plugin

Yeah it is. As its in the catalog it has to be as only the dll is uploaded -(the path is never specified by plugin makers) the location is up to Emby server install. (Should be %appdata%\Emby-Server\plugins - can't double check my Windows path as away though)

 

If the dll isn't there, or it is not installed from catalogs correctly that would certainly explain why no devices show up - although would have thought wouldn't get html page either.

 

 

Glenn

Edited by GlennNZ

Share this post


Link to post
Share on other sites
Xzener

Its there, sorry... I can be blind sometimes.

 

Ok, how can I delete a client from being "known" from Emby Server??

 

Nevermind... I renamed the Emby Sever "Devices" folder to Devices_off to generate a new one... Worked like a charm. ;)  Thanks!

Edited by Xzener

Share this post


Link to post
Share on other sites
Xzener

Found another library hidden in the "Movies" list. It would be best to ignore this one IMO, or an option to turn off/on in settings...

 

5777fd5fb2e06_Capture.png

Edited by Xzener

Share this post


Link to post
Share on other sites
Xzener

All quite skinable by the user with XML files - in skin directory - just duplicate skin directory, rename and change whatever is needed.

Should be relatively easy to do both.

 

Glenn

 

I don't follow. Rename the "Skin" folder and edit the XML files? I'd like to edit the entire app to be porta it view. Your saying a user can do this by editing the XML, why not make it an option for the app??

 

The files in the "Skin" folder are Xaml files... Are those the ones you are referring to??

Edited by Xzener

Share this post


Link to post
Share on other sites
Xzener

Now that I have Emby Theater saved as the device to monitor/control... It doesn't follow when I select a TV Show. The only time FV+ GUI changes is when I start a show. I then get the "Now Playing" view. It is controllable... Which is very cool.

 

I have some ideas to help make this app even better. Please let me know if its ok to give suggestions or feature requests.

Share this post


Link to post
Share on other sites
Xzener

Is there anything I can do, minus reorganizing my movies, to fix the "Movies" area in FV+??

Share this post


Link to post
Share on other sites
GlennNZ

I don't follow. Rename the "Skin" folder and edit the XML files? I'd like to edit the entire app to be porta it view. Your saying a user can do this by editing the XML, why not make it an option for the app??

 

The files in the "Skin" folder are Xaml files... Are those the ones you are referring to??

Yes. Except duplicate and rename the next folder in - and then adjust whatever you like (new skin you have just created is selectable in main app)

Have a look at the Kodi thread for some skin based discussion.

 

You modify the skin files as you need to - yes they are xaml files - then within the app you select what skin you would like to use. Can also change backdrops etc they same way

Edited by GlennNZ
  • Like 1

Share this post


Link to post
Share on other sites
GlennNZ

Now that I have Emby Theater saved as the device to monitor/control... It doesn't follow when I select a TV Show. The only time FV+ GUI changes is when I start a show. I then get the "Now Playing" view. It is controllable... Which is very cool.

 

I have some ideas to help make this app even better. Please let me know if its ok to give suggestions or feature requests.

That is expected behavior.

Emby does not report browsing unlike Kodi with Frontview+ add on.

 

Hence with Emby you do not get 'relevant fanart' like you do with Kodi/Frontview+ add on enabled.

 

However you do get fanart for either tv or movies if you have enabled and set this up. The manual covers most of it quite well.

 

Glenn

Edited by GlennNZ
  • Like 1

Share this post


Link to post
Share on other sites
GlennNZ

Is there anything I can do, minus reorganizing my movies, to fix the "Movies" area in FV+??

Probably not.

I'll need to adjust the Emby plugin for movies when I'm back.

 

Glenn

  • Like 1

Share this post


Link to post
Share on other sites
Xzener

Hello Glenn,

 

I recieved my Mimo UM-740 today. After struggling to set it up as a secondary touchscreen monitor, I ran into an issue. Its not FV+ related, but a problem none the less. My monitor is stuck at an 800X480@62hz resolution, and is greyed out. I am unable to set it to the 800X600 to allow FV+ to display correctly. The bottom selections on the home GUI are cut off. I'm unable to get to settings, power, and connection options.

 

What does "Force Resolution" do? I had it selected. Unselecting it did nothing. When I turn the projector off, the Mimo FV+ display changes a bit and I am able to select the bottom option, but is still a tad cut off.

 

I think this must be a windows 10 limitation... As the screen is extended, it doesn't allow the second display to be changed?? I gave up for the night and will research a resolution tonight at work if I have the chance.

 

If anyone has a Mimo touchscreen monitor, I could definitely use some help.

Edited by Xzener

Share this post


Link to post
Share on other sites
Xzener

What is strange is the settings menu is fully shown on screen. Also when I select TV Series, that menu looks fine too. It's just the Home page of the FV+ GUI that is cut off.

 

Any ideas there Glenn??

Edited by Xzener

Share this post


Link to post
Share on other sites
Xzener

Nevermind on the resolution issue, the native resolution is 800X480. So, just need to figure out why FV+ menus are cutoff.

 

I will post some screen shots of the issues tomorrow. Hopefully I can get this resolved.

 

By the way Glenn, I'm enjoying the app so far. Can't wait to design a cup holder for this thing and istall it in one of my theater chairs. Keep up the great work.

Edited by Xzener

Share this post


Link to post
Share on other sites
GlennNZ

Nevermind on the resolution issue, the native resolution is 800X480. So, just need to figure out why FV+ menus are cutoff.

 

I will post some screen shots of the issues tomorrow. Hopefully I can get this resolved.

 

By the way Glenn, I'm enjoying the app so far. Can't wait to design a cup holder for this thing and istall it in one of my theater chairs. Keep up the great work.

The resolutions and its settings are quite customisable.

 

Have a look in the settings.xml file - another setting to change/try would be the <hack480> setting

 

Glenn

Edited by GlennNZ

Share this post


Link to post
Share on other sites
Xzener

Had a look at the settings.xml file. Everything looked straight forward until I got to the resolution area... Not sure what language that was written, not an easy height x width I was hoping to find. I have no idea how to set that up. :blink:

 

Also, the <hack480> had no effect both true and false.

 

What are the dimensions of the app?? Doesnt seem as though its a 16X9, more of a 4:3 look. Any plans for an either or in the settings??

Edited by Xzener

Share this post


Link to post
Share on other sites
Xzener

Thought I would post some pictures of the issues Im having...

 

Here is a picture of the home screen, as you can see the "Other" menu is completely cutoff and unreachable.

5781c977d6933_Capture2.png

 

Here is a picture of the now playing screen, the bottom is cut off (similar to the image above). The scroll bar, info and volume features are unreachable.

5781c9e6d6307_Capture.png

Share this post


Link to post
Share on other sites
GlennNZ

It's likely because the 800x480 format isn't supported well

Most of the 2nd screens are 4:3 format.

 

Double check you don't have any Windows dpi settings enabled - that can change the zoom factor and cause similar issues.

Try a lower resolution of 640x480 and see whether this fixes (temporarily)

Interesting that the hack480 didn't change anything.. Will check that when back as well

 

Other option is to modify the skin (the xaml files) which are a pain to change - and tends to be more trial and error. (Either yours or mine though!)

 

Happy to look at better 16:9 screen support when back (after fixing the movie database import for your setup) but I find the xaml files very very time consuming to alter. Visual studio and other xaml editors don't seem to manage these files well.

 

Glenn

 

Glenn

Share this post


Link to post
Share on other sites
Xzener

Looking forward to working through these issues when you get back. I have not messed with DPI settings (never have , always cause issues). Wish I had more time to learn the Xaml files, but am currently in school and have no time to trial and error my way through these files.

 

This display is locked into a 800X480 AR, everything is greyed out so that is out... Luckily I have found that the best setup is to make my Mimo the main display and launch Emby Theater onto the secondary display. Touch is working well... Just need to fix the AR issues and we can move forward. Not to mention the strange "Movies" selection issue.

 

Looking forward, and excited to get this working.

Share this post


Link to post
Share on other sites
GlennNZ

That doesn't sound ideal - not having it set up as 2nd screen?

 

Hack480 - true - should alter the tv and movie details screen only - likely fixing the bottom most of your two photos.

 

Glenn

Edited by GlennNZ

Share this post


Link to post
Share on other sites
Xzener

For now it's ideal for my setup. I can't for the life of me figure out why, when set as second screen, the cursor moves on main screen when touching the Mimo.

 

So, as a work around, I set the Mimo as main, and the theater screen as secondary. Emby Theater launches on the secondary, and the Mimo works (minus the issues) good.

Share this post


Link to post
Share on other sites
GlennNZ

Just realized something is up with your screen size

 

This is 800 x 480

 

fa6f3c52715b742bb8ef7d6c1228b853.png

 

ve680w.jpg

 

(From Kodi thread were ultimately dpi setting was issue)

 

Your screen shot does not seem to be 800x480?

 

Could something be up with it? Check with paint or photoshop how many pixels you are displaying.

 

Glenn

Edited by GlennNZ

Share this post


Link to post
Share on other sites
Xzener

Sorry for the confusion... The Mimo is set as secondary, but I have it set as main screen otherwise Tge mouse moves on the theater screen as opposed to the secondary display. This is all very aggravating and so far it us the only way FV+ works properly as a touchsceen to control ET.

Share this post


Link to post
Share on other sites
Xzener

I tried to change DPI settings on the Mimo, but its greyed out and default is set to 100% (Recommended).

 

I'm certain you are right about the display. The generic PnP monitor driver is dated 2006, which is very old. Perhaps I can find a newer one to try.

Edited by Xzener

Share this post


Link to post
Share on other sites
Xzener

Ok, a little progress here. I decided to try pluging the Mimo into my Surface. Same resolution issue, but, the resolution for 800X480, 32bits, 62hz was selectable. Setting it to that resolution shank the GUI window, but the home screen was the same size. I opened up the settings.xml and noticed the resolution was now set. I forced closed the FV+ process in Task Manager, restarted FV+ and voila... The GUI is now full screen. I am going to transfer the resolution setting to my HTPC FV+ setting.xml and report back.

 

Success!!

 

I now have a full screen home, and now playing windows.

 

Ok, now just need to get the movies folder issue sorted.

 

I had a though a bit ago. Can I customize the "Videos" tab and have an option to select of DVD, Bluray, or TV Series??

 

And, have an option to get rid of "Audio" since I don't have audio on my server??

 

Thanks for the help Glenn.

Edited by Xzener

Share this post


Link to post
Share on other sites
GlennNZ

Good to hear.

 

The resolution settings are a bit difficult - but horizontal and vertical resolutions are the main one to change. (If needed)

 

MIMO monitors appear to use displaylink drivers -http://www.displaylink.com/downloads which there is a very uptodate driver on their website - that might be worth a go if ongoing issues. (Previous user had similar usb displaylink display - which did need to be updated to latest driver)

 

Re: Requests:

1. Can have a look at making audio menu disappear via a setting; although again becomes xaml editing more than anything else which is quite time consuming.

2. Customising the Video tab is doable - but essentially means changing everyone's local Sql database to this format. Local Database changes are not backwards compatible and would force everyone into this format as well.

Personally I can't remember the last dvd-equivalent format movie I watched (particularly on projector) there would be huge rounds of complaints about what this blurry mess was!

That is also the main reason I added the date-sort for both movies and TV shows (Sorted by episode date) so when you enter the menu the most recently added show or movie appears first. I find in my watching experience we rarely go past the first few pages of this sort.

 

Anyhow, Might be able without spending much time have a selectable second menu after movies ordered by another factor ?resolution. Again would mean a database update to add those details to the local database. (My other issue is the localdatabase is single across all possible remote connections, Kodi, Plex, and Emby - so to change database for one have to change for all - so triple the work)

 

Will think on it.

 

Glenn

Share this post


Link to post
Share on other sites
Xzener

Thanks for the input. I hadn't thought about Plex and Kodi, so I guess that could cause problems. My DVDs have been converted to MKV, 1:1 rips. They look very good, not a blurry mess at all. I just prefer grouping them this way, Blurays are mainly Sci-Fi/Action type movies, where my DVDs are chick flicks and comedy's.

 

Setting up this Mimo has been very time consuming, trial and error. I have yet to find a dependable setup. I definitely don't like having it as my main main display, Emby Theater will launch into the last display used, but as soon as I power down my theater (PC stays on), all display settings get messed up, even loose touch function requiring a calibration. But I have to duplicate the displays, calibrate, then set the Mimo as the main display to have touch functionality with FV+. Not ideal at all.

 

I think I may go ahead and buy a cheap Intel NUC to dedicate FV+... Over kill, maybe, but will produce the outcome I'm looking for.

 

I've search all over the internet for a fix for my situation. It doesn't make sense how a secondary touch display cant be extended without the mouse issue.

 

I will look into reorganizing my movies and group them together, in the mean time it would be nice to disable the "Audio" tab.

 

Thanks.

Edited by Xzener

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...