Jump to content
GlennNZ

FrontView+ [for Windows]iMon replacement, NowPlaying 2nd Screen

Recommended Posts

GlennNZ

Hi GlennNZ, gonna try this :)

 

Is this your repo: https://github.com/Ghawken/FrontView/commits/master ?

Thats the one.

 

Try this new exe, replace the old one.  (its 1.106)

Better yet - use 1.107 has this and a few other fixes

 

This: 

Will automatically update/reset screen settings if

<MinimiseAlways>false

and

<DisableResolutionDetection>false

in settings.xml

 

If DisableResolutionDetection - true will resort to default, current behaviour

 

Glenn

FrontView.zip

Edited by GlennNZ

Share this post


Link to post
Share on other sites
GlennNZ
Version 1.107

- Reinstate DisableResolutionDetection: -- setting in settings.xml file

reinstates screen settings on screen change if <MinimiseAlways>false and <DisableResolutionDetection>false

if <DisableResolutionDetection>true - will resort to current behaviour where screen changes are ignored.

 

- Multiple Fixes for browsing fanart if changing from Kodi to Emby and back again 

KODI:

- Fix/Ignore theme.mp3 files - no nowplaying info for these files and keeps relevant fanart going -

(difficult to sort out but done I believe -Issue was keeping relevant Fanart going despite the playback event and loss of Path information)

Further Fixes for config File

Share this post


Link to post
Share on other sites
Oxide

@@Glenn is it possible to have 2 or more devices linked and working with FrontView+?

 

For example 2 LCD displays for 2 different users showing the correct info per user?

Share this post


Link to post
Share on other sites
GlennNZ

@@Glenn is it possible to have 2 or more devices linked and working with FrontView+?

 

For example 2 LCD displays for 2 different users showing the correct info per user?

Hi!

Hadn't seen that question coming!

What do you mean exactly? Same network, same emby server, running two separate computers each with LCD screen?

 

Not impossible to sort out.

 

Initial thoughts:

 

Can do with Kodi currently, but since Emby is server based Emby server plugin only sends one set of selected information for that client. Could add two or three or four client support to server plugin, but would be work to do and also more work for server to send.

 

I think what the ideal solution would be is to have a plugin for Emby home theatre (and to give frontview+ an option to connect to Emby server, or local running version of Emby home theatre)

This should enable relevant browsing fanart (like Kodi plugin) and also enable multiple copies, connections.

 

Hopefully plugin information for home theatre (there is the "coming soon") is available soon and supports the information needed, if so will work on a Emby home theatre plugin for FrontView+

 

Glenn

Edited by GlennNZ

Share this post


Link to post
Share on other sites
GlennNZ

Update

 

Version 1.108

- Hopefully fix focus issue that was created by refreshing screen on awake/sleep/screen change.

(if using <DisableResolutionDection>false - to restore screen settings after sleep)

 

Let me know if doesn't

Edited by GlennNZ

Share this post


Link to post
Share on other sites
GlennNZ

Version 1.108 Kodi Service Fix

- Inadvertent error in KodiService past couple of releases

- Fixed here. (Only change Kodi FrontView Service)

 

Download from Mediafire: Link Below:

https://www.mediafire.com/?11ns9cc9sp3k34u

Share this post


Link to post
Share on other sites
jjstecchino

Hello Glenn, thank you for working at this plugin.

I am probably doing something wrong. I followed the manual best I could. I am trying to use frontview+ with emby. The server configuration part seems ok. The remote is connected, but as it tries to refresh the library it hangs there at "songs"

The log shows this:

[22:21:47.5835] SERVER        : Starting Server Thread... 
[22:21:47.5875] FrontView+    : Starting version :1.0
[22:21:47.5895] FrontView+    : Starting build : 107
[22:21:47.5925] OSInfo        : Name = Windows 7
[22:21:47.5945] OSInfo        : Edition = 
[22:21:47.5965] OSInfo        : Service Pack =
[22:21:47.6005] OSInfo        : Version = 6.2.9200.0
[22:21:47.6025] OSInfo        : Bits = 64
[22:21:47.6045] OSInfo        : Culture = en-US
[22:21:47.6055] FrontView+ Debug : : Checking for another instance
[22:21:47.6105] Kodi Source   : Checking for Kodi Source xml file
[22:21:47.6755] FrontView-Plugs : Loading : C:\Program Files (x86)\FrontView+\Plugins\Remote.Emby.dll
[22:21:47.6845] FrontView-Plugs : Plugin : Emby (Version : 101)
[22:21:47.6865] FrontView-Plugs : Loading : C:\Program Files (x86)\FrontView+\Plugins\Remote.Plex.dll
[22:21:47.6925] FrontView-Plugs : Plugin : Plex (Version : 100)
[22:21:47.6945] FrontView-Plugs : Loading : C:\Program Files (x86)\FrontView+\Plugins\Remote.XBMC.Frodo.dll
[22:21:47.6985] FrontView-Plugs : Plugin : Kodi 15.2/16 (Version : 145)
[22:21:48.0836] FrontView+    : End init
[22:21:49.0852] FrontView+    : Starting Library Refresh
[22:21:49.3894] YatseApp      : Error [ Object reference not set to an instance of an object. ] ( System.NullReferenceException )
RefreshMusicSongsLibrary : 0 / 0
   at FrontView.Yatse2Window.RefreshMusicSongsLibrary()
   at FrontView.Yatse2Window.RefreshLibrary()
   at FrontView.Yatse2Window.UpdateRemote()
   at FrontView.Yatse2Window.Timer_Tick(Object sender, EventArgs e)
   at System.Windows.Threading.DispatcherTimer.FireTick(Object unused)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Any help appreciated

 

Thanks

 

Claudio

Share this post


Link to post
Share on other sites
GlennNZ

Hello Glenn, thank you for working at this plugin.

I am probably doing something wrong. I followed the manual best I could. I am trying to use frontview+ with emby. The server configuration part seems ok. The remote is connected, but as it tries to refresh the library it hangs there at "songs"

The log shows this:

[22:21:47.5835] SERVER        : Starting Server Thread... 
[22:21:47.5875] FrontView+    : Starting version :1.0
[22:21:47.5895] FrontView+    : Starting build : 107
[22:21:47.5925] OSInfo        : Name = Windows 7
[22:21:47.5945] OSInfo        : Edition = 
[22:21:47.5965] OSInfo        : Service Pack =
[22:21:47.6005] OSInfo        : Version = 6.2.9200.0
[22:21:47.6025] OSInfo        : Bits = 64
[22:21:47.6045] OSInfo        : Culture = en-US
[22:21:47.6055] FrontView+ Debug : : Checking for another instance
[22:21:47.6105] Kodi Source   : Checking for Kodi Source xml file
[22:21:47.6755] FrontView-Plugs : Loading : C:\Program Files (x86)\FrontView+\Plugins\Remote.Emby.dll
[22:21:47.6845] FrontView-Plugs : Plugin : Emby (Version : 101)
[22:21:47.6865] FrontView-Plugs : Loading : C:\Program Files (x86)\FrontView+\Plugins\Remote.Plex.dll
[22:21:47.6925] FrontView-Plugs : Plugin : Plex (Version : 100)
[22:21:47.6945] FrontView-Plugs : Loading : C:\Program Files (x86)\FrontView+\Plugins\Remote.XBMC.Frodo.dll
[22:21:47.6985] FrontView-Plugs : Plugin : Kodi 15.2/16 (Version : 145)
[22:21:48.0836] FrontView+    : End init
[22:21:49.0852] FrontView+    : Starting Library Refresh
[22:21:49.3894] YatseApp      : Error [ Object reference not set to an instance of an object. ] ( System.NullReferenceException )
RefreshMusicSongsLibrary : 0 / 0
   at FrontView.Yatse2Window.RefreshMusicSongsLibrary()
   at FrontView.Yatse2Window.RefreshLibrary()
   at FrontView.Yatse2Window.UpdateRemote()
   at FrontView.Yatse2Window.Timer_Tick(Object sender, EventArgs e)
   at System.Windows.Threading.DispatcherTimer.FireTick(Object unused)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Any help appreciated

 

Thanks

 

Claudio

 

Hi

Sorry to hear about your troubles.

 

First thing to say would be if not using Library Function on FrontView+ can turn off library and set it to not update on start via xml file or settings screen.  In Xml file change below to false.

  <RefreshOnConnect>true</RefreshOnConnect>

Just checked updating library on my system (latest version 1.108) and updates everything fine including songs.  Initally I was wondering whether may have been emby database change that was issue - but fact my version works would suggest not.

 

To check further - need to have debug and trace logging enabling when you start.  In settings screen or here in Xml file:  Set both to true:

  <Debug>true</Debug>
  <DebugTrace>true</DebugTrace>

Turn these on and then post log - probably as zip file as will be reasonably log.  

 

Hopefully with that will get to bottom of issue

 

Looking at the code- maybe localizedString issue - Not English as Language?  (The log will show)

Have attached new build of FrontView.exe file - just replace current one with this.  Adds a catch exception to this error - so if error does still occur won't crash/hang - and reports the error a bit better.

 

Thanks

FrontView 1.08.zip

Edited by GlennNZ

Share this post


Link to post
Share on other sites
jjstecchino

Here is the log with debug enabled. English is the language

FrontView+.log

Edited by jjstecchino

Share this post


Link to post
Share on other sites
GlennNZ

Hi

Thanks for the quick reply.

 

There were some changes in Emby handling of Music Data requests - have essentially completely updated.  

 

Also fixed Genres which required a bit more server input when updating library.  End result is Frontview gets more information but takes a bit more time

 

Please check and post Trace/Debug log again.

Replace files with these ones attached.  (  FrontView Plus 1.109.zip  )

 

 

Glenn

Edited by GlennNZ

Share this post


Link to post
Share on other sites
jjstecchino

Hello Glenn, 

 

Thank you for your fix, it seems to work well and all the libraries are now downloaded fine. I can see my movies in frontview+. The movies though have a generic thumbnails rather than the proper picture from emby server. However I can start a movie from front view and play it on the emby theater app. I can't control pause/play/stop/etc. from front view whereas I can do that from the emby server web remote so it should be possible to add this support. There are few issues with focus being stolen from emby and not returned, i.e. use the touch screen on frontview+ than can't use the harmony remote until I click with the mouse on emby theater to return focus. Overall front view plus is very usable and a great addition.

 

Thank you very much for your work, it really brings new life to an otherwise excellent but obsolete case as sound graph decided neither to support icon anymore nor open source their code and this is a pity. I am running windows 10 and the emby theater app plus frontview+ is a killer combination.

 

I'll be glad to give you all the feedback you need and fi you like help a little with the code. Is the github repo up to date? What version of VS are you using?

 

Thanks again

 

Claudio

Share this post


Link to post
Share on other sites
jjstecchino

Another suggestion is to have on the emby frontview+ catalog plugin page a link to the latest version download.

Share this post


Link to post
Share on other sites
GlennNZ

Hello Glenn,

 

Thank you for your fix, it seems to work well and all the libraries are now downloaded fine. I can see my movies in frontview+. The movies though have a generic thumbnails rather than the proper picture from emby server. However I can start a movie from front view and play it on the emby theater app. I can't control pause/play/stop/etc. from front view whereas I can do that from the emby server web remote so it should be possible to add this support. There are few issues with focus being stolen from emby and not returned, i.e. use the touch screen on frontview+ than can't use the harmony remote until I click with the mouse on emby theater to return focus. Overall front view plus is very usable and a great addition.

 

Thank you very much for your work, it really brings new life to an otherwise excellent but obsolete case as sound graph decided neither to support icon anymore nor open source their code and this is a pity. I am running windows 10 and the emby theater app plus frontview+ is a killer combination.

 

I'll be glad to give you all the feedback you need and fi you like help a little with the code. Is the github repo up to date? What version of VS are you using?

 

Thanks again

 

Claudio

Hi

 

Thanks for the offer - the Github is now uptodate - my usage is slightly messy as I use VisualStudio to code but commandline to upload - various reasons. Will probably try to update github and then clone that into VisualStudio to work on in future.

 

Have made quite a few more changes/checks/mainly for null Database entries which was causing issues.

Uploading the full install setup to MediaFire now and will link first page. Now Version 1.110.

 

1. ThumbNails  (Need Log)

Mine display and download fine, so they should work - welcome to zip and send a trace/debug log if can.

Happy to have a look at.

 

2: Focus (new version fixed)

- is a difficult issue, particularly with MadVR and other actually having the focus.

FrontVIew does have a setting KeepFocus - and is possible to send focus back to other process - problem is what other process?

When was originally written was simple as gave focus back to a process running called Xbmc - now, with Emby, multiple playback options including web etc, MadVR rendering (I would guess that would have the focus - actually it doesnt ) - its far more difficult.

Can have a think about it, and best option may be to return focus to whatever had it ever Timer tick

 

Edit: Actually making some changes now...

Okay - have updated Focus & Updated main page download (!) to version 1.110

FrontView will return Focus to Emby.Theater 2 (new version only checked for currently) after remote commands/and occasionally

Enable in Settings.xml file

<KeepFocus>true</KeepFocus> --> this refers to Focus of Media Player - Not focus of Frontview!

Not particularly aggressive - but seems to work well.

 

3. Remote Control

- Should and does work on my system.  (haven't made any changes to this code)

Other emby playback devices such as Web etc do - and FrontView controls those fine (or it did when I last tested :)

Tested: Emby Home Theatre 2 does support remote control and FrontView and works fine on my system (version 2.0.0 and updated to 2.1.6 always functioning correctly)  Correctly pausing, stopping going forward etc..

 

May be issue of application startup - Frontview needs emby client running on startup as that is when it checks for remote support.

To test close frontview and restart, and retest Remote commands.  If that fixes - look at timing of startup apps etc

 

If yours doesn't - need log I suspect. :)

 

Cheers

 

Glenn

Edited by GlennNZ

Share this post


Link to post
Share on other sites
jjstecchino

Hello Glenn, what version of visual studio are you using? tried to compile on vs15 but cant die to a security exception in windowsbase.dll. I am not familiar yet on the ClickOnce security on .NET 4 and above. How do you solve that other than disabling security alltogether?

Edited by jjstecchino

Share this post


Link to post
Share on other sites
jjstecchino

3. Remote Control

- Should and does work on my system.  (haven't made any changes to this code)

Other emby playback devices such as Web etc do - and FrontView controls those fine (or it did when I last tested :)

Tested: Emby Home Theatre 2 does support remote control and FrontView and works fine on my system (version 2.0.0 and updated to 2.1.6 always functioning correctly)  Correctly pausing, stopping going forward etc..

 

May be issue of application startup - Frontview needs emby client running on startup as that is when it checks for remote support.

To test close frontview and restart, and retest Remote commands.  If that fixes - look at timing of startup apps etc

 

If yours doesn't - need log I suspect. :)

 

Cheers

 

Glenn

 

It may be a startup order issue. I have both frontview+ and emby set to startup on windows logon, I suspect that frontview is starting before emby. I'll check and let you know

Share this post


Link to post
Share on other sites
jjstecchino

RE: Remote control

 

Confirmed it is a startup order problem. If I start emby theater first it works just fine. This is however a problem as emby usually start last in order to have focus and be controlled with the remote. Would it be possible for frontview to continue checking for a frontend if one is not found on startup? This would solve the problem.

 

On a different note I was able to compile and run frontview on VS15 after disabling the security check for the project. I would love to help adding some new themes of different colors just as imon has, so that the look of the screen can be customized to the display color of the other AV component.

 

PS what is your time zone?

Edited by jjstecchino

Share this post


Link to post
Share on other sites
jjstecchino

If you like to add to frontview setup, I made skins of different color similar to iMon. I just photoshopped the default background to give similar consistency. I am including my skin directory but it is larger than I can upload here.

 

Here is a dropbox link http://www.dropbox.com/s/ylwdpvtppl50l7b/Skin.zip?dl=0

  • Like 1

Share this post


Link to post
Share on other sites
GlennNZ

RE: Remote control

 

Confirmed it is a startup order problem. If I start emby theater first it works just fine. This is however a problem as emby usually start last in order to have focus.

 

PS what is your time zone?

Thanks. Will have a look at code when can - prob next few days - might be possible to change - although seem to remember was reason for this. Other option is delay start to Frontview - quite a few free apps to control startup order.

 

Time zone wise - GMT -10, was about 4am when you wrote this!

 

If you like to add to frontview setup, I made skins of different color similar to iMon. I just photoshopped the default background to give similar consistency. I am including my skin directory but it is larger than I can upload here.

 

Here is a dropbox link http://www.dropbox.com/s/ylwdpvtppl50l7b/Skin.zip?dl=0

Yes - can make or update skins without code needed.

Just need to duplicate and rename skin directory in program files -then can alter any part - new skin can be selected in settings.

Will download and have look at yours today - to large to include with setup - but happy to include link for separate download.

 

How is the focus solution? Seems pretty robust at my testing.

 

Thumbnails -> likely secondary to folder setup I presume -> but need log.

 

Finally if making any code changes need to fork at Github and update your code at your fork - then can push if needed.

 

Glenn

Share this post


Link to post
Share on other sites
jjstecchino

Remote control, start order and recheck if client not detected -> would be a much cleaner solution if handled by front view rather than relying on external apps to change startup order. If Emby is already full screen, front view starting last would steal focus and display the Windows start bar. Requiring to mouse click on Emby to restore focus.

 

Focus issue seems to be resolved in the last update

 

Skins -> I just modified the background image of the default skin, but I had to duplicate everything else in the default skin for each different skin hence the size. Don't know if there is a different solution to avoid duplication of common resources.

 

I forked the repo and reading the code.

 

Get -10 -> Australia?

Edited by jjstecchino

Share this post


Link to post
Share on other sites
GlennNZ

Hi

Remote issue is to control need to have SessionID for that emby client/session.  Doesnt exists before Emby client actually starts.  Could have it check a lot later/delay this check and will have a look into that.  But presently sorts all this out at the time of connection to the remote client/server with all the hand-shaking, authority etc - and then lets remote API know whether supports remote or not.  Was attempting to remove remote button display if remote not supported

 

Could set API SupportsRemote setting to always true for Emby Remote - and then run later check for SessionID 2 minutes or so after startup.  Will have a look at options - other issue is currently check for remote support may return false or true - could make the bool variable nullable and have a null,false,true and recheck periodically only if null.

 

Good about focus.

 

Just your thumbnails left.

 

Glenn

 

(Sorry though you knew Australia - its in the sideline)

Edited by GlennNZ

Share this post


Link to post
Share on other sites
GlennNZ

Hi

 

Skin:

Happy to link to first page - probably needs a readme as to where to put the files - into %appdata% etc.

If Dropbox durable link can post that or use another?

 

 

Remote Control

Fixed.  New files to replace here - updates to 1.111

Pretty easy fix - change bool to nullable bool - true, false or null.  Only if SupportsRemote null & remote command attempted recheck if client running and whether supports remote.

 

Full Setup file Version 1.111

https://www.mediafire.com/?uuw6dvwkwdmhbiy

 

 

Just thumbnails left to go?

 

 

Glenn

FrontView 1.111 .zip

Edited by GlennNZ

Share this post


Link to post
Share on other sites
jjstecchino

Hello Glenn, thank you for working at this. I look forward to try the new version as I get home.

 

Regarding the skins, if you like you can place the file in mediafire with the other for consistency, also I dont know how much bandwidth dropbox allow with the free account.

For each skin the only thing changed is the background image, which in itself is quite small. This could be addressed by the installer program, which after install can duplicate the default skin directory for as many skin backgrounds are needed and then just copy the background images in the right place. In this way only a few images will need to be included in the package. I dont think the installer code included in github, is it? If you add it to the repository and If you dont mind I'll take a stab at coding that? Otherwise I can write a batch file to do that.

 

The thumbnails started to work after I started frontview after the emby client. My bad if I didnt tell you.

 

Overall frontview+ is working very well. The only other thing I noticed is the weather city selection does not work. For me did not do any search based on the city name. I had to change the weather code in the xml.

 

Another feature I think it would be nice is a setting in the xml to change the timing and amount of dimming of the frontview screen when playing a movie. I personally would like to leave it undimmed a little bit longer and dont dim quite as much (on my screen it is practically black). I realized this is personal preference, hence the setting. I would like to try to do it myself, if you dont mind. I may not be able to succeed as I find the programming techniques used to write front view quite advanced for my amatourish programming level. 

Share this post


Link to post
Share on other sites
GlennNZ

Hello Glenn, thank you for working at this. I look forward to try the new version as I get home.

 

Regarding the skins, if you like you can place the file in mediafire with the other for consistency, also I dont know how much bandwidth dropbox allow with the free account.

For each skin the only thing changed is the background image, which in itself is quite small. This could be addressed by the installer program, which after install can duplicate the default skin directory for as many skin backgrounds are needed and then just copy the background images in the right place. In this way only a few images will need to be included in the package. I dont think the installer code included in github, is it? If you add it to the repository and If you dont mind I'll take a stab at coding that? Otherwise I can write a batch file to do that.

 

The thumbnails started to work after I started frontview after the emby client. My bad if I didnt tell you.

 

Overall frontview+ is working very well. The only other thing I noticed is the weather city selection does not work. For me did not do any search based on the city name. I had to change the weather code in the xml.

 

Another feature I think it would be nice is a setting in the xml to change the timing and amount of dimming of the frontview screen when playing a movie. I personally would like to leave it undimmed a little bit longer and dont dim quite as much (on my screen it is practically black). I realized this is personal preference, hence the setting. I would like to try to do it myself, if you dont mind. I may not be able to succeed as I find the programming techniques used to write front view quite advanced for my amatourish programming level. 

 

Hi

A Bit of time today - so thought would have a look

 

Thumbnails

Load do download/cache in the background so can take a while to show up.  I haven't changed anything with regards file handling.

 

But regarding your two requests;

Basically your two requests FrontView supports now, already without any code changes neeed

 

Time to Dim

Setting in xml File

  <DimmingTimer>15</DimmingTimer>

Time from start of playback when Dimming occurs.

 

Amount and timeframe of Dim

Is a Skin setting.

In Animations.xml skin file  - admittedly somewhat harder to change - but easy to have a few skins with different Dim levels to suit.

    <Storyboard x:Key="stb_ShowDimming">
        <DoubleAnimationUsingKeyFrames BeginTime="00:00:00" Storyboard.TargetName="grd_Dimming" Storyboard.TargetProperty="(UIElement.Opacity)">
            <SplineDoubleKeyFrame KeyTime="00:00:00" Value="0"/>
            <SplineDoubleKeyFrame KeyTime="00:00:05" Value="0.5"/>

As Above - here I have changed the Default Value to 0.5  (from 0.9) and also made the dim occur over 5 seconds.

 

I have figured out to move this to main settings.xml file  -- xaml is a bit of a pain/wouldn't suggest you start on that.  

Have changed my currenly unpublished version of the code - to add a DimAmount to Settings xml file.  

Depending on the skin setting it will then use this for amount of Dim.

 

Skins

They to big file wise I agree.  

I use a NSIS compiler for the installer which is somewhat custom according to my directories/where files are. 

You are right could copy the same files over multiple times - but that would make FrontView take up 200MB of disk space!

 

Could have stand alone installer for the skins, dropping them into %appdata% /FrontView+/Skin  ?

Something like would do the job I suspect - and is really easy to use.  (I started with it before NSIS)

http://www.installsimple.com/

 

Will have a look at code and see if can have code check Default if another skin missing a piece - suspect this will be big deal given xaml though.  (Basically have looked and is not possible without really re-writing)

 

Weather

Yep - the yahoo weather locationID search website that was used is closed and there doesn't seem to be alternative to search for location ID.

Yahoo has also moved on to using WOIED.

So unless weather and classes re-written - will have to enter locationID in XML

 

Well have used up the bit of free-time recoding the weather city search bit - unfortunately Yahoo API is quite limited and most of the locations found don't appear in Yahoo's xml api - so essentially you can't use them for weather/forecast.  So took the far bigger step of rewriting the Weather engine API completely to use WUnderground API (currently its using my API Key)  All looking good, new icons amongst other data.  Just have to add optional API Key setting in xml file in case using my Key API max's out the number of allowed free requests   (free one allows 500/day).  Pretty easy to get your own and free.  Will sort out those details and then post update.

 

 

Glenn

 

 

Glenn

 

(I attached edited Animation.xml skin file - but pretty straight forward to change as above)

Animations.zip

Edited by GlennNZ

Share this post


Link to post
Share on other sites
GlennNZ

Release 1.113

WEATHER API Completely  rewritten - do need Wunderground API Key however!  (free, easy access)
 
Link in Setting Page
Completely rewritten Weather API - Moved to Wunderground
New Weather Icons, Backgrounds
Search works - huge range of location options; given Wunderground
 
57119dd664fed_Weathersearch.png
 
5711ba3a4e060_WeatherApiSettings.png
 
57119df6a4c79_WeatherForecast.png
 
 
Release 1.112
Add Xml Settings <DimAmount> value from 0 to 1 (eg. 0.5, or 0.9) amount of Dim applied to screen
(setting also adjustable with Skin Animation.xml file) Depending on skin may override Settings.xml setting.
 
 
Weather side of things may need some testing (!)  Thanks for your help.
 
 
 
Plus:
 
Skins:
Courtesy of 
jjstecchino

Skins for FrontView+ Compatible with new/or old weather;

Download from here:  (Install setup.exe file)
https://www.mediafire.com/?2n17c6is845ztlq

 

Thanks

 

 
 
 
Glenn
Edited by GlennNZ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...